15:01 <cyphermox> #startmeeting DMB
15:01 <meetingology> Meeting started Mon Apr 10 15:01:25 2017 UTC.  The chair is cyphermox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:01 <meetingology> 
15:01 <meetingology> Available commands: action commands idea info link nick
15:01 <cpaelzer> writing already in other window
15:01 <cyphermox> #topic Review of previous action items
15:01 <cyphermox> rbasak to add slashd to the new SRU-UPLOADERS team (carried-over, pending TB action)
15:02 <cyphermox> what is the status with that, still pending?
15:02 <rbasak> Still pending a TB action.
15:02 <rbasak> They seemed to have missed it in their last meeting.
15:03 <cyphermox> do they have a bug for that?
15:03 <cyphermox> oh ok
15:03 <rbasak> Their next meeting is tomorrow I believe.
15:03 <rbasak> So I intend to chase again then.
15:03 <cyphermox> ack
15:03 <rbasak> Indeed there is a bug: https://bugs.launchpad.net/ubuntu-community/+bug/1674440
15:03 <ubottu> Launchpad bug 1674440 in ubuntu-community "[TB/DMB] ACL for ~ubuntu-sru-developers" [Undecided,New]
15:03 <cyphermox> I'll skip ~mapreri's, I saw the bug and it's still open
15:03 <rbasak> Unfortuntely their process it to look for bugs there assigned to the tech board, and only they have persmission to do that it seems.
15:03 <bdmurray> rbasak: can you ask them about that tomorrow too?
15:03 <cyphermox> hehe
15:04 <cyphermox> I can go to that meeting
15:04 <rbasak> bdmurray: ack
15:04 <cyphermox> I already watch them
15:04 <cyphermox> next: rbasak to sort Aron's request
15:04 <mapreri> wow
15:04 <rbasak> I'm sorry Aron, I've failed at that.
15:04 <rbasak> Please carry over.
15:04 <cyphermox> zug zug!
15:05 <cyphermox> everything else is marked done
15:05 <rbasak> Or did someone else take that in the end?
15:05 <rbasak> I don't recall having it as an action for me.
15:05 <mapreri> Question: shouldn't those bugs be at the very least subscribe the TB?
15:05 <rbasak> In any case, I'll sort out what's going on.
15:05 <mapreri> s/be//
15:05 <cyphermox> rbasak: I'm just relaying what's on the agenda :/
15:05 <rbasak> mapreri: perhaps. I did email the tech board directly with the bugs.
15:05 <rbasak> cyphermox: understood :)
15:05 <cyphermox> do you want me to look at it instead?
15:06 <rbasak> I can't remember what it is.
15:06 <mapreri> oh well, fine
15:06 <cyphermox> ok
15:06 <cyphermox> mapreri: we'll pester them tomorrow :)
15:06 <mapreri> I could probably just get more involved in more core stuff and get core-dev :P
15:06 <cyphermox> or if I catch a second, I'll ask someone directly
15:06 <rbasak> mapreri: please do :-)
15:06 <cyphermox> ok; moving on
15:07 <cyphermox> I'm going "fast" because bdmurray is on a time limit; and we have lots to review
15:07 <cyphermox> #topic Package Set/Per Package Uploader Applications
15:07 <cpaelzer> rbasak: cyphermox: FYI - mail sent
15:07 <cyphermox> ta
15:09 <cyphermox> #subtopic Christian Ehrhardt's multipath-tools PPU; and postgres PPU
15:09 <cpaelzer> and MOTU?
15:09 <cyphermox> we shoudl review PPU separately
15:09 <cpaelzer> or is that a seperate chunk of deciding in terms of PPU
15:09 <cpaelzer> ok
15:09 <cyphermox> ^ I think given the various applications though, both PPU at the same time seems like an optimisation.
15:09 <cpaelzer> https://wiki.ubuntu.com/ChristianEhrhardt/MultipathToolsPPUApplication
15:09 <bdmurray> Speaking of optimization I'm ready to vote
15:09 <cpaelzer> https://wiki.ubuntu.com/ChristianEhrhardt/PostgresPPUApplication
15:10 <cyphermox> now we're talkin'.
15:10 <rbasak> I have the pleasure of working with cpaelzer. I don't remember being asked for an endorsement, but he has mine for all three applications.
15:10 <cpaelzer> rbasak: I didn't ask to not compromise you here for the decision
15:10 <cpaelzer> cyphermox: I asked because he is Mr. Multipath
15:10 <rbasak> Fair enough
15:10 <rbasak> You're getting one here anyway :-P
15:10 <cyphermox> cpaelzer: fwiw you should not feel like I "own" multipath-tools
15:10 <rbasak> cpaelzer is diligent in his work, always asks when unsure, and his uploads are of very high quality.
15:10 <cyphermox> then we
15:11 <rbasak> So I'm happy to endorse him for all three applications, and I have no further questions and am ready to vote.
15:11 <cyphermox> uggh
15:11 <cyphermox> then we're all ready to vote?
15:11 <cyphermox> sil2100 ?
15:11 <sil2100> I think I don't have any questions myself
15:11 <cyphermox> cpaelzer: I do have one.
15:11 <bdmurray> I may have one question
15:11 <sil2100> Since I also had some experience in reviewing cpaelzer's uploads from the SRU queue
15:11 <cyphermox> ok
15:12 <cyphermox> bdmurray: you first.
15:12 <sil2100> (and sprinting)
15:12 <bdmurray> pitti says that there were some regressions in the last round of postgresql SRUs. How can that be avoided going forward?
15:13 <cpaelzer> yeah that was "fun" for certain degrees of fun - pitti promised "there would never be some" and just on the first we took over we broke the rule :-)
15:13 <cpaelzer> for the details that was on the MRE updates
15:13 <cpaelzer> the stable releases changed parts that primarily affected testcases
15:14 <cpaelzer> bdmurray: on these in particular there is not much to prevent them other than testing in advance which we did this time as well
15:14 <cpaelzer> we knew about them from the dep8 tests on bileto IIRC
15:14 <cpaelzer> and I worked through the dependent packages to adapt testcases were needed
15:14 <rbasak> Did these regressions hit the updates pocket? It's not clear to me from the bug.
15:14 <cpaelzer> it was in some sense dep8 only regressions rbasak
15:14 <cpaelzer> so it was stopped in -proposed
15:15 <cpaelzer> we analyzed and cleaned up
15:15 <rbasak> Ah OK, thanks.
15:15 <cpaelzer> and from there things become green and good again
15:15 <cpaelzer> bdmurray: there is one thing we can improve on thou
15:15 <cpaelzer> which this time was less optimal since this was our first take over from pittei (our = nacc + me)
15:15 <cpaelzer> we could have started about 2 days earlier to see it sooner
15:16 <cpaelzer> but that was all I'd think on this special case
15:16 <cyphermox> cpaelzer: how did you get so tall?
15:16 <cyphermox> cpaelzer: or how come am I so short?
15:16 <bdmurray> cyphermox: I think its too late for you
15:16 <cyphermox> ;)
15:16 <bdmurray> cpaelzer: Okay, thanks
15:16 <cpaelzer> cyphermox: honestly - stretch while going to sleeping and wishing to grow
15:16 <cyphermox> ready to vote?
15:16 <cyphermox> bdmurray has a point, too late for me.
15:17 <cyphermox> #vote cpaelzer to have PPU rights for multipath-tools
15:17 <meetingology> Please vote on: cpaelzer to have PPU rights for multipath-tools
15:17 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:17 <cpaelzer> cyphermox: as a team we are just the right size on average
15:17 <rbasak> +1
15:17 <meetingology> +1 received from rbasak
15:17 <bdmurray> +1
15:17 <meetingology> +1 received from bdmurray
15:17 <cyphermox> (specifically multipath-tools, then I'll do the other
15:17 <cyphermox> +1
15:17 <meetingology> +1 received from cyphermox
15:18 <bdmurray> sil2100: ?
15:18 <sil2100> +1
15:18 <meetingology> +1 received from sil2100
15:19 <cyphermox> #endvote
15:19 <meetingology> Voting ended on: cpaelzer to have PPU rights for multipath-tools
15:19 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:19 <meetingology> Motion carried
15:19 <cyphermox> #vote cpaelzer to have PPU rights for postgres
15:19 <meetingology> Please vote on: cpaelzer to have PPU rights for postgres
15:19 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:19 <rbasak> +1
15:19 <meetingology> +1 received from rbasak
15:19 <bdmurray> +1
15:19 <meetingology> +1 received from bdmurray
15:20 <sil2100> +1
15:20 <meetingology> +1 received from sil2100
15:21 <cyphermox> +1
15:21 <meetingology> +1 received from cyphermox
15:21 <cyphermox> #endvote
15:21 <meetingology> Voting ended on: cpaelzer to have PPU rights for postgres
15:21 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:21 <meetingology> Motion carried
15:21 <cyphermox> ok, next up is Robert Jennings
15:21 <rcj> https://wiki.ubuntu.com/rcj/PerPackageUploadUbuntuCloud
15:21 <cyphermox> #topic Robert Jennings PPU application for Ubuntu Cloud packageset
15:21 <cyphermox> rcj: please introduce yourself :)
15:22 <rcj> Hello.  I've been working on delivery of public cloud images for 3 years and doing packing-related work for those images like open-vm-tools and livecd-rootfs (not in this packageset)
15:23 <rcj> and drop-in fixes when I find them
15:24 <rcj> I'm applying for PPU rights for UbuntuCloud to service those packages related to image delivery.
15:24 <rbasak> The last sponsored upload you made to this package was 2016-04-25, right?
15:24 <rbasak> to this packageset
15:24 <rcj> That is correct
15:25 <rbasak> Is there any reason you haven't uploaded more recently? Eg. no need, or others have been doing it? And how often do you expect you'll need to upload in the near future?
15:26 <rcj> A lot of our work is geared toward the infrastructure for delivery.  But we have also grown our team and spread out the packaging work to train others.
15:26 <rcj> I expect that uploads will increase however in the near future due to changing workload.
15:27 <sil2100> rcj: any reason you want to have the upload rights now instead after doing some sponsored uploads?
15:28 <rbasak> Also AFAICT arges sponsored you last in 2015, and that's the only sponsoring endorser on this application.
15:29 <rcj> sil2100: I am looking to help out with uploads to provide coverage for the public cloud team
15:29 <sil2100> We usually prefer that people get upload rights granted after they already have some experience through packages that are sponsored by others
15:32 <rcj> My sponsored uploads are not as current as I'd like, yes
15:32 <cyphermox> fwiw, based on the uploads I've reviewed, I'm +0 on this application; I think there isn't much more necessary to make me +1; but there are quite few uploads in general
15:32 <cyphermox> that said; the cloud packageset is special in that AFAIK, it doesn't change much
15:33 <rcj> And packages like walinuxagent are specific to the environments we directly support
15:34 <cyphermox> cloud-init though has been +1d by smoser.
15:34 <rbasak> I'm afraid I'm currently -1
15:35 <rbasak> We haven't gotten to asking you questions about general Ubuntu development knowledge.
15:35 <rbasak> But at a minimum I usually expect to see recent sponsored uploads.
15:36 <rbasak> Is there any reason this case is exceptional? Are you having any difficulty in finding sponsors, for example?
15:38 <rcj> We are having some troubles and I was asked to bring this forward.  When my uploads were more current I had been told to hold off.
15:38 <cyphermox> rcj: how come? seems to me like you could ask just about anyone in your team.
15:38 <cyphermox> (such as me, I sponsor lots of stuff)
15:40 <rcj> cyphermox: Yes, including the larger team helps.  The desire is to have an additional person with PPU on the cloud delivery team as well.
15:41 <cyphermox> right
15:41 <rbasak> That's definitely a worthwhile goal.
15:42 <rbasak> But the way to achieve that is to have you work with a sponsor for a while, so that we can be confident that you understand the details for this particular set of packages.
15:42 <rcj> I can take this back, work on additional sponsored uploads, and bring it forward with further endorsements.
15:43 <rbasak> I think even one endorsement is fine, if that sponsor has been working with you closely and recently on a representative sample of the work.
15:44 <rcj> Thank you for the feedback.
15:44 <cyphermox> rcj: thanks for coming up rcj
15:44 <cyphermox> rcj: as previously mentioned, I'm always available to sponsor uploads
15:45 <cyphermox> there are no Contributing Developer applications; so moving on
15:45 <rcj> cyphermox: Thank you.
15:45 <cyphermox> #topic MOTU applications
15:45 <cyphermox> #subtopic cpaelzer's MOTU application
15:45 <bdmurray> rcj: I'm happy to be your second choice too
15:45 <cpaelzer> sorry, was trying to discuss dpek/libvirt issues - back with you
15:46 <cpaelzer> https://wiki.ubuntu.com/ChristianEhrhardt/MOTU-nis-pg-more-Application
15:46 <cpaelzer> essentially I got to file the request for the postgres tools around PG itself, but it pops up in many regular tasks
15:47 <cpaelzer> nis was one example but this is so old I hope nobody has to touch it too often
15:47 <cpaelzer> but in general MOTU things showed up in our server bug triage sometimes
15:47 <cpaelzer> when bugs start at server packages but solutions grow out of there
15:47 <cpaelzer> also on bug squashing day activities I hit a few
15:47 <cpaelzer> and finally on patch piloting
15:47 <cpaelzer> which by the needs a calendar update
15:48 <rbasak> I recall a few of these.
15:48 <cpaelzer> is anybody taking at least the scheduling over from daniel?
15:48 <rbasak> As well as pg-*, there's also dovecot-antispam for example.
15:48 <cpaelzer> right that as well
15:48 <rbasak> So I think it's about time we just gave cpaelzer MOTU so he doesn't need to keep getting exceptions.
15:48 <cpaelzer> as I said it seems the server-work grows out of the server upload set the deeper I get into working with all of this
15:49 <cpaelzer> and this lead me to this MOTU applications with these explicit examples, but it might jsut as well another package next week
15:49 <cpaelzer> the former PPUs where core-dev + personal - so they didn't apply as MOTU exception
15:50 <cyphermox> what about some of the sponsored packages; do you have endorsements from xnox or nacc to go along with them?
15:50 <cyphermox> rbasak: same story; why not write an endorsement for cpaelzer?
15:50 * nacc wasn't asked or forgot if he was :)
15:51 <cpaelzer> I didn't collect all of them for endorsement - we might ping them if you want
15:51 <nacc> happy to do it, but probably not during the meeting right now
15:51 <bdmurray> i thought there were some endorsements on his core dev app
15:51 <cpaelzer> bdmurray: yes, there were from when we downgraded it about a year ago
15:51 <cpaelzer> I also started collecting core-dev reasoning bug work, but the list isn't long enough yet to show up here with that yet
15:51 <cyphermox> well, in that case, why aren't we reviewing a core-dev application?
15:52 <cpaelzer> you can decide the track record or not, I can paste the list of this year
15:52 <cpaelzer> I only started in late January
15:52 <rbasak> cyphermox: I wasn't asked, but I'm happy to provide the same IRC endorsement as I did above.
15:52 <cpaelzer> bug 1675770 lvm more than 8 stripes
15:52 <ubottu> bug 1675770 in lvm2 (Ubuntu) "lvcreate cannot use more than 8 stripes" [High,Fix released] https://launchpad.net/bugs/1675770
15:52 <cpaelzer> bug 1668093 openssh ssh-keyscan -H clobber
15:52 <ubottu> bug 1668093 in openssh (Ubuntu Yakkety) "ssh-keygen -H corrupts already hashed entries" [High,Fix committed] https://launchpad.net/bugs/1668093
15:52 <cpaelzer> bug 1670745 openssh ssh-keyscan port
15:52 <ubottu> bug 1670745 in openssh (Ubuntu Yakkety) "ssh-keyscan : bad host signature when using port option" [Undecided,Fix committed] https://launchpad.net/bugs/1670745
15:52 <cpaelzer> bug 1673491 libnl crash
15:52 <ubottu> bug 1673491 in libvirt (Ubuntu) "[Zesty] libnl3 Segmentation fault in sriov environments" [Undecided,New] https://launchpad.net/bugs/1673491
15:52 <cpaelzer> bug 1630516 logrotate fails to overwrite
15:52 <ubottu> bug 1630516 in logrotate (Ubuntu Yakkety) "Logrotate doesn't clean old system logs, allowing them to fill the disk" [High,In progress] https://launchpad.net/bugs/1630516
15:52 <cpaelzer> in case you want to check a few
15:52 <rbasak> I'm talked to cpaelzer about core dev before.
15:53 <rbasak> Back then I wasn't sure if he had enough wide ranging stuff.
15:53 <cyphermox> rbasak: I feel we're wasting time if there are already sufficient endorsements for core-dev and the work to show for it; then we might as well review a core-dev application; if all the DMB members here agree.
15:54 <rbasak> I don't think cpaelzer has dealt with everything a core dev might have to deal with, for example a transition.
15:54 <rbasak> In the past, that was holding me back from recommending that he apply for core dev.
15:54 <cyphermox> ok, in that case, are we ready to vote?
15:54 <rbasak> But I think I've reached the stage now that I'd be happy to endorse him anyway. He's very active in uploading, not being able to upload stuff tends to block him, and he's careful and diligent.
15:55 <rbasak> I'm sure he knows more about library ABI matters than I do, and I supposedly have handled transitions.
15:55 <cyphermox> we need to try to hold everyone to the same standard though; if anybody else had not done a transition, would you support a core-dev application?
15:55 <cpaelzer> DPDK forces me to do so on that end
15:56 <cpaelzer> btw I brought the hopefully final fix to that upstream - no next merge we will finally have saner ABI in that
15:56 <cyphermox> given time constraints, we should vote now if nobody has questions
15:56 <rbasak> No further questions.
15:56 <cpaelzer> and I'll soon work with nacc on PG transition into aa so I'll get guided through my first one
15:57 <rbasak> Sorry, I missed your question
15:57 <cyphermox> #vote cpaelzer to join  MOTU
15:57 <meetingology> Please vote on: cpaelzer to join  MOTU
15:57 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:57 <rbasak> +1
15:57 <meetingology> +1 received from rbasak
15:57 <cyphermox> +1
15:57 <meetingology> +1 received from cyphermox
15:57 <cyphermox> bdmurray: ?
15:58 <cyphermox> he might have had to leave
15:58 <rbasak> if anybody else had not done a transition, would you support a core-dev application> yes, if there was enough material to weigh up to a +1.
15:58 <sil2100> I think I saw sufficient for MOTU, so:
15:58 <sil2100> +1
15:58 <meetingology> +1 received from sil2100
15:59 <cyphermox> I pinged infinity, just in case.
15:59 <rbasak> While we're waiting...
16:00 <cyphermox> yeah?
16:00 <rbasak> cpaelzer tends to fix things that he touches, and I haven't seen evidence that he's ever made an error that an existing core dev wouldn't make.
16:00 <bdmurray> sorry, +1 for MOTU
16:00 <cyphermox> cool
16:00 <rbasak> And he's very active across the archive.
16:00 <cyphermox> rbasak: I know
16:00 <cyphermox> at this point it's more trying to finish the meeting than anything else given that bdmurray could only stay for an hour
16:01 <rbasak> So I think that perhaps outweighs my "no transition" point in a way that other applicants haven't convinced me in the past.
16:01 <rbasak> Sure
16:01 <cyphermox> +1
16:01 <meetingology> +1 received from cyphermox
16:01 <cyphermox> #endvote
16:01 <meetingology> Voting ended on: cpaelzer to join  MOTU
16:01 <meetingology> Votes for:3 Votes against:0 Abstentions:0
16:01 <meetingology> Motion carried
16:01 <rbasak> The 4th was from bdmurray and hadn't registered with meetingology I think?
16:01 <cyphermox> (bdmurray's +1 is above but didn't register because it wasn't the first thing on the line)
16:01 <bdmurray> yeah, my bad
16:01 <rbasak> I'd be happy to take the post-meeting actions for cpaelzer
16:01 <rbasak> Perhaps easiest as he's on my team?
16:01 <cyphermox> ack
16:02 <cyphermox> [ACTION] rbasak to handle cpaelzer's upload rights modifications
16:02 * meetingology rbasak to handle cpaelzer's upload rights modifications
16:02 <cpaelzer> thanks everybody
16:02 <cyphermox> no SRU or core-dev applications
16:02 <rbasak> I had a couple of items for AOB.
16:02 <cyphermox> anythign outstanding on the mailing list first?
16:02 <rbasak> Ah, that was one of those.
16:03 <cyphermox> we can make it AOB
16:03 <cyphermox> #topic AOB
16:03 <rbasak> Iulian Udrea "Reactivation of ~iulian's membership in ~motu"
16:03 <bdmurray> I've got to get moving but will read scrollback.
16:03 <rbasak> Does this need a majority vote?
16:03 <rbasak> bdmurray: thank you for attending!
16:03 <cyphermox> does what need?
16:03 <cyphermox> iulian's request?
16:03 <rbasak> Yes
16:03 <sil2100> Do we have a policy for such things?
16:04 <sil2100> I know for short deprecations we just 'did it'
16:04 <cyphermox> I think we should just do it
16:04 <rbasak> Do we know how long his break is?
16:04 <rbasak> I think we should at the least understand when and why the membership ceased.
16:05 <cyphermox> * Iulian Udrea (~iulian) expired from motu (on 2017-01-04)
16:06 <cyphermox> I don't know whether he has core-dev before that expired earlier, but he's also still in motu-release (assuming this is still useful)
16:06 <rbasak> Ah
16:06 <rbasak> That's fine then I guess.
16:06 <cyphermox> I also do have AOB, but it's a FYI only
16:06 <rbasak> My other team was on my email "Ordering of decisions to create a packageset and a first uploader"
16:06 <cyphermox> ~langpack-uploader was showing up in the team monitoring emails; I fixed that to be skipped
16:07 <rbasak> I'd like to achieve consensus on that, but nobody has replied.
16:07 <rbasak> My other item
16:07 <cyphermox> I think doing the work doesn't need to happen until it really does (ie there is an uploader), but we can still vote and approve a packageset before there are uploaders.
16:08 <rbasak> Define "approve a packageset" please.
16:08 <cyphermox> voting for it; deciding that it makes sense.
16:08 <rbasak> For Budgie, would that mean "#vote A packageset defined as "Ubuntu Budgie" will be created?
16:08 <rbasak> "
16:09 <cyphermox> rbasak: I don't think that one is a good example
16:09 <rbasak> Or anything more extensive?
16:09 <rbasak> Well, that's the one where we ended up in a twist.
16:09 <cyphermox> the Ubuntu Budgie packageset should be an automatic seed-based one.
16:09 <cyphermox> otherwise a "PPU" kind of packageset for a subset of those, which is what David was asking for previously.
16:11 <cyphermox> in that case, it probably needs that that decision be informed by both what will go in that packageset initially, what it's used for (there might be a better way to do things) and whether the person asking for it is likely to have their application approved; as if they don't, then someone else or the same person might ask for something quite different later.
16:11 <cyphermox> but all this is probably best left for the mailing list.
16:11 <rbasak> Please do reply to the mailing list.
16:12 <cyphermox> is this all?
16:13 <rbasak> That's all I had, thanks.
16:13 <cyphermox> cool. I think that's it for this meeting then
16:13 <cyphermox> #endmeeting