16:00 <powersj> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Feb 28 16:00:17 2017 UTC.  The chair is powersj. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <rharper> \o
16:00 <powersj> I'll wait a moment to get a few more folks
16:00 * jgrimm waves, but not paying attention. in another meeting
16:01 <nacc> \o
16:01 <rbasak> o/
16:01 <powersj> alright let's get started
16:01 <powersj> #topic Review ACTION points from previous meeting
16:02 <powersj> nacc to review jgrimm's openvpn MR
16:02 <nacc> i believe that's done
16:02 <jgrimm> merged, done
16:02 <powersj> great! next...
16:02 <powersj> jgrimm to review server packages for anything new (or missed) that needs merging
16:03 <jgrimm> ongoing. mark done
16:03 <powersj> he may be busy as he said... I can follow up after
16:03 <powersj> ah ok :)
16:03 <powersj> one more...
16:03 <powersj> rbasak to look at seeding iotop & nicstat with powersj
16:03 <powersj> done!
16:03 <rbasak> \o/
16:03 <nacc> let's release already :)
16:03 <nacc> we're so done
16:03 <powersj> all action points done :D
16:03 <rharper> heh
16:03 <powersj> #topic Zesty Development
16:03 <powersj> #link https://wiki.ubuntu.com/ZestyZapus/ReleaseSchedule
16:03 <powersj> #subtopic blueprints
16:04 <powersj> #https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:04 <powersj> I see 7 inprogress
16:04 <powersj> any updates here?
16:05 <nacc> excuses is a lot clearer now -- still working through some updates, but i think our bigger packages are through, except for openldap
16:05 <rbasak> Don't forget to keep minuting things - easy to forget :)
16:05 <powersj> cool!
16:05 <powersj> ah yes
16:06 <nacc> i'll do another sweept today -- my current unknown blocker is the log4ada regression
16:06 <powersj> #info blueprint is looking good, big stuff done, except openldap
16:06 <powersj> #subtopic Release Bugs
16:06 <powersj> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:07 <powersj> Anything of note here? nacc you are only one with something, 2 unassigned
16:07 <nacc> powersj: that is getting deferred to z+1
16:07 <cpaelzer> the libvirt one will be an SRU
16:07 <nacc> i'm workingon setting maas up for it by then
16:07 <cpaelzer> it is super low importance
16:07 <cpaelzer> I might even nack an SRU on a deeper look
16:07 <nacc> cpaelzer: we may want to re-ping the release team on remving src:postgresql-9.6 on irc
16:08 <cpaelzer> oh yeah - ack nacc
16:08 <nacc> cpaelzer: actually, i'll do it today, if htat's ok
16:08 <nacc> need to remove php7.1 as well
16:08 <powersj> #action cpaelzer to ping release team on removing src:postgresql-9.6
16:08 * meetingology cpaelzer to ping release team on removing src:postgresql-9.6
16:08 <cpaelzer> absolutely
16:08 <powersj> oops lol
16:08 <powersj> #undo
16:08 <meetingology> Removing item from minutes: ACTION
16:08 <cpaelzer> nacc: highlight me on the ping and let them know that it is you-or-me to contact
16:08 <cpaelzer> we cover almost all timezones together
16:08 <nacc> cpaelzer: ack
16:09 <powersj> #action nacc to ping release team on removing src:postgresql-9.6 and src:php7.1
16:09 * meetingology nacc to ping release team on removing src:postgresql-9.6 and src:php7.1
16:09 <powersj> any other release bug comments or I'm moving on....
16:09 <powersj> #info looking good, minor issues for libvirt, otherwise covered
16:09 <powersj> #topic Server & Cloud Bugs & SRU/Pending Uploads (caribou)
16:09 <powersj> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:10 <powersj> caribou: any update?
16:10 <caribou> oops, sorry forgot to prepare,just give me a minute
16:10 <powersj> ok :)
16:10 <cpaelzer> I have mine of the week prepped
16:10 <cpaelzer> DONE: Strongswan (X,Y), Multipath (X), Qemu (X,Y,UCA)
16:10 <cpaelzer> INPROG: Qemu (T), Qemu (X,Y), Libvirt (T/X/Y/Z)
16:10 <cpaelzer> The Qemu X/Y is complex and stuck in testing and dev discussions at the moment
16:10 <cpaelzer> The multipath is actually just helping STS so this will be in Caribous list
16:11 <caribou> #info SRU are pending for : ceph, libvirt, sosreport, multipath-tools, python-os-brick, sssd
16:11 <cpaelzer> caribou: can you link me the incoming libvirt SRU?
16:11 <cpaelzer> trusty?
16:12 <caribou> cpaelzer: LP: #1317491
16:12 <ubottu> Launchpad bug 1317491 in libvirt (Ubuntu Trusty) "virsh blockcommit hangs at 100%" [Medium,Fix committed] https://launchpad.net/bugs/1317491
16:12 <cpaelzer> ah yeah I'm on that - thanks
16:12 <powersj> caribou: great, thanks. Any other comments?
16:13 <caribou> powersj: nothing else, no
16:13 <powersj> great
16:14 <powersj> moving on.
16:14 <powersj> #topic Weekly Updates & Questions for the QA Team (powersj)
16:14 <powersj> #link https://jenkins.ubuntu.com/server/
16:14 <powersj> Last week got the JLP merge request in and merged, so we should be able to see cloud-init git based CI in the next week or two. There is a remaining piece of functionality that I do not have done yet though, but not required for our use case.
16:14 <powersj> Lots of changes and modifications to curtin vmtests to make them more stable. I have a list of things I still need to get done and hope to do this week.
16:14 <powersj> Worked with Christian on QEMU migration tests, however finding the LXD is really running into issues now on our main test system even launching a container. See https://github.com/lxc/lxd/issues/2814 I need to get this cleaned up as most of our tests rely on LXD.
16:14 <powersj> questions?
16:14 <cpaelzer> powersj: we can go on using dir instead of zfs for now
16:15 <powersj> cpaelzer: I'd like to avoid that, as it is incredibly slower and makes some other tests time out
16:15 <cpaelzer> powersj: that never has shown the bug - and yes slower sometimes, but better than not at all
16:15 <powersj> true
16:15 <powersj> #info ci for cloud-init coming soon...
16:15 <cpaelzer> actually I have cases wher eit is faster btw, but if we have timeouts on cloud-init/curtin ok
16:15 <powersj> #info lxd issue, slowing down/stopping testing
16:16 <powersj> ok we can play with it after the meeting
16:16 <cpaelzer> ack powersj
16:16 <powersj> I would like to get the lxd guys on the system if possible though to help resolve this
16:16 <cpaelzer> yep I suggested the same last time
16:16 <rharper> sounds like an action
16:17 <powersj> #action powersj to see about getting the lxd team onto torkoal
16:17 * meetingology powersj to see about getting the lxd team onto torkoal
16:17 <powersj> any other questions?
16:17 <powersj> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:18 <powersj> Not sure I see either of them
16:18 <cpaelzer> ping smb he was around
16:19 <cpaelzer> here he is
16:19 <smb> sorry got distracted
16:19 <smb> So, mostly to mention that 4.10 should now be in the zesty archive
16:19 <powersj> #info zesty archive should have 4.10
16:20 <powersj> awesome, thank you!
16:20 <rharper> smb: I filed a bcache bug last week
16:20 * rharper finds
16:20 <smb> rharper, have not seen it, maybe you could subscribe me
16:21 <rharper> smb: ok
16:21 <cpaelzer> ah kernel
16:21 <cpaelzer> FYI - debugged a regression mainline 3.18.22-031822.201510031227 to mainline 3.18.21-031821.201509020527 today. Covers all that crosses that like Trusty -> Xenial.
16:21 <cpaelzer> TL;DR for server raid arrays there might be a performance regresssion, read bug 1668557 if yu need details and a tuning fix.
16:21 <ubottu> bug 1668557 in linux (Ubuntu) "Write performance regression severely affecting hpsa controllers" [Undecided,Invalid] https://launchpad.net/bugs/1668557
16:21 <rharper> bug 1667078
16:21 <ubottu> bug 1667078 in linux (Ubuntu) "bcache device numbers increase by 16" [Medium,Confirmed] https://launchpad.net/bugs/1667078
16:21 <cpaelzer> mine is a kernel fix that "has to stay" but will cause trouble for some upgrades
16:21 <cpaelzer> so for awareness towards smb and caribou
16:21 <rharper> smb: subscribed; thanks
16:22 <smb> rharper, thanks
16:22 <smb> cpaelzer, and also thanks
16:22 <powersj> anything else for kernel?
16:22 <powersj> #topic Upcoming Call For Papers
16:23 <powersj> #link https://lwn.net/Calendar/Monthly/cfp/
16:23 <powersj> I didn't see anything here
16:23 <powersj> anyone have something, otherwise moving on
16:23 <powersj> #info nothing here
16:23 <powersj> #topic Ubuntu Server Team Events
16:23 <powersj> not aware of anything here either
16:23 <powersj> #info nothing here
16:24 <powersj> #topic Open Discussion
16:24 <powersj> *crickets*
16:25 <powersj> anything? otherwise I'll end this
16:25 <cpaelzer> ah
16:25 <cpaelzer> here
16:25 <powersj> ah :)
16:25 <cpaelzer> I was triaging a lot recently and I wondered if it might be worth to have a nginx-triaging-style page also for mysql
16:25 <cpaelzer> rbasak: ^^
16:25 <cpaelzer> (I know he is not here)
16:25 <powersj> yes please
16:26 <cpaelzer> it turns out 80% of the bugs are actually different variants of three issues
16:26 <cpaelzer> socket not reachable, user misconfigured, old features enabled that no more work
16:26 <cpaelzer> maybe together we can make it 5 which cover >90%
16:26 <cpaelzer> maybe this could be an actiaon for rbasak, powersj and me
16:26 <cpaelzer> action rather
16:26 <powersj> agreed
16:26 <cpaelzer> make a draft wiki page
16:27 <cpaelzer> and on triaging link to that and be faster so often
16:27 <powersj> #action rbasak, powersj, cpaelzer to draft mysql triage response page like nginx has
16:27 * meetingology rbasak, powersj, cpaelzer to draft mysql triage response page like nginx has
16:28 <cpaelzer> now even I'm silent - I know it is a rare thing :-P
16:28 <powersj> cpaelzer: did you catch nacc up on triaging?
16:28 <cpaelzer> I did not want to say in pub, but yes
16:28 <powersj> well thank you
16:28 <nacc> yes, many thanks to cpaelzer !
16:28 <cpaelzer> ~+15 for ubunut-server to look deeper into
16:28 <powersj> haha
16:29 <cpaelzer> the magical Ubu  Nut - cracking
16:29 <powersj> last call, any other topics?
16:29 <cpaelzer> https://dudleys.files.wordpress.com/2008/02/ubunut.jpg
16:29 <powersj> #topic Announce next meeting date, time and chair
16:29 <cpaelzer> the ubunut
16:29 <powersj> same time, same place, with cpaelzer as chair
16:29 <cpaelzer> damn
16:29 <cpaelzer> ack
16:29 <powersj> o/
16:30 <powersj> #endmeeting