19:15 <rbasak> #startmeeting DMB
19:15 <meetingology> Meeting started Mon Feb 27 19:15:02 2017 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:15 <meetingology> 
19:15 <meetingology> Available commands: action commands idea info link nick
19:15 <rbasak> #topic Review of previous action items
19:15 <chiluk> o/
19:15 <rbasak> cyphermox to handle Sean Davis' xfdashboard packageset request
19:15 <rbasak> cyphermox to refresh Kubuntu packageset
19:15 <rbasak> cyphermox: I think both of those are done?
19:15 <cyphermox> both still todo, hopefully I can get to them later
19:15 <rbasak> Oh, OK.
19:16 <cyphermox> for now I'm fighting maas here.
19:16 <rbasak> #action cyphermox to handle Sean Davis' xfdashboard packageset request (carried over)
19:16 * meetingology cyphermox to handle Sean Davis' xfdashboard packageset request (carried over)
19:16 <rbasak> #action cyphermox to refresh Kubuntu packageset (carried over)
19:16 * meetingology cyphermox to refresh Kubuntu packageset (carried over)
19:16 <rbasak> #topic Ubuntu Contributing Developer Applications
19:16 <rbasak> #subtopic Ross Gammon (rosco2)
19:16 <rbasak> Rosco2: hello!
19:16 <Rosco2> Hi All
19:17 <rbasak> #link https://wiki.ubuntu.com/RossGammon/ContributingDeveloperApplication
19:17 <rbasak> I reviewed Ross' previous application earlier.
19:17 <rbasak> Looking for the link
19:18 <rbasak> #link https://irclogs.ubuntu.com/2016/08/01/%23ubuntu-meeting.html#t15:21
19:19 <rbasak> Does anyone have any further questions for Rosco2?
19:19 <micahg_mobile> I'm wondering what has changed
19:20 <micahg_mobile> I see comments now, but I don't see any uploads past October
19:20 <cyphermox> well, his last meeting was in august.
19:21 <bdmurray> okay, but 3 uploads since august doesn't seem like enough to show significance.
19:21 <micahg_mobile> 3 uploads in 6 months isn't significant and sustained contribution IMHO
19:21 <Rosco2> No uploads recently - but some waiting for sponsorship
19:22 <cyphermox> I'm not saying it necessarily meets the guidelines, just that there exists uploads since last review.
19:23 <micahg_mobile> Rosco2: you're also already an Ubuntu member, so this status won't confer any additional rights
19:23 <rbasak> Rosco2: have you had any other development activity you can call out apart from uploads and uploads pending sponsorship?
19:24 <Rosco2> Well this year so far in Ubuntu has mainly been about releases
19:24 <micahg_mobile> Not that Contributing dev isn't a nice badge of honor as well, but just wanted to point that out
19:24 <Rosco2> I have been ISO testing for point releases & Zesty Beta 1
19:25 <rbasak> I see 15 uploads in all and two in the sponsorship queue.
19:25 <rbasak> Latest thing in the sponsorship queue is dated 21 Feb
19:25 <Rosco2> There are also a few backports that have gone stale that I need to get back to
19:27 <rbasak> Any other questions for Rosco2?
19:28 <rbasak> #vote Grant Rosco2 Contributing Developer
19:28 <meetingology> Please vote on: Grant Rosco2 Contributing Developer
19:28 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:28 <rbasak> +1
19:28 <meetingology> +1 received from rbasak
19:28 <micahg_mobile> +1
19:28 <meetingology> +1 received from micahg_mobile
19:29 <rbasak> I think the number of uploads, even if over a long period of time and not very dense currently, adds up to significant enough. I appreciate your contributions.
19:29 <rbasak> Especially as Set, Timo and Daniel all appear happy with your work.
19:29 <micahg_mobile> Ditto
19:29 <Rosco2> thanks
19:30 <cyphermox> +12
19:30 <meetingology> +12 received from cyphermox
19:30 <cyphermox> ugh
19:30 <cyphermox> +1, obviously.
19:30 <meetingology> +1, obviously. received from cyphermox
19:30 <bdmurray> I guess I don't need to vote then
19:30 <bdmurray> but I will anyway
19:30 <bdmurray> +1
19:30 <meetingology> +1 received from bdmurray
19:30 <rbasak> #endvote
19:30 <meetingology> Voting ended on: Grant Rosco2 Contributing Developer
19:30 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:30 <meetingology> Motion carried
19:31 <rbasak> Congratulations Rosco2 and thank you for your contributions.
19:31 <rbasak> Can someone volunteer to sort that and announce it please?
19:31 <Rosco2> Your'e welcome. Tanks for your time everyone
19:32 <rbasak> #action rbasak to add Rosco2 to the contributing developer team
19:32 * meetingology rbasak to add Rosco2 to the contributing developer team
19:32 <rbasak> #action rbasak to announce Rosco2's new contributing developer team membership
19:32 * meetingology rbasak to announce Rosco2's new contributing developer team membership
19:32 <rbasak> #topic SRU uploader proposal
19:32 <rbasak> #link https://lists.ubuntu.com/archives/ubuntu-devel/2017-February/039690.html
19:32 <rbasak> My position is a +1 already obviously.
19:33 <bdmurray> rbasak: Do you expect people to already have some upload rights before applying to this new team? If so what kind?
19:33 <rbasak> To the other board members: opinions? Objections? Anything I can address before a vote?
19:33 <rbasak> bdmurray: no, I expect new members of this team to be uploading directly for the first time by joining it.
19:34 <chiluk> rbasak that's why it's a great idea ^^
19:34 <rbasak> Right, as a stepping stone.
19:34 <bdmurray> rbasak: directly uploading for the first time to main / restricted?
19:34 <rbasak> bdmurry: yes. But in stable releases only, for things that meet SRU policy only.
19:34 <sarnold> rbasak: as a member of the security team but not core-dev I've got similar privileges; it's a bit strange to have privileges to push updates to ~25M machines but not to check in changes to -devel. But it'd be far more annoying to have to go through patch piloting for every change..
19:34 <rbasak> bdmurray sorry :)
19:35 <micahg_mobile> Sarnold, that was a loophole I meant to address several years ago :)
19:35 <sarnold> micahg_mobile :)
19:35 <bdmurray> I guess I have concerns as an SRU team member about keeping up with the volume of reviews. Its some what challenging as it is.
19:36 <rbasak> bdmurray: I do expect the DMB to grant this only to applicants who have shown that they understand SRU policy and procedure by having a good track record of doing these things. And there would be a second sanity check through the SRU team anyway. But if there's any concern that an applicant will bother the SRU team, I'd expect that application to be refused.
19:36 <chiluk> bdmurray.. .ubuntu-sru team would still have to approve the upload.
19:36 <tinoco> bdmurray: it would be the same amount since our case load wouldn't change
19:36 <bdmurray> tinoco: its not just a team for you though, anybody could apply to join it.
19:36 <rbasak> bdmurray: it might also be reasonable to expect endorsements for the SRU team and refuse an application if there aren't any. I hadn't considered that before.
19:36 <micahg_mobile> Bdmurray: I brought that up at the last meeting and was told the load would be the same
19:37 <rbasak> micahg_mobile: yeah that's MHO.
19:37 <tinoco> you can control the load with the amount of people you approve. controlling bottleneck in the sru team if needed.
19:37 <rbasak> I don't see any reason why this would open the floodgates to the SRU team.
19:38 <micahg_mobile> I can forsee such a case :)
19:38 <rbasak> Currently the demand comes from Canonical STS who are getting their SRU requests sponsosred anyway
19:39 <rbasak> Uploads under this scheme would either be acceptable to the SRU team, or not.
19:39 <rbasak> If they're acceptable, then we should be taking them and growing the SRU team even if it does increase workload. Why should we be turning down good SRU contributions?
19:39 <bdmurray> I don't think saying "we can't have more people in the team because the SRU team is overloaded" is fair
19:39 <rbasak> If they're not acceptable, then I'm proposing that we don't grant membership of this team to such applicants.
19:39 <micahg_mobile> Yeah, but once we compress the feedback window by eliminating sponsorship, there's the potential to start throwing more fixes in
19:40 <rbasak> micahg_mobile: that's true, but that's a good thing surely?
19:40 <bdmurray> Will there be a way for an SRU team member to request removal of somebody from the team?
19:40 <rbasak> bdmurray: who do you think is saying that?
19:41 <rbasak> request removal> I'm not sure the DMB has ever had to do that before, but if it came up, it would presumably be the DMB who would handle it.
19:41 <rbasak> (and I think we have the remit)
19:41 <bdmurray> tinoco said "you can control the load with the amount of people you approve"
19:41 <rbasak> Ah, OK.
19:41 <tinoco> bdmurray: totally agree on what you are saying
19:42 <rbasak> I'd take a request to have someone removed from any uploading team quite seriously.
19:42 <bdmurray> If there is a way for the SRU team to get people removed I'd feel better. Although the SRU team would need a way to keep track of rejections I guess.
19:42 <rbasak> And perhaps the DMB should deal with that in private or something.
19:43 <rbasak> But given the SRU team have to review everything anyway, it would make no sense for the DMB to refuse to remove someone the SRU team want removed.
19:43 <rbasak> So how about:
19:44 <rbasak> 1) We expect SRU team endorsement on any application.
19:44 <rbasak> 2) The SRU team can ask for any SRU uploader to be removed.
19:44 <rbasak> s/expect/require/ if you prefer.
19:45 <rbasak> Whether the SRU team think any single SRU team member should be able to request removal, or it needs a majority, or what, could perhaps be entirely up to them.
19:46 <rbasak> By "can ask for" I mean "the DMB will do it".
19:46 <micahg_mobile> It should be either a majority of the SRU team or DMB votes (or both)
19:47 <bdmurray> The SRU team is rather large so majority seems like a lot to me.
19:47 <micahg_mobile> Ok, I just want some checks here
19:47 <rbasak> Taking off my SRU team hat for a moment, I was thinking of leaving how they want to resolve their decision as up to them.
19:48 <micahg_mobile> DMB vote is fine even if 1 person requests the DMB to review
19:49 <rbasak> Let me write this down: http://pad.ubuntu.com/m9xRiL8pyP
19:52 <rbasak> How does that look? Does that cover all options that have been proposed?
19:53 <bdmurray> I don't think "requires" SRU team member endorsement is necessary.  SRU sponsor would be fine.  Its harder to find the SRU accepter than it is the SRU sponsor.
19:54 <bdmurray> As an SRU team member I don't recall good uploads rather its the rejects I remember more.
19:55 <bdmurray> I'd also like to see members of this ubuntu-sru-uploaders team not leave stuff languishing in -proposed.
19:55 <bdmurray> The pending-sru report is full of sadness.
19:56 <slashd> bdmurray, most of our work in STS requires to SRU to be Fix Release before we close the support ticket with customer
19:56 <slashd> so it won't be a problem for us
19:57 <chiluk> bdmurray, so that's an additional permission bit... promotion from -proposed -> -updates... are you proposing that ubuntu-sru-uploader have those rights?
19:57 <bdmurray> chiluk: No, I'm saying verify your uploads if nobody else does.
19:57 <tinoco> chiluk: i believe he said for us to verify things more quickly.
19:58 <slashd> chiluk, I think he is talking about the verification-done step
19:58 <micahg_mobile> I agree with bdmurray on the endoresements piece
19:58 <micahg_mobile> And rbasak on how a member should be removed
19:59 <slashd> bdmurray,rbasak, Does this potential sru-uploader team would be able to nominate bugs for release without approval ?
19:59 <rbasak> slashd: I think that's a separate issue.
19:59 <slashd> rbasak, ack
19:59 <rbasak> And doesn't really fall under the DMB.
20:00 <rbasak> It's a bug squad/bug control thing.
20:00 <slashd> ok, disregard my last comment then
20:00 <rbasak> We should still address that, but not at the DMB.
20:00 <bdmurray> rbasak: it might just work with the acl
20:00 <rbasak> I'm hoping so :)
20:01 <rbasak> cyphermox: opinions?
20:01 <chiluk> rbasak, i'm part of both bug control and bug squad teams, and don't have permission to approve nominated releases...
20:01 <rbasak> chiluk: I'm aware :)
20:01 <chiluk> rbasak do you know what team I'm missing?
20:01 <rbasak> chiluk: I believe you get it if you can upload the package.
20:01 <rbasak> But let's talk about that another time.
20:02 <rbasak> Back to the pad
20:02 <rbasak> For joining, I'm happy to not require 2 either.
20:02 <bdmurray> upload the package or member of a special ubuntu-release-nominators team
20:03 <micahg_mobile> Uploader rights for the package or there are two other teams I think, ubuntu-release and I thought we made one team that didn't have other rights attached to it
20:03 <micahg_mobile> That's it
20:04 <rbasak> bdmurray, micahg_mobile: how does the pad look for you now? Are you comfortable with what we have now?
20:04 <bdmurray> Can we resolve line 1?
20:04 <rbasak> Good point.
20:05 <rbasak> I'm happy either way.
20:05 <micahg_mobile> Yeah, I think it is fine
20:05 <rbasak> I guess that means I say "expected".
20:06 <rbasak> But if someone wants to tighten it to "requires" I'm fine with that.
20:06 <bdmurray> That's what I expect
20:06 <rbasak> Now that's a confusing statement :-)
20:06 <rbasak> You expect someone to tigthen it to "requires"? :-P
20:06 <bdmurray> I expect it to say excpet not requires
20:07 <rbasak> OK I'll change it.
20:07 <rbasak> And let me take out 2, since we seem to have some consensus it isn't required.
20:09 <rbasak> cyphermox: ?
20:10 <cyphermox> sorry, I'm busy
20:11 <rbasak> OK
20:12 <rbasak> micahg_mobile, bdmurray: are you +1 on the current pad?
20:12 <bdmurray> yes
20:13 <micahg_mobile> Yes
20:13 <rbasak> Great, thanks! I guess there's no need for a formal meetingology vote for the sake of it.
20:13 <rbasak> We'll need one more +1.
20:13 <rbasak> Shall we move on and let the others vote offline?
20:14 <rbasak> I will copy the pad, clean up and post it to the thread.
20:14 <micahg_mobile> Rbasak: Shows up in the meeting logs as a vote :)
20:14 <rbasak> #topic Expiring DMB members
20:15 <micahg_mobile> Can we change members to membership please?
20:15 <rbasak> micahg_mobile: you mean line 11
20:15 <rbasak> ?
20:15 <micahg_mobile> Current topic :)
20:16 <rbasak> #topic Expiring DMB membership
20:16 <rbasak> cyphermox pointed out that his membership expires soon
20:16 <rbasak> 2015-03-02
20:16 <cyphermox> yep, in 4 days
20:16 <cyphermox> FWIW, +1 on the SRU proposal from me
20:16 <rbasak> Oh great, thanks. Then it's done :)
20:16 <rbasak> \o/
20:17 <rbasak> s/2015-03-02/2017-03-01/
20:17 <cyphermox> ... or less than four days
20:17 <rbasak> Yeah, so we need to organise nominations and a vote for cyphermox's seat, right?
20:17 <rbasak> cyphermox: are you intending to stand again?
20:17 <micahg_mobile> I think the first thing would be to ask the TB to extend cyphermox's membership 4 weeks so we can hold an election
20:17 <cyphermox> rbasak: I'm not sure.
20:18 <rbasak> micahg_mobile: that sounds reasonable. Everyone happy with that?
20:18 <bdmurray> +1 for the extension
20:18 <bdmurray> Doesn't Adam expire this year too?
20:19 <rbasak> #agreed The DMB will ask the TB to extend cyphermox's membership 4 weeks so we can hold an election
20:19 <rbasak> Yes, 2017-08-03
20:19 <rbasak> Should we hold an election early for that seat too, or wait?
20:19 <cyphermox> ask infinity?
20:19 <bdmurray> I guess it is 5 months
20:19 <micahg_mobile> His membership expires in August, we could seek 2 now and have the second one's term start in August
20:20 <rbasak> I'm fine either way
20:20 <rbasak> Also, would it be an idea to adjust term lengths to get those two seats lined up?
20:20 <bdmurray> Are we excluding anybody by holding the election early?
20:20 <rbasak> Just to save admin in the future. I don't think anyone will care about the length adjustments, will they?
20:21 <micahg_mobile> 18 months or so for the second one I guess
20:22 <rbasak> Yeah that sounds right
20:22 <rbasak> OK so two things
20:23 <rbasak> 1) Hold an election for infinity's seat now, together with cyphermox's seat.
20:23 <rbasak> 2) Shorten infinity's seat's next term to coincide expiry with cyphermox's seat's next term.
20:24 <rbasak> Presumably we'd hold the usual ranked CIVS thing and give the top result the longer immediate seat, and the second result the shorter delayed seat?
20:24 <rbasak> Everyone happy with that?
20:24 <bdmurray> 0) ask for extension for cyphermox
20:25 <rbasak> Yep
20:25 * rbasak minuted that already :)
20:25 <rbasak> I thought that was uncontroversial :)
20:26 <bdmurray> okay
20:26 <rbasak> cyphermox? micahg_mobile?
20:27 <cyphermox> heh, either way is fine by me
20:29 <slashd> rbasak, with regard to the sru-uploader team ... what are the next steps ? Do you guys need more votes or we can already say it is officially approved ?
20:32 <slashd> and when do you think ppl can start applying for this new team ?
20:33 <rbasak> slashd: I'll sort it on the mailing list afterwards.
20:33 <slashd> rbasak perfect, tks
20:33 <slashd> tks all for your time about this subject
20:35 <micahg_mobile> Rbasak, I'm good with that
20:36 <rbasak> Great, thanks!
20:36 <rbasak> Any volunteers to sort it out?
20:38 <bdmurray> which thing?
20:38 <bdmurray> If its the SRU team thing could we break up the tasks?
20:38 <rbasak> The three things - extending cyphermox's term, organising the vote, announcing the adjustment of terms, etc.
20:39 <rbasak> I'm happy to take sorting out the SRU team thing.
20:39 <bdmurray> I guess we can't make cyphermox do it
20:39 <bdmurray> So I'll do it
20:40 <rbasak> Thank you!
20:41 <rbasak> #action bdmurray to sort out votes and related items in respect of the two upcoming expiring DMB memberships
20:41 * meetingology bdmurray to sort out votes and related items in respect of the two upcoming expiring DMB memberships
20:41 <rbasak> #action rbasak to sort out the SRU uploaders team
20:41 * meetingology rbasak to sort out the SRU uploaders team
20:41 <rbasak> #topic Any other business
20:41 <rbasak> Anything else to raise?
20:41 <chiluk> rbasak.. my core dev application status?
20:41 <rbasak> Let me check.
20:42 <chiluk> thanks.
20:42 <bdmurray> I may have replied privately not publicly.
20:43 <rbasak> So there was no vote from anyone at the IRC meeting, correct?
20:44 <chiluk> rbasak not that I recall ...
20:44 <micahg_mobile> I'm sorry, I thought that was addressed in the last meeting, but I don't remember the conclusion
20:45 <rbasak> I count +1s from sil2100, BenC and cyphermox.
20:46 <rbasak> bdmurray: I don't see a private or public vote from you, nor from Adam.
20:46 <bdmurray> rbasak: looking
20:46 <rbasak> And I had deferred for the ~ubuntu-sru-uploader topic. Now that is resolved, I need to look again, but I suspect the reason I did that was because I felt that would be more appropriate.
20:46 <rbasak> But I'll give myself an action to look again properly.
20:47 <bdmurray> I see a sent mail about it
20:49 <rbasak> #action rbasak to vote on chiluk's core dev application
20:49 * meetingology rbasak to vote on chiluk's core dev application
20:49 <bdmurray> resent it
20:50 <rbasak> Ah
20:50 <rbasak> I see it.
20:50 <rbasak> In that case, I don't need to do anything :)
20:50 <rbasak> #undo
20:50 <meetingology> Removing item from minutes: ACTION
20:50 <rbasak> chiluk: congratulations :)
20:50 <chiluk> WOOHOO!
20:50 <chiluk> thanks guys.
20:51 <rbasak> Now this one we _can_ give to cyphermox :-)
20:51 <rbasak> #action cyphermox to add chiluk's core dev membership
20:51 * meetingology cyphermox to add chiluk's core dev membership
20:51 <rbasak> #action cyphermox to announce chiluk's core dev membership
20:51 * meetingology cyphermox to announce chiluk's core dev membership
20:51 <rbasak> cyphermox: seems only fair as bdmurray is handling your seat :-)
20:51 <rbasak> OK. AOAOB?
20:52 <rbasak> I guess we're done then!
20:52 <rbasak> Thank you all for your patience. Long meeting!
20:52 <rbasak> #endmeeting