16:03 <slangasek> #startmeeting
16:03 <meetingology> Meeting started Thu Jan 19 16:03:48 2017 UTC.  The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03 <meetingology> 
16:03 <meetingology> Available commands: action commands idea info link nick
16:03 <cyphermox> kind of wondering why that's required for audio?
16:04 <slangasek> chiluk: able to /initiate/ it from the OS, I think you mean :)
16:04 <xnox> chiluk, but it kind of does reboot system into the UEFI egg, hence can't do anything
16:04 <slangasek> [TOPIC] lightning round
16:04 <slangasek> $ echo $(shuf -e barry doko bdmurray slangasek caribou infinity sil2100 robru cyphermox tdaitx xnox chiluk mwhudson)
16:04 <gaughen> o/
16:04 <slangasek> barry caribou infinity doko mwhudson xnox chiluk slangasek tdaitx bdmurray robru cyphermox sil2100
16:04 <chiluk> oh yeah forgot about that xnox.. still slick.
16:04 <barry> win!
16:04 <sil2100> Damn, I won...
16:04 <barry> no meeting last week, so 2-week status
16:04 <barry> python-webencodings 0.5-2; python-persistent 4.2.2-1; various other debian things; html5lib/python-bleach regressions - will be looking at proposed branch to regress html5lib to seven-9s version (test w/pip); python-pip 9.0.1-2 (fixes python3.6 compat); python-mode 1:6.2.3-1
16:04 * sil2100 hates being last, needs to wait so long for his turn
16:05 <barry> network-manager still has not promoted due to systemd regression; looked at LP: #1647031 (still cannot reproduce locally due to kvm crash *inside* virt-qemu); i think this is not related to network-manager but a more general systemd regression (i think pitti confirmed)
16:05 <ubottu> Launchpad bug 1647031 in systemd (Ubuntu) "systemd-resolved’s 127.0.0.53 server does not follow CNAME records" [High,Triaged] https://launchpad.net/bugs/1647031
16:05 <chiluk> way better than lenovo that requires a CD-ROM... *(seriously I tried a usb stick).
16:05 <barry> ubuntu-image: released 0.14 to subsume 0.13; contains several autopkgtest fixes; still need to q/a the SRUs & snap; LP: #1650402; LP: #1655735; various housekeeping; LP: #1656371; LP: #1656391;
16:05 <ubottu> Launchpad bug 1650402 in Ubuntu Image "Add CI for Python 3.6" [Medium,Fix committed] https://launchpad.net/bugs/1650402
16:05 <ubottu> Launchpad bug 1655735 in linux (Ubuntu) "Incompatible libdevmapper 1.02.136 (2016-11-05) and kernel driver (unknown version)." [High,Incomplete] https://launchpad.net/bugs/1655735
16:05 <ubottu> Launchpad bug 1656371 in Ubuntu Image "Sparse file unittests fail on zfs" [High,Fix committed] https://launchpad.net/bugs/1656371
16:05 <ubottu> Launchpad bug 1656391 in Ubuntu Image "mount autopkgtest failure in lxc container" [Critical,Fix committed] https://launchpad.net/bugs/1656391
16:05 <barry> looked at autopkgtest-buildvm-ubuntu-cloud problems, but it only occurred on yakkety and i've since upgraded all machines to zesty; debian bug #783202
16:05 <ubottu> Debian bug 783202 in autopkgtest "[adt-buildvm-ubuntu-cloud] timeout nearly after display "Net device info"" [Normal,Open] http://bugs.debian.org/783202
16:05 <barry> looked at nova ftbfs on trusty w/python 2.7.12-1-14.02
16:05 <barry> looked at claws-mail 3.14.1-2 promotion bug - it's caused by gpgme1.0 ftbfs (LP: #1647204)
16:05 <ubottu> Launchpad bug 1647204 in gpgme1.0 (Ubuntu) "1.8.0-2 FTBFS in zesty 17.04" [Undecided,Confirmed] https://launchpad.net/bugs/1647204
16:05 <barry> python3.6 transition work for z; ppa test rebuild begun; scripts to sync/copy/status/rebuild updated, refined, and gitified;
16:05 <barry> --done--
16:05 <caribou> Bugfix :
16:05 <caribou> LP: #103690 - IBM ppc64 - crash tool does not work on 4.8 kernels
16:05 <ubottu> Launchpad bug 103690 in ndiswrapper (Ubuntu) "Ndiswrapper can't connect to WPA network using 2.6.20-14-generic on amd64 (feisty)" [Undecided,Invalid] https://launchpad.net/bugs/103690
16:05 <caribou> merge crash tool
16:06 <caribou> Sosreport 3.3 trusty SRU
16:06 <caribou> trusty, yakkety & xenial actually
16:06 <caribou> Sponsor slashd krb5 SRU for LP: #1648901
16:06 <ubottu> Launchpad bug 1648901 in krb5 (Ubuntu Xenial) "SPNEGO crash on mechanism failure" [Medium,In progress] https://launchpad.net/bugs/1648901
16:06 <caribou> (done)
16:09 <bdmurray> no infinity
16:09 <xnox> infinity is off...
16:09 <xnox> doko,
16:10 <doko> - finish the trusty/python 2.7 test rebuild. for now, identified python-glanceclient nova oslo.messaging glance cinder as failing. these at least need investigation
16:10 <doko> - python 3.5.3 release
16:10 <doko> - GCC: extract, reduce, forward ppc64el ICE, fixed with the next upload
16:10 <doko> - GCC: update to the 2007-01 snapshot
16:10 <doko> - next GCC update, GCC cross fixes
16:10 <doko> - some non-security openjdk-8 updates
16:10 <doko> (done)
16:10 <xnox> i guess mwhudson not here?!
16:11 <xnox> deputy systemd: integrate instead of systemd-shim hand off to tvoss et.al.
16:11 <xnox> receive bugs from tvoss et.al. about racy start of snapd units due to cgmanager
16:11 <xnox> redo deputy systemd, without conflicts with systemd-shim and without cgmanager
16:11 <xnox> stable, in unaproved queue
16:11 <xnox> fix old s390x bugs
16:11 <xnox> upload installer SRUs for 16.04.2, hopefully (most are released now, remaining netcfg is optional/cosmetic)
16:11 <barry> doko: yeah, i looked at those but it'll take a deeper dive
16:11 <xnox> refresh of merges
16:11 <xnox> Away next week, skiing in Arosa, CH
16:11 <xnox> ..
16:11 <doko> barry: coreyb already uploaded kombu to -proposed. some of these should be fixed with this upload
16:11 <barry> doko: cool
16:13 <bdmurray> chiluk: you're up
16:13 <chiluk> LP#1647389 - Deployed xenial-mitaka cloud and can now reproduce
16:13 <chiluk> LP#1655225 - Have a fix that seems to have resolved it.  Need to check debdiff, and then ready for upload/SRU
16:13 <chiluk> LP#1650067 - Having to create an original patch in order to resolve as attempts to backport patches has grown to too much change 600-700 lines.  I have hope an original patch should be much smaller.
16:13 <chiluk> --done--
16:13 <bdmurray> slangasek: your turn
16:13 <slangasek> * short week, bank holiday Monday + sprint travel swap Tuesday
16:13 <slangasek> * clearing downed branches from driveway and yard due to ice storm
16:13 <slangasek> * improve kernel SRU processing: lp:~vorlon/ubuntu-archive-tools/kernel-sru-review/ now tries to auto-accept UEFI binaries for us
16:13 <slangasek> * SRUs
16:13 <chiluk> ubotto no love?
16:13 <slangasek> * ppc64el SRUs for 16.04.2
16:13 <slangasek> * unpicking nvme regression between kernel and systemd
16:13 <slangasek> * ubuntu-core candidate image builds with snapd 2.21
16:13 <slangasek> (done)
16:14 <tdaitx> = Back from vacations since Monday
16:14 <tdaitx> = OpenJDK Updates
16:14 <tdaitx> * OpenJDK 8
16:14 <tdaitx> - Patches available on last Saturday
16:14 <tdaitx> - Applied to current OpenJDK 8 package
16:14 <tdaitx> - Updated package to 8u121 as it was released earlier
16:14 <tdaitx> - Currently under test and looking for regressions
16:14 <tdaitx> * OpenJDK 7
16:14 <tdaitx> - started backports
16:14 <tdaitx> (done)
16:14 <bdmurray> worked with webops to requeue some old core files
16:14 <bdmurray> reported daisy bug LP: #1655145 re interrupted core file reception
16:14 <bdmurray> testing --graceful-timeout in canonistack (it works from the charm)
16:14 <bdmurray> modified daisy app charm to utilize --graceful-timeout for gunicorn
16:14 <ubottu> Launchpad bug 1655145 in Daisy "interrupted core file reception results in lack of resubmission" [Low,Triaged] https://launchpad.net/bugs/1655145
16:14 <bdmurray> submitted gunicron charm MP for graceful-timeout support
16:14 <bdmurray> sumitted RT 98894 regarding updating staging daisy app charm
16:14 <bdmurray> investigation into / fixing of retracer swift 404 issues
16:14 <bdmurray> worked on modifications to apport-retrace to use a gdb sandbox LP: #1517257
16:14 <ubottu> Launchpad bug 1517257 in apport (Ubuntu) "apport-retrace should install and use gdb for target release" [Medium,Triaged] https://launchpad.net/bugs/1517257
16:14 <bdmurray> research into / testing of unattended-upgrades bug LP: #1654070
16:14 <ubottu> Launchpad bug 1654070 in unattended-upgrades (Ubuntu) "sanity check can fail for packages missing dependencies" [Medium,Triaged] https://launchpad.net/bugs/1654070
16:14 <bdmurray> wrote a bug pattern for ros upgrade failure bug LP: #1611737
16:14 <bdmurray> worked with juliank re SRU verification of LP: #1651923
16:14 <bdmurray> modified / tested Kees's gdb patch based off upstream feedback
16:14 <bdmurray> some SRU reviews with sil2100
16:14 <ubottu> Launchpad bug 1611737 in ubuntu-release-upgrader (Ubuntu) "Can't upgrade from 14.04 to 16.04 if ros-indigo-desktop-full or ros-indigo-perception installed from ROS servers" [Undecided,Confirmed] https://launchpad.net/bugs/1611737
16:14 <ubottu> Launchpad bug 1651923 in apt (Ubuntu Yakkety) "apt https method decodes redirect locations and sends them to the destination undecoded." [High,Fix committed] https://launchpad.net/bugs/1651923
16:15 <bdmurray> ✔ done
16:15 <bdmurray> robru: you are up
16:16 <bdmurray> cyphermox: ?
16:16 <cyphermox> yeah
16:16 <xnox> horum, never heard of ros-indigo-desktop......
16:17 <cyphermox> xenial:
16:17 <cyphermox> - SRU grub2 PowerNV petitboot menu fix (bug LP: #1447500)
16:17 <cyphermox> - debugging os-prober SRU output w/ slashd (bug LP: #1579609)
16:17 <ubottu> Launchpad bug 1447500 in grub2-signed (Ubuntu Xenial) "Ubuntu creates cluttered Petitboot menu entries" [Medium,Fix committed] https://launchpad.net/bugs/1447500
16:17 <cyphermox> - grub-installer NVMe PReP support SRU (bug LP: #1656048)
16:17 <cyphermox> - juju 2.0.2 SRU (bug LP: #1648894)
16:17 <cyphermox> yakkety:
16:17 <cyphermox> - juju 2.0.2 SRU (bug LP: #1648894)
16:17 <ubottu> Launchpad bug 1579609 in os-prober (Ubuntu Xenial) "os-prober bug resulting in possible FS corruption" [Critical,Fix committed] https://launchpad.net/bugs/1579609
16:17 <ubottu> Launchpad bug 1656048 in grub-installer (Ubuntu Xenial) "grub-installer might not install to the PReP partition of NVMe disks" [High,In progress] https://launchpad.net/bugs/1656048
16:17 <ubottu> Launchpad bug 1648894 in juju-core (Ubuntu Yakkety) "[SRU] Juju 2.0.2" [High,In progress] https://launchpad.net/bugs/1648894
16:17 <cyphermox> zesty:
16:17 <cyphermox> - HTX (htxubuntu) DASD exercisers fail (bug LP: #1648561)
16:17 <cyphermox> - Juju 2.0.2 upload to zesty (bug LP: #1648894)
16:17 <cyphermox> - cluttered Petitboot menu fix in grub2 (bug LP: #1447500)
16:17 <cyphermox> - (disabling os-prober for PowerNV)
16:17 <ubottu> Launchpad bug 1648561 in os-prober (Ubuntu Xenial) "HTX (htxubuntu) DASD exercisers fail" [High,Triaged] https://launchpad.net/bugs/1648561
16:17 <cyphermox> - debugging ubiquity-only startup
16:17 <cyphermox> - grub-installer support for PReP backing partition on NVMe (bug LP: #1656048)
16:17 <cyphermox> - netplan bonding support
16:17 <cyphermox> - netplan bonding unit/intregration tests
16:17 <cyphermox> - reviewing ubuntu-budgie slideshow changes
16:17 <cyphermox> - ubiquity-dm panel HiDPI fixes
16:17 <cyphermox> ±other stuff:
16:17 <cyphermox> - netplan bonding+bridging planning
16:17 <cyphermox> (done)
16:17 <doko> tdaitx: 8u121 for arm64 too? didn't see that yet
16:18 <sil2100> (one week status, forgot what was going on last week already)
16:18 <sil2100> - Landing team work, silo coordination
16:18 <sil2100> - Participating in some SRU reviews
16:18 <sil2100> - walinuxagent 2.2.2:
16:18 <sil2100> * Preparing the packaging, building test debs in PPA
16:18 <sil2100> * Setting up an Azure account, fighting with the setup
16:18 <sil2100> * Testing the packages on Azure VMs (basic tests)
16:18 <sil2100> * Pushing packages to zesty, yakkety, xenial and trusty, poking for approval to -proposed
16:18 <sil2100> * Looking into properly handling conffile defaults changes
16:18 <sil2100> - Writing up steps needed to be done when adding new flavors on a wiki
16:18 <tdaitx> doko, using 8u112 with the hotspot security patches for that, just waiting to compare build results and see if it is sane
16:18 <sil2100> - Finalizing and enabling ubuntu-personal auto daily-builds on canonistack
16:18 <sil2100> - Discussion regarding ubuntu-core image builds
16:18 <sil2100> - Looking into getting the dbus bugfix release migrated to xenial-updates
16:19 <slangasek> cyphermox: petitboot menu fix ♥
16:19 <sil2100> - Updating packageset for xubuntu
16:19 <sil2100> (done)
16:19 <cyphermox> slangasek: it should help making that not suck.
16:19 <slangasek> alrighty
16:19 <cyphermox> barry: did you have fun with systemd/network-manager? I kind of expected having to deal with that :)
16:19 <barry> cyphermox: oh, lots :(
16:20 <barry> cyphermox: let's talk after the meeting
16:20 <cyphermox> sure.
16:20 <slangasek> cyphermox: AIUI you still can deal with it, since systemd is blocking things?
16:20 <cyphermox> slangasek: yes, just need to catch up on what has been done so far.
16:20 <slangasek> ok
16:20 <slangasek> anything on status?
16:21 <cyphermox> I do need some SRU reviews.
16:22 <slangasek> cyphermox: which release / anything that warrants queue jumping?
16:22 <cyphermox> some things that would be good to have for 16.04; grub2 and grub-installer on ppc64el
16:22 * xnox would want netcfg sru review
16:22 <cyphermox> not that it warrants queue jumping though.
16:23 <xnox> (it is small if one filterdiff -x */po/* spew from debconf-update)
16:23 <bdmurray> the queue is rather long...
16:23 <cyphermox> and the equivalent SRUs for yakkety.
16:23 <slangasek> cyphermox: I don't see grub2 in queue for xenial
16:23 <cyphermox> there's also juju-core.
16:23 <cyphermox> grub2 in xenial was already moved to proposed.
16:23 <xnox> maybe i should spend time verifying things in there, cause there is a lot of committed things, but not validated =/
16:23 <slangasek> cool; I can commit a big block of time to reviews tomorrow
16:24 <slangasek> fwiw I've done some sru releases this morning prompted by maas needing released, looks like we've had a backlog of things needing released?
16:24 <slangasek> xnox: yes, that too
16:24 <sil2100> I can also continue working on SRUs tomorrow, but still there will have to be someone to double-check them for me
16:24 <sil2100> So not much help from me yet
16:24 <slangasek> sil2100: your mentor hasn't given you the green light yet to do them on your own?
16:24 <xnox> yeah, things that got released today were all dandy =)
16:24 <cyphermox> I'll have a good look at pending-sru to see if there are things I can review that slipped through the cracks
16:25 <slangasek> [TOPIC] SRUs
16:25 <slangasek> ohey topic
16:25 <cyphermox> wee
16:25 <sil2100> I didn't do that many of them, some were reviewed by Robie
16:25 <sil2100> Since I overlap with him more than bdmurray usually
16:25 <bdmurray> He hasn't looked at releasing verified stuff either afaik.
16:25 <sil2100> No, that not yet, just doing UNAPPROVED reviews so far
16:26 <slangasek> sil2100: ok.  you asked me earlier about whether you should be set loose, and I said your mentor should comment; has rbasak given an indicator of what's left to do?
16:26 <bdmurray> slangasek: I think there were / are a fair number of autopkgtest failures with the SRUs
16:26 <slangasek> bdmurray: yeah, I just marked nplan bad-test in yakkety for example
16:27 <slangasek> ATM the only way those autopkgtest failures get resolved is if the sru team drives them, so...
16:27 <bdmurray> that's sad
16:28 <slangasek> bdmurray: well, nothing flags the autopkgtest failures on the bug and nobody but the sru team looks at http://people.canonical.com/~ubuntu-archive/pending-sru.html
16:28 <slangasek> so maybe we need automation to post to the sru bugs when there are autopkgtest failures?
16:29 <bdmurray> slangasek: from sru-report or the autopkgtest infrastructure?
16:29 <slangasek> bdmurray: sru-report is probably saner
16:30 <slangasek> bdmurray: do you want to follow up on this?
16:31 <bdmurray> I'll have a think about it (the bug)
16:31 <sil2100> slangasek: let me poke Robie to see if he was happy with my SRU reviews so far
16:31 <slangasek> [ACTION] bdmurray to think about exposing autopkgtest failures on SRU bugs
16:31 * meetingology bdmurray to think about exposing autopkgtest failures on SRU bugs
16:31 <slangasek> sil2100: ok, cool
16:31 <slangasek> [TOPIC] AOB
16:31 <slangasek> anything else?
16:31 <sil2100> bdmurray: you think if Robie gives me a +1 I could at least do the UNAPPROVED ones by myself? :)
16:32 <slangasek> doko, gaughen: fwiw we need to talk about rustc... the security team tells me it's becoming a hard build-dependency for new upstream versions of firefox
16:32 <bdmurray> sil2100: Have not approved anything? If so why?
16:32 <sil2100> bdmurray: I would then poke you or him for the verified ones if I start going though them
16:32 <gaughen> ack
16:32 <sil2100> bdmurray: I was approving, but only after you or Robie double-checked them
16:32 <bdmurray> sil2100: So you haven't REJECTED anything?
16:32 <cyphermox> my AOB: if someone pings me for something and I don't respond, ping harder, I may be in the zone working on the bond and bridge support for netplan.
16:33 <doko> slangasek: yes, I expected something like this ... that's why I updated it. only problem ... doesn't yet exist for armhf. maybe it will with the next release
16:33 <cyphermox> (ie. telegram beeps on my phone)
16:33 <sil2100> bdmurray: not yet actually, not besides the ones that were superseeded (like the ubuntu-image ones)
16:33 <slangasek> doko: right.  but I guess we need to SRU this all the way back to trusty as well
16:33 <doko> slangasek: the good thing is that we already have the regular llvm updates ...
16:34 <bdmurray> sil2100: I think its important to have an understanding of what types of things cause a reject.
16:34 <doko> ahh, not yet 3.9 ... so we to convince the mesa maintainers =)
16:34 <xnox> do we support firefox/armhf on trusty?!
16:34 <sil2100> bdmurray: agreed
16:35 <slangasek> xnox: we don't have *any* rustc package in trusty
16:35 <slangasek> xnox: and in xenial, we only have it on amd64 + i386
16:35 <sil2100> bdmurray: yeah, didn't have any packages that would warrant a reject - ubuntu-image had issues that I found and pointed out and reuploaded, but that was just it
16:35 <bdmurray> sil2100: I guess when I look at the queue today and find things to reject I could send them your way, but then you'd know to look real carefully!
16:35 <slangasek> so it's a bit of a mess, given that the firefox package does exist on other archs in previous LTSes
16:35 <xnox> as in i thought trusty should be red herring as there is no armhf desktop platform with X stack that can run firefox.
16:36 <xnox> (w.r.t. lack of armhf in rustc)
16:36 <xnox> =?
16:36 <xnox> =/
16:36 <slangasek> well, as I said, armhf is not specifically the issue
16:37 <slangasek> ok... anything else?
16:39 <slangasek> #endmeeting