19:03 <sil2100> #startmeeting DMB meeting
19:03 <meetingology> Meeting started Mon Dec 12 19:03:15 2016 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:03 <meetingology> 
19:03 <meetingology> Available commands: action commands idea info link nick
19:03 <sil2100> Should we start off like any usual DMB meeting?
19:03 <sil2100> I suppose so
19:03 <sil2100> #topic Review of previous action items
19:04 <sil2100> Action: rbasak to get mapreri's PPU additions done by the TB <- what's the status of this one?
19:04 <rbasak> Let me check. One minute.
19:05 <rbasak> bug 1643648 - still outstanding.
19:05 <ubottu> bug 1643648 in ubuntu-community "[TB/DMB] PPU additions for ~mapreri" [Undecided,New] https://launchpad.net/bugs/1643648
19:05 <sil2100> Ok
19:06 <sil2100> Action: rbasak to address GunnarHj's im-config yakkety question on the ML <- I have problems with memory recently, is this done?
19:06 <rbasak> I made progress, just checking to see if it is done.
19:08 <rbasak> This is still todo. Sorry!
19:08 <rbasak> The TB have done their part, now I need to do mine.
19:08 <sil2100> ACK, let's leave it around for the next meeting then
19:08 <sil2100> Action: rbasak to address cpaelzer's dovecot-antispam ubuntu-server packageset request on the ML <- from what I see this is done I think, right?
19:09 <rbasak> Done.
19:09 <sil2100> Action: sil2100 to update the lubuntu packageset according to the current seed (carried over)  <- this is now also done for zesty, I might still back-port the same packageset changes to yakkety and xenial, but that's a different story I suppose
19:09 <sil2100> The original request is done I would say
19:10 <sil2100> #topic PPU Applications
19:11 <sil2100> fossfreedom: hello!
19:11 <fossfreedom> hi!
19:11 <sil2100> fossfreedom: could you introduce yourself?
19:11 <fossfreedom> My name is David Mohammed - also known as fossfreedom - and I am the project lead of Ubuntu Budgie (formerly budgie-remix).
19:11 <sil2100> https://wiki.ubuntu.com/fossfreedom/UbuntuBudgieDevApplication <- link to the application in mention
19:11 <fossfreedom> Key responsibilities is the maintenance of our budgie packages -through the QA expected by the Ubuntu release team ...
19:11 <fossfreedom> and meeting the release cadence - our packages are a mixture of Debian (sync with Ubuntu) and Ubuntu specific packages.
19:12 <fossfreedom> Thanks in advance for considering my (our) application to be able to maintain our packages within Ubuntu.
19:13 <BenC> With the amount of time you’ve been around the community, I’m a bit surprised to not see any endorsements.
19:13 <sil2100> BenC: there are endorsements
19:13 <sil2100> BenC: look at the bottom of the page, they're below the template
19:13 <BenC> Ah, I see now.
19:13 <rbasak> fossfreedom: this packageset doesn't yet exist, correct?
19:13 <fossfreedom> correct
19:13 <BenC> Thanks
19:14 <rbasak> Do we know what packages would be in the set?
19:14 <fossfreedom> listed at the top of the application
19:14 <rbasak> Ah
19:14 <rbasak> Thanks
19:14 <fossfreedom> ooo - saw a mistake
19:14 <fossfreedom> the indicator applet has been accepted in debian
19:14 <fossfreedom> its no longer new
19:15 <rbasak> OK
19:15 <fossfreedom> and our ubuntu-budgie-meta has been sponsored
19:17 <rbasak> Which of these packages are Ubuntu-only?
19:17 <fossfreedom> just a sec
19:17 <rbasak> And are there any packages here that are derived from Debian and that you don't maintain in Debian?
19:18 <fossfreedom> budgie-desktop-environment, budgie-artwork, budgie-welcome, budgie-wallpapers, ubuntu-budgie-meta
19:19 <fossfreedom> All others listed are our packages that have been sponsored and accepted in debian
19:20 <rbasak> So to make sure I haven't misunderstood, the answer to my Debian maintenance question is "no"?
19:21 <fossfreedom> If I've understood the question - no derived debian packages - they are either in debian and sync'd or are ubuntu specific
19:21 <sil2100> fossfreedom: a standard question from me - are you aware of how proposed migration works in Ubuntu?
19:22 <fossfreedom> before the debian freeze date - yes sponsored, and auto sync'd I believe.
19:22 <rbasak> fossfreedom: no, I mean: apart from Ubuntu specific packages, is there any package in your requested list that you *do not* maintain in Debian?
19:23 <fossfreedom> no.
19:23 <rbasak> Right, that answers my question - thanks :)
19:23 <fossfreedom> sure.  sorry about that!
19:24 <rbasak> fossfreedom: for the packages in Debian, what sort of uploads do you expect will be necessary in Ubuntu?
19:25 <fossfreedom> Intend to maintain the debian specific packages via debian.  Only after the various freeze dates would I want to look at critical and stability fixes specific to ubuntu coming from upstream
19:26 <rbasak> OK. And if we do grant you upload access today, under what circumstances must you seek approval before uploading to Ubuntu?
19:26 <rbasak> OK. And if we do grant you upload access today, under what circumstances must you seek approval _anyway_ before uploading to Ubuntu?
19:27 <sil2100> fossfreedom: (please also note my question above ^ after answering rbasak)
19:27 <fossfreedom> not sure I understand - if I have doubts - will ask via ubuntu-motu
19:28 <rbasak> fossfreedom: under what release cycle freeze conditions must you seek approval before uploading, and from whom?
19:28 <fossfreedom> k - think you are referring to feature freeze?
19:29 <fossfreedom> release managers - but not sure who they are - will need to ask
19:30 <rbasak> There are other freezes too, but let's start with feature freeze.
19:30 <fossfreedom> sil2100 - are you referring to sending first to proposed.  testing, confirming before moving to universe?
19:30 <rbasak> What can you upload when only feature freeze is in effect, and what can you not upload during the same time?
19:31 <fossfreedom> basically my understanding is concentrate on bugs and stability issues.
19:31 <fossfreedom> dont introduce new features
19:31 <fossfreedom> especially dont break libraries - api's etc.
19:31 <sil2100> fossfreedom: let's say there's such a situation: you upload your package to ubuntu, the package goes to, let's say, zesty-proposed and stays there for over a week - what would you do? Is this a normal situation?
19:32 <fossfreedom> in that circumstance I would hop into ubuntu-motu and seek guidance.
19:32 <fossfreedom> no - before freeze that would be most unexpected I noticed
19:33 <fossfreedom> after freeze - depends on the issue at hand.
19:34 <rbasak> depends> can you be more specific?
19:34 <sil2100> fossfreedom: ok, I guess that's a good start - do you know http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html and update_output.txt ?
19:35 <fossfreedom> lets say the problem at hand is complicated - involving more than one package - possibly concerning a package that we depend upon but is not ours.  Yes - in that example, I would expect things will take longer to check and double check
19:35 <sil2100> In case you didn't, it's a good thing to bookmark and to look at once you see your package being stuck in -proposed
19:36 * cyphermox is around
19:36 <rbasak> cyphermox: o/
19:36 <sil2100> Anyway, any other questions to fossfreedom ?
19:36 <fossfreedom> noted . thanks for the link
19:36 <micahg> fossfreedom: why did you overwrite the changelog when you uploaded a new version? http://launchpadlibrarian.net/296645594/ubuntu-budgie-meta_0.0.1_0.1.diff.gz
19:37 <fossfreedom> that was a bit of confusion .  Apparently daniel uploaded but myself and mapreri didnt know - maprari also sponsored and uploaded over the top
19:39 <rbasak> I think I'm done with questions, thanks.
19:40 <cyphermox> we normally deal with this in two steps, first packageset creation, then joining the packageset.
19:40 <cyphermox> or just PPU
19:41 <rbasak> IMHO, we should vote on granting fossfreedom upload rights first, and then think about what to do wrt. packagesets/PPU. Because if we don't move to grant fossfreedom upload rights, then the packageset discussion is pointless.
19:42 * BenC agrees
19:42 <rbasak> Presumably what we'd give fossfreedom upload rights to (whether via a packageset or PPU) is uncontroversial?
19:42 <sil2100> Agreed
19:42 <cyphermox> well, my vote would be based on what the packageset is, TBH
19:42 <micahg> yeah, usually packageset comes first
19:42 <micahg> but we can table the actions on creation if no one is granted rights
19:42 <rbasak> OK
19:42 <rbasak> Whatever sil2100 wants to do I guess, as he's chairing!
19:43 <sil2100> Since we already did review the applicant and a 'recommended' set of packages for the packageset has been proposed, I would say we should vote basing on the current knowledge
19:44 <cyphermox> what does that mean?
19:44 <sil2100> I mean that we should vote as if the packageset in mention had the packages as proposed in the application
19:45 <sil2100> And in case the packageset ends up different, we can then bring this up on the meeting
19:45 <micahg> is that list actually defined?
19:45 <micahg> ah, yeah, I see it now
19:45 <sil2100> budgie-desktop, budgie-desktop-environment, budgie-artwork, budgie-welcome, budgie-wallpapers, arc-theme, moka-icon-theme, faba-icon-theme, rhythmbox-plugin-alternative-toolbar, budgie-indicator-applet
19:46 <fossfreedom> + ubuntu-budgie-meta
19:47 <sil2100> cyphermox: would you be fine with this?
19:47 <cyphermox> just a second, almost done looking this over
19:47 <sil2100> I don't want to over-extend the meeting as we still have another applicant for today
19:47 <sil2100> Ok, thanks
19:50 <cyphermox> yeah ok to vote
19:50 <sil2100> #vote for David Mohammed to get upload rights for the budgie packageset
19:50 <meetingology> Please vote on: for David Mohammed to get upload rights for the budgie packageset
19:50 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:52 <rbasak> -1
19:52 <meetingology> -1 received from rbasak
19:53 <BenC> +1
19:53 <meetingology> +1 received from BenC
19:54 <micahg> +0, great start, great job getting packages into Debian, would like to see a little more experience with the packages
19:54 <meetingology> +0, great start, great job getting packages into Debian, would like to see a little more experience with the packages received from micahg
19:54 <cyphermox> we never defined what the packageset was yet though
19:55 <micahg> sil2100 listed the packages before the vote, but you are correct, that it's not official
19:55 <micahg> *officially listed in the vote
19:56 <cyphermox> +1 there is evidence of involvement, but I can't see much in terms of uploads (though some are obviosly maintained in Debian directly). On the basis that this is for a new flavor and that the risk is low (leaf packages specific to the flavor) I'm inclined to acquiesce.
19:56 <meetingology> +1 there is evidence of involvement, but I can't see much in terms of uploads (though some are obviosly maintained in Debian directly). On the basis that this is for a new flavor and that the risk is low (leaf packages specific to the flavor) I'm inclined to acquiesce. received from cyphermox
19:57 <cyphermox> I would strongly strongly suggest pinging people on IRC when you need sponsoring. I know I'm always happy to sponsor packages and give review, and later add testimonial to applications
19:59 <fossfreedom> k - sure - Jeremy has done the vast majority of uploads and sponsoring for the team
19:59 <cyphermox> who are the team?
19:59 <fossfreedom> I myself do the packaging - the link to the team is here https://budgie-remix.org/our-team/
20:03 <sil2100> +1 conditionally from me as this is a new flavor and things need to get going, assuming the packageset stays as mentioned above - but PLEASE always ask more experienced sponsors while in doubt
20:03 <meetingology> +1 conditionally from me as this is a new flavor and things need to get going, assuming the packageset stays as mentioned above - but PLEASE always ask more experienced sponsors while in doubt received from sil2100
20:03 <fossfreedom> fully agree with you sil2100
20:04 <sil2100> Ok, I guess that's everyone present
20:04 <sil2100> #endvote
20:04 <meetingology> Voting ended on: for David Mohammed to get upload rights for the budgie packageset
20:04 <meetingology> Votes for:3 Votes against:1 Abstentions:1
20:04 <meetingology> Motion carried
20:04 <rbasak> So I think that's not quorate?
20:04 <sil2100> Yeah, I think it isn't
20:05 <micahg> right
20:05 <sil2100> So we'll have to move it to the mailing list
20:05 <rbasak> fossfreedom: I wrote up my reasons for my -1 ready to paste. I'll do that now.
20:05 <rbasak> This was not an easy decision, as you can probably tell from the votes! I
20:05 <rbasak> really appreciate your contributions to Ubuntu, and in maintaining Ubuntu
20:05 <rbasak> Budgie for us. Personally, I'd be +1 in granting you Ubuntu Contributing
20:05 <rbasak> Developer status, though that would require a further formal DMB vote.
20:05 <rbasak> However, I reget that I'm not satisfied with your understanding of the Ubuntu release process. I think this is important, particularly for a flavour lead.
20:05 <rbasak> For example, the key differentiation for uploading during feature freeze is the simple criteron of whether the upload incorporates just bugfixes or feature changes, but you seemed to be unable to state this.
20:05 <cyphermox> it's most definitely not a motion carried outcome; as per https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase
20:05 <rbasak> I am satisfied with the other aspects of your application.
20:06 <sil2100> fossfreedom: so for now your application is still being processed
20:06 <sil2100> fossfreedom: since you didn't get the required number of votes we'll contintue this through the ML to get the remaining DMB memebers votes
20:06 <fossfreedom> thanks - will continue normally motu sponsoring.  We have a number of updates to make.  thanks all for your time.
20:07 <rbasak> fossfreedom: I'm sorry we couldn't decide in this meeting. We do all appreciate your contributions and hope you will continue regardless of the outcome here. Despite our individual opinions I'm sure we all want to get you to the stage that we're unamimously happy to grant you upload access.
20:07 <sil2100> Let me put an action item for this
20:07 <sil2100> #action sil2100 to handle fossfreedom's application further through e-mail
20:07 * meetingology sil2100 to handle fossfreedom's application further through e-mail
20:08 <sil2100> Ok, let's move on!
20:08 <rbasak> Does everyone have time to consider slashd's application? I do, but I appreciate we're 70 minutes in.
20:08 <sil2100> BenC, cyphermox, slashd, micahg - you all have time for another application still?
20:08 <cyphermox> yep
20:09 <BenC> Yeah
20:09 <micahg> I have a call in 20 min, but we can try
20:09 <sil2100> #topic MOTU Applications
20:09 <sil2100> slashd: hello! You still around? Could you please introduce yourself?
20:09 <slashd> I'm a Software Engineer in the Support Sustaining Engineering Group within Canonical helping in driving Canonical customer and community bugs into resolution by troubleshooting, fixing bugs, providing guidance & workarounds, for different areas of expertise which may cover areas such as: kernel/usermode, drivers, virtualization, network, cloud, storage, ... [https://wiki.ubuntu.com/slashd/MOTU] [https://launchpad.net/~slas
20:09 <slashd> hd] Since I first started contributing I think I've always been acting as a good team player, doing updates of high quality with as much details as I could provide, never been afraid to ask questions when in doubt and that I have the detective skills that this role requires.
20:09 <sil2100> https://wiki.ubuntu.com/slashd/MOTU <- application
20:12 <sil2100> slashd: first question: I noticed that m_deslaur mentioned required improvement in better formatted changelogs - could you elaborate what he could have had in mind?
20:13 <slashd> sil2100, I think he was refering to the fact, my first changelog were not as descriptive as he wanted
20:13 <slashd> sil2100, I think I fix that
20:14 <slashd> I really pay attention to experience ppl feedbacks, to always improve myself
20:15 <rbasak> slashd: are you expecting to do many uploads to universe?
20:16 <rbasak> slashd: and what have you uploaded that is or was in universe?
20:17 <slashd> rbasak, as you can see I'm not dedicated to a specific package or pkgset mostly due to the nature of my work at Canonical where I have to fix whaterver is broken (main, universe, ...) so I expect to do upload of course when a problem arise and also sponsor other ppl debdiff to help the community, ....
20:18 <sil2100> slashd: what would be the primary reason for you to apply for MOTU?
20:18 <slashd> rbasak, libpam-sshauth AFAI remember
20:19 <slashd> sil2100, I want to involve myself more in Ubuntu development, helping fixing issue, help other in sponsoring debdiff, ...
20:20 <cyphermox> slashd: the point of rbasak's question is that we give upload rights after proof of involvement, rather than "because I would like to X"
20:21 <slashd> cyphermox, right, I agree that most of my work has been done for main pkg
20:22 <sil2100> Any other questions?
20:22 <rbasak> FTR, I have worked with slashd on SRUs.
20:22 <slashd> rbasak, cyphermox, I simply think that being MOTU is a good step toward gaining upload experiences ..... and eventually will earn some strip to help even more in other areas
20:23 <rbasak> AIUI, that's the main outcome of his work at Canonical, since from my perspective at least he mainly seems to handle requests that come from Canonical customers, and they generally and understandably tend to be about stable releases.
20:23 <cyphermox> yep
20:23 <rbasak> From that perspective, I'd like to see slashd being able to upload SRUs directly.
20:23 <cyphermox> well, he still won't, for the most part
20:24 <micahg> slashd: well, as cyphermox mentioned, we usually want the experience before the upload rights
20:24 <rbasak> I'm not sure if MOTU is the right path for that, unless slashd is actually making significant contributions to universe, or is being blocked from doing so. I don't think he is.
20:24 <rbasak> It's a new thing I think that Canonical STS employees are contributing to Ubuntu in this way.
20:24 <rbasak> I can only recall caribou as the other person doing this.
20:24 <rbasak> So perhaps this is something the DMB needs to tackle.
20:24 <cyphermox> and to illustrate my point, " being MOTU is a good step toward gaining upload experiences" is precisely what we don't want, and rather give MOTU based on having seen enough evidence that someone knows what they're doing enough to not break universe
20:24 <slashd> rbasak for now there is only caribou yes
20:25 <rbasak> I don't think it's appropriate to force Canonical STS employees contribution to Ubuntu SRUs in main to have to make unrelated contributions to MOTU first as a path to getting upload access to the stuff they're actually helping with.
20:25 <rbasak> Nor do I think it's appropriate to grant MOTU to people not actually contributing to universe.
20:26 <sil2100> Ok, should we maybe start the vote? Or are there any questions to slashd before we continue?
20:26 <rbasak> So, I'm -1 on giving slashd MOTU, but I think it's an action item for the DMB to work out how to fix this so that there's a direct way for slashd and his colleagues to get upload access to do SRUs in main.
20:26 <micahg> rbasak: SRUs go into a queue anyways, it doesn't help so much to have "upload rights" for SRUs unless there were a high volume, and I don't think we're seeing that
20:26 <cyphermox> there isn't really a way to do that aside from being able to upload in main though
20:27 <slashd> rbasak, I know another sts memeber is about to apply for coredev in Jan so this point I think would be nice to be addressed
20:27 <micahg> right, but that could be set per-series if need be
20:27 <cyphermox> ie. SRUs are just an upload, the difference of being stuck in the unapproved queue is just because of the state of the release
20:28 <cyphermox> well, i suppose it could be, but that wouldn't be up to the DMB to statute on.
20:28 <rbasak> Yeah, we could tell Launchpad to allow some new ~ubuntu-sru-uploaders team access to upload to stables but not development.
20:28 <rbasak> I believe it would be within the DMB's remit to set this up if we decided it is appropriate.
20:29 <cyphermox> I don't think deciding whether it's appropriate is DMB-level
20:29 <sil2100> Do we want an action item for this?
20:29 <rbasak> And then slashd and his colleagues would have a clear path forward, whether or not you think slashd himself has enough of a track record right now.
20:29 <sil2100> e.g. for us to remember this for the next meetings?
20:29 <rbasak> I'll happily take an action to take it to the list.
20:29 <rbasak> cyphermox: so we disagree, which is fine. How about: after I take this to the ML, you ask the TB to decide whether it is within our remit?
20:30 <cyphermox> sure. whatever :)
20:30 <sil2100> #action rbasak to start a discussion on the ML regarding the possibility of setting up a specialized team with access to upload packages to stable releases only
20:30 * meetingology rbasak to start a discussion on the ML regarding the possibility of setting up a specialized team with access to upload packages to stable releases only
20:30 <sil2100> Phew, hope this more or less outlines it
20:30 <sil2100> Anyway, let's head for the vote
20:30 <rbasak> slashd: would you like us to proceed to vote on MOTU, or would you like to withdraw that pending the outcome of my action?
20:30 <cyphermox> my point is it's a rather large exception and we don't create the packageset ourselves
20:30 <micahg> I see an average of 3 uploads a month here, I'm not sure the volume warrants special consideration
20:31 <rbasak> micahg: understood. We can discuss that on the ML. I'm just concerned that we're stifling progress by not having this path, even if it is discussed and leads to "no action without more volume".
20:31 <slashd> rbasak, let's see the outcome of you action I think, can you put me on CC on this ?
20:31 <rbasak> slashd: I really don't mind whether you want the vote or not. Up to you.
20:32 <rbasak> CC> sure.
20:32 <rbasak> OK. So are we done with slashd's application for now then?
20:32 <slashd> brookswarner, chiluk, interesting discussion here for us ^^
20:32 <sil2100> Ok, so if I understand that: no vote today on this?
20:32 <rbasak> That's my understanding, yes.
20:33 <slashd> thanks for your time guys, I think we can go ahead with rbasak action item, and then depending on the result will see what is next
20:33 <sil2100> Ok then
20:34 <sil2100> #topic Any other business
20:34 <sil2100> I suppose none here as we're far over our schedule
20:34 <sil2100> #endmeeting