15:03 <rbasak> #startmeeting DMB
15:03 <meetingology> Meeting started Mon Nov 21 15:03:59 2016 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:04 <rbasak> #topic Review of previous action items
15:04 <rbasak> sil2100 to deal with the juju packageset creation
15:04 <rbasak> sil2100 sil2100 to update the lubuntu packageset according to the current seed
15:04 <rbasak> sil2100: how's that going?
15:05 <sil2100> Not finished yet, sorry about that - I added new lubuntu packages to the packageset, but eh, still didn't clear up the old ones
15:05 <sil2100> Was doing that semi-manually since the script wasn't reliable
15:05 <rbasak> Yeah I've resorted to doing that too :-/
15:05 <rbasak> sil2100: what about juju packageset? Or did that get deferred because we have no uploaders?
15:06 <sil2100> Promise to resolve this this week
15:06 <sil2100> rbasak: there are no uploaders right now so it's more of a thing 'for the future'
15:06 <rbasak> #action sil2100 to update the lubuntu packageset according to the current seed (carried over)
15:06 * meetingology sil2100 to update the lubuntu packageset according to the current seed (carried over)
15:06 <sil2100> I wanted to do that but then learned that the TB needs to do that
15:06 <rbasak> sil2100: OK, do you still want an action for that or shall we drop it?
15:06 <sil2100> Let's drop it
15:06 <rbasak> OK
15:07 <sil2100> We can really take care of it when it's needed, I don't want to bother the TB without much merit from that
15:07 <rbasak> #done sil2100 to deal with the juju packageset creation
15:08 <rbasak> #topic MOTU Applications
15:08 <rbasak> #subtopic MattiaRizzolo (mapreri) - application (for Nov 21th)
15:09 <rbasak> mapreri: hello! Please could you start by introducing yourself?
15:09 <mapreri> o/
15:10 * josvaz__ also here for the same reason as philroche
15:10 <mapreri> I've been contributing to the community (loco team ubuntu-it mostly) since 5 years or so, 3 years ago I started doing some dev stuff like merges, etc.  Then I later shifted a bit on the Debian side of the equation, were I became DD last year.
15:10 <mapreri> This is the tl;dr story of me, guess it's a bit longer on the wiki, but I'm happy to provide more.
15:11 <rbasak> Thanks!
15:11 <rbasak> Does anyone have questions for mapreri?
15:12 <rbasak> Well, I have some :)
15:13 <mapreri> shot them :)
15:13 <rbasak> What are your specific reasons for applying for MOTU?
15:16 <mapreri> First, even if this is not true and I know it isn't, I feel a bit limited in what I can do.  I know that since I became DM (and then DD) I started doing a lot more just because I didn't even to bother sponsors anymore.  Practical examples includes carrying over library transitions in ubuntu; In the past year I started (or collaborated) several of them in Debian, but for the ubuntu side I just prodded my usual sponsors with "please do the
15:16 <mapreri> needed rebuild of these", which is lame.  And then I'd like to help a bit with sponsorship stuff; it's working atm, but it's pretty clear that it could use another hand.
15:17 <mapreri> I also have an interested in the same packages I maintain in Debian, but given that I actually care about more than just my garden I figured I could do more.
15:18 <mapreri> s/interested/interest/
15:18 * LocutusOfBorg will be happy to stop signing and uploading is requests :p
15:18 <rbasak> OK, thanks.
15:18 <sil2100> mapreri: are you also going throught the sponsoring queue to find things that need some work?
15:19 <mapreri> (and, incidentally, I'd like to also apply for PPU for a couple of packages I have in main in ubuntu, btw)
15:20 <mapreri> sil2100: from time to time I look at http://reqorts.qa.ubuntu.com/reports/sponsoring/index.html to see how things are (and they are quite good atm, tbh), but no, I'm not reviewing stuff atm, nor actively looking at it.
15:20 <sil2100> Like, doing reviews so that eventual sponsors have it easier, prepare debdiffs etc.
15:20 <sil2100> Ok
15:21 <rbasak> Next question from me: what and how do you check if an upload is appropriate for Ubuntu with respect to our development cycle?
15:22 <mapreri> like, if that given upload is ok considering the moment we're in the given cycle?  (i.e. freezes, etc?)
15:23 <rbasak> Right, that's my question.
15:23 <mapreri> if it's that, basically everything's good untile the Import Freeze, after that changes should be pondered according to which phase the development cycle is
15:24 <rbasak> Can you give me an example of a (made up if needed) change that isn't OK to upload at a particular time?
15:25 <mapreri> starting a openssl transitions one month before the freeze counts as a thing not to do?  /me grumbles
15:26 <rbasak> In Ubuntu specifically. What I'm looking for is that you're aware of the Ubuntu development cycle specifically, and that you know what not to upload when.
15:26 <mapreri> otherwise, umh, for example after the feature freeze a new major version of a software which changes all of its interface is not good.
15:27 <rbasak> Do you know where you can find the current freeze dates for Zesty?
15:27 <mapreri> I have scribus in universe.  If it happens they release the new 1.5.x series, that's going to change all the interface and invalidate old file types, that's something I'd put after the FF
15:27 <mapreri> https://wiki.ubuntu.com/ZestyZapus/DraftReleaseSchedule ?
15:28 <mapreri> s/I'd put/I wouldn't put/ meh
15:28 <rbasak> Great, thanks.
15:28 <rbasak> I hadn't noticed it was still in draft!
15:28 <mapreri> that was a hell of a typo
15:28 <rbasak> I thought it probably was. I was waiting for the correction :-)
15:28 <sil2100> mapreri: ok, one question from me, a rather easy one: when you get some packages sponsored, do you make sure the new package migrates to the release pocket correctly?
15:28 <sil2100> mapreri: if yes, where do you go to check if a package gets stuck in -proposed?
15:28 <cyphermox> it's not a typo, I, slangasek and infinity have yet to go through it one last time and make it not draft
15:28 <mapreri> yes
15:29 <rbasak> cyphermox: the "s/I'd put/I wouldn't put/ meh" I mean :)
15:29 <mapreri> sil2100: http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html + _output.txt (which I'm perfectly able to read)
15:29 <sil2100> Excellent
15:29 <cyphermox> yeah, I figured after :)
15:29 <rbasak> Any more questions for mapreri?
15:29 <rbasak> micahg: ?
15:29 <sil2100> Not from me, I'm all good
15:30 <mapreri> JOOI, do you know if anybody though to have the britney output more integreted into LP?
15:30 <mapreri> thought*
15:30 <rbasak> I'm not aware of any plans for this.
15:31 <mapreri> oh, well..  guess it's fine enough as it is already (just boring to load multi-MB web page..)
15:32 <sil2100> I guess micahg has no questions
15:32 <rbasak> I think micahg had to step away briefly, and we need him for a quorate vote as there are only four members here today, including him.
15:33 <mapreri> I'm not going anywhere, you can move to another candidate and ask me more questions later if you want :)
15:33 <rbasak> Let's go ahead with the vote. micahg can provide his opinion later anyway.
15:33 <rbasak> #vote Grant mapreri MOTU
15:33 <meetingology> Please vote on: Grant mapreri MOTU
15:33 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:34 <rbasak> sil2100, cyphermox: ^
15:34 <sil2100> o/
15:35 <sil2100> +1 (upload history says it all)
15:35 <meetingology> +1 (upload history says it all) received from sil2100
15:35 <sil2100> The world could always use more MOTUs
15:36 <mapreri> :)
15:36 <cyphermox> +1
15:36 <meetingology> +1 received from cyphermox
15:36 <micahg> +1
15:36 <meetingology> +1 received from micahg
15:36 <rbasak> +1
15:36 <meetingology> +1 received from rbasak
15:36 <rbasak> #endvote
15:36 <meetingology> Voting ended on: Grant mapreri MOTU
15:36 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:36 <meetingology> Motion carried
15:36 <mapreri> \o/\o/
15:36 <mapreri> Thank you all! :)
15:36 <rbasak> mapreri: congratulations, and thank you for helping Ubuntu out!
15:36 <sil2100> mapreri: congrats!
15:37 <rbasak> Who wants to take the actions to add mapreri?
15:37 <mapreri> Question: if I wanted to ask for PPU for a couple of packages in main, shall I just email the team?
15:38 <rbasak> Technically PPU additions require quorum (four +1s). But we can try to do that on the ML if you want unless in response someone wants to take it to IRC perhaps?
15:38 <mapreri> (those would be pbuilder and libreoffice-dictionaries, btw)
15:38 <rbasak> Or shall we just vote on that now?
15:38 <rbasak> (given that we've all just reviewed all your work)
15:39 <mapreri> (yeah, figured it would be a kinda good moment, even if off agenda (sorry!))
15:40 <rbasak> mapreri: GunnarHj already uploads libreoffice-dictionaries. Are you in touch with him?
15:41 <mapreri> rbasak: we collaborated last year yes - e.g. he sent some changes to debian, I included them and then he re-uploaded those to debian, given that we couldn't sync the package just yet
15:41 <mapreri> the second debian is an ubuntu..
15:42 <rbasak> OK, let's vote on that then.
15:42 <rbasak> #vote Grant mapreri PPU to pbuilder and libreoffice-dictionaries
15:42 <meetingology> Please vote on: Grant mapreri PPU to pbuilder and libreoffice-dictionaries
15:42 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:44 <cyphermox> +1
15:44 <meetingology> +1 received from cyphermox
15:45 <rbasak> micahg, sil2100: ^
15:45 <micahg> +1
15:45 <meetingology> +1 received from micahg
15:45 <rbasak> Also, I'm still looking for a volunteer to make changes/announcements etc.
15:45 <sil2100> +1
15:45 <meetingology> +1 received from sil2100
15:45 <rbasak> +1
15:45 <meetingology> +1 received from rbasak
15:45 <rbasak> #endvote
15:45 <meetingology> Voting ended on: Grant mapreri PPU to pbuilder and libreoffice-dictionaries
15:45 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:45 <meetingology> Motion carried
15:45 <mapreri> \o/
15:45 <mapreri> Thank you all again! :)
15:46 <rbasak> I guess I'm doing it then!
15:47 <micahg> added to MOTU, TB needs to add PPI
15:47 <micahg> PPU
15:47 <rbasak> Ah, thanks micahg!
15:47 <rbasak> Do you mind sorting those?
15:47 <rbasak> (and the announcement)
15:47 <sil2100> You're welcome!
15:47 <micahg> been having a little trouble with email I'm trying to resolve
15:47 <rbasak> OK, I'll sort
15:47 <rbasak> #action rbasak to announce mapreri's MOTU and PPU status
15:47 * meetingology rbasak to announce mapreri's MOTU and PPU status
15:47 <rbasak> #action rbasak to get mapreri's PPU additions done by the TB
15:47 * meetingology rbasak to get mapreri's PPU additions done by the TB
15:47 <sil2100> micahg: thanks for handling those o/
15:48 <rbasak> #subtopic Gianfranco Costamagna (costamagnagianfranco)
15:48 <rbasak> LocutusOfBorg: hello!
15:49 <LocutusOfBorg> hello :)
15:50 <rbasak> LocutusOfBorg: shall I jump straight to questions? What are your thoughts on the "Areas of Improvement" type comments from the endorsers of your application?
15:51 <LocutusOfBorg> I don't have any real answer, I think giings is right
15:51 <LocutusOfBorg> FWIW I try to find the best approach following each cases, and try to keep transitions in sync with Debian
15:52 <LocutusOfBorg> and I try to avoid breaking the freeze whenever possible :)
15:52 <rbasak> OK
15:52 <rbasak> What about pitti's comment on dropping deltas?
15:52 <LocutusOfBorg> but sometimes I think breaking it is the right thing to do
15:52 <rbasak> (well, eliminating rather than dropping I guess)
15:52 <LocutusOfBorg> I think this happened only once, and I still didn't get why and how my workflow failed
15:53 <LocutusOfBorg> it didn't happen again, so I couldn't debug it further
15:53 <LocutusOfBorg> considering I uploaded ~1k packages or more, I didn't consider it a real issue
15:53 <rbasak> To be clear, which question are you answering there?
15:53 <LocutusOfBorg> http://people.ubuntuwire.org/~stefanor/ubuntu-activity/
15:53 <LocutusOfBorg> it happened once that during a merge I dropped an ubuntu delta that was still needed
15:54 <rbasak> Ah, I see.
15:54 <LocutusOfBorg> when I got mail I readded it quickly
15:54 <LocutusOfBorg> not sure if MoM failed, or I failed, or both of us :p
15:54 <rbasak> As an aside, if MoM failed then that's still the uploader's responsibility to check it, IMHO.
15:55 <LocutusOfBorg> completely true
15:55 <rbasak> Final question. Above you said "sometimes I think breaking it is the right thing to do". What process would you follow if you thought this case the case?
15:55 <rbasak> this was the case?
15:55 <LocutusOfBorg> I *always* bother people on #-release :)
15:56 <rbasak> What if I said it was OK in #ubuntu-release? Would you upload it then?
15:56 <LocutusOfBorg> I don't bother people for some particular cases, e.g. when a new kernel is uploaded after the freeze, and my pet virtualbox-dkms breaks
15:56 <rbasak> Maybe that's too much of a trick question, sorry.
15:56 <LocutusOfBorg> rbasak, last time I checked you weren't part of ubuntu-release team :p
15:56 <rbasak> I mean: how do you know...right :)
15:56 <rbasak> OK, I'm done.
15:56 <rbasak> Does anyone have any other questions for LocutusOfBorg?
15:57 * mapreri thinks we are supposed to know who wears the release hat :)
15:57 <LocutusOfBorg> usually I ask directly to one release team member, who I think is the best person to answer my question
15:58 <rbasak> I think that's fine, since any one release team member can grant an exception.
15:58 <rbasak> #vote Grant LocutusOfBorg core dev
15:58 <meetingology> Please vote on: Grant LocutusOfBorg core dev
15:58 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:58 <rbasak> micahg, sil2100, cyphermox: ^
16:01 <micahg> LocutusOfBorg: could you please clarify what you mean by your comment about a kernel upload after freeze and virtualbox-dkms breaks?
16:02 <LocutusOfBorg> micahg, a new kernel release usually breaks kernel modules
16:03 <micahg> yes, but what does that mean in terms of virtualbox that you would do
16:03 <LocutusOfBorg> virtualbox builds virtualbox-dkms and virtualbox-guest-dkms kernel modules, and I have to adapt them to make them working/buildable
16:03 <LocutusOfBorg> e.g. I did this some days ago
16:03 <LocutusOfBorg> http://launchpadlibrarian.net/293649507/virtualbox_5.1.8-dfsg-6build1_5.1.8-dfsg-7~build1.diff.gz
16:03 <LocutusOfBorg> look for e.g.
16:04 <LocutusOfBorg> + #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 8, 0)
16:04 <LocutusOfBorg> +     r = ttm_bo_move_memcpy(bo, evict, no_wait_gpu, new_mem);
16:04 <LocutusOfBorg> ++#elif LINUX_VERSION_CODE < KERNEL_VERSION(4, 9, 0)
16:04 <cyphermox> yeah API changes often break dkms
16:04 <sil2100> Right, so it's anyway a case where you're just fixing a breakage, so all good
16:04 <LocutusOfBorg> yes, indeed
16:05 <sil2100> Ok, as for voting:
16:05 <sil2100> +1
16:05 <meetingology> +1 received from sil2100
16:07 <micahg> +1
16:07 <meetingology> +1 received from micahg
16:07 <cyphermox> +1
16:07 <meetingology> +1 received from cyphermox
16:07 <rbasak> +1
16:07 <meetingology> +1 received from rbasak
16:07 <rbasak> #endvote
16:07 <meetingology> Voting ended on: Grant LocutusOfBorg core dev
16:07 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:07 <meetingology> Motion carried
16:08 <LocutusOfBorg> thanks :)
16:08 <rbasak> LocutusOfBorg: congratulations, and thank you for looking after Ubuntu for us!
16:08 <mapreri> \o/
16:08 <mapreri> LocutusOfBorg: really, ^5 !
16:08 <sil2100> LocutusOfBorg: congrats!
16:08 <LocutusOfBorg> thanks :D
16:08 <rbasak> LocutusOfBorg: to be clear, what I think we were looking for is that you understand that though the virtualbox fix is obviously needed, from a process perspective it is that it is a bugfix that allows you to upload after feature freeze without release team approval, not just because it's obviously appropriate.
16:09 <LocutusOfBorg> rbasak, yes I got it
16:09 <sil2100> +1 on rbasak's statement
16:10 <rbasak> LocutusOfBorg: we were just struggling a little to hear that from you, but I think we all concluded that you understood that in the end :)
16:11 <LocutusOfBorg> :) I try to find the best tradeoff between breaking changes and bugfixes, it isn't always a clear line, but I ask when in doubt
16:11 <rbasak> action rbasak to announce LocutusOfBoar'd core dev status
16:11 <rbasak> #action rbasak to add LocutusOfBorg to ~ubuntu-core-dev
16:11 * meetingology rbasak to add LocutusOfBorg to ~ubuntu-core-dev
16:11 <LocutusOfBorg> ta
16:11 <rbasak> #action rbasak to announce LocutusOfBoar'd core dev status
16:11 * meetingology rbasak to announce LocutusOfBoar'd core dev status
16:11 <rbasak> s/Boar/Borg/ Sorry!
16:11 <LocutusOfBorg> :)
16:12 <rbasak> #topic Request to add gce-compute-image-packages to the ubuntu-cloud packageset
16:13 <rbasak> philroche: o/
16:13 <philroche> rbasak: o/
16:13 <rbasak> Sorry we didn't address this on the ML already.
16:13 <philroche> np
16:14 <rbasak> I'm surprised that the package isn't seeded.
16:14 <rbasak> And nor is it in main. But it's installed by default?
16:15 <rbasak> That should have no bearing on packageset membership though.
16:15 <philroche> This is a new package. The previous incarnation, gce_utils [1], was in proposed. [1] https://launchpad.net/ubuntu/+source/gce-utils
16:15 <philroche> *is in proposed
16:15 <rbasak> I think your request is obviously correct now that I've looked, so +1 for the packageset change, and we don't need a vote.
16:16 <philroche> Super. Thanks
16:16 <rbasak> #action rbasak to add gce-compute-image-packages to the ubuntu-cloud packageset
16:16 * meetingology rbasak to add gce-compute-image-packages to the ubuntu-cloud packageset
16:16 <rbasak> I'm not sure it's in the right place though. Perhaps a question for the release team.
16:17 <josvaz__> thanks Robbie!
16:17 <rbasak> philroche: is the package in cloud images today?
16:18 <philroche> rbasak: It is in Yakkety dailies images for GCE
16:18 <rbasak> OK, I'll raise that separately, thanks. Not a DMB thing.
16:18 <rbasak> #topic Any other business
16:18 <rbasak> I'd like to raise two things.
16:19 <rbasak> 1) Requests in the ML not yet addressed; 2) Meeting dates over the Christmas period.
16:20 <rbasak> I see GunnarHj's request and cpaelzer's request in the ML not yet addressed. I'd be happy to take both of these.
16:20 <rbasak> But we should probably have a section in the agenda to check for these. Any objections to me adding that?
16:21 <rbasak> For future meetings, the next meeting on 5 December should I think be fine.
16:21 <rbasak> 19 December seems unlikely to get quorum and currently has no applications.
16:22 <rbasak> Same for 2 Jan.
16:22 <rbasak> So I propose we drop those two, and next meet on 16 Jan, unless anyone objects (now or later).
16:23 <rbasak> I guess that means nobody objects.
16:23 <rbasak> #action rbasak to address GunnarHj's im-config yakkety question on the ML
16:23 * meetingology rbasak to address GunnarHj's im-config yakkety question on the ML
16:24 <rbasak> #action rbasak to address cpaelzer's dovecot-antispam ubuntu-server packageset request on the ML
16:24 * meetingology rbasak to address cpaelzer's dovecot-antispam ubuntu-server packageset request on the ML
16:25 <rbasak> #agreed Skip meetings on 19 December and 2 January unless anyone objects now or in the future
16:25 <rbasak> #agreed Add "Unaddressed ML requests" to the meeting agenda
16:25 <rbasak> #endmeeting