16:03 <powersj> #startmeeting ubuntu-server-team
16:03 <meetingology> Meeting started Tue Oct 18 16:03:10 2016 UTC.  The chair is powersj. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03 <meetingology> 
16:03 <meetingology> Available commands: action commands idea info link nick
16:03 <smoser> o/
16:03 <powersj> #topic Review ACTION points from previous meeting
16:03 <powersj> (jamespage) checkin with old iscsitarget users on relevancy with new kernels
16:04 <powersj> anything here?
16:04 <jgrimm> powersj, if we don't get an update in next irc meeting, i'll work via email
16:05 <powersj> ok, moving on
16:05 <powersj> #topic Yakkety Development
16:05 <powersj> #link https://wiki.ubuntu.com/YakketyYak/ReleaseSchedule
16:05 <nacc> that should be Zesty now, right?
16:05 <powersj> done with this topic now?
16:05 <powersj> :)
16:05 <jgrimm> :)
16:05 <cpaelzer> nacc: it is not there yet
16:05 <powersj> any lingering or post-release yakkety issues?
16:06 <nacc> cpaelzer: which is not?
16:06 <jgrimm> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:06 <jgrimm> just a reminder that the blueprint is open for business that we want to track ^^
16:07 <rharper> jgrimm: we may want to add the /boot install outcome
16:07 <powersj> great! anything else for yakkety or zesty dev?
16:07 <jgrimm> rharper, agreed. i'll fix now
16:07 <nacc> jgrimm: would you be ok with adding putting the importer live to the blueprint? or should we keep it unofficial? :)
16:07 <rharper> I think rbasak was going to take that to ubuntu-devel as well
16:08 <jgrimm> rharper, yep
16:08 <jgrimm> nacc, feel free to use blueprint for it (or create new separate and link)
16:08 <nacc> jgrimm: thanks
16:08 <jgrimm> its not terribly formal.. however we feel it helps us be effective.
16:08 <nacc> absolutely
16:09 <jgrimm> rharper, added /boot to blueprit
16:09 <jgrimm> blueprint even
16:09 <powersj> ok moving on
16:09 <powersj> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:09 <powersj> wwops
16:09 <powersj> #subtopic Release Bugs
16:10 <powersj> do we have rbasak?
16:10 <nacc> i recollect seeing in my scrollback he might be out
16:10 <jgrimm> ah, new stuff in the report at least
16:10 <powersj> ah yes he is out today
16:11 <jgrimm> powersj, i just did a quick look at the y report.  all have owners or in progress that I don't see anything worth bringing up here.
16:11 <powersj> jgrimm: thank you! moving on
16:11 <powersj> #topic Server & Cloud Bugs (caribou)
16:11 <powersj> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:12 <jgrimm> powersj, caribou unable to make it today, sent status ahead of time that he had nothing to bring up today
16:12 <powersj> making this easy on me ;)
16:12 <powersj> #topic Weekly Updates & Questions for the QA Team (powersj)
16:12 <powersj> #link https://jenkins.ubuntu.com/server/
16:12 <powersj> Yakkety ISO testing last week, few issues with ppc64el and ppc
16:13 <powersj> Focus is on cloud-init integration testing. Goal is still to have something working by Friday in our jenkins (linked above)
16:13 <powersj> any questions for me?
16:13 <smoser> powersj, woot!
16:13 <jgrimm> looks good.  will be great to have cloud-init integration tests finally !
16:13 <powersj> :)
16:14 <powersj> ok moving on then
16:14 <cpaelzer> I still feel too red on the migration tests powersj
16:14 <cpaelzer> is the ball currently with you or me ?
16:14 <powersj> cpaelzer: I agree - let me remind myself of status later today and send you mail
16:14 <cpaelzer> powersj: I'll let you remind yourself :-P
16:14 <powersj> :)
16:14 <powersj> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:14 * cpaelzer stops stropping people reminding things
16:15 <cpaelzer> stopping even
16:15 <smb> Nothing to report from here
16:15 <powersj> ok
16:15 <powersj> #topic Upcoming Call For Papers
16:16 <powersj> anything here?
16:16 <jgrimm> checking
16:17 <jgrimm> CFP for OSCON is Oct 25, FOSDEM is Oct 31.
16:18 <jgrimm> powersj, fwiw.. i usually rely upon the LWN CFP deadline page.
16:18 <powersj> jgrimm: good to know, I will go read that after this
16:19 <powersj> anything else from folks?
16:19 <rharper> jgrimm: link ?
16:19 <rharper> just  #  link it here
16:19 <jgrimm> #link http://lwn.net/Calendar/Monthly/cfp/
16:20 <powersj> excellent, thank you!
16:20 <jgrimm> np
16:20 <powersj> #topic Ubuntu Server Team Events
16:20 <smoser> is zesty open for uploads ?
16:20 <jgrimm> good question
16:20 <cpaelzer> smoser: not a few hours ago
16:20 <cpaelzer> smoser: I saw xnox having extra work since not all things were ready
16:21 <cpaelzer> smoser: so I wouldn't rush things today unless we hear a "go"
16:21 <nacc> i'm seeing stuff go into z-p on #ubuntu-release
16:21 <jgrimm> ooo > Unapproved: mistral (zesty-proposed/universe) [3.0.0-1 => 3.0.0-1ubuntu1] (no packageset
16:21 <nacc> but that might be an artifact of the copy forward?
16:21 <nacc> not sure
16:21 <nacc> the /topic says its still closed
16:21 <cpaelzer> well then it was resolved in the last few hours
16:21 <cpaelzer> but copy?
16:21 <jgrimm> so some bits getting close
16:21 <cpaelzer> yeah ack
16:22 <powersj> anyting for team events?
16:22 <powersj> anything rather
16:23 <powersj> ok, moving on
16:23 <powersj> #topic Open Discussion
16:23 <cpaelzer> I have two topics for this one
16:24 <cpaelzer> One would be a discussion on proactive stable updates for qemu
16:24 <cpaelzer> I found that 2.5 got 2.5.1 and 2.5.1.1 upstream
16:24 <cpaelzer> FYI - http://paste.ubuntu.com/23344536/
16:24 <cpaelzer> the CVEs are already in by the security Team
16:24 <cpaelzer> 2.5 is Xenial = LTS
16:24 <nacc> cpaelzer: would this be a MRE kind of thing?
16:24 <nacc> Micro Release Exception
16:24 <cpaelzer> that is kind of what I'm wondering about
16:24 <rharper> I don't think so
16:25 <rharper> those are all bugs (just not filed against xenial)
16:25 <cpaelzer> I'd think since it is only bug fixes not
16:25 <cpaelzer> rharper: exactly
16:25 <nacc> rharper: ah ok
16:25 <cpaelzer> I would suggest I open a bug and work against that over the next time, but wanted to ask for any objections
16:25 <cpaelzer> like "we usually don't because ..."
16:25 <rharper> I think we should chat with the openstack team
16:25 <nacc> https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases fwiw, MRE is for (aiui) bugfix microreleases upstream
16:25 <rharper> they possibly have a similar cadence of changes/fixes
16:25 <cpaelzer> FYI - debian hasn't got to them since all releases are on 2.4.* or 2.6.* now
16:26 <nacc> that's what i followed for php7.0, e.g.
16:26 <rharper> nacc: ah, nice
16:26 <cpaelzer> nacc: interesting
16:26 <nacc> it just puts it on the SRU team radar to approve a 'new' upstream version (not normally allowed) in the SRU
16:26 <cpaelzer> ok, without objection I think I'll handle this as such microrelease
16:26 <rharper> cpaelzer: won't that increase delta?
16:27 <rharper> until sync?
16:27 <cpaelzer> rharper: it will increase the delta to something that isn't maintained - that is what I tried to say above
16:27 <nacc> cpaelzer: fyi, LP: #1569609 is how i filed it
16:27 <cpaelzer> Debian is either on <2.5 or >2.5 on all releases
16:27 <ubottu> Launchpad bug 1569609 in php7.0 (Ubuntu Xenial) "[SRU] microrelease exception for src:php7.0" [Wishlist,Fix released] https://launchpad.net/bugs/1569609
16:27 <nacc> and y is already on 2.6.x right?
16:28 <nacc> rharper: so this would only be for x, aiui
16:28 <cpaelzer> yes Y=2.6
16:28 <cpaelzer> exactly
16:28 <rharper> well, why not T or P ?
16:28 <cpaelzer> it is only X for all of the Debian/Ubuntu world
16:28 <rharper> I guess I don't get why we're doing it now and only for X ?
16:28 <cpaelzer> rharper: I didn't check the same might apply for T (and update to 2.0)
16:28 <rharper> it's a nice to have
16:28 <nacc> because somebody cares enough to do it? :)
16:28 <rharper> not a care
16:28 <rharper> a _cost_
16:29 <rharper> which we've not explored w.r.t impact on other choices
16:29 <nacc> i thought cpaelzer was saying the cost was we might get bugs for all of the bugfixes
16:29 <nacc> so we'd be backporting those individually to x
16:29 <rharper> but if we don't get those?
16:29 <nacc> i mean, they are known bugs in the upstream version x is based on
16:29 <rharper> so, in the past, it's been a judgement call during the process
16:29 <cpaelzer> nacc: right, I thought those are known issues and fixing bugs in non emergency mode as a batch would be worth it
16:30 <nacc> rharper: yeah, i'm not sure what makes the most sense
16:30 <rharper> let's continue the discussion w.r.t trade-offs of time vs. benefit;  I think jgrimm and openstack folks should opine on the matter
16:30 <jgrimm> cpaelzer, have you done any looking at the bugs fixed to see if any of that list seem critical?
16:31 <rharper> we could discuss this next week and return here with our findings
16:31 <cpaelzer> jgrimm: just slightly, would need a bit more time to do so
16:31 <jgrimm> i do think i can be swayed, as qemu is critical component to our stack
16:31 <nacc> sounds like an action item :)
16:31 <cpaelzer> rharper: that is good, I'll analyze the severity and come back with it
16:31 <rharper> right, and getting some input from other teams
16:31 <rharper> will it increase churn? help them out?
16:32 <cpaelzer> #action cpaelzer investigating severity of issues covered by qemu 2.5. stable releases and ask other Teams on their input
16:32 * meetingology cpaelzer investigating severity of issues covered by qemu 2.5. stable releases and ask other Teams on their input
16:32 <nacc> yeah, the testing impact is a good point, it's an integration point
16:32 <powersj> cpaelzer: was that both of your topics?
16:32 <cpaelzer> that was one
16:32 <jgrimm> fwiw, the newton c-a, does _not_ include a y qemu.
16:32 <rharper> one more =)
16:33 <rharper> jgrimm: it won't until Z
16:33 <rharper> IIUC
16:33 * cpaelzer is moving to second topic
16:33 <rharper> they pull from archive until it goes out of support
16:33 <jgrimm> rharper, ack
16:34 <cpaelzer> that actually was brought up by rharper - which was TL;DR "We should follow-up on this:" in regard to VNIC offloads
16:34 <cpaelzer> I think here is the right place to discuss, unless you prefer doing that via ML
16:35 <cpaelzer> #link https://www.youtube.com/watch?v=NjlyutCppcU&list=PLrninrcyMo3IkTvpvM2LK6gn4NdbFhI0G&index=10
16:35 <rharper> sure;  at netdev 1.2 there was a discussion on vnic performance and specifically offload features, in KVM and containers
16:35 <cpaelzer> I checked Xenial and Yakkety and we were already at the recommended setting
16:35 <rharper> exercised on top of 16.04
16:35 <rharper> I wanted to see the paper/slides so I could get the data
16:35 <cpaelzer> the question is what else could/should we (not?) do based on that
16:36 <cpaelzer> rharper: getting data would be nice - just to see if there are any outliers that we want to care for
16:36 <rharper> yeah
16:36 <rharper> exactly
16:36 <rharper> specifically  VM to VM and container to container (LXD)  vs. say docker (libnetwork )
16:36 <rharper> bridge mode vs. something else
16:36 <cpaelzer> what is good is that the most common "huge" case for us will be openstack and that is optimized a lot for east/west traffic in VM/VM
16:37 <rharper> right
16:37 <cpaelzer> about 4 times faster than what they had, but getting access to the data would allow to get from "I assume" to "we know"
16:37 <cpaelzer> and for the container east/west I'm interested to know about
16:37 <cpaelzer> rharper: will you kindly inquire that data?
16:37 <rharper> yeah, I need to look around for more details
16:38 <rharper> the other performance (which I don't know if the video covered)
16:38 <rharper> is small-packet-performance, latency
16:38 <cpaelzer> rharper: the video did not cover the others
16:38 <cpaelzer> rharper: I had it running in background
16:38 <cpaelzer> rharper: didn't come back to it
16:38 <rharper> I ran across an interesting KVM paper on that;
16:38 <cpaelzer> rharper: wait that was Stephen Hemminger right?
16:38 <rharper> yes
16:39 <cpaelzer> I'll likely meet him on Thursday on DPDK Userspace
16:39 <cpaelzer> while I feel buried I tihnk I'll define another action for me
16:39 <cpaelzer> at least to kindly ask for more there
16:39 <rharper> sure
16:39 <cpaelzer> #action cpaelzer will try to ask Stephen Hemminger for more data on the netdev presentation
16:39 * meetingology cpaelzer will try to ask Stephen Hemminger for more data on the netdev presentation
16:39 <powersj> any other actions?
16:40 <cpaelzer> I stalled you long enough - I'm done
16:40 <powersj> any other topics?
16:40 <jgrimm> nacc, .. import status?
16:40 <powersj> yes - shall I update the agenda to say "zesty" instead of "yakkety"?
16:40 <jgrimm> powersj, yes please!
16:40 <brauner> have we agreed on zesty as the new release name?
16:41 <powersj> #ACTION powersj to update agenda to remove yakkety add in zesty
16:41 * meetingology powersj to update agenda to remove yakkety add in zesty
16:41 <rharper> #link http://www.linux-kvm.org/images/d/df/02x11-AspenMario_Smarduch-Migrating_NFV_applicatoins_to_KVM_Guest.pdf
16:41 <jgrimm> brauner: Zesty Zapus
16:41 <nacc> jgrimm: i need to sync with rbasak on tagging and we should be ready for 1.0
16:41 <powersj> brauner: http://www.markshuttleworth.com/
16:41 <nacc> jgrimm: importer seemed to run fine last night on the packages we care about, i wanted to confirm with rbasak that all the MRs we did last cycle are tagged
16:42 <jgrimm> cool.. we can start assigning out some merges once done and zesty open for business!
16:42 <nacc> jgrimm: my plan is to update all the lpusip trees by EOW and then we will look to flip over to lpusdp
16:42 <jgrimm> great!
16:42 <nacc> working on documentation today
16:43 <powersj> last call!
16:43 <powersj> #topic Assigned merges/bugwork (rbasak)
16:44 <powersj> since he is out, just a friendly reminder to update the sheet!
16:44 * jgrimm thought he killed that from agenda
16:44 <powersj> lol it is in the copy and paste page
16:44 <jgrimm> ahhh
16:44 <powersj> I'll remove it
16:44 <jgrimm> thanks
16:44 <powersj> #topic Announce next meeting date, time and chair
16:44 <powersj> Same time, same place
16:44 <powersj> beisner will be our host
16:45 <powersj> that's all folks!
16:45 <powersj> #endmeeting