16:00 <jamespage> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Sep 20 16:00:54 2016 UTC.  The chair is jamespage. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <jamespage> welcome!
16:00 <jgrimm> o/
16:01 <jamespage> #topic Review ACTION points from previous meeting
16:01 <jamespage> (jgrimm) Add a url for server release bugs to irc commands for meetings
16:01 <jamespage> not that I can see just yet?
16:01 <jgrimm> jamespage, leave it there. i want to discuss later
16:01 <jamespage> #action jgrimm  Add a url for server release bugs to irc commands for meetings
16:01 * meetingology jgrimm  Add a url for server release bugs to irc commands for meetings
16:02 <jamespage> right
16:02 <jgrimm> thanks
16:02 <jamespage> #topic Yakkety Development
16:02 <jamespage> #link https://wiki.ubuntu.com/YakketyYak/ReleaseSchedule
16:02 <jamespage> Final Beta on thursday
16:02 <jamespage> Final freeze on the 6th October
16:02 <jamespage> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:03 <jgrimm> nothing interesting therein.
16:03 <jamespage> nope
16:03 <jamespage> anything else to raise? I know I have an expected ovs 2.6.0 release this week to handle
16:03 <jamespage> we've been running snapshots to-date
16:03 <cpaelzer_> I wait for this snap to get tested with dpdk
16:04 <jamespage> jgrimm, anything from you?
16:04 <cpaelzer_> but I think I covered the config dpdk on OVS 2.6 bug
16:04 <jgrimm> jamespage, i'm good
16:04 <jamespage> cpaelzer_, you did - thankyou
16:04 <cpaelzer_> one more thing from me
16:04 <cpaelzer_> I uploaded a new qemu which changes machine types for migration (meintioned two weeks ago)
16:04 <cpaelzer_> if anybody runs into new unexpected issues please let me know
16:04 <cpaelzer_> testing can never be complete enough
16:04 <nacc> jgrimm: one update on the openipim MR/FFe -- upstream openipmi has no news or changelog file that is current. Which means the FFe is going to be quite a bit of work to submit :/
16:05 <nacc> *openipmi
16:05 <jgrimm> that's annoying
16:06 <nacc> jgrimm: yeah... it's unclear to me how much effort it's worth spending at this point in the cycle?
16:06 <jgrimm> ok, chat with me later. leaning that direction
16:06 <jamespage> nacc, what's the driver?
16:06 <jgrimm> jamespage, nothing but currency
16:06 <jamespage> debian has a new version?
16:06 <nacc> and embarassingly that i told jgrimm it was already done :)
16:06 <jamespage> lol
16:06 <jgrimm> heh. i was leaving that out. :)
16:07 <nacc> jamespage: newer than what is in yakkety, yeah
16:07 <jamespage> .18 -> .22
16:07 <jamespage> its only a patch update
16:07 <jamespage> how big is the debdiff? I'd debate whether this even needs a FFe
16:07 <nacc> the merge itself is very complicated
16:08 <nacc> well, relatively speaking
16:08 <jamespage> ah so that's where the risk lies
16:08 <nacc> imo, yeah
16:08 <nacc> also, openipmi versioning is garbage
16:08 <jamespage> lol
16:08 <jamespage> right so its not really a patch release
16:08 <nacc> and 2.0.18 -> 2.0.22 is not necessarily compatible, might be major changes
16:08 <jamespage> I like those ones
16:08 <nacc> yeah
16:08 <jamespage> okies
16:08 <nacc> and without a changelog/news, i ahve to go look at the commits :)
16:08 <jamespage> jgrimm, nacc: I'd probably timebox effort - and then postpone to +1 if its not looking likely
16:09 <jamespage> anything else for yakkety?  we have the normal slew of rc's going in for openstack - release is on the 6th
16:09 <jgrimm> jamespage, seems reasonable. thanks
16:09 <nacc> jamespage: ack
16:09 <jamespage> #topic Server & Cloud Bugs (caribou)
16:09 <jamespage> caribou, you're up!
16:10 <caribou> not much to bring up
16:10 <caribou> fixed some APT bug
16:10 <caribou> oh, & working on a sosreport charm
16:10 <caribou> that's it
16:10 <jamespage> caribou, that might make a nice action on any charm tbh
16:11 <jamespage> any questions for caribou?
16:11 <jamespage> ...
16:11 <jamespage> ..
16:11 <jgrimm> nope
16:11 <jamespage> .
16:11 <jamespage> ok moving on
16:11 <jamespage> #topic Weekly Updates & Questions for the QA Team (powersj)
16:11 <powersj> Four remaining automated ISO failures 2x yakkety lxc (still triaging) 2x trusty minimal-virtual (LP# 1625675). Also have the 6x disk-footprint tests to get working.
16:11 <jamespage> powersj, hello!
16:11 <powersj> howdy!
16:11 <powersj> Working on Ubuntu server ISO oversize issues. Filing bug against ghostscript for pulling in a 70+MB font package.
16:11 <powersj> Added s390x testing to simplestreams. Triage of Curtin vmtest issues. Submitting request to add i386 slave to Jenkins today. Met with cpaelzer to get QEMU migration tests into Jenkins.
16:11 <powersj> Bug triage here and there. Thanks to rbasak for merge request to Ubuntu Sever triage script.
16:12 <jamespage> #link https://jenkins.ubuntu.com/server/
16:12 <powersj> questions?
16:12 <powersj> comments? suggestions? jokes?
16:12 <nacc> powersj: can you provide a link to the tool here too?
16:12 <nacc> *script
16:12 <powersj> https://github.com/powersj/ubuntu-server-triage
16:12 <nacc> thanks!
16:13 <jgrimm> thanks powersj
16:13 <powersj> np!
16:14 <jamespage> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:14 <smb> We might be that >..< close to move to kernel 4.8 for yakkety. Still it is hard to say when for real. Also there was something I thought of bringing up if I could remember... cpaelzer_ , maybe you do? I only find empty space in my brain today ... :/ And we talked about it just yesterday...
16:14 <cpaelzer_> hands over an iscsi reminder to smb
16:14 <smb> ah right
16:14 <jamespage> smb, wow that's a late switch!
16:14 <smb> question is the iscsitarget dkms package
16:15 * jamespage shivers a little
16:15 <smb> not sure anybody really uses that one still because there is an iscsi target in the kernel
16:15 <jamespage> tgt and lio right?
16:15 <jamespage> maybe iscsitarget as well?
16:15 <smb> tgt is the userspace part
16:16 <jamespage> ah yes
16:16 <smb> iscsitarget no longer compiles with 4.6 + kernels and upstream has not done any change for a year or more
16:16 <smb> So we kind of would want to drop it in yakkety
16:17 <smb> and see whether anybody starts screaming
16:17 <jamespage> smb, I remember some users at rackspace cloud
16:17 <jamespage> we might want to check whether they are still users
16:17 <jamespage> leave that with me
16:17 <smb> jamespage, ack, thanks
16:17 <jamespage> #action jamespage checking with old iscsitarget  users on relevancy with new kernels
16:17 * meetingology jamespage checking with old iscsitarget  users on relevancy with new kernels
16:18 <jamespage> #topic Upcoming Call For Papers
16:18 <jamespage> any calls for papers?
16:18 <jamespage> ...
16:18 <jamespage> ..
16:18 <jamespage> .
16:18 <jamespage> no ok
16:18 <jamespage> #topic Ubuntu Server Team Events
16:18 <jamespage> openstack summit is in a month in barcelona - there will be a few ubuntu-server team members there
16:19 <jamespage> anything else?
16:19 <jamespage> ...
16:19 <cpaelzer_> here
16:19 <cpaelzer_> typing
16:19 <jamespage> cpaelzer_, ok
16:19 * jamespage waits for cpaelzer_ to type
16:19 <cpaelzer_> for former CFP topic
16:19 <cpaelzer_> almost forgot
16:20 <cpaelzer_> if anybody likes to pick typos and other things to complain about feel free to take a look at
16:20 <cpaelzer_> https://docs.google.com/presentation/d/1mCRAkUO78_Jud9DhFR922AoxrZpGsLbzsPI_SmS0U1U
16:20 <cpaelzer_> done
16:20 <cpaelzer_> thanks jamespage for waiting on my slow typing
16:20 <jamespage> np cpaelzer_
16:21 <jamespage> good luck :-)
16:21 <jamespage> #topic Open Discussion
16:21 <jamespage> any open things?
16:21 <powersj> rbasak, iso testing?
16:22 <rbasak> Yeah
16:22 <powersj> how should we plan for that?
16:22 <rbasak> So we've been caught short with ISO testing needs during release week in the past.
16:22 <rbasak> I thought we could try and nominate testers in advance for that.
16:22 <rbasak> So people can schedule in some time.
16:22 <jamespage> is this just a final set of eyes on what the automated testing does right?
16:23 <rbasak> Some of the automated testing is broken, isn't it?
16:23 <rbasak> We had to do some testing manually last time.
16:23 <powersj> correct - however I was more concerned with the manual testing
16:23 <powersj> re: http://iso.qa.ubuntu.com/
16:23 <rbasak> I believe some of that was supposed to be automated so we didn't need to do it manually. That's what I believe broke at some point.
16:24 <jamespage> yeah - the iso test cases had automated counterparts at one point in time
16:24 * jamespage wrote v1 of that system about 6 years ago
16:24 <powersj> well in that case, the yakkety ISO tests are all passing, except the lxc ones
16:24 <rbasak> I just thought that if anything manual is required, we could assign it ahead of time. Perhaps to me, nacc, cpaelzer_ with powersj taking point.
16:24 <powersj> yeah
16:24 <rbasak> That's all I think needs doing.
16:24 <jamespage> ok
16:24 <cpaelzer_> well, share the pain - thats ok
16:25 <powersj> ok I'll put a sheet together and we cna sign up
16:25 <rbasak> Thanks!
16:25 <cpaelzer_> IIRC in the past xnox did the s390 testing
16:25 <cpaelzer_> so it might not be on us only
16:25 <jamespage> #action powersj to put together iso testing signup sheet
16:25 * meetingology powersj to put together iso testing signup sheet
16:25 <jamespage> #topic Assign daily bug triage for week (powersj, rbasak, nacc, cpaelzer)
16:25 <rbasak> Thank you for bringing that up powersj
16:25 <powersj> np
16:25 <rbasak> I think this topic is running itself now, along with the bug assignments.
16:26 <powersj> yeah
16:26 <jamespage> good oh
16:26 <rbasak> Does anyone feel we still need these on the agenda?
16:26 <powersj> FYI I am sprinting next week, so up to 3 of you
16:26 <rbasak> powersj: is the triage rota adjusted appropriately?
16:26 <powersj> imo, we can pull it off given it seems to be working, when rbasak does his triage ;)
16:26 <rbasak> Oh
16:26 <powersj> yes
16:26 <rbasak> I believe I'm out next week too
16:26 <cpaelzer_> no objections to my assignments for like the next 10 days
16:26 <xnox> jamespage, LPAR cannot be end to end automate. z/VM kind of can be - I have some preseeds that are running semi-automated via ssh and c3270 access, KVM can be automated against these, but currently is not.
16:26 <rbasak> I caught up on my triaging backlog today :)
16:27 <xnox> jamespage, overall it's not automated, and there is no iso.qa.ubuntu.com gated release
16:27 <powersj> woohoo
16:27 <cpaelzer_> rbasak: you are on 30th septmber next week
16:28 <rbasak> cpaelzer_: that's for me to do on Monday, so I guess that's fine?
16:28 <powersj> yeah
16:28 <powersj> cpaelzer_, and nacc do daily triage all next week
16:28 <powersj> rbasak and I take the following week
16:29 <cpaelzer_> ok
16:29 <jamespage> all good then?
16:29 <powersj> I think so
16:29 <jamespage> great
16:29 <jamespage> #topic Assigned merges/bugwork (rbasak)
16:29 <nacc> powersj: ack
16:29 <rbasak> Any comments on bugwork progress?
16:29 <nacc> this one can also be dropped then, from future agendas?
16:29 <nacc> or do we want to keep it for a while?
16:29 <rbasak> I'm fine to drop it.
16:30 <rbasak> We could move any required bugwork discussion into the "Yakkety Development" topic
16:30 <nacc> +1
16:30 <nacc> in theory, it should be business as usual, unless blocked on something, and bring it up there?
16:30 <jgrimm> rbasak, i think i need to do a sweep through it with you.. i think some reassignments may be in order
16:30 <rbasak> OK
16:30 <jgrimm> or some nudging by me. :)
16:31 <powersj> rbasak, fwiw I could use 2 more small ones if you have 'em
16:31 <rbasak> powersj: OK, I'll look for some for you.
16:31 <rbasak> powersj: feel free to cherry-pick from the backlog yourself if you like.
16:31 <powersj> ok
16:31 <powersj> I'll do that
16:31 <rbasak> I was trying to pick ones that may lead to easy uploads to get you some experience of that.
16:31 <jgrimm> rbasak, i'll probably grab a new one too
16:32 <rbasak> The "bitesize" tagged ones can be useful for ths.
16:32 <cpaelzer_> I already grabbed a few and added them to the list
16:32 <cpaelzer_> so no new new ones to be taken atm unfortunately
16:32 <rbasak> Yeah I've done the same.
16:36 <rbasak> jamespage: I guess we're done with this topic?
16:36 <jamespage> #topic Announce next meeting date, time and chair
16:36 <jamespage> ok so looks like its arosales
16:36 <jamespage> same time next week folks
16:37 <jamespage> #endmeeting