15:03 <bdmurray> #startmeeting DMB meeting
15:03 <meetingology> Meeting started Mon Aug 29 15:03:22 2016 UTC.  The chair is bdmurray. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:03 <bdmurray> #topic Review of previous action items
15:03 <sil2100> Thanks!
15:03 <bdmurray> cyphermox: any news on the Mate package changes?
15:05 <cyphermox> done!
15:05 <cyphermox> I'm updating the packagesets now
15:05 <bdmurray> Does anybody know if infinity made the changes for GunnarHj and Otto?
15:06 <cyphermox> I don't know
15:06 <cyphermox> but I could do the LP team changes for Otto if necessary
15:06 <rbasak> I sorted Otto.
15:06 <rbasak> I did all three of my actions on the agenda.
15:07 <rbasak> Oh, sorry.
15:07 <rbasak> There was an infinity task to actually add Otto's PPU.
15:07 <rbasak> I haven't/can't do that.
15:08 <rbasak> And it appears nobody has PPU to mariadb-10.0 yet.
15:08 <bdmurray> Okay, lets leave infinity's two items on there but if cyphermox could sort out Ott's access that would be great.
15:08 <rbasak> AIUI, it needs a TB member.
15:09 <bdmurray> rbasak: Okay, I think infinity is out for the week.   I'll try to find one to help then.
15:09 <rbasak> Thanks!
15:10 <bdmurray> #topic Package Set/Per Package Uploader Applications
15:10 <rbasak> bdmurray: https://lists.ubuntu.com/archives/devel-permissions/2016-August/000951.html is relevant, if an alternative TB member is found.
15:10 <bdmurray> #subtopic Daniel Watkins / ubuntu-cloud packageset
15:10 <Odd_Bloke> o/
15:11 <bdmurray> #subtopic Daniel Watkins / ubuntu-cloud packageset
15:12 <bdmurray> Odd_Bloke: could you introduce your self and your work?
15:12 <Odd_Bloke> Sure.
15:13 <Odd_Bloke> I'm Dan Watkins, I'm a member of the Canonical Certified Public Cloud team.  We're responsible for the images produced at cloud-images.ubuntu.com, and the images that are published in to the major public clouds.
15:14 <Odd_Bloke> We're a small team, so everyone is generally responsible for everything, but my backgroun is in Python, so I do a lot of work with cloud-init.
15:14 <sil2100> Looking at your upload history, how do you feel about your experience with Debian packaging?
15:14 <Odd_Bloke> The tools in the ubuntu-cloud pacakageset are used primarily in cloud applications, so are directly applicable to the work we do.
15:15 <sil2100> Since most of your uploads were either patches or code-changes (in livecd-rootfs for instance)
15:15 <Odd_Bloke> I'm not the most experienced packager, but I am confident in Python packages.
15:15 <Odd_Bloke> WHich make up a decent chunk of these packages.
15:17 <Odd_Bloke> I have done work in other packages, just not to the same extent.
15:17 <Odd_Bloke> So I would expect to look for support in cases where I'm not fully confident in the changes that I'm looking to make.
15:17 <Odd_Bloke> (I believe that people I've worked with would vouch for my ability to identify when I need to look for support. :)
15:18 <sil2100> Fair enough, it's best to always ask when you're not sure how to deal with something
15:19 <Odd_Bloke> Absolutely; we work with the kernel and foundations team a lot (for non-packaging work), so I'm used to liaising with others when necessary.
15:20 <Odd_Bloke> Though, of course, the aim would be to reduce those cases over time. :)
15:20 <bdmurray> rbasak, cyphermox: Do you have any questions?
15:21 <rbasak> No questions.
15:22 <rbasak> I've worked with Odd_Bloke over the years, most recently at a week-long sprint last month.
15:22 <cyphermox> Odd_Bloke: do you know what is the current state of the archive? Given upload rights now, could you currently upload stuff without question?
15:22 <rbasak> So I have an understanding of his technical capabilities, etc.
15:22 <Odd_Bloke> cyphermox: Nope, we're feature-frozen at the moment.
15:23 <cyphermox> right, that's really all I wanted to hear about :)
15:23 <cyphermox> no more questions
15:23 <sil2100> No questions here as well
15:24 <bdmurray> #vote for Daniel Watkins ubuntu-cloud packageset upload rights
15:24 <meetingology> Please vote on: for Daniel Watkins ubuntu-cloud packageset upload rights
15:24 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:25 <rbasak> +1
15:25 <meetingology> +1 received from rbasak
15:25 <sil2100> Generally I would prefer to see a bit more uploads before giving PPU rights, but since the package-set is fairly small and not super-dangerous (especially that it's all managed by his team) + the endorsements, I would say:
15:25 <sil2100> +1
15:25 <meetingology> +1 received from sil2100
15:25 <cyphermox> +1
15:25 <meetingology> +1 received from cyphermox
15:25 <bdmurray> +1
15:25 <meetingology> +1 received from bdmurray
15:26 <bdmurray> #endvote
15:26 <meetingology> Voting ended on: for Daniel Watkins ubuntu-cloud packageset upload rights
15:26 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:26 <meetingology> Motion carried
15:26 <cyphermox> sil2100: I beg to disagree about not so dangerous. some packages there have the potential of breaking boot for cloud images :)
15:26 <rbasak> Yes, I did feel that the number of uploads was pretty low. I feel that he just made it over the line for PPU.
15:26 <sil2100> Odd_Bloke: congratulations!
15:26 <Odd_Bloke> \o/
15:26 <sil2100> cyphermox: sure, but as said, it's all his job right? ;)
15:26 <rbasak> (well, a limited packageset)
15:26 <cyphermox> sil2100: well, yes
15:27 <Odd_Bloke> Thanks all. :)
15:27 <rbasak> bdmurray: please could you assign actions? The three things I think are required are: add to ~ubuntu-dev if not already; add to packageset ACL, and announce (to the news team and in the devel-permissions thread at a minimum).
15:28 <bdmurray> rbasak: to myself?
15:28 <cyphermox> or to me
15:28 <sil2100> +1 on adding exact actions, this way we won't forget about stuff
15:28 <rbasak> To whomever we nominate :)
15:28 <rbasak> Yeah we agreed on assigning actions to avoid missing stuff a few meetings ago.
15:28 <cyphermox> I'm volunteering.
15:28 <bdmurray> #action cyphermox to add Odd_Bloke to ubuntu-dev
15:28 * meetingology cyphermox to add Odd_Bloke to ubuntu-dev
15:29 <bdmurray> #action cyphermox to add Odd_Bloke to ubuntu-cloud packageset
15:29 * meetingology cyphermox to add Odd_Bloke to ubuntu-cloud packageset
15:29 <rbasak> I don't mind three things being inside one action FWIW; I just identified three things in case they get split :)
15:29 <bdmurray> #action cyphermox to announce the result of Odd_Bloke's application
15:29 * meetingology cyphermox to announce the result of Odd_Bloke's application
15:29 <rbasak> Thank you!
15:30 <bdmurray> #topic adding libdumbnet and zerofree to the ubuntu-cloud packageset
15:30 <bdmurray> Odd_Bloke: Could you talk about that briefly?
15:31 <Odd_Bloke> These are packages that were pulled in to main as a result of open-vm-tools being pulled in to main.
15:31 <Odd_Bloke> Which is in the ubuntu-cloud packageset.
15:31 <Odd_Bloke> My team is the bug supervisor for bugs in them.
15:31 <Odd_Bloke> So it seems like they naturally belong in the same packageset.
15:31 <sil2100> For both of those, yes?
15:32 <Odd_Bloke> Yep, for both.
15:32 <sil2100> Since looking at the packages themselves I wasn't sure if those were typically cloud-oriented, one of them was a Recommends of open-vm-tools
15:33 <sil2100> Also, I saw that basically almost all development for those happens in Debian
15:33 <Odd_Bloke> Yeah, I don't anticipate these being a regular upload.
15:34 <Odd_Bloke> But having upload rights to packages that our team has volunteered to maintain would make that job easier if a case ever did come up where an Ubuntu upload were needed. :)
15:36 <bdmurray> Do we need to vote on this?  I'm okay with it.
15:36 <rbasak> AIUI, it only needs one DMB member to +1 it. No vote required.
15:37 <sil2100> Ok, if you guys are ok with it then I'll add those to the packageset
15:38 <cyphermox> I'm not sure
15:38 <cyphermox> I have a hard time deciding how zerofree is cloud-specific ?
15:38 <sil2100> I originally wanted to do that but I didn't feel like it's the right way
15:38 <sil2100> Hence my doubts above
15:38 <sil2100> So I wanted to discuss it here
15:39 <rbasak> Does a package need to be specific to the goals of a particular packageset as a requirement to add it to that packageset?
15:39 <rbasak> Or would that just be a reason to have it in multiple packagesets?
15:39 <Odd_Bloke> zerofree isn't cloud-specific, but it is used heavily in the production of cloud images.
15:40 <cyphermox> a packageset usually has a definition that the packages should match to, at least to some degree
15:40 <cyphermox> however, looking into the team, it looks like maybe it's fine
15:40 <rbasak> "Description: Packages required to create, bootstrap, use or configure Ubuntu Cloud images and their derivatives."
15:40 <cyphermox> Packages required to create, bootstrap, use or configure Ubuntu Cloud images and their derivatives
15:40 <cyphermox> right
15:40 <cyphermox> that's a pretty wide description though
15:40 <sil2100> Yeah
15:40 <rbasak> It is, but it appears that the DMB has previously voted on having that wide description.
15:41 <rbasak> We would narrow it. That would require 4 +1s AIUI.
15:41 <rbasak> *could
15:41 <sil2100> I'm not sure also what policies we have, if we want to add packages to packagesets as-is or only if we see it makes sense, like, in anticipating actual uploads
15:41 <rbasak> But I'm find with that description. Odd_Bloke's team needs that sort of breadth to be useful, IMHO.
15:41 <cyphermox> no, I'm fine with how it currently is
15:41 <rbasak> *fine
15:42 <cyphermox> yeah
15:42 <cyphermox> well, +1 for zerofree from me
15:42 <cyphermox> just looking at libdumbnet now :)
15:42 <cyphermox> +1 for that one too, I guess
15:42 <rbasak> sil2100 raises a good point, but I see no reason to object if there isn't another team paying attention to this packages (and it appears to me that there isn't).
15:43 <sil2100> Ok, if more experienced DMB members are ok then please add me an action item for that :)
15:43 <cyphermox> actually, it's under core-dev and server too
15:43 <rbasak> What is?
15:44 <cyphermox> well, both zerofree and libdumbnet
15:45 <rbasak> open-vm-tools is in the server seed.
15:45 <rbasak> Which pulls in libdumbnet1 too.
15:46 <cyphermox> it's all good; should we carry on?
15:46 <rbasak> Though with my server team hat on, I can confirm that the server team looks to Odd_Bloke's team for any open-vm-tools related uploads.
15:46 <rbasak> So really it's just his team.
15:46 <bdmurray> #action sil2100 to add libdumbnet and zerofree to ubuntu-cloud packageset
15:46 * meetingology sil2100 to add libdumbnet and zerofree to ubuntu-cloud packageset
15:47 <cyphermox> well it really just was to see who had theoretically access to upload the packages
15:47 <sil2100> Thanks!
15:47 <bdmurray> #topic Ubuntu Core Developer Applications
15:47 <cyphermox> not necessarily who takes the responsibility
15:47 <rbasak> Ah, OK.
15:47 <bdmurray> #subtopic Nish Aravamudan
15:48 <bdmurray> nacc: For the record could you introduce yourself and your work?
15:48 <nacc> bdmurray: sure!
15:49 <nacc> Hi everyone! My name is Nish Aravamudan and I'm a member of the Canonical Server team. I'm working with rbasak and cpaelzer on the release side of things for the Server Team, so helping work through bugs and issues across the distribution related to server.
15:52 <nacc> I've had several uploads sponsored already, touching many packages, and have become the de facto responder to PHP7.0 bugs in 16.04 and on (and helping work through bugs in PHP5 as best I can in 14.04)
15:53 <bdmurray> Does anybody have an questions for nacc?
15:53 <sil2100> I like the number of uploads, although most of those I see were rebuilds/dep-changes for the php transition, right?
15:53 <bdmurray> I've seen quite a few SRUs for 16.04, iirc.
15:53 <nacc> sil2100: yeah, probably ~400 or so were related to the PHP transition, which was pretty large. Not all were rebuilds/dep-changes, some were syncs, and a few required patches (which then I sent to Debian)
15:54 <nacc> bdmurray: yeah, some of the transition and fixes to the packages themselves have come via SRU
15:54 <sil2100> nacc: since the list is so big (and I haven't had the time to check this), how many of those uploads you got sponsored were main packages?
15:54 <rbasak> I have no questions for nacc (I work with him and we speak regularly).
15:55 <cyphermox> no questions
15:55 <sil2100> (I know php is, but yeah)
15:55 <nacc> sil2100: a good question :) I have touched several packages in main (qemu, php itself, etc.). I apologize but I'm actually on vacation right now and not at my normal computer to search on.
15:56 <sil2100> Just trying to see if core-dev is a necessity here or maybe MOTU would be good enough, but possibly php here is the 'thing'
15:56 <sil2100> Ok, so I'll just drop one quick packaging question here:
15:57 <sil2100> nacc: let's say you need to rename a binary package foo into foobar in the given release
15:59 <sil2100> nacc: what would be the control field's you'd use to make that happen and not break stuff on upgrades?
15:59 <sil2100> *fields
16:00 <nacc> sil2100: i have not done that yet myself, but I believe the general method involves dummy/transitional package named foo that depends (I think) on foobar. You'd possibly also want foobar to conflict with foo? I  probably would spend some time consulting the debian manual on this and other developers to be sure :)
16:02 <sil2100> nacc: yeah, that's a good direction, breaks is better suited here generally instead of conflicts
16:02 <sil2100> And remember you'd need a Replaces too
16:02 <sil2100> But you'd find that in the debian manual
16:03 <nacc> sil2100: ah ok; that makes sense; and of course on the replaces, sorry for forgetting that!
16:05 <bdmurray> sil2100: anything else?
16:05 <sil2100> All from me
16:05 <bdmurray> #vote Nish Aravamudan for Ubuntu Core Developer
16:05 <meetingology> Please vote on: Nish Aravamudan for Ubuntu Core Developer
16:05 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:06 <bdmurray> +1
16:06 <meetingology> +1 received from bdmurray
16:08 <cyphermox> +1
16:08 <meetingology> +1 received from cyphermox
16:11 <bdmurray> sil2100, rbasak: ?
16:11 <sil2100> One moment, still thinking, give me 2 more minutes
16:12 <sil2100> +1
16:12 <meetingology> +1 received from sil2100
16:12 <rbasak> +1 I would have preferred to recuse myself, but given that everyone else here is unanimous, I'm adding my +1 so that we have a quorate vote
16:12 <meetingology> +1 I would have preferred to recuse myself, but given that everyone else here is unanimous, I'm adding my +1 so that we have a quorate vote received from rbasak
16:13 <bdmurray> #endvote
16:13 <meetingology> Voting ended on: Nish Aravamudan for Ubuntu Core Developer
16:13 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:13 <meetingology> Motion carried
16:13 <bdmurray> nacc: Congratulations
16:13 <sil2100> nacc: congratulations! But please, whenever in doubt consult things with more experienced core-devs
16:14 <nacc> Thank you everyone!
16:14 <nacc> sil2100: absolutely!
16:14 <nacc> sil2100: I plan on being very cautious :)
16:14 <bdmurray> cyphermox: Do you mind also taking care of the changes for nacc?
16:14 <sil2100> You're doing a great job in overall but I was still a bit weary of giving so much power to someone fairly, well, unexperienced
16:14 <cyphermox> no problem
16:14 <nacc> sil2100: totally understood :)
16:15 <bdmurray> #action cyphermox to add nacc to ubuntu-coredev and announce result of application
16:15 * meetingology cyphermox to add nacc to ubuntu-coredev and announce result of application
16:15 <bdmurray> #topic AOB
16:15 <sil2100> But seeing all your work on php, starting off with MOTU might have been a bit of a waste of time - also, rbasak and slangasek did endorse you with details
16:16 <nacc> sil2100: yeah, i've worked closely (and plan on continuing to do so) with both of them
16:16 <bdmurray> anything else?
16:17 <bdmurray> Okay, then.
16:17 <bdmurray> #endmeeting