17:00 <tinwood> #startmeeting openstack-charms-meeting
17:00 <meetingology> Meeting started Wed Jul  6 17:00:48 2016 UTC.  The chair is tinwood. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:00 <meetingology> 
17:00 <meetingology> Available commands: action commands idea info link nick
17:00 <tinwood> welcome all!
17:01 <gnuoy> thanks
17:01 <tinwood> The first topic is:
17:01 <tinwood> #topic Review ACTION points from previous meeting
17:01 <tinwood> Looking at the last minutes, gnuoy, it's about moving this meeting!?
17:01 <gnuoy> sure, I've done a subtopic for each action in the past
17:02 <gnuoy> but I'm guessing you're looking at me for moving this meeting...
17:02 <tinwood> Not sure I follow.
17:02 <gnuoy> #subtopic gnuoy to move this meeting
17:02 <gnuoy> ^ that sort of thing
17:02 <gnuoy> anyway
17:02 <gnuoy> I have a gerrit request up for scheduling the meeting
17:03 <gnuoy> but we can't have this slot
17:03 <tinwood> (Still new at this) I guess I have to do that?
17:03 <gnuoy> we can have: http://paste.ubuntu.com/18635394/
17:03 <tinwood> And those map to times, I'm guessing.
17:04 <gnuoy> tinwood, good point they are all 17:00 UTC
17:04 <gnuoy> so, I propose openstack-meeting-4 biweekly-even
17:04 <gnuoy> on a Monday
17:05 <thedac> works for me
17:05 <gnuoy> biweekly means we can have another meeting if we need for apac
17:05 <tinwood> We'd have to move our charms catchup?
17:05 <gnuoy> 1 week in USA friendly time, one week in apac friendly
17:05 <tinwood> Or is that earlier? (UTC vs BST).
17:06 <gnuoy> not everyone would attend both
17:06 <thedac> tinwood:  that is one hour earlier
17:06 <tinwood> Sounds okay then.
17:06 <gnuoy> this meeting is 17:00 UTC
17:06 <tinwood> Yes, I like those slots
17:06 <coreycb> that time sounds good to me
17:06 <gnuoy> ok, I will book that first slot, thanks
17:06 <tinwood> Okay, sounds like an action - is that okay for you to do gnuoy as you're running with it.
17:07 <gnuoy> yep
17:07 <tinwood> #action gnuoy to try to book first slot from http://paste.ubuntu.com/18635394/
17:07 * meetingology gnuoy to try to book first slot from http://paste.ubuntu.com/18635394/
17:07 <tinwood> thanks gnuoy
17:07 <tinwood> #topic State of Development for next Charm Release
17:08 <tinwood> Any comments on this topic, please?
17:08 <gnuoy> Keystone v3 support in the dashboard has landed
17:08 <tinwood> \o/
17:08 <thedac> Apparmor for nova-compute is close. I am fighting an amulet race condition at the moment.
17:09 <gnuoy> A few caveats though. The dashboard now has to have a db relation if you want to use keystone v3
17:09 <gnuoy> Designate and designate bind should land this week.
17:09 <tinwood> barbican is very close, but has a bug upstream :(
17:09 <coreycb> I have a number of deploy from source reviews ready for review, which should cover the bulk of getting DFS into shape.  the corresponding c-h changes have landed for the current reviews.
17:10 <gnuoy> \o/
17:10 <gnuoy> coreycb, hopefully you should get your charmhelper syncs for free
17:10 <gnuoy> with jamespages ch sync for licensing changes
17:10 <tinwood> So it looks like it's all heading in the right direction.
17:11 <gnuoy> one more thing
17:11 <tinwood> Any more before we move on?
17:11 <gnuoy> all interfaces and layers are in Git/Gerrit now
17:11 <gnuoy> ^ Repoint reviews if you need to!
17:11 <coreycb> gnuoy, very nice
17:11 <gnuoy> jamespages work but am happy to take the credit
17:12 <coreycb> :)
17:12 <tinwood> Oh, at the feature freeze day is next week.
17:12 <gnuoy> yea! good point
17:12 <thedac> coreycb++
17:13 <gnuoy> Thursday next week to be precise
17:13 <tinwood> So anything that has to make the release needs to be done by next Thursday.
17:13 <coreycb> tinwood, feature-wise, at least
17:13 <tinwood> yes
17:14 <tinwood> next:
17:14 <tinwood> #topic Release Bugs
17:14 <tinwood> gnuoy, would you have your link handy?
17:15 <tinwood> I'm guessing: #link https://goo.gl/HJjORI
17:15 <gnuoy> yep
17:15 <tinwood> Yes, there are 32 bugs on the list.
17:16 <gnuoy> ...and we still seem to making little progress
17:16 <gnuoy> that seems to be like 32 too many
17:16 <tinwood> Do they need to be shifted by 16.07?
17:17 <tinwood> bearing in mind some of them are quite 'old'.
17:17 <gnuoy> I'm not sure, I think James does something about retargeting bus
17:17 <gnuoy> * bugs
17:17 <jamespage_shadow> so long as our run rate on bugs is stable, I think we're ok - we need to focus on high priority bugs first
17:17 <jamespage_shadow> (of coursE)
17:18 <jamespage_shadow> I would encourage you all to take some time over the next week and spend an hour on the bug queue
17:18 <jamespage_shadow> please :-)
17:18 <jamespage_shadow> I'll be focussing on reviews, landing and bugs in the next 8 days in the runup to final freeze
17:18 <tinwood> okay, that sounds like a good plan.
17:19 <tinwood> #topic Openstack Events
17:19 <tinwood> I noticed an email that said there was a week to go for submitting talk abstracts for ODS?  Did I read that right?
17:20 <gnuoy> tinwood, I think your looking at an out of data agends
17:20 <gnuoy> * agenda
17:20 <gnuoy> I have next agenda item as "Openstack talk submissions for ODS
17:20 <gnuoy> "
17:20 <gnuoy> ...
17:20 <tinwood> indeed. sorry.
17:20 <gnuoy> np, they were adds
17:21 <tinwood> #topic Openstack talk submissions for ODS
17:21 <gnuoy> So, hands up if you've submitted one!
17:21 * gnuoy keeps his hand down
17:21 * tinwood knows nothing :(
17:21 <coreycb> I plan to submit one, not sure what yet though
17:21 <tinwood> aparently ONE talk has been submitted so far.
17:22 <tinwood> according to the email I saw.
17:22 <thedac> gnuoy: we talked about a Openstack charms development talk we could co-author
17:22 <gnuoy> yes, agreed
17:23 <tinwood> I'd love to collaborate as I enjoy talking.
17:23 <tinwood> but not if you've already got a partner!
17:23 <thedac> sounds good we can discuss offline
17:23 <gnuoy> and lets talk to markbaker about getting a charm school workshop as well
17:24 <jamespage_shadow> some general guidance - talk about things openstack-ish that are really interesting to the general community
17:24 <jamespage_shadow> we're (almost) and openstack project, so this is a great change to let the world know about us!
17:24 <jamespage_shadow> deploying openstack talks +1000
17:25 <jamespage_shadow> beisner, testing stuff good as well - maybe some s390-ish?
17:25 <tinwood> Anything else on ODS?
17:25 <tinwood> Any actions?
17:26 <cargonza> wrt to charm school, I need to sync with the sales team to field the attendance...
17:26 <tinwood> #action cargonza to sync with sales team re charm school at ODS Barcelona
17:26 * meetingology cargonza to sync with sales team re charm school at ODS Barcelona
17:26 <cargonza> I'll coordinate logistics with the admins (ie. rooms, av, etc.)
17:26 <gnuoy> awesome
17:27 <tinwood> excellent.
17:27 <tinwood> Okay, next topic looks a bit strange.
17:27 <tinwood> #topic What does the chair of this meeting do after the meeting?
17:27 <gnuoy> ok, this one is mine
17:28 <gnuoy> The chair of this meeting doesn't always seem to be following the actions outlined in the wiki
17:28 <coreycb> drinks a beer and goes to bed?
17:28 * tinwood lol
17:28 <gnuoy> So, can we review the process and amend accordingly
17:29 <tinwood> My first time so ..
17:29 <gnuoy> tinwood, I think thats an action for jamespage and I
17:29 <jamespage_shadow> agreed -
17:29 <jamespage_shadow> once we move under #openstack for meetings we get automated minutes; but I'd like for us to announce the meeting prior to it happening
17:30 <jamespage_shadow> and summarize on the openstack-dev ML afterwards
17:30 <tinwood> #action gnuoy & jamespage to review the chair's post meeting process and amend as required.
17:30 * meetingology gnuoy & jamespage to review the chair's post meeting process and amend as required.
17:30 <jamespage_shadow> which is not as documented on the ubuntu wiki, but that's where we came from , not where we want to be
17:30 <jamespage_shadow> lets get that sorted out between now and next week
17:31 <gnuoy> tinwood, sorry, I meant previous chairs not you
17:31 <gnuoy> what I really meant was:
17:31 <tinwood> okay, that sounds good.  I'm hoping one of you is a chair for the first openstack-meetings meeting.
17:31 <gnuoy> We have a process documented and I don;t think its clear to everyone so lets review that
17:32 <tinwood> Right, so there's an action for that.  okay to move on?
17:32 <gnuoy> sounds good to me
17:32 <tinwood> #topic workload status messages, max 20 chars and proper case?
17:32 <gnuoy> ok, so, thats me as weel
17:32 <gnuoy> * well
17:32 <tinwood> I think I'm guilty here.
17:33 * thedac hides
17:33 <gnuoy> There was a suggestion that we are consistent accross all charms and use proper caps and limit them to 20 chars
17:33 <tinwood> When you say 'Proper Caps', what do you mean?
17:33 <gnuoy> I'm not convinced tbh. I think we'll loose valuable info
17:33 <gnuoy> Like this
17:33 <gnuoy> rather than
17:33 <gnuoy> like this
17:34 <tinwood> Okay, that's good.
17:34 <tinwood> What's the driver?
17:34 <tinwood> for 20 chars only?
17:34 <thedac> I agree a max 20 chars will lose valuable information
17:34 <gnuoy> I think its useful to say: all these interfaces are missing...
17:34 <gnuoy> thats more that 20chars right there
17:35 <coreycb> that is fairly limiting, 20 chars
17:35 <coreycb> perhaps the requester will negotiate
17:35 <tinwood> Unless it's "'mysql', 'hsm', is miss..."
17:36 <jamespage_shadow> okies - so I think working some examples might be useful
17:36 <jamespage_shadow> then we can review appropriately and see what works well
17:36 <coreycb> jamespage, +1
17:36 <tinwood> It sounds like we need to pull together all of the workload statuses we set, put them down somewhere, and review it?  Or is that too much?
17:37 <coreycb> or gnuoy ^
17:37 <gnuoy> Maybe aim for nice caps and succint message but not limit chars
17:37 <gnuoy> coreycb, haha that was jamespage
17:37 <coreycb> lol
17:37 <coreycb> tinwood, I think that's a good idea
17:38 <coreycb> at least a subset of the common messages
17:38 <tinwood> This sounds like an action.  Who's not here today?
17:39 <tinwood> Seriously, do we need this as a minuted action?
17:39 <gnuoy> tinwood, I don't think so. Maybe lets all keep in mind the formatting of thos stauses
17:39 <gnuoy> * those
17:40 <tinwood> Can I ask where the '20' came from?
17:40 <gnuoy> it was a suggestion floating around for people with limited terminal width
17:40 <thedac> --format yaml FTW
17:41 <gnuoy> haha yeah
17:42 <tinwood> okay, so no action, but try to keep them short and snappy.  assess_status() is a repeat offender as it concatenates missing interfaces ... a lot.
17:42 <tinwood> #topic Openstack Events
17:42 <tinwood> We may have covered this, but any more events?
17:42 <gnuoy> Well ODS but I think we've covered that
17:43 <tinwood> Ok, moving on to:
17:43 <tinwood> #topic Open Discussion
17:43 <tinwood> The floor is yours.
17:44 <gnuoy> I have nothing to openly discuss :-)
17:44 * tinwood chuckles
17:44 <thedac> Do we want to discuss the email thread about hosting third party OS charms?
17:44 <tinwood> fire away.
17:44 <thedac> congress and charm partner charms
17:45 <thedac> Should all charms go upstream or is there a selection criteria?
17:45 <gnuoy> there are no 3rd party os charms
17:46 <jamespage_shadow> as a project, openstack charms should be embracing anyone who wants to charm their part of openstack
17:46 <thedac> agreed. I am aksing if the charm partner SDN charms should also be in this category
17:46 <jamespage_shadow> publication of such charms to the juju charm store is dependent on them meeting the criteria as set out by the juju charm team
17:47 <jamespage_shadow> thedac, +1 absoluletey
17:47 <jamespage_shadow> thedac, plumgrid already asked, onos want to be
17:47 <jamespage_shadow> I think the model of charms-core + charms-<group>-core will work well here
17:47 <thedac> ok, so if we could document the procedure that would be helpful
17:47 <jamespage_shadow> sure - I'll put something in the charm-guide
17:48 <thedac> great
17:48 <jamespage_shadow> #action jamespage document procedure for setup of sub-charm group ownership for SDN/storage vendors etc...
17:48 * meetingology jamespage document procedure for setup of sub-charm group ownership for SDN/storage vendors etc...
17:48 <tinwood> jamespage, beat me to it.
17:49 <gnuoy> thanks jamespage
17:49 <tinwood> Anything more for Open Discussion?
17:49 <gnuoy> not from me
17:49 <gnuoy> or from jamespage
17:49 <thedac> I am good
17:49 <coreycb> I'm good as well
17:49 <tinwood> Great.
17:50 <tinwood> #action Announce next meeting date, time and chair
17:50 * meetingology Announce next meeting date, time and chair
17:50 <tinwood> So the chair rotates; who's up for it next?
17:50 <gnuoy> tinwood, it's in the wiki, one sec
17:50 <gnuoy> tinwood, thedac is the winner
17:50 <tinwood> \o/
17:51 <tinwood> At the moment, we're assuming next Wednesday at 17.00UTC here again?
17:51 <gnuoy> tinwood, yes, I hope its elsewhere but will post a redirect here if needs be
17:51 <thedac> ok
17:52 <tinwood> okay, then.  With no further ado, thanks everybody and ...
17:52 <tinwood> #endmeeting