16:01 <jamespage> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue May 24 16:01:01 2016 UTC.  The chair is jamespage. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:01 <jamespage> #topic Review ACTION points from previous meeting
16:01 * jamespage looks
16:01 <rbasak> o/
16:01 <jamespage> ah - nacc was due to announce the v1 importer - I think we can mark that done
16:01 <jgrimm> indeed, nacc sent out email along with call for testing
16:01 <jamespage> awesome
16:01 <jamespage> #topic Yakkety Development
16:01 <jamespage> #link https://wiki.ubuntu.com/YakketyYak/ReleaseSchedule
16:02 <jamespage> feature definition freeze is up on thursday
16:02 <jamespage> jgrimm, are folks still doing bp's?
16:03 <jgrimm> not particularly, though we do have a generic server one for tracking high level work
16:03 <jgrimm> fairly empty atm except for nginx work planned
16:03 <jamespage> great
16:03 <jamespage> #subtopic Release Bugs
16:03 <jamespage> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:03 <jamespage> http://launchpad.net/bugs/1578344
16:03 <ubottu> Launchpad bug 1578344 in nginx (Ubuntu Yakkety) "code duplication between nginx-*.postinst and init script" [Low,Triaged]
16:04 <jamespage> http://launchpad.net/bugs/1577739
16:04 <ubottu> Launchpad bug 1577739 in samba (Ubuntu Yakkety) "samba security regression tracking bug" [Undecided,Confirmed]
16:04 <jamespage> looks like one security bug
16:04 <jgrimm> yup
16:04 <rharper> o/
16:04 <jamespage> and a nginx bug which thomas has hold of
16:04 <jamespage> good-oh
16:04 <jgrimm> indeed
16:04 <jamespage> #topic Server & Cloud Bugs (caribou)
16:04 <jamespage> caribou, you're up
16:05 <caribou> haking at kdump-tools/makedumpfile
16:05 <caribou> maybe I should have this added to the blueprint
16:05 <jamespage> sounds like a nice idea
16:05 <jgrimm> caribou, please do
16:05 <caribou> ok, will do as there appears to be a bit more effort that I thought :)
16:06 <jamespage> #action caribou to add kdump-tools/makedumpfile to server team blueprint
16:06 * meetingology caribou to add kdump-tools/makedumpfile to server team blueprint
16:06 <jamespage> #topic Weekly Updates & Questions for the QA Team
16:06 <jamespage> hmm - who does qa team these days?
16:06 <jgrimm> jamespage, skip.. missing a QA person atm
16:06 <jamespage> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:06 <smb> No news (supposedly good news then).
16:06 <jamespage> \o/
16:08 <jamespage> #topic Upcoming Call For Papers
16:09 <jamespage> anything?
16:09 <jamespage> #topic Open Discussion
16:09 <rbasak> o/
16:09 <rbasak> I think you missed "Assigned merges/bugwork" in the agenda. I was going to ask to do this at the end anyway, since I want to get updates on progress of those assigned bugs and assign new bugs to people, but many people here aren't involved in assigned bugwork and I don't want to hold them up.
16:10 <jamespage> anything for open discussion
16:10 <jamespage> rbasak, https://wiki.ubuntu.com/ServerTeam/Meeting/IRCCommands following this
16:10 <rbasak> So would you like to add me as #chair and I can take that item and let you go?
16:10 <jamespage> rbasak, you want to handle that now?
16:10 <jamespage> #chair rbasak
16:10 <meetingology> Current chairs: jamespage rbasak
16:10 <jamespage> youre on
16:10 <nacc> also, if it matters to anyone else, i'm only seeing about half the text due to the netsplit still :)
16:11 <jgrimm> eek
16:11 <rbasak> So first, let's get progress updates on bugs previously assigned. No progress is fine, I'd just like to know if that's the case.
16:11 <rbasak> jgrimm: I have you down for bug 1397250. How's that going?
16:11 <ubottu> bug 1397250 in libnss-ldap (Ubuntu) "SIGPIPE not caught in do_atfork_child()" [High,Triaged] https://launchpad.net/bugs/1397250
16:11 <rbasak> nacc: any progress on bug 1318317 please?
16:11 <ubottu> bug 1318317 in openipmi (Ubuntu Trusty) "openipmi startup script removes kernel modules" [High,Fix committed] https://launchpad.net/bugs/1318317
16:12 <jgrimm> rbasak, have not touched in ages. :(   will try to resurrect this week!!!
16:12 <rbasak> rharper: I have you down for four: bug I think you missed "Assigned merges/bugwork" in the agenda. I was going to ask to do this at the end anyway, since I want to get updates on progress of those assigned bugs and assign new bugs to people, but many people here aren't involved in assigned bugwork and I don't want to hold them up.
16:12 <rbasak> Oops
16:12 <rbasak> Let's try that again.
16:12 <rbasak> rharper: I have you down for four: bug 1384503, bug 1457957, bug 1511735 and bug 1518440.
16:12 <ubottu> bug 1384503 in rsync (Ubuntu Trusty) "rsync fails on large files with compression" [Undecided,Incomplete] https://launchpad.net/bugs/1384503
16:12 <rharper> rbasak: ok
16:12 <ubottu> bug 1457957 in puppet (Ubuntu Vivid) "puppet uses upstart for service status checks in vivid" [High,Triaged] https://launchpad.net/bugs/1457957
16:12 <ubottu> bug 1511735 in libnl3 (Ubuntu Trusty) "libnl: fail to bind() netlink sockets" [Medium,Fix committed] https://launchpad.net/bugs/1511735
16:12 <ubottu> bug 1518440 in MAAS "tgt fails to install in LXD" [Medium,Triaged] https://launchpad.net/bugs/1518440
16:12 <nacc> rbasak: sorry, what kind of progress should there be? xenial is fixed, and trusty sru has been committed, i guess need to ping ibm to test
16:12 <rbasak> And magicalchicken isn't here, but he had bug 869017 and bug 1394403.
16:12 <ubottu> bug 869017 in kbd (Ubuntu) "Ubuntu server enables screenblanking, concealing crashdumps (DPMS is not used)" [Medium,Triaged] https://launchpad.net/bugs/869017
16:13 <ubottu> bug 1394403 in apache2 (Ubuntu Trusty) "RewriteRule of "^$" is broken" [Medium,Incomplete] https://launchpad.net/bugs/1394403
16:14 <rbasak> nacc: driving it so that we don't have to worry about it any more. I guess if an SRU is pending verification that can you finish up driving that please? If you've chased and verification isn't forthcoming then we can consider it done from an assignment perspective I think.
16:14 <nacc> rbasak: ack, just provided a comment
16:14 <cpaelzer> if it is not tracked already - in addition to smosers guidance (he might be the one on your list) I work on bug 1574113 with iterations https://code.launchpad.net/~paelzer/cloud-init/test-apt-source/  https://code.launchpad.net/~paelzer/cloud-init/add-apt_source-handling-for-bug-1574113/
16:14 <ubottu> bug 1574113 in MAAS "curtin/maas don't support multiple (derived) archives/repositories with custom keys" [Critical,Triaged] https://launchpad.net/bugs/1574113
16:14 <cpaelzer> also working on bug 1546547 with the upcoming dpdk merge (will be a while until it is complete)
16:14 <ubottu> bug 1546547 in dpdk (Ubuntu) "DPDK shared library versioning" [Medium,Triaged] https://launchpad.net/bugs/1546547
16:15 <rbasak> cpaelzer: I'm not tracking those but I can add them, thanks.
16:16 <rbasak> I have five more bugs I'd like to assign to non-uploaders. These all look straightforward (though they might turn out not to be). Though not that important, I think it'll be helpful to ramp up non-uploaders to getting upload rights.
16:17 <rbasak> nacc, cpaelzer, rharper: shall I list them, and you can grab the ones you fancy?
16:17 <rbasak> bug 1511222, bug 1423498, bug 1491406
16:17 <ubottu> bug 1511222 in apache2 (Ubuntu Trusty) "Incorrect trusted proxy match test in mod_remoteip" [Medium,Triaged] https://launchpad.net/bugs/1511222
16:17 <ubottu> bug 1423498 in squid3 (Ubuntu Vivid) "FTP upload causes squid hang" [Undecided,Confirmed] https://launchpad.net/bugs/1423498
16:17 <ubottu> bug 1491406 in augeas (Ubuntu) "augeas-lenses-1.2.0 - NagiosCfg lens broken for /etc/nagios.cfg due to spaces" [Undecided,New] https://launchpad.net/bugs/1491406
16:17 <rbasak> bug 1507681, bug 1524635
16:17 <ubottu> bug 1507681 in psmisc (Ubuntu Precise) "killall with 65 arguments kills more than expected" [Medium,Triaged] https://launchpad.net/bugs/1507681
16:17 <ubottu> bug 1524635 in haproxy (Ubuntu) "haproxy syslog configuration causes double logging" [Medium,Confirmed] https://launchpad.net/bugs/1524635
16:18 <rbasak> Any preferences, or shall I assign them in turn?
16:18 <cpaelzer> I'd prefere the psmisc one
16:18 <cpaelzer> not sure how fast I'll get to it but thats what this meeting will sove over time
16:19 <rbasak> Great, thanks!
16:19 <jgrimm> rbasak: fyi magicalChicken will be working for me full time this summer again.. he can take one too (starting next week)
16:20 <rbasak> jgrimm: thanks. He has two already. Shall I give him one more?
16:20 <jgrimm> that works!
16:20 <rbasak> OK, if there are no other preferences, I'll assign the rest in turn. No point holding up this meeting - I'll assign and Launchpad will email you.
16:21 <jgrimm> thanks rbasak
16:21 <nacc> rbasak: yeah, just assign any to me
16:21 <nacc> rbasak: i'm possibly a bit busy this week w/ php7 in debian
16:21 <rbasak> My goal here is to get a production line of bugs being fixed. If your assigned bugs get held up and blocked not by you, then that's absolutely fine - we'll treat them as clear of assignment and assign more. I just want as many bugs as possible not blocked by a developer.
16:21 <nacc> rbasak: also, want to get to merges too
16:22 <rbasak> nacc: ack. As long as everybody has bugs to get on with, jgrimm can prioritise Canonical staff as needed.
16:24 <rbasak> I think I'm done. Thanks all.
16:24 <rbasak> Anything more for open discussion?
16:24 <jamespage> okies
16:24 <jamespage> #topic Announce next meeting date, time and chair
16:24 <rbasak> I'll move this section to even more at the end of the meeting for next time.
16:24 <jamespage> +7 days same time same place
16:24 <jamespage> see you then
16:24 <jamespage> #endmeeting