19:09 <sil2100> #startmeeting DMB meeting
19:09 <meetingology> Meeting started Mon May 23 19:09:24 2016 UTC. The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:09 <meetingology>
19:09 <meetingology> Available commands: action commands idea info link nick
19:09 <micahg> o/ I"m kinda here, but otp
19:09 <BenC> o/
19:09 <sil2100> #topic Review of previous action items
19:09 <sil2100> o/
19:09 <BenC> Appologies for the tardiness
19:09 <sil2100> We have a quorum then
19:10 <sil2100> Ok, so action items:
19:10 <sil2100> cyphremox Update Mate packages per Iain Laney's suggestions
19:10 <sil2100> Not sure if that happened ^ ?
19:10 <sil2100> cyphermox is not around but anyone else knows maybe?
19:10 <rbasak> I could try asking Launchpad but no point holding the meeting up for that.
19:11 <sil2100> Ok, let's continue then, we can follow up on that later indeed
19:11 <sil2100> #topic Package Set/Per Package Uploader Applications
19:11 <sil2100> #subtopic GunnarHj
19:12 <bdmurray> I thought there was a question about whether or not he needed new endorsements.
19:12 <sil2100> So the topic in mention is GunnarHj's request to extend his PPU rights to more packages
19:12 <sil2100> Without a new batch of endorsements
19:13 <GunnarHj> As regards endorsements, dholbach entered one on my old applications.
19:13 <sil2100> bdmurray: you think we should have a separate vote for that, or just treat it as part of the vote for PPU extension?
19:13 <GunnarHj> https://wiki.ubuntu.com/GunnarHj/PerPackageUploaderApplication
19:16 <sil2100> Any opinions regarding our current situation ^ ?
19:16 <bdmurray> sil2100: I guess voting, I don't think we have a policy for extending PPU uploads.
19:16 <rbasak> sil2100: IMHO it's fine without a separate vote. If somebody isn't happy because of a desire to see endorsements, then that can be made clear in a single vote.
19:16 <sil2100> Right, I agree with rbasak's view here as well
19:16 <bdmurray> if it were someone applying for core dev we would want to see endorsements.
19:17 <sil2100> Right
19:17 <bdmurray> not just reuse their motu ones.
19:17 <sil2100> Any members have questions to GunnarHj before we start the vote?
19:17 <sil2100> The extended package set can be found here:
19:17 <sil2100> https://lists.ubuntu.com/archives/devel-permissions/2016-May/000924.html
19:17 <rbasak> Yes
19:18 <rbasak> GunnarHj: as you're applying without endorsements, I feel I have to ask: do you know of any reason why your sponsors wouldn't want to give you an endorsement? Anything they have been unhappy about?
19:19 <GunnarHj> rbasak: No, I'm not aware of any such reason. AFAIK they are reasonably happy with my performance. I felt this was in effect similar to extending a packageset, so for convenience reasons... That's all.
19:20 <rbasak> Thanks. That makes me wonder actually. Does this set of packages form a packageset? Should we be creating one instead?
19:21 <rbasak> It seems to me that it generally is "language support". Is this accurate?
19:21 <GunnarHj> rbasak: I have thought the same. Not easy to define a packageset for l10n/i18n though...
19:21 <GunnarHj> rbasak: Yes, it's "language support" in a sense.
19:21 <rbasak> Why is "l10n/i18n" not a good description? :)
19:22 <GunnarHj> rbasak: Sure, ok for me...
19:22 <rbasak> Does accountsservice and/or ubuntu-docs fit into this as well? I imagine the latter does? What about accountsservice?
19:23 <GunnarHj> rbasak: The part of accountsservice I'm dealing with is closely related to language-selector. (ubuntu-docs does not fit IMO.)
19:24 <rbasak> OK, thanks.
19:25 <rbasak> I'm interested in the DMB elders' views on this. Should we create a i18n packageset?
19:25 * sil2100 is a newbie here
19:25 <sil2100> bdmurray: ^?
19:25 <bdmurray> I don't think there is a need at this point in time.
19:25 <micahg> if we think people might be interested in such a thing, it sounds fine
19:26 <GunnarHj> Currently I'd proably be the only member.
19:26 <bdmurray> In which case I'd wait for another member.
19:26 <rbasak> OK
19:26 <sil2100> Maybe let's think about it next time
19:26 <bdmurray> Or look for other devs w/ PPU for some of those packages.
19:27 <sil2100> An action item for this maybe? Could someone check this?
19:28 <sil2100> Does anyone want to pick up checking other devs with the same/similar sets of packages?
19:28 <bdmurray> I will
19:29 <sil2100> #action bdmurray to check for other PPU devs with similar packages to the proposed 'language support' packageset
19:29 * meetingology bdmurray to check for other PPU devs with similar packages to the proposed 'language support' packageset
19:29 <sil2100> Ok, any other questions?
19:31 <sil2100> Let's vote in that case
19:32 <sil2100> #vote
19:32 <meetingology> Please vote on:
19:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:32 <sil2100> Sorry, cat pressed enter too soon...
19:32 <sil2100> #endvote
19:32 <meetingology> No vote in progress
19:32 <rbasak> Interesting.
19:33 <rbasak> Is this Perl "empty string vs. undef"?
19:33 <sil2100> #vote Gunnar Hjalmarsson on extending PPU packages as per request
19:33 <meetingology> Please vote on: Gunnar Hjalmarsson on extending PPU packages as per request
19:33 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:34 <bdmurray> +1
19:34 <meetingology> +1 received from bdmurray
19:34 <sil2100> +1 (I suppose his work on the requested packages shows sufficient knowledge and involvement)
19:34 <meetingology> +1 (I suppose his work on the requested packages shows sufficient knowledge and involvement) received from sil2100
19:35 <rbasak> +1 on the strength and nature of previous endorsements
19:35 <meetingology> +1 on the strength and nature of previous endorsements received from rbasak
19:36 <rbasak> As a new DMB member I found it pretty hard without endorsements though, so I'm not sure about how I feel about this in principle. GunnarHj's previous endorsements were very strong though so I have little doubt about it this time.
19:36 <rbasak> BenC? micahg?
19:36 <BenC> +1
19:36 <meetingology> +1 received from BenC
19:37 <bdmurray> I guess I've seen a lot of his work as an SRU team member.
19:37 <sil2100> I suppose the packages were similar 'in nature' to the ones previously in his PPU rights so I guess this time it seemed to be natural and ok
19:37 <BenC> I found enough paper trail to be comfortable.
19:37 <micahg> +0 I unfortunately didn't have time to review, but have seen good work in the past
19:37 <meetingology> +0 I unfortunately didn't have time to review, but have seen good work in the past received from micahg
19:38 * BenC reviewed it this morning
19:38 <sil2100> #endvote
19:38 <meetingology> Voting ended on: Gunnar Hjalmarsson on extending PPU packages as per request
19:38 <meetingology> Votes for:4 Votes against:0 Abstentions:1
19:38 <meetingology> Motion carried
19:38 <sil2100> GunnarHj: congratulations!
19:38 <GunnarHj> Thanks for the showed confidence! :)
19:38 <sil2100> I never did this before, who can actually do the permission changes in this case?
19:39 <rbasak> GunnarHj: thank you for looking after these packages for Ubuntu
19:39 <sil2100> I suppose I could do this as well but I would have to be instructed
19:39 <rbasak> edit-acl from ubuntu-archive-tools
19:39 <sil2100> Ok, let me put that on my list in that case
19:39 <rbasak> I haven't actually used it to change permissions yet but I think I understand it now.
19:39 <rbasak> I'm happy to take the action if you like, so I can learn the ropes.
19:40 <sil2100> rbasak: ok, so you go first, I'll pick it up next time in that case
19:40 <sil2100> rbasak: thanks!
19:40 <rbasak> ack
19:40 <sil2100> Ok, so I guess that's it for this topic, nothing more on the agenda
19:40 <sil2100> #topic AOB
19:41 <rbasak> sil2100: set me an #action please?
19:41 <sil2100> Ah, right!
19:41 <rbasak> sil2100: also a carry over for cyphermox I guess.
19:41 <sil2100> #action rbasak to make permission changes for new PPU packages for GunnarHj
19:41 * meetingology rbasak to make permission changes for new PPU packages for GunnarHj
19:41 <bdmurray> I don't see ubuntu-mate here either fwiw https://wiki.ubuntu.com/UbuntuDevelopers#Ubuntu_Developers_.28from_delegated_teams.29
19:41 <sil2100> #action cyphermox Update Mate packages per Iain Laney's suggestions
19:41 * meetingology cyphermox Update Mate packages per Iain Laney's suggestions
19:42 <sil2100> Ok, any other business?
19:43 <bdmurray> I wonder if that wiki page should be updated to include ubuntu-mate-dev
19:43 <rbasak> I assumed that would be for cyphermox to do when he looks at creating the packageset?
19:44 <bdmurray> Ah, fair enough.
19:44 <sil2100> btw. I saw "Ubuntu uTouch Uploaders (Launchpad: ~ubuntu-utouch-dev)" which doesn't exist apparently
19:44 <sil2100> Does anyone know why is it listed there? Was that supposed to be for ubuntu-touch or for some utouch packages that we don't have anymore?
19:45 <sil2100> I wonder if there are more items that do not exist anymore right now
19:46 <bdmurray> sil2100: You should check ;-)
19:47 <sil2100> Ok, if that's a sensible action item let me add that for myself ;)
19:48 <sil2100> #action sil2100 to check the state of Ubuntu uTouch Uploaders and any other teams that might be non-existent
19:48 * meetingology sil2100 to check the state of Ubuntu uTouch Uploaders and any other teams that might be non-existent
19:48 <sil2100> Right, anything else?
19:48 <rbasak> fonts-* is a really big list
19:48 <rbasak> Is that OK?
19:49 <rbasak> It surprises me, I just wanted to check if it was just me
19:49 <rbasak> http://paste.ubuntu.com/16642048/
19:50 <rbasak> The other expansions are as I'd expect.
19:51 <rbasak> For fonts-* would it worth creating a packageset called "fonts-*" just to make it a little more manageable?
19:52 <sil2100> hm, indeed a huge list
19:52 <rbasak> If nobody knows I can take it to the list.
19:52 <sil2100> That idea seems worth considerating
19:53 <rbasak> OK I'll take it to the list.
19:53 <sil2100> Ok
19:53 <GunnarHj> As regards fonts-*: Sure, it's long. And probably there is no reason to touch most of them in Ubuntu (synced from Debian). But it's hard to anticipate when there is a need...
19:54 <rbasak> GunnarHj: sure - looking at your upload history I think it makes little sense to give you PPU to just what you've touched, since next time it's likely to be another and they presumably all work the same way.
19:55 <rbasak> So I support giving you upload rights to it all, just wondering how technically to do it such that it remains manageable for us.
19:55 <rbasak> I'll take it to the list.
19:55 <sil2100> If there are no other items, let's finish today's meeting and discuss the fonts-* packageset on the ML
19:56 <sil2100> Assuming we're good to finish up
19:56 <sil2100> #endmeeting