19:09 <infinity> #startmeeting DMB meeting
19:09 <meetingology> Meeting started Mon Apr 25 19:09:34 2016 UTC.  The chair is infinity. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:09 <meetingology> 
19:09 <meetingology> Available commands: action commands idea info link nick
19:09 <infinity> #topic Review actions from last meeting
19:10 <infinity> cyphermox to make membership changes
19:10 <infinity> Iz done?
19:10 <cyphermox> yes, iz done.
19:10 <infinity> bdmurray to summarize meeting / send announcements
19:12 <infinity> That appears to have not been done since Sept 2015. :P
19:12 <infinity> Perhaps time to revisit team reports.
19:12 <infinity> DMB members who didn't consent to fill in feedback to Noskcaj
19:12 <infinity> ^-- Did people do this?
19:12 <BenC> I don’t know what that is
19:13 <BenC> It was on the agenda last week, too.
19:13 <infinity> I missed the last meeting which is, I assume, where this action came up?
19:13 <BenC> Last meeting
19:13 <infinity> Oh.
19:13 <infinity> Well, does someone know what it means?  If not, we should strike it instead of carrying it.
19:13 <BenC> I think it’s left over from September.
19:13 <sil2100> I guess this was some leftover from the previous meetings? Like the old old?
19:13 <infinity> cyphermox: Any ideas?
19:14 <micahg> yeah, at this point it's a new DMB and he should reapply if he has people willing to endorse his application
19:14 <infinity> Check.
19:14 <infinity> I'll strike the action.
19:14 <BenC> So let it be written...
19:14 <cyphermox> infinity: indeed
19:14 <infinity> Moving on.
19:15 <infinity> flexiondotorg: You here?
19:15 <flexiondotorg> Present.
19:15 <infinity> #topic Martin Wimpress MATE PPU upload application
19:15 <infinity> flexiondotorg: Tell us all about MATE, yourself, your life histoy, and you'd cat's medical records.
19:16 <flexiondotorg> OK
19:16 <infinity> While slackers like me go read the application.
19:16 <flexiondotorg> MATE is the continuation of GNOME2.
19:16 <flexiondotorg> But updated to support modern technologies suchs as gsettings, systemd and GTK3+
19:17 <BenC> How many other people are involved in the project?
19:17 <flexiondotorg> I'm a MATE core team member and have been for several years now.
19:17 <flexiondotorg> I also am chief executive minion for MATE Desktop team.
19:17 <flexiondotorg> For MATE, about 6 regular core contriutors.
19:18 <BenC> Do you mentor contributors outside of the core?
19:18 <flexiondotorg> And about 20 somewhat regualr commiters.
19:18 <flexiondotorg> I do.
19:18 <infinity> flexiondotorg: So, at a quick glance, even without any nitpicking interview bits, I'd say PPU for the 7 packages you listed is probably a no-brainer, *but* I'd also argue you made the packageset way too small.
19:18 <flexiondotorg> I've mentored via GSoC
19:18 <infinity> flexiondotorg: What's your argument for not including the entire mate desktop environment in this?
19:18 * BenC wondered that as well
19:18 <flexiondotorg> infinity, Orginally the package set included all of MATE.
19:18 <flexiondotorg> I was asked to reduce it.
19:19 <micahg> is this a packageset application or PPU?
19:19 <flexiondotorg> I maintain mATE in Debian.
19:19 <infinity> flexiondotorg: ORLY?  Who asked you to reduce it?
19:19 <flexiondotorg> So all of MATE is synced from Debian directly to Ubuntu without changes.
19:19 <infinity> I mean, I assume the DMB, but I clearly missed that meeting. :P
19:19 <flexiondotorg> infinity, I forget who asked.
19:19 <BenC> Is there an existing package set that 1 or more of the other core contributors has access to?
19:19 <flexiondotorg> But look at the wiki history, you'll see I removed loads.
19:19 <infinity> flexiondotorg: Yes, and that works well for you in the devel cycle, but you just signed up for a 3 year LTS, and you can't sync from Debian for that.
19:19 <flexiondotorg> Yes.
19:20 <flexiondotorg> When the freeze happens I make fixes in Debian and then requestsync those to Ubuntu.
19:20 <flexiondotorg> And that slow us up somewhat.
19:20 <infinity> Anyhow, I think we can break this into two topics so we don't get bogged down in more confusion and delays for you.
19:20 <sil2100> flexiondotorg: as per our IRC PM discussion, it's best to ask for more - if it's too much we would propose a smaller set then
19:20 <infinity> Does anyone have questions for Martin WRT the current package set request and his competencies?
19:21 <flexiondotorg> So if I was able to process those MATE syncrequests during freeze it would be a great help and also unburden the desktop, sponsors and release teams who I've leaned on quite a bit over the last 18 months.
19:21 <infinity> We'll attack the issue of the size of the set in a second.
19:22 <flexiondotorg> Should I propose the MATE Desktop package set now?
19:22 <infinity> Right, I don't see anyone stumbling over themselves to ask things.  So I'm doing this in two bits.
19:22 <BenC> I’m good on competency and relevance of his application
19:22 <infinity> flexiondotorg: Sec. :P
19:22 <sil2100> Fine from my side, I already had opportunities to see flexiondotorg's work
19:22 <infinity> #startvote Create a MATE packgeset (based on the current set in the wiki) and give Martin Wimpress upload rights for it
19:22 <rbasak> I think flexiondotorg having driven the milestones speaks for itself wrt. his knowledge of the release cycle.
19:23 <BenC> +1
19:23 <infinity> #vote Create a MATE packgeset (based on the current set in the wiki) and give Martin Wimpress upload rights for it
19:23 <meetingology> Please vote on: Create a MATE packgeset (based on the current set in the wiki) and give Martin Wimpress upload rights for it
19:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:23 <rbasak> And with him maintaining in Debian, general upload access is a no-brainer. Together with his Ubuntu contributions.
19:23 <infinity> Better.
19:23 <infinity> +1
19:23 <meetingology> +1 received from infinity
19:23 <sil2100> +1
19:23 <meetingology> +1 received from sil2100
19:23 <BenC> +1
19:23 <meetingology> +1 received from BenC
19:23 <rbasak> +1
19:23 <meetingology> +1 received from rbasak
19:23 <infinity> #endvote
19:23 <meetingology> Voting ended on: Create a MATE packgeset (based on the current set in the wiki) and give Martin Wimpress upload rights for it
19:23 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:23 <meetingology> Motion carried
19:23 <micahg> +1
19:23 <infinity> micahg: We had quorum, you're too late. ;)
19:23 <infinity> Okay.  So, second knock-off item.
19:24 <infinity> #vote We believe the MATE packageset is probably too limited, vote to assign an action to Martin to propose a larger scope for review out-of-band or at the next meeting
19:24 <meetingology> Please vote on: We believe the MATE packageset is probably too limited, vote to assign an action to Martin to propose a larger scope for review out-of-band or at the next meeting
19:24 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:24 <infinity> +1
19:24 <meetingology> +1 received from infinity
19:24 <BenC> +1
19:24 <meetingology> +1 received from BenC
19:24 <sil2100> +1
19:24 <meetingology> +1 received from sil2100
19:24 <rbasak> +1
19:24 <meetingology> +1 received from rbasak
19:24 <sil2100> (would give that to him already personally)
19:24 <rbasak> But presumably we can start with his list?
19:25 <infinity> rbasak: Right, hence why I did it in two votes.  We'll set him up ASAP with the current list, then expand it based on his proposed additions.
19:25 <infinity> Delaying the former for the latter seems pointless.
19:25 <rbasak> Yeah that's what I was asking. I didn't think we'd just voted for that :)
19:25 <micahg> +1
19:25 <meetingology> +1 received from micahg
19:25 <infinity> #endvote
19:25 <meetingology> Voting ended on: We believe the MATE packageset is probably too limited, vote to assign an action to Martin to propose a larger scope for review out-of-band or at the next meeting
19:25 <meetingology> Votes for:5 Votes against:0 Abstentions:0
19:25 <meetingology> Motion carried
19:25 <rbasak> But I think it's safe to assume that everyone's fine with it.
19:25 <rbasak> (or understood that already if it's just me)
19:26 <infinity> flexiondotorg: Alright, you have an action to bring us a better/expanded list.  But we'll hook you up with the tiny list after the meeting's done.
19:26 <flexiondotorg> Thanks everyone, that's brilliant :-)
19:26 <infinity> Oh, and I'll take an executive action to make this retroactive to xenial, so you're not stuck mainintaining an LTS you can't upload to. :P
19:26 <BenC> flexiondotorg: Congrats
19:27 <flexiondotorg> infinity, That's even more perfect.
19:27 <rbasak> flexiondotorg: what took you so long? :-)
19:27 <sil2100> ;)
19:27 <flexiondotorg> rbasak, The DMB was on hiatus ;-)
19:27 <infinity> #action infinity to update xenial and yakkety for ubuntu-mate packageset and flexiondotorg's upload privs to same
19:27 * meetingology infinity to update xenial and yakkety for ubuntu-mate packageset and flexiondotorg's upload privs to same
19:28 <infinity> #action flexiondotorg to bring us an expanded MATE packageset proposal
19:28 * meetingology flexiondotorg to bring us an expanded MATE packageset proposal
19:28 <flexiondotorg> Thanks everyone.
19:28 <sil2100> yw, congratulations!
19:29 <infinity> Okay, and due to both the lack of psusi in the meeting and the lack of endorsements on his application, we'll defer him to another time.
19:29 <infinity> #topic AOB
19:29 <infinity> Next chair is BenC.
19:30 <infinity> With a backup of sil2100
19:30 <sil2100> Uh oh!
19:30 <sil2100> Ok
19:30 <infinity> I'd like to propose that someone actually fix the (&(*!%%! fridge calendar to (a) accurately represent the meeting times and (b) invite everyone with their preferred calendar email address (adam.conrad@canonical.com for me, please)
19:31 <infinity> Anyone want to take that action?
19:31 <sil2100> I could take care of that - never did anything to the fridge before
19:31 <infinity> I might actually show up to meetings if my phone yells at me.
19:31 <sil2100> Besides opening up for food and drinks
19:31 <infinity> sil2100: It's not too hard to sort out.  Go nuts.
19:31 <infinity> The key is knowing the meeting times.
19:31 <infinity> Which I clearly don't.
19:31 <sil2100> Ok, add an action item so I don't forget
19:32 <infinity> #action sil2100 to fix the Fridge calendar to list DMB meetings at the right times and invite the current members
19:32 * meetingology sil2100 to fix the Fridge calendar to list DMB meetings at the right times and invite the current members
19:32 <sil2100> Thanks o/
19:32 <infinity> sil2100: For Canonical employees, invite first.last@canonical (unless someone requests otherwise), since those are our work calendars.  You might have to ask the non-canonical people for their preferred annoyance address for gcal invites.
19:32 <micahg> do we want to take a poll for meeting times for the new board
19:33 <infinity> We're 4 NA and 2 EU, and no APAC?
19:33 <infinity> Shouldn't be hard to just find one time that works for all 6.
19:33 <infinity> Unless we want to keep alternating to make it easier on applicants.
19:33 <rbasak> I'm happy with the current timing. Evening for me isn't great but presumably that'd be a bit harsh.
19:34 <micahg> I think that alternation is for applicants, yes
19:34 <rbasak> So alternating works for me.
19:34 <infinity> Kay.  I'm not picky, so long as I have reminders. ;)
19:34 <BenC> benmcollins13@gmail.com for my cal
19:35 <rbasak> first.last@ubuntu.com for me please.
19:35 <infinity> rbasak: ubuntu.com, really?  Not canonical.com?  Do you run two calendars?
19:36 <infinity> (weirdo)
19:36 <rbasak> Oh, good point. I have no idea where calendar invites actually go when sent by email.
19:36 <rbasak> @canonical.com is my gcal.
19:36 <meetingology> rbasak: Error: "canonical.com" is not a valid command.
19:36 <infinity> Right, canonical.com then. :P
19:36 <rbasak> But I'm not sure sent-by-email invites work anyway.
19:36 <infinity> rbasak: Right, the Fridge is more magic than sent-by-email.
19:37 <rbasak> Ah, OK. Thanks.
19:37 <infinity> micahg: Preferred email for gcal invites, for sil2100 to sort?  The rest of us can just use @canonical.
19:37 <infinity> And I'd like to close the meeting.
19:38 <infinity> Which I'll do if no one has AOAOB.
19:38 <infinity> Going once.
19:38 <infinity> Twice.
19:38 <infinity> #endmeeting