21:06 <tsimonq2> #startmeeting Ubuntu LoCo Portal Planning
21:06 <meetingology> Meeting started Wed Feb 24 21:06:08 2016 UTC. The chair is tsimonq2. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:06 <meetingology>
21:06 <meetingology> Available commands: action commands idea info link nick
21:06 <tsimonq2> Welcome to the meeting to plan items for the LoCo portal!
21:07 <tsimonq2> I kinda already know who's here, so let's just get to business! :)
21:07 <tsimonq2> Here is what I kinda threw together: https://wiki.ubuntu.com/LoCoTeamPortal/Meetings/20160224
21:08 <pleia2> o/
21:08 <tsimonq2> hello pleia2 :)
21:08 <wxl> oh hai pleia2 !
21:08 <nhaines> o/
21:08 <pleia2> if you'd like, I could share some of what we did in 2012 to jumpstart development
21:08 <wxl> hai nhaines :)
21:09 <pleia2> (it obviously didn't work, but we learned some things)
21:09 <tsimonq2> so now I want to look at existing portal bugs and see if we can point out a few, just for the sake of looking them over: https://bugs.launchpad.net/loco-team-portal/
21:09 <tsimonq2> #topic Existing *
21:10 * tsimonq2 guesses he did that right :)
21:10 <wxl> buncha undecided/news that need triaged
21:10 <tsimonq2> well what kinda concerns me is that there are some critical bugs
21:10 <tsimonq2> that's not good
21:11 <tsimonq2> and then a whole lot of wishlist items among others
21:12 <tsimonq2> the critical bugs are: bug 881019 bug 1225610 bug 1273491 bug 1372124
21:12 <ubottu> bug 881019 in Launchpad itself "Lp login is broken after account merge" [High,Triaged] https://launchpad.net/bugs/881019
21:12 <ubottu> bug 1225610 in LoCo Team Portal "Standard Timezone are reverted back to UTC" [Critical,Triaged] https://launchpad.net/bugs/1225610
21:12 <ubottu> bug 1273491 in LoCo Team Portal "Merge functionnality only merges the events" [Critical,Triaged] https://launchpad.net/bugs/1273491
21:12 <ubottu> bug 1372124 in LoCo Team Portal "The Django version that the LTP uses is unsupported now" [Critical,Triaged] https://launchpad.net/bugs/1372124
21:12 <tsimonq2> oh that's weird it says one of them is just high...
21:12 <wxl> that first one sounds like it MIGHT be an sso issue
21:12 <wxl> and frankly kind of edge casey
21:13 <daker> tsimonq2: bug 881019 we can't do much, it's on LP side
21:13 <tsimonq2> so should it be taken off the portal tracker?
21:13 <wxl> i mean, how many users do we have that have merged lp accounts?
21:13 <tsimonq2> ¯\_(ツ)_/¯
21:13 <tsimonq2> I don't know, you have a point, wxl
21:13 <wxl> tsimonq2: it needs further testing to confirm that it's sso, but i vote making it low
21:13 <tsimonq2> I vote that as well
21:14 <daker> tsimonq2: a few
21:14 <tsimonq2> well just remove the LoCo portal from that
21:14 <tsimonq2> I think it's just irrelevant
21:14 <wxl> bug 1225610 seems like it needs to be tested further. i'm not sure we can call it triaged without it being confirmed
21:14 <ubottu> bug 1225610 in LoCo Team Portal "Standard Timezone are reverted back to UTC" [Critical,Triaged] https://launchpad.net/bugs/1225610
21:14 <tsimonq2> I have experienced it
21:15 <tsimonq2> could we confirm?
21:15 <wxl> well if you say you have, you could then confirm it
21:15 <wxl> bug 1273491 needs reviewed
21:15 <ubottu> bug 1273491 in LoCo Team Portal "Merge functionnality only merges the events" [Critical,Triaged] https://launchpad.net/bugs/1273491
21:16 <tsimonq2> #action Remove bug 881019 from the LoCo Portal Project on Launchpad
21:16 * meetingology Remove bug 881019 from the LoCo Portal Project on Launchpad
21:16 <ubottu> bug 881019 in Launchpad itself "Lp login is broken after account merge" [High,Triaged] https://launchpad.net/bugs/881019
21:16 <wxl> bug 1372124 we talked about before. we need to get to a current django
21:16 <ubottu> bug 1372124 in LoCo Team Portal "The Django version that the LTP uses is unsupported now" [Critical,Triaged] https://launchpad.net/bugs/1372124
21:16 <daker> tsimonq2: maybe we can rework the TZ stuff once we migrate to a newer django version
21:16 <wxl> +1 daker
21:16 <daker> wxl: first thing to do is to check with IS first
21:16 <wxl> in fact i'd say that should be our #1 priority before we start messing with much else
21:16 <tsimonq2> yeah I agree, daker, if we are using an old django version that should totally be considered
21:16 <tsimonq2> +1 wxl
21:17 <tsimonq2> #action Upgrade the django version for the LoCo Portal
21:17 * meetingology Upgrade the django version for the LoCo Portal
21:17 <tsimonq2> also, something that I noticed is that the LoCo portal running in production is a commit behind
21:18 <tsimonq2> daker: would you be willing to talk to IS to get that fixed?
21:18 <daker> tsimonq2: also check with IS what version to use
21:18 <tsimonq2> the docs are lacking for how to do that
21:18 <wxl> #action wxl make an rt ticket re: upgrading django and what version to use
21:18 * meetingology wxl make an rt ticket re: upgrading django and what version to use
21:18 <daker> tsimonq2: what do you mean ?
21:19 <tsimonq2> daker: well I know there is documentation somewhere to submit an IS ticket for this, that needs to be reviewed
21:19 <wxl> tsimonq2: i got that. i can talk to is (see action)
21:19 <daker> https://wiki.ubuntu.com/LoCoTeamPortal/ReleaseProcess
21:20 <tsimonq2> wxl: alright, cool, I guess that's out of the way
21:20 <tsimonq2> bug 1273491?
21:20 <ubottu> bug 1273491 in LoCo Team Portal "Merge functionnality only merges the events" [Critical,Triaged] https://launchpad.net/bugs/1273491
21:20 <tsimonq2> what's up with that?
21:20 <wxl> needs reviewed
21:20 <tsimonq2> whoops sorry didn't see :)
21:21 <tsimonq2> so I think that's it for reviewing existing bugs?
21:21 <tsimonq2> s/existing/critical/
21:21 <wxl> yep
21:21 <wxl> someone needs to triage, too
21:21 <tsimonq2> I really think the other bugs can be looked at seperately if you choose, but the critical ones should be fixed ASAP
21:21 <tsimonq2> yeh I can help with that, wxl
21:22 <wxl> tsimonq2: action it :)
21:22 <tsimonq2> #action Triage the LoCo Portal Bugs on Launchpad: https://bugs.launchpad.net/loco-team-portal/
21:22 * meetingology Triage the LoCo Portal Bugs on Launchpad: https://bugs.launchpad.net/loco-team-portal/
21:22 <tsimonq2> wxl: :P
21:23 <tsimonq2> so is that it for existing items?
21:23 <tsimonq2> as always, non-existent bugs can be reported here: https://bugs.launchpad.net/loco-team-portal/+filebug
21:23 <wxl> yep and i think we can tackle requested features once we get a handle on having a stable version with current django, etc
21:24 <tsimonq2> I agree
21:24 <tsimonq2> #topic New features
21:25 <tsimonq2> Okay, so does anyone want to speak up and request a feature for the portal? Just throw an idea out there.
21:26 <tsimonq2> Anyone?
21:26 <tsimonq2> Well, I guess we don't really need this, so I'll move on, unless somebody speaks up within the next 30 seconds
21:27 <tsimonq2> #topic Release schedule?
21:27 <tsimonq2> so i was wondering, do we need a release schecule for the tracker?
21:27 <tsimonq2> something to plan this out
21:27 <wxl> hm
21:27 <tsimonq2> or should it be on a case-by-case process of fixing bugs?
21:28 <daker> tsimonq2: i guess just case-by-case
21:28 <wxl> well it would be nice to have a release schedule, ideally
21:28 <tsimonq2> nhaines, pleia2: Do you have prior experience with this?
21:28 <wxl> but i think that given current resources and the state of the project, i'd suggest case-by-case
21:28 <tsimonq2> is there a point in time that it should be implemented?
21:29 <pleia2> I've not been involved with the point releases
21:29 <wxl> naw, i don't think so. just keep on fixing bugs and adding features regularly and no one will complain XD
21:29 <pleia2> most of my focus last time around was making sure devs had a dev environment, and telling people about how to bring it up with vagrant
21:29 <tsimonq2> pleia2: what's vagrant?
21:30 <tsimonq2> or is that a person?
21:30 <pleia2> tool for creating localized, virtual development environments
21:30 <tsimonq2> ahh okay
21:31 <tsimonq2> but I guess it might be good to have time-based goals for things
21:31 <nhaines> I haven't been involved in releases either.
21:31 <pleia2> our concern was having developers :)
21:31 <tsimonq2> alright :)
21:31 <nhaines> That's my main question. *Do* we have developers for this?
21:31 <tsimonq2> That's a really good question.
21:32 <tsimonq2> I'm willing to help
21:32 <wxl> pleia2: do you have that documented?
21:32 <wxl> i'm also willing to help
21:32 <pleia2> wxl: http://princessleia.com/journal/?p=6662
21:32 <tsimonq2> yesm and we need documentation as well
21:32 <tsimonq2> *yes
21:32 <pleia2> wxl: it walks through what's already on the wiki
21:32 <tsimonq2> pleia2: link?
21:32 <wxl> tsimonq2: you should get a dev wiki page if there isn't already one
21:32 <pleia2> https://wiki.ubuntu.com/LoCoTeamPortal
21:32 <tsimonq2> ahh okay
21:32 <pleia2> under "Get Started" has links
21:32 <tsimonq2> wxl: there is :)
21:32 <wxl> tsimonq2: k nevermind :)
21:33 <pleia2> and since this was from back in 2012, it was all on 12.04
21:33 <wxl> riiiight so we should have action to double check all that
21:33 <tsimonq2> I guess documentation really needs to be updated, because as you said, this was from 4 years ago, and if we want to have developers, we need good docs
21:33 <wxl> with a mid-term goal of getting more devs to fix these issues once we have the major infrastructure problems fixed
21:33 <pleia2> being able to bring ltp up on vagrant on our laptop/desktop was a huge help to getting anyone who is familiar with django/python looking at bugs
21:34 <tsimonq2> #action Revise existing documentation
21:34 * meetingology Revise existing documentation
21:34 <pleia2> ultimately we didn't really succeed, people get busy, back then daker was our core dev too
21:34 <pleia2> but I think it's great that you're trying again
21:35 <tsimonq2> yeah, I really think the LoCo portal has the potential to be a really useful tool
21:35 <daker> #action Upgrade vagrant to the lastest version
21:35 * meetingology Upgrade vagrant to the lastest version
21:35 <tsimonq2> I guess we are getting off topic for releases, so I'll change that quick
21:35 <tsimonq2> #topic Documentation
21:35 <tsimonq2> so what do we need updated?
21:36 <pleia2> I recommend someone going through all the links on https://wiki.ubuntu.com/LoCoTeamPortal
21:37 <pleia2> I was the last one to touch that page, in 2012
21:37 <tsimonq2> let's start with discussing the Get Started portion
21:37 <pleia2> LoCoTeamPortal (last edited 2012-08-28 08:57:38 by lyz)
21:37 <tsimonq2> #subtopic "Get Started"
21:37 <tsimonq2> #progress "Get Started"
21:37 <tsimonq2> oh :P
21:37 <tsimonq2> anyways
21:38 <tsimonq2> it just shows how to branch the repo and now to open the INSTALL file
21:38 <tsimonq2> I could totally see this being a seperate page
21:38 <tsimonq2> thoughts?
21:39 <wxl> i don't see that as a bad thing
21:39 <tsimonq2> me neither
21:39 <tsimonq2> I'll #action it
21:39 <tsimonq2> #action tsimonq2: Move the "Get Started" to a different subpage
21:39 * meetingology tsimonq2: Move the "Get Started" to a different subpage
21:40 <pleia2> I think checking all sections for accuracy should be the highest priority, you can reshuffle at any time
21:40 <tsimonq2> yeah I agree
21:41 <tsimonq2> but we laready have an action item there :)
21:42 <tsimonq2> so I think docs needs to be a major focus of this
21:42 <tsimonq2> anything else about documentation before we move on?
21:43 <tsimonq2> #topic Existence/How do we make it more useful?
21:44 <tsimonq2> so we know this has been used by teams, but I have been hearing that tems are starting to move away from it
21:44 <tsimonq2> *teams
21:44 <tsimonq2> how do we make this more useful
21:44 <tsimonq2> ?
21:44 <wxl> well
21:44 <tsimonq2> and should this still exist?
21:44 <wxl> i hear some people complaining about it
21:44 <wxl> (but people complain about everything)
21:44 <tsimonq2> heheheh I guess
21:45 <wxl> but as far as the loco team is concerned, i see no plan to move away from it
21:45 <wxl> i like it
21:45 <tsimonq2> I agree
21:45 <wxl> it does add functionality that doesn't exist on the wiki
21:45 <tsimonq2> and I just think it needs a bit of work
21:45 <tsimonq2> which is why we are here :)
21:45 <wxl> we can always work on better integrating information between the two resources but that's simple
21:46 <wxl> i'd say the bigger issue with the loco team is getting people to even look at ANY of the resources
21:46 <tsimonq2> yeah
21:46 <wxl> i was in the community for years before i ever heard of the notion of locos!
21:47 * tsimonq2 wonders if Ubuntu has a marketing team...
21:47 <pleia2> there is an inactive community marketing team (mailing list, channel)
21:48 * wxl wonders if Canonical has a community manager XD
21:48 <nhaines> wxl: about half a dozen of them. :P
21:48 <wxl> nhaines: i guess manager is not the right word. a liason. evangelist.
21:50 <tsimonq2> #votesrequired 3
21:50 <meetingology> votes now need 3 to be passed
21:50 <tsimonq2> #voters nhaines wxl tsimonq2 pleia2 daker
21:50 <meetingology> Current voters: daker nhaines pleia2 tsimonq2 wxl
21:50 <tsimonq2> #vote Does the LoCo Portal still need to exist?
21:50 <meetingology> Please vote on: Does the LoCo Portal still need to exist?
21:50 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
21:50 <tsimonq2> I guess I want to see if this is a universal opinion
21:50 <wxl> +1 for me
21:50 <meetingology> +1 for me received from wxl
21:50 <tsimonq2> +1 It's really useful
21:50 <meetingology> +1 It's really useful received from tsimonq2
21:51 <nhaines> +1 It's a critical piece of infrastructure at this time.
21:51 <meetingology> +1 It's a critical piece of infrastructure at this time. received from nhaines
21:51 <pleia2> +1 still being used by many teams
21:51 <meetingology> +1 still being used by many teams received from pleia2
21:51 <wxl> if anyone else wants to vote that isn't on the list of voters, please say so
21:51 <tsimonq2> I'll give them a minute from now
21:51 <tsimonq2> then I'll end it :)
21:52 <wxl> i'd be curious to see what daker says ("-1 i don't want to develop this crap anymore") XD
21:52 <tsimonq2> in the meantime, I guess Twitter/Facebook posts might be something to consider, maybe something like built-in meeting announcements with links :)
21:52 <wxl> i'm kidding, btw.
21:52 <tsimonq2> #endvote
21:52 <meetingology> Voting ended on: Does the LoCo Portal still need to exist?
21:52 <meetingology> Votes for:4 Votes against:0 Abstentions:0
21:52 <meetingology> Motion carried
21:52 <genii> Even though our Loco ( Ubuntu Canada) was not renewed, we still use those event pages for our release parties and other things like Ubuntu Hours
21:53 <tsimonq2> awesome, genii :)
21:53 <daker> +1 but it's need to be complementary with the other tool provided by canonical
21:53 <tsimonq2> other tool?!?!?!?
21:53 <wxl> genii: yikes a whole country and not renewed? :( come see the loco-council!
21:53 <tsimonq2> #topic Misc.
21:54 <tsimonq2> anything else from anyone?
21:54 <tsimonq2> I think it would be a good idea to have another meeting at the same time and day of the week/week as next month, so March 23
21:55 <tsimonq2> would everyone be good with that?
21:55 <wxl> works for me
21:55 <tsimonq2> then we can look at what's been done
21:55 <tsimonq2> daker? you ultimately decide because the meeting doesn't go on without you :)
21:56 <daker> tsimonq2: i am having some internet connexion :/
21:56 <daker> issues*
21:56 <tsimonq2> daker: does March 23, same time, work for you?
21:57 <daker> tsimonq2: yes
21:57 <tsimonq2> alright good
21:57 <tsimonq2> right at 4 PM CST(idk what it is UTC or other time zones), I'll end the meeting, just in case anyone wants to say anything else
21:58 <wxl> tsimonq2: /exec - date -u
21:59 <tsimonq2> at 22 utc :)
21:59 <tsimonq2> thanks wxl :D
21:59 <tsimonq2> okay, thanks guys, I'll see you next month! have a nice afternoon/night! :)
22:00 <wxl> thx tsimonq2
22:00 <tsimonq2> #endmeeting