16:01 <zul> #startmeeting
16:01 <meetingology> Meeting started Tue Jan 19 16:01:11 2016 UTC.  The chair is zul. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:01 <zul> #action Review ACTION points from previous meeting
16:01 * meetingology Review ACTION points from previous meeting
16:02 <zul> was there any action points from the previous meeting
16:02 <cpaelzer> late o/
16:02 <teward> thought there wasn't a previous meeting?
16:02 <teward> (one was missed, I think)
16:02 <zul> ok then
16:03 <zul> action: Xenial Development
16:03 <zul> jgrim: do you want to take this one
16:04 <zul> jgrimm: ^^^
16:04 <zul> #topic  Xenial Development
16:04 * jgrimm notices
16:05 <zul> smoser: ^^^
16:05 <jgrimm> feature freeze on its way Feb 18
16:05 <jgrimm> mad scramble for merges, would love more help. most important packages for merge being tracked in blueprint.
16:06 <jgrimm> but as this is an LTS release ideally would get currency across as much as feasibly possible
16:06 <zul> cool anything else?
16:06 <jgrimm> that's abou tit
16:06 <jgrimm> about it. eek
16:06 <teward> just for FYI awareness...
16:06 <zul> #topic Assigned bugwork (rbasak)
16:07 <zul> teward: go ahead
16:07 <teward> nginx 1.9.9-1ubuntu1 merged in on the 16th, after a -0ubuntu1 direct upload due to Debian being months behind
16:07 <teward> (from the 6th)
16:07 <rbasak> I've deferred bug work in favour of focusing on merges from the blueprint for now.
16:07 <teward> just wanted to give that as an awareness / FYI, with no additional action items there :)
16:07 <rbasak> Thanks teward!
16:07 <jgrimm> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-x-server-core
16:07 <rbasak> teward is so on the ball with nginx, I didn't think it necessary to create a blueprint item to track it.
16:08 <teward> rbasak: may wish to for the post-FF ones, though I have to add to my workflow to poke the Release team for FF review, with each new version made available
16:08 <teward> (especially with SRU post-release, for 1.10.x)
16:08 <rbasak> Understood, thanks.
16:08 <rbasak> Shall I add a work item for 1.10.x?
16:09 <teward> that's the ultimate goal, but that's something to look for in March/April
16:09 <teward> since nginx upstream won't be releasing 1.10.x until around that time, most likely after Xenial is released
16:09 <teward> (so that would be a post-Xenial SRU as soon as that's available)
16:09 <teward> rbasak: up to you whether you want the 1.9.x tasks added, for keeping it up to date with upstream/Debian
16:10 <zul> anything else?
16:10 <rbasak> OK, I've added a task for 1.10.x, marked as blocked. It may well be that we release without it, in which case we can translate that to an SRU bug.
16:10 <zul> #topic Server & Cloud Bugs (caribou)
16:10 <zul> caribou: anything?
16:10 <caribou> o/
16:10 <rbasak> caribou: congratulations!
16:10 <caribou> I'm almost done with the nut merge
16:10 <caribou> rbasak: thanks!
16:11 <jgrimm> caribou, nice!
16:11 * caribou got voted as Core Dev for those following on TV
16:11 <rbasak> caribou is our newest core dev, as of yesterday.
16:11 <zul> sweet
16:11 <jgrimm> caribou, congratulations!!!!
16:11 <cpaelzer> gz caribou!
16:11 <kickinz1> caribou, \o/
16:11 <caribou> thanks everyone ! I'll be more effective to help out
16:11 <jgrimm> indeed
16:12 <arges> woo hoo
16:12 <caribou> I have a question to bring up regarding HA support (clvm + dlm)
16:12 <caribou> maybe a good time now or later during AOB
16:12 <caribou> ?
16:13 <caribou> want to discuss it now ?
16:13 * rbasak looks at zul
16:14 <zul> up to you
16:14 <zul> im double booked right now
16:14 <caribou> right now, clvm is in main but dlm is in Universe
16:14 <caribou> libdlm3 in main though. We have people who want a supported solution to implement shared storage
16:15 <caribou> jgrimm: it would be important for our next LTS to have a clear statement on how we support shared storage access with clvm
16:15 <zul> agreed
16:16 <rbasak> So this is a question of what we want in main?
16:16 <caribou> at the same time, the dlm package has been uninstallable for two years with only one people complaining
16:16 <rbasak> That's a question for Canonical I guess, so between jgrimm and kirkland.
16:16 <caribou> rbasak: yes, what we want to offer in main (not only Canonical; do we want to demote clvm out of main ?)
16:17 <caribou> rbasak: but I agree, I can take it with jgrimm & Dustin
16:17 <jgrimm> caribou, yes please.
16:18 <caribou> other than that I'm good, nothing else
16:18 <caribou> thanks again !
16:18 <zul> ok moving on
16:18 <zul> #topic Weekly Updates & Questions for the QA Team (matsubara)
16:19 <zul> he aint here...
16:19 <zul> anyone have anything?
16:19 <teward> there's one action item on there
16:19 <teward> underneath there, though if matsubara's not here maybe it needs to be delayed to next meeting?
16:19 <zul> fine with me :)
16:19 <teward> thoughts from the others on the team, whether we push the QA issue to next meeting, due to Matsubara's absense?
16:19 <teward> absence*
16:20 <teward> oop there's matsubara, maybe
16:20 <matsubara> sorry, ISP issues
16:20 <rbasak> Did Phill's subsequent email to the ML retract this agenda point? That wasn't clear to me. Is he here?
16:20 <phillw> o/
16:20 <matsubara> I was trying to connect back to join the meeting
16:21 <rbasak> phillw: o/
16:21 <matsubara> just to clarify the issue further, we do have smoke tests (automated) for i386 running. I think phillw concerns were about the iso tracker manual tests (that's from what I understand about the issue)
16:21 <rbasak> phillw: did you still want to raise this with matsubara?
16:21 <matsubara> not sure at what point we are at the meeting
16:22 <phillw> yeah, I can arrange for the manual tests on the iso tracker to be arried out periodically if the team maintains that version.
16:22 <rbasak> "    32-bit QA and Support Discussion (phillw) " is where I think we are.
16:22 <phillw> *carried
16:22 <matsubara> https://jenkins.qa.ubuntu.com/view/Trusty/view/Smoke%20Testing/
16:23 <matsubara> that shows that we do have i386 automated tests for trusty isos
16:23 <matsubara> and it's in my todo list to move those to our https://server-team-jenkins.canonical.com/ instance and of course update them to include xenial tests as well
16:24 <hggdh> just a question: we have not been smoke-testing Xenial on i386?
16:26 <matsubara> hggdh, for some reason they haven't run for a long time, I'll look into it. I've been bad at monitoring those tests runs
16:26 <zul> anything else?
16:26 <hggdh> one more pont
16:26 <hggdh> point*
16:27 <hggdh> I ould like to know if we are going to keep on doing i386 tests; also, are we going to re-introduce manual testing, or is the team's opinion that the automated smoke tests are enough?
16:29 <matsubara> I think the automated tests we have are enough and cover the main workflows with server installs
16:29 <jgrimm> matsubara, i'd like to understand what the differences are tho
16:30 <rbasak> Shall we defer this, and then matsubara can maybe give us a full answer next week?
16:30 <jgrimm> between automated smoke vs manual tests, and where/when the manual tests have historically been run.  seems like we need to come back next week with a bit more data and opinion.
16:30 <jgrimm> rbasak, agreed
16:30 <rbasak> zul: an action for matsubara please?
16:30 <zul> rbasak: for?
16:31 <rbasak> matsubara to research and answer whether we want to resume manual testing for i386
16:31 <hggdh> a more knowledge-based response to jgrimm's points
16:31 <zul> action: Matsubara to research and answer whether we want to resume manual testing for i386
16:31 <matsubara> jgrimm, I think mainly process wise but I might be wrong. the only mandatory ones in the ISO tracker http://iso.qa.ubuntu.com/qatracker/milestones/351/builds/110651/testcases/1403/results are basically covered by the https://jenkins.qa.ubuntu.com/view/Trusty/view/Smoke%20Testing/job/trusty-server-amd64-smoke-lvm/ for example
16:31 <zul> #action: Matsubara to research and answer whether we want to resume manual testing for i386
16:31 * meetingology : Matsubara to research and answer whether we want to resume manual testing for i386
16:31 <rbasak> Thanks!
16:31 <matsubara> but that's fine I can take that action and explaing further
16:31 <zul> anything else?
16:31 <jgrimm> thank you matsubara
16:32 <matsubara> thanks zul, rbasak, jgrimm, teward and phillw
16:32 <hggdh> phillw: this was your point. No comments?
16:32 <matsubara> oh and hggdh too
16:32 <hggdh> heh
16:32 <zul> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:32 <hggdh> matsubara: I am still alive :-)
16:32 <matsubara> nice to see you around hggdh, long time, no talk!
16:32 <zul> arges: i know you are around
16:32 <phillw> i will put in diary to be here next meeting, Thanks,
16:32 <arges> zul: nothing here
16:32 <arges> ..
16:32 <arges> oh
16:33 <arges> doing the libvirt merge
16:33 <arges> .
16:33 <hggdh> matsubara: indeed
16:33 <kickinz1> arges, I had some kernel traces when running schroot on top of btrfs with a bcache backend. Di you see the bug?
16:33 <zul> arges: ok cool
16:33 <arges> kickinz1: nope whats the bug#?
16:33 <zul> anything for arges?
16:34 <kickinz1> arge https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1532145
16:34 <ubottu> Launchpad bug 1532145 in linux (Ubuntu) "Kernel Panic wrt btrfs while sbuild/schroot" [High,Confirmed]
16:34 <arges> kickinz1: ok i'll tag it so we work on it
16:34 <arges> thanks
16:34 <kickinz1> arges, np
16:34 <zul> #topic Upcoming Call For Papers
16:35 <zul> #topic Ubuntu Server Team Events
16:35 <zul> there is something in california this week and fossdem is next week (ill be there)
16:35 <zul> anyting else?
16:36 <zul> if not
16:36 <zul> #topic Open Discussion
16:36 <zul> anything to bring up
16:36 <zul> if not
16:36 <zul> #endmeeting