15:43 <xnox> #startmeeting Developer Membership Board
15:43 <meetingology> Meeting started Mon Jan 18 15:43:47 2016 UTC.  The chair is xnox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:43 <meetingology> 
15:43 <meetingology> Available commands: action commands idea info link nick
15:43 <xnox> aha
15:44 <xnox> sergiusens, caribou are you about?
15:44 <sergiusens> xnox, I am
15:45 <caribou> me too
15:45 <xnox> cool.
15:45 <xnox> i believe we have a qurum, so let's start.
15:46 <xnox> #topic PPU uploader Sergio Schvezov for snappy and snapcraft
15:46 <xnox> https://wiki.ubuntu.com/SergioSchvezov
15:46 <xnox> sergiusens, please introduce yourself and briefly elaborate on your application =)
15:47 <sergiusens> Hi, I am part of the Ubuntu Core team at Canonical. I'm currently working on snappy Ubuntu Core, the snappy tool itself until recently (not directly now). Now I am leading snapcraft development and I would most of all like to be able to upload snapcraft.
15:47 <sergiusens> I can elaborate if needed
15:48 * ogra_ is here to cheer for sergiusens :)
15:48 <xnox> sergiusens, both are written in golang?
15:48 <ogra_> *\o/*
15:49 <ogra_> ^ (pompoms)
15:49 <sergiusens> xnox, snappy in golang, snapcraft python3
15:50 <ogra_> and while i totally trust sergios packaging skills, i really think the next step needs to be core-dev after this application :)
15:50 <xnox> sergiusens, do you have continous testing for both against the archive? for example do you test building with golang 1.6 and python 3.5?
15:50 <sergiusens> snapcraft, has 89% coverage of unit tests, 91% if you aggregate integration tests and running all our current examples. (the integration tests are also setup as autopackage tests, but I don't think we've ever uploaded that yet)
15:50 <xnox> sergiusens, sounds good. yeah autopackage tests are the best to keep out broken toolchains from migrating (and breaking) your builds.
15:50 <sergiusens> xnox, for snapcraft, we do test  with 3.5 in mind
15:51 <sergiusens> xnox, for snappy we don't do 1.6 yet to support the gcc-go supported arches
15:52 <sergiusens> xnox, snappy takes it one step further, each new PR (github, yes) triggers a test on image full run
15:52 <sergiusens> test on image on one of the canonistack servers with ubuntu core
15:53 <sergiusens> canonistack == internal cloud (just in case)
15:53 <xnox> sergiusens, looking at the package names... is it really "snappy" the compresion algorithm package you are after to have upload rights for?
15:53 <xnox> or is it ubuntu-snappy and snapcraft?
15:54 <ogra_> the latter :)
15:54 <sergiusens> xnox, oh, it is ubuntu-snappy; you are indeed right
15:54 <ogra_> we dont use snappy in snappy
15:54 <sergiusens> sorry about that :-/
15:54 * sergiusens fixed in the wiki
15:55 <xnox> sergiusens, looking at the upload history i see that mostly mvo uploads ubuntu-snappy, have you ever uploaded ubuntu-snappy?
15:55 <sergiusens> xnox, no, I just ask him
15:56 <sergiusens> xnox, but mvo spreads thin these days, I thought I'd help him out since I know a lot about the ubuntu-snappy internals (and its packaging as I've worked on it through MRs/PRs)
15:56 <xnox> but i do see that mvo endorses you.
15:57 <xnox> !dmb-ping
15:57 <ubottu> cyphermox, infinity, Laney, micahg, xnox, bdmurray, stgraber: DMB ping
15:57 <xnox> do you have more questions for sergiusens ?
15:57 <cyphermox> not me. I'm already familiar with sergiusens' work
15:58 <Laney> yes
15:58 <Laney> looking at https://launchpad.net/ubuntu/+source/ubuntu-snappy we can see that ubuntu-snappy is stuck in xenial-proposed
15:58 <Laney> can you tell us how you'd find out what's going on there and maybe suggest how it might get unstuck?
15:59 <sergiusens> Laney, I'd look at the excuses page
15:59 <sergiusens> http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html
16:00 <sergiusens> what I see now after opening it, is that it seem the packaging has moved from 'any' to a subset of arches, so I'd need to talk to an archive admin
16:00 <xnox> sergiusens, how do you check the current status of the autopkgtests for a package? for example for snapcraft?
16:01 <sergiusens> if that is really what is wanted (but I'd have to check with the uploader who did that) :-)
16:01 <Laney> does https://launchpadlibrarian.net/234022487/buildlog_ubuntu-xenial-s390x.ubuntu-snappy_1.7.2+20160113ubuntu1_BUILDING.txt.gz tell you anything?
16:01 <sergiusens> xnox, I know there is a page for that too, I just don't have the link handy, sorry
16:02 <xnox> sergiusens, on the excuses page above, do a Ctrl-F search for "autopkgtest for snapcraft" there are links to logs.
16:02 <xnox> sergiusens, and it looks like it has always failed http://autopkgtest.ubuntu.com/packages/s/snapcraft/
16:03 <sergiusens> xnox, yeah, that's why I said, the autopackage tests I worked on haven't been uploaded yet :-) This predates me
16:04 <xnox> sergiusens, looking at ubuntu-snappy history for debian/ folder, last commit from you was in July 2015. Do you really need upload rights for ubuntu-snappy?
16:04 <ogra_> to take load of mvo, yes
16:04 <sergiusens> xnox, no I don't need them, I just really want snapcraft ones, ubuntu-snappy is a nice to have and to help my team mates
16:06 * Laney thinks it's okay for packaging to be stable
16:06 <micahg> +1 :)
16:07 <xnox> sergiusens, how do you choose a source packaging format for a package? and which one do you default to?
16:07 <sergiusens> xnox, fwiw, September 2015 was my focus switch from ubuntu-snappy to snapcraft
16:08 <sergiusens> xnox, I prefer to use non native (even though these packages say the contrary)
16:08 <xnox> ok.
16:09 <sergiusens> xnox, rule of thumb, native == ubuntu tools (or debian)
16:09 <sergiusens> ubuntu exclusive
16:10 <xnox> #vote grant sergiusens PPU rights for ubuntu-snappy, snapcraft
16:10 <meetingology> Please vote on: grant sergiusens PPU rights for ubuntu-snappy, snapcraft
16:10 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:10 <Laney> +1
16:10 <meetingology> +1 received from Laney
16:11 <Laney> crickets
16:11 <xnox> #voters
16:11 <meetingology> Current voters:
16:11 * xnox sigh
16:11 <cyphermox> +1
16:11 <meetingology> +1 received from cyphermox
16:12 <xnox> +1
16:12 <meetingology> +1 received from xnox
16:12 <micahg> +1
16:12 <meetingology> +1 received from micahg
16:12 <xnox> that's it right?
16:12 <xnox> #endvote
16:12 <meetingology> Voting ended on: grant sergiusens PPU rights for ubuntu-snappy, snapcraft
16:12 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:12 <meetingology> Motion carried
16:12 <ogra_> \o/
16:12 <sergiusens> yay, thanks
16:12 <xnox> #voters Laney cyphermox xnox micahg
16:12 <meetingology> Current voters: Laney cyphermox micahg xnox
16:12 <caribou> congratulations sergiusens
16:12 <sergiusens> caribou, thanks
16:13 <xnox> #topic Core Dev Application - caribou
16:13 <xnox> #url https://wiki.ubuntu.com/LouisBouchard/Core%20Dev%20Application
16:13 <xnox> caribou, hello =) please introduce yourself
16:13 <caribou> Hello, my name is Louis Bouchard,
16:14 <caribou> my daily work revolves around fixing ubuntu bugs & doing SRU for the stable  releases
16:14 <caribou> I also have upload rights for sosreport and makedumpfile since 09/14 if I remember right
16:14 <caribou> since most of my work revolves around Main packages, I have decided to ask for core dev rights
16:15 <caribou> I'm also trying to do more merges
16:15 <caribou> and being more involved in the development process
16:15 <caribou> finally, I do some development work around kdump-tools, makedumpfile & sosreport
16:16 <Laney> if you get approved, will you help out with patch piloting? :)
16:16 <caribou> I would like to.
16:16 <caribou> I have a lot of colleagues who rely on sponsorship so I know the value of being available for review & upload
16:17 <xnox> caribou, have you had SRUs that went south after publication? and what have you done to minimize damage?
16:17 <caribou> xnox: luckily, none that I can remember
16:18 <caribou> xnox: my first reaction would be to revert the change that causes failure if it can be easily identifie
16:18 <caribou> d
16:18 <xnox> caribou, are you aware of the crash report monitoring?
16:19 <caribou> yes, very recently pitti pointed me to an issue with rsyslog that caused crashes
16:19 <caribou> I also know that a lot of work on it is done by bdmurray especially on the retracers
16:19 <xnox> right.
16:19 <caribou> I've used apport-retrace myself a few times
16:20 <xnox> caribou, and bdmurray can also set phasing on the updates, that is after update is published in -proposed it can be reset to 0% and thus prevent any new machines automatically installing or offering the update.
16:20 <caribou> I also had a lot of exposure to kernel crash dumps but those are not treated as such
16:21 <caribou> xnox: yes, I recently discovered about phased updates; a concept I had heard of from Google
16:21 <xnox> caribou, yeah, we had it since 14.04 or so (not on release day, but later during 14.10/15.04 cycles phased updates for 14.04 were enabled)
16:21 <xnox> !dmb-ping
16:21 <ubottu> cyphermox, infinity, Laney, micahg, xnox, bdmurray, stgraber: DMB ping
16:22 <xnox> any more questions for caribou ?
16:22 <Laney> nope!
16:23 <cyphermox> all good
16:24 <xnox> micahg, ?
16:24 <micahg> I'm good
16:25 <xnox> #vote grant caribou ubuntu core dev rights
16:25 <meetingology> Please vote on: grant caribou ubuntu core dev rights
16:25 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:25 <xnox> +1
16:25 <meetingology> +1 received from xnox
16:25 <Laney> +1
16:25 <meetingology> +1 received from Laney
16:26 <Laney> micahg: cyphermox
16:26 <cyphermox> +1
16:26 <meetingology> +1 received from cyphermox
16:26 <micahg> +1
16:26 <meetingology> +1 received from micahg
16:26 <Laney> |O|
16:26 <cyphermox> sorry, I was in ppc64el lalaland
16:27 <Laney> were you fixing udisks2?
16:27 <Laney> yes you were
16:27 <Laney> you great human
16:27 * xnox ponders what's the point of setting #voters if it doesn't end the vote
16:27 <xnox> #endvote
16:27 <meetingology> Voting ended on: grant caribou ubuntu core dev rights
16:27 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:27 <meetingology> Motion carried
16:27 <cyphermox> Laney: udisks2?
16:27 <xnox> caribou, congrats =)
16:27 <caribou> xnox: Laney: cyphermox: micahg: thank you very much !
16:27 <Laney> http://autopkgtest.ubuntu.com/packages/u/udisks2/xenial/ppc64el/
16:27 <cyphermox> caribou: congrats
16:27 <Laney> dholbach: get this fine fellow on the patch pilot list!
16:27 <caribou> happy to continue to be helpful to the community
16:28 <mapreri> xnox: it restricts the ability to vote, otherwise everybody on the channel can cast a vote
16:28 <xnox> mapreri, i see, thanks.
16:28 <xnox> #topic next chair
16:28 <xnox> who should be the next chair? is it Laney or somebody else?
16:28 <Laney> infinity
16:29 <cyphermox> yup
16:29 <Laney> see the list on the agenda
16:29 <xnox> #action infinity to chair the next DMB meeting
16:29 * meetingology infinity to chair the next DMB meeting
16:29 <Laney> take xnox and move to the end
16:29 <Laney> when you are updating it
16:29 <micahg> we need to kick off the nomination process for DMB soon
16:29 <Laney> yes
16:29 <xnox> #topic any other bussiness
16:29 <micahg> current member terms expire 3/3 I think, so Feb 29 is the last meeting
16:30 <xnox> do we really need to kick of DMB? i thought it's not soon.
16:30 <Laney> 2016-03-10
16:30 <micahg> sorry, 23/9
16:30 <micahg> 3/9
16:31 <xnox> so we have 3 people expiring right? bdmurray micahg and xnox ?
16:31 <xnox> and infinity is on the other cycle, or on this cycle?
16:31 <Laney> 2016-02-29 is the last meeting before
16:32 <dholbach> Laney: thanks - will do
16:32 <xnox> dholbach, oh you want to run our election? thank you =)
16:32 <dholbach> what?
16:32 <Laney> so we should start the 2 week vote on 2016-02-14
16:32 <dholbach> sorry, I've only half been paying attention... I was referring to adding caribou to the pilots :)
16:33 <xnox> dholbach, ah, haha, ok =)
16:33 <Laney> therefore nominations starting on 2016-01-31
16:33 <caribou> dholbach: Laney: I'll need some help if you want to get me going
16:33 <Laney> although if it's anything like last time we'll have trouble finding people
16:33 <Laney> so should maybe give it an extra week
16:33 <xnox> Laney, sounds good. and i should draft a shout-out before that.
16:33 <dholbach> caribou: sure
16:33 <Laney> 2016-01-24
16:34 <Laney> xnox: I'm thinking about retiring then too
16:34 <Laney> will decde
16:34 <Laney> +i
16:34 <xnox> Laney, ahead of your current term?
16:34 <Laney> yeah
16:34 <xnox> Laney, i am legitimately expiring ;-)
16:35 <xnox> Laney, last year you told me i should serve till the end of term, and not expire ;-)
16:35 <xnox> Laney, you should stay for one more year.... =)
16:35 * Laney has been on DMB since 2011-02-22
16:35 <Laney> we'll see, maybe nobody wants to nominate themselves anyway
16:35 <xnox> fair enough.
16:35 <xnox> anything else?
16:36 <Laney> wait
16:36 <Laney> will you start it with 3 + 2 weeks?
16:36 <Laney> i.e. on sunday?
16:36 <Laney> assuming you were volunteering to be returning officer
16:37 <xnox> Laney, i think i am stuck with returning officer role. I was going to start it on monday the 25th, rather than sunday.
16:37 <xnox> Laney, do we always end things on Sunday?
16:37 * xnox doesn't like working on sunday
16:37 <Laney> usually advertise it as such anyway
16:37 <Laney> at least before the meeting on the monday
16:37 <Laney> it's more important for the actual vote
16:37 <Laney> nominations not so much
16:37 <xnox> ack.
16:37 <xnox> i see, true.
16:38 <Laney> so a week today?
16:38 <xnox> yeap
16:38 <Laney> ok
16:38 <xnox> #endmeeting