19:06 <micahg> #startmeeting DMB meeting
19:06 <meetingology> Meeting started Mon Jan  4 19:06:24 2016 UTC.  The chair is micahg. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:06 <meetingology> 
19:06 <meetingology> Available commands: action commands idea info link nick
19:06 <micahg> Welcome to the DMB meeting
19:07 <micahg> #topic Review of previous action items
19:07 <micahg> #subtopic DMB members who didn't consent to fill in feedback to Noskcaj
19:07 <micahg> I'm guessing we didn't do this again?
19:08 <micahg> carried
19:08 <micahg> #topic Package Set/Per Package Uploader Applications
19:09 <micahg> #subtopic TimoJyrinki / ubuntu-qt-packages
19:09 <micahg> I think this just needs a quick vote, right?
19:10 <stgraber> yeah
19:10 <cyphermox_> yup
19:10 <stgraber> and some paperwork as I believe we have the set but no team, I'll take care of that part
19:10 <micahg> ok
19:11 <micahg> #voters micahg stgraber cyphermox_ bdmurray
19:11 <meetingology> Current voters: bdmurray cyphermox_ micahg stgraber
19:12 <stgraber> Mirv -> +1 (IMHO this could have been handled without the extra round
19:12 <stgraber> trip)
19:12 <micahg> #vote Please vote to grant TimoJyrinki rights to the ubuntu-qt-packages packageset
19:12 <meetingology> Please vote on: Please vote to grant TimoJyrinki rights to the ubuntu-qt-packages packageset
19:12 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:12 <stgraber> that's from Laney ^
19:12 <stgraber> +1
19:12 <meetingology> +1 received from stgraber
19:12 <micahg> +1
19:12 <meetingology> +1 received from micahg
19:12 <bdmurray> +1
19:12 <meetingology> +1 received from bdmurray
19:12 <cyphermox_> +1
19:12 <meetingology> +1 received from cyphermox_
19:13 <micahg> #endvote
19:13 <meetingology> Voting ended on: Please vote to grant TimoJyrinki rights to the ubuntu-qt-packages packageset
19:13 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:13 <meetingology> Motion carried
19:13 <micahg> that's +5 actually, so that passes
19:13 <micahg> stgraber: you ok with the action items around that
19:13 <stgraber> yeah, I'll take care of it
19:14 <infinity> Derp.  I'll learn when this meeting is some day.
19:14 <micahg> #action stgraber to create team for ubuntu-qt-packages and add timo-jyrinki to it
19:14 * meetingology stgraber to create team for ubuntu-qt-packages and add timo-jyrinki to it
19:14 <micahg> #voters infinity
19:14 <meetingology> Current voters: bdmurray cyphermox_ infinity micahg stgraber
19:15 <micahg> welcome infinity
19:16 <micahg> I think ginggs is next on the agenda
19:16 * xnox is here, sorry i'm late
19:16 <micahg> #topic Ubuntu Core Developer Application
19:16 <micahg> #voters xnox
19:16 <meetingology> Current voters: bdmurray cyphermox_ infinity micahg stgraber xnox
19:16 <micahg> #subtopic Graham Inggs
19:16 <micahg> #link https://wiki.ubuntu.com/GrahamInggs/CoreDevApplication
19:17 <micahg> ginggs: can you introduce yourself please
19:18 <ginggs> hi, I'm Graham Inggs, I've been a MOTU for 2 years and would like to become a core-dev
19:20 <cyphermox_> I see a lot of uploads, but I find it a little hard to see what work you did that was in main specifically, could you help by pointing us at some things you`re particularly proud of?
19:21 <xnox> cyphermox_, well, looking at http://ubuntu-dev.alioth.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsoree=Graham+Inggs&sponsoree_search=name it seem like all the things that were sponsored in 2014 & 2015 were for main, as all other universe uploads are just in launchpad related packages.
19:21 <ginggs> in main there have been some nvidia driver uploads (those are restricted, actually)
19:22 <ginggs> recently I was invovled with the suitesparse transition
19:22 <cyphermox_> xnox: not on my own computer, so I`m without my bookmarks :P
19:22 <xnox> cyphermox_, ah =) ok, np. =) still chatting is more personal =)
19:23 <ginggs> then there have been the occasional syncs from debian
19:24 <xnox> ginggs, after uploading a package into ubuntu, do you do any follow-ups after that?
19:25 <ginggs> i remain subscribed to the bugs and often subscribe to all bugs for those packages
19:25 <ginggs> i also check that the packages build everywhere they are supposed to and migrate from proposed
19:26 <infinity> ginggs: I don't think I have any questions, per se, about your technical skill.  More just a question of what you intend to do with permissions to the entire archive.
19:26 <infinity> ginggs: Specific main packages you care about, more involvement in transitions, etc.
19:26 <infinity> (ie: don't be a core-dev unless you need to be)
19:28 <ginggs> I would probably upload Nvidia drivers from time to time, but I will co-ordinate with tseliot on those, but if there is a fix I won't always have to wait on him
19:29 <stgraber> micahg: actually, I won't be able to carry that action until the CC adds me back to the TB :)
19:29 <xnox> ginggs, would you at all have any time to be a sponsor, and/or review things to be sponsored? http://reqorts.qa.ubuntu.com/reports/sponsoring/index.html
19:29 <xnox> stgraber, lolz =)
19:29 <stgraber> micahg: got everything else done but can't actually add the archive ACL as that requires to be a TB member
19:29 <stgraber> was wondering why LP didn't like me and was giving me odd 401s for some stuff, that'd be why
19:29 <ginggs> Yes, I have sponsored a few packages already https://ubuntu-dev.alioth.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=Graham+Inggs&sponsor_search=name&sponsoree=&sponsoree_search=name
19:29 <micahg> stgraber: right, saw the mail on that earlier
19:30 <ginggs> obviously I haven't been able to sponsor any main packages, but being a core-dev would allow me to
19:30 <xnox> nice =)
19:33 <infinity> ginggs: Right, so that's where it hinges for me.  An application for status is pointless, an application because you intend to do core-devy things is great, we need more people doing generally awesome general things.
19:34 <infinity> ginggs: If you're all about helping people with review/sponsorship (emphasis on the REVIEW part), and mangling other main packages here and there, I'm happy with it.
19:37 <ginggs> i'm very particular about testing before sponsoring
19:38 <stgraber> micahg: elmo was kind enough to run edit-acl for me, so that's my action taken care of
19:38 <micahg> stgraber: cool, thanks
19:38 <micahg> ginggs: have you worked with the -proposed pocket migration to the release pocket in the devel release at all?
19:39 <ginggs> i'm familiar with this page: http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html
19:40 <micahg> have you ever helped a package migrate to the release pocket?
19:40 <ginggs> and i know to check for autopkgtest failures
19:40 <ginggs> and reverse-depends
19:40 <ginggs> is that what you mean?
19:41 <micahg> yes, partially, have you actually fixed any issues that have come about due to an autopkgtest failure to help a package migrate?
19:41 <ginggs> yes
19:42 <micahg> I believe I've seen you work on transitions, so I won't ask about those
19:42 <micahg> great
19:42 <micahg> I think that's it for questions
19:43 <micahg> #vote Please vote on ginggs becoming core-dev
19:43 <meetingology> Please vote on: Please vote on ginggs becoming core-dev
19:43 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:44 <cyphermox_> +1
19:44 <meetingology> +1 received from cyphermox_
19:44 <bdmurray> +1
19:44 <meetingology> +1 received from bdmurray
19:44 <stgraber> +1
19:44 <meetingology> +1 received from stgraber
19:46 <micahg> +1
19:46 <meetingology> +1 received from micahg
19:46 <xnox> +1
19:46 <meetingology> +1 received from xnox
19:46 <micahg> and a +1 from Laney in absentia
19:46 <micahg> #endvote
19:46 <meetingology> Voting ended on: Please vote on ginggs becoming core-dev
19:46 <meetingology> Votes for:6 Votes against:0 Abstentions:0
19:46 <meetingology> Motion carried
19:46 <micahg> ginggs: congrats
19:46 <cyphermox_> I`m going to have to go soon
19:47 <ginggs> thanks, all!
19:47 <LocutusOfBorg1> congratz ginggs
19:47 <cyphermox_> congrats ginggs
19:47 <micahg> cyphermox_: we still have quorum without you
19:47 <cyphermox_> yeah, just saying in advance.
19:48 <micahg> I don't see psusi around
19:48 <micahg> #topic MOTU applications
19:48 <micahg> #subtopic Gianfranco Costamagna
19:48 <micahg> #link https://wiki.ubuntu.com/GianfrancoCostamagna/MOTUApplication
19:49 <micahg> LocutusOfBorg1: could you introduce yourself please
19:50 <LocutusOfBorg1> Hi, I'm Gianfranco Costamagna, I'm Debian Developer since 5 months, and I have been a DM since 2012 or 2013. I became a DD since I like to maintain my packages there, and sync on Ubuntu, but I always wanted to be an Ubuntu Developer (I applied for NM because somebody told me it was easier to became an Ubuntu starting from being a DD)
19:51 <LocutusOfBorg1> I worked a lot on merges, and on forwarding patches to Debian (you will see some syncs, because I uploaded the ubuntu delta on Debian and synced soonafter the accept)
19:51 <LocutusOfBorg1> s/a lot/on a lot
19:52 <LocutusOfBorg1> my interests are keeping packages in sync, or at least up-to-date with Debian (this includes looking at merges or doing them myself)
19:52 <LocutusOfBorg1> (e.g. I opened a gambas3 merge a few seconds ago, still needing work, but with a preliminar patch)
19:53 <LocutusOfBorg1> I think that's all :)
19:53 <micahg> LocutusOfBorg1: have you ever worked with any of the Ubuntu flavors (Xubuntu/Kubuntu/Lubuntu) whose packages mainly are in universE?
19:53 <xnox> LocutusOfBorg1, are you going to upload boost-mpi-source1.58 =) and do you know why it needs an upload now? =))))))))
19:54 <LocutusOfBorg1> xnox, sure
19:54 <LocutusOfBorg1> micahg, I think I don't remember none of them
19:54 <LocutusOfBorg1> but I might be wrong, it has been 3 years since my start :)
19:56 <micahg> do you know of a way to tell a package is on a particular Ubuntu image, in case you need to give one of the flavors a heads up on an upload (or preferably discuss beforehand if it's a potentially disruptive change)
19:56 <LocutusOfBorg1> honestly not
19:57 <micahg> so, there's a script in ubuntu-dev-tools
19:58 <micahg> called seeded-in-ubuntu that can tell you if a package that you're about to upload is on an image
19:58 <LocutusOfBorg1> thanks
19:58 <xnox> LocutusOfBorg1, which tools do you usually use when working on ubuntu? =)
19:58 <LocutusOfBorg1> I know reverse-depends, pbuilder-dist, grab-merge, and many others, but never used seeded-in-ubuntu
19:58 <infinity> (Takes a source package as an argument)
19:59 <LocutusOfBorg1> I use grab-merge, and dput, and debdiff to look to the output
19:59 <LocutusOfBorg1> for sync I use syncpackage (well, I can't now), and requestsync
19:59 <LocutusOfBorg1> I use backportpackage
20:00 <LocutusOfBorg1> update-maintainer
20:00 <mapreri> oh, last time I manually looked at all seeds :\
20:00 <infinity> LocutusOfBorg1: FWIW, this application is a strong +1 from me, as long as you continue your trend of asking questions and being careful about your uploads.  Better to be inquisitive than to be wrong. ;)
20:01 <LocutusOfBorg1> I think I'll start using pull-debian* checksymbols and something more, such as check-mir
20:01 <LocutusOfBorg1> thanks infinity, better safe than sorry :)
20:01 <micahg> LocutusOfBorg1: are you aware of the release cycle in Ubuntu and the various freezes?
20:02 <LocutusOfBorg1> micahg, completely https://wiki.ubuntu.com/XenialXerus/ReleaseSchedule
20:02 <LocutusOfBorg1> :)
20:02 <micahg> :)
20:02 * LocutusOfBorg1 also breaks freezes each time, e.g. for virtualbox
20:02 * LocutusOfBorg1 because kernel is uploaded after the freeze, and vbox ships a kernel module :)
20:04 <micahg> LocutusOfBorg1: do you just upload (or request sponsorship), or do you have to do something else before you can upload a new major version after feature freeze?
20:04 <LocutusOfBorg1> check reverse-dependencies, I shouldn't start a transition
20:04 <LocutusOfBorg1> and for sure it needs to migrate from proposed, so each thing that can prevent migration should be avoided/fixed
20:05 <LocutusOfBorg1> and check new features carefully for possible breaks
20:05 <cyphermox_> I gotta go now, my vote would be +1 :)
20:05 <cyphermox_> see you all later!
20:05 <LocutusOfBorg1> e.g. https://bugs.launchpad.net/ubuntu/+source/can-utils/+bug/1290253
20:05 <ubottu> Launchpad bug 1290253 in can-utils (Ubuntu) "[Ffe] Sync can-utils 0.0+git20140227-1 (universe) from Debian unstable (main)" [Wishlist,Fix released]
20:05 <LocutusOfBorg1> thanks cyphermox
20:05 <LocutusOfBorg1> e.g. this page is so important for me http://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html
20:06 <micahg> LocutusOfBorg1: what's the 'Ffe' part in the bug?
20:06 <LocutusOfBorg1> feature freeze exception, something I like to ask ;)
20:07 <micahg> right, that's the piece I was getting at :0
20:07 <micahg> :)
20:07 <LocutusOfBorg1> e.g. https://bugs.launchpad.net/ubuntu/+source/ettercap/+bug/1382848 https://bugs.launchpad.net/ubuntu/+source/ettercap/+bug/1161001
20:07 <ubottu> Launchpad bug 1382848 in ettercap (Ubuntu) "[FFe] Sync ettercap 1:0.8.1-1 (universe) from Debian unstable (main)" [Medium,Fix released]
20:07 <ubottu> Launchpad bug 1161001 in ettercap (Ubuntu) "[ffe] please Sync ettercap 1:0.7.6-1 (universe) from Debian unstable (main)" [Wishlist,Fix released]
20:08 <micahg> ok, if there's no more questions, I'll start the vote
20:09 <micahg> #vote Gianfranco Costamagna for MOTU
20:09 <meetingology> Please vote on: Gianfranco Costamagna for MOTU
20:09 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:09 <infinity> +1
20:09 <meetingology> +1 received from infinity
20:10 <stgraber> +1
20:10 <meetingology> +1 received from stgraber
20:10 <bdmurray> +1
20:10 <meetingology> +1 received from bdmurray
20:11 <micahg> +1
20:11 <meetingology> +1 received from micahg
20:12 <xnox> +1
20:12 <meetingology> +1 received from xnox
20:12 <xnox> and cyphermox is probably gone now.
20:12 <micahg> #endvote
20:12 <meetingology> Voting ended on: Gianfranco Costamagna for MOTU
20:12 <meetingology> Votes for:5 Votes against:0 Abstentions:0
20:12 <meetingology> Motion carried
20:12 <micahg> LocutusOfBorg1: congrats
20:12 <LocutusOfBorg1> thanks :) [21:05:15] <cyphermox_> I gotta go now, my vote would be +1 :)
20:12 <mapreri> :) congrats mate ;)
20:12 <LocutusOfBorg1> thanks you all :D
20:13 <micahg> #topic AOB
20:13 <micahg> #info next chair is infinity
20:14 <xnox> there was a poke that there will be members expiring from dmb.
20:14 <micahg> yep
20:14 <micahg> #info DMB election for 3 seats soon
20:14 <micahg> any volunteers to run it?
20:14 <xnox> one of which is I, and I shall not be nominating myself to run in the election.
20:14 <xnox> just thought to let you all know.
20:14 <infinity> xnox: Sounds like you just nominated yourself to run the election itself, then, so you can replace yourself. :P
20:15 <xnox> infinity, damn, i guess i do qualify to be a returning officer *sigh*
20:15 <xnox> also infinity you are extra special - your expiry term is out of sync with everybody else.
20:16 <micahg> yeah, I think that was a mistake
20:16 <xnox> i wonder if that's a mistake and e.g. you should be either aligned to the 2016 or the 2017 cycles.
20:16 <micahg> should be 2017
20:16 <infinity> That was because I was in some special by-election to replace ScottK, wasn't I?
20:16 <micahg> yep
20:16 <micahg> and he had just been elected that year
20:16 <micahg> *re-elected
20:16 <xnox> infinity, yes you are special =)
20:17 * infinity is a pretty, pretty snowflake.
20:17 <micahg> ok, we'll find a victI^Wvolunteer to run the election at the next meeting
20:18 <micahg> anything else?
20:18 <micahg> #endmeeting