16:02 <rbasak> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Nov 17 16:02:13 2015 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <rbasak> Who's here?
16:02 <rbasak> #topic Review ACTION points from previous meeting
16:02 <hallyn> \o
16:02 <rbasak> rbasak look at https://code.launchpad.net/~psivaa/ubuntu-test-cases/lvm-grub-preseed-fix/+merge/258620 and https://code.launchpad.net/~om26er/ubuntu-test-cases/fix_minimal_image_size_test/+merge/235298
16:02 <rbasak> Sorry, I haven't done this yet. I'll carry it over.
16:02 <rbasak> #action rbasak look at https://code.launchpad.net/~psivaa/ubuntu-test-cases/lvm-grub-preseed-fix/+merge/258620 and https://code.launchpad.net/~om26er/ubuntu-test-cases/fix_minimal_image_size_test/+merge/235298
16:02 * meetingology rbasak look at https://code.launchpad.net/~psivaa/ubuntu-test-cases/lvm-grub-preseed-fix/+merge/258620 and https://code.launchpad.net/~om26er/ubuntu-test-cases/fix_minimal_image_size_test/+merge/235298
16:02 <rbasak> #topic Xenial Development
16:03 <rbasak> It's mainly merge and sync time at the moment.
16:03 <rbasak> I have a list of areas that need looking at. I'd like to assign some things to people.
16:04 <hallyn> for instance?
16:04 <rbasak> Let me list them.
16:04 <rbasak> strongswan
16:04 <rbasak> systemd-boot tagged bugs for server packages
16:04 <rbasak> DPDK (I think cpaelzer and smb are working on this)
16:05 <rbasak> etckeeper - we should drop the bzr delta now and resync with Debian, being careful to manage upgrade paths, and then stop worrying about this package.
16:05 <rbasak> I'm working on MySQL upstream.
16:05 <rbasak> NTP needs a merge and some bugs fixing
16:05 <arges> i got libvirt
16:05 <rbasak> freeipmi and logwatch need merges
16:05 <rbasak> I'd like to look at deprecating mail-stack-delivery post-Xenial.
16:06 <hallyn> etckeeper sounds scary.  though might be fun
16:06 <rbasak> "Big" merges I think need doing are dovecot, nut, amavisd-new and bacula.
16:06 <rbasak> That's my list.
16:06 <cpaelzer> rbasak, I can confirm working on DPDK
16:06 <rbasak> cpaelzer: how are you doing with nis? Do you want to take on one of the other merges as well?
16:07 <rbasak> The deadline for all of this is feature freeze, which is scheduled for 18 Feb.
16:07 <cpaelzer> rbasak, I havent found the time to do the nis fix for a proper transition on upgrade yet
16:07 <cpaelzer> I hope to get it somewhen in November to a state ready for review
16:08 <cpaelzer> rbasak, diving head on into dpdk I don't need an extra merge as of now
16:08 <rbasak> hallyn: do you want etckeeper then?
16:08 <hallyn> not right now.
16:09 <hallyn> if you keep a list somewhere where ppl can grab items that'd be useful, but not sure how
16:09 <rbasak> I know that nobody wants this stuff right now, but I'd like to have someone nominated for each thing with a non-immediate (Feb) deadline
16:09 <hallyn> blueprint :)
16:09 <rbasak> Yeah I should have a blueprint.
16:09 <hallyn> thta i can do - put me down
16:09 <rbasak> #action rbasak to create blueprint for Xenial feature work
16:09 * meetingology rbasak to create blueprint for Xenial feature work
16:09 <hallyn> (by feb :)
16:09 <rbasak> OK. Thanks! Do you want a sooner goal hallyn for reminder purposes?
16:09 <hallyn> yes
16:10 <rbasak> End of Nov for now?
16:10 <hallyn> yeah
16:10 <rbasak> Thank you.
16:10 <hallyn> (cause i' not around much indec)
16:10 <rbasak> cpaelzer: can I do the same for you for a merge please?
16:10 <rbasak> kickinz1: around? Can I give you a merge too please?
16:11 <cpaelzer> rbasak, End of Nov is what I want to track myself as of now for nis
16:11 <kickinz1> rbazak, yes
16:12 * rbasak looks for something to give to kickinz1
16:12 <hallyn> eh make it an action to find something :)
16:13 <smoser> o.
16:13 <rbasak> smoser: can I give you the systemd-boot issues maybe?
16:13 <smoser> link ?
16:14 <rbasak> https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscri
16:14 <rbasak> ber=&field.structural_subscriber=ubuntu-server&field.component-empty-marker=1&field.tag=systemd-boot&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_no_package.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&fie
16:14 <rbasak> ld.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
16:14 <rbasak> Lovely.
16:14 <rbasak> I searched for tag=systemd-boot, package/series subscriber=ubuntu-server.
16:15 <rbasak> There are 10.
16:15 <smoser> http://tinyurl.com/nzecls5
16:15 <rbasak> Thanks
16:16 <smoser> i'm sorry i joined late.
16:16 <smoser> are you just asking me to triage ? or to commit to fixing .
16:17 <rbasak> I'd like you to drive those for Xenial please. Fix as appropriate anything you deem important.
16:17 <rbasak> If not important, feel free to triage to low importance and leave.
16:17 <hallyn> delegate :)
16:18 <rbasak> I'll find kickinz1 something after looking through the merge list later.
16:18 <rbasak> #action rbasak to find kickinz1 a merge to do
16:18 * meetingology rbasak to find kickinz1 a merge to do
16:18 <smoser> rbasak, ok.
16:18 <rbasak> smoser: thanks
16:18 <rbasak> Any comments for Xenial development in general before I move on?
16:19 <rbasak> I'll skip my Assigned bugwork section in the agenda. Right now I'd like to focus on features.
16:19 <rbasak> (since we're early cycle)
16:19 <rbasak> #topic Server & Cloud Bugs (caribou)
16:19 <caribou> I'm good rbasak
16:19 <rbasak> OK thanks
16:19 <rbasak> #topic Weekly Updates & Questions for the QA Team (matsubara)
16:20 <rbasak> matsubara isn't here, so let's move on.
16:20 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:20 <smb> Not much new here (beside dpdk which isn't really kernel).
16:20 <smb> Do we have questions?
16:20 <rbasak> Thanks smb.
16:20 <rbasak> #topic Upcoming Call For Papers
16:21 <rbasak> Anything new?
16:21 <rbasak> #topic Ubuntu Server Team Events
16:21 <rbasak> Any new events?
16:22 <rbasak> #topic Open Discussion
16:22 <rbasak> I'm out next week.
16:22 <rbasak> #topic Announce next meeting date, time and chair
16:22 <rbasak> jgrimm: will you be OK to chair next week? You're next in the list.
16:23 <jgrimm> rbasak, ack
16:23 <rbasak> The next meeting will be Tue Nov 24 16:00 UTC 2015. jgrimm will chair.
16:23 <rbasak> Thanks all!
16:23 <rbasak> #endmeeting