15:31 <cyphermox> #startmeeting DMB 2015-10-26
15:31 <meetingology> Meeting started Mon Oct 26 15:31:05 2015 UTC.  The chair is cyphermox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:31 <meetingology> 
15:31 <meetingology> Available commands: action commands idea info link nick
15:31 <cyphermox> #voters micahg cyphermox xnox bdmurray
15:31 <meetingology> Current voters: bdmurray cyphermox micahg xnox
15:31 <cyphermox> #votesrequired 4
15:31 <meetingology> votes now need 4 to be passed
15:31 <cyphermox> #topic Review of the previous action items
15:32 <cyphermox> Laney isn't around, so we'll just skip to the main topic, I guess
15:32 <cyphermox> #subtopic Granting membership for PPU/packageset uploaders by default
15:32 <xnox> +1
15:32 <cyphermox> do we want to discuss this before we vote?
15:32 <micahg> so, my position is that some should have membership and some shouldn't
15:33 <cyphermox> This is about the default process for PPU/packageset uploaders, whether they should ask to have membership too when they apply for upload rights
15:33 <micahg> PPU doesn't, flavor packagesets should, other packagesets were not decided from what I remember
15:33 <xnox> micahg: the question, whether it's opt-in, or opt-out.
15:34 <micahg> right, so, it's a mix
15:34 <cyphermox> why shouldn't PPU? and under which conditions do you feel packagesets might or might not?
15:34 <micahg> so, the whole goal was to lower the bar for PPU so that more people can apply when they have the technical skills, but not the significant and sustained part
15:35 <cyphermox> fair enough
15:35 <cyphermox> still though, doesn't the significant and sustained part get implicitly verified in the way that we account for whether they have the technical skills?
15:35 <micahg> so, ,if we're doing that, I would think it should be like any other membership where the applicant needs to apply for it
15:36 <micahg> it could
15:36 <cyphermox> ok
15:36 <xnox> well.
15:36 <xnox> if one wants upload rights apply for PPU for a package and/or packagest.
15:36 <cyphermox> I feel it might be a little counterproductive to get them to ask for it, etc when they go for upload rights -- if we're to do that, we might as well have them apply to the RMB simply
15:37 <xnox> if one wants membership apply for contributing member, MOTU, or core.
15:37 <xnox> cyphermox: we have developer path to membership only - contributing developer.
15:37 <micahg> I think it should be made abundantly clear to applicants that if they're just going for PPU or a packageset where there isn't a requirement for significant & sustained contribution that they have the option to apply to dev membership as well if they feel they've fulfilled the significant and sustained piece as well
15:37 <cyphermox> oh, true
15:38 <cyphermox> so, should we vote then?
15:38 <micahg> it's basically was it 1 upload every 6 months or something a bit more significant
15:38 <cyphermox> fwiw, Laney's vote was +1, but he didn't take part of the discussion here now
15:39 <micahg> but as xnox said, the DMB is still the best place to grant that membership
15:39 <micahg> * evaluate and grant
15:42 <micahg> my problem with opt-out is that it increases the risk we'll reject applicants, if it's opt-in, worst case is they have to come back in 2 weeks
15:43 <bdmurray> How does that work?
15:44 <bdmurray> "> Individuals, when they apply to the DMB for packageset or PPU rights,
15:44 <bdmurray> > will be considered separately for their upload access and for Ubuntu
15:44 <bdmurray> > membership (the latter being optional, and usually not explicitly
15:44 <bdmurray> > requested)."
15:45 <cyphermox> should we make it explicitly clear with the applicant then whether they expect to be considered for membership at the meeting?
15:47 <bdmurray> No, "we didn't expect people to have to say they want membership too"
15:47 <micahg> that was not my understanding
15:47 <cyphermox> no, we didn't expect, but we can ask
15:47 <micahg> I thought for the PPU/packagesets where it wasn't coupled, they would have to ask explicitly
15:48 <bdmurray> Okay, and the way I read Laney's email is that we will asume they want to be considered for membership.
15:49 <micahg> right, that seems to be his position
15:49 <cyphermox> that's the way I read it too
15:50 <bdmurray> But the two things aren't coupled together.
15:50 <micahg> well, for some they were (flavor & kernel packagesets, MOTU/core-dev)
15:53 <cyphermox> so, voting?
15:54 <cyphermox> #vote Should uploaders be granted Ubuntu membership by default
15:54 <meetingology> Please vote on: Should uploaders be granted Ubuntu membership by default
15:54 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:54 <micahg> -1
15:54 <meetingology> -1 received from micahg
15:54 <micahg> wait
15:54 <micahg> that should be a little more narrow, no?
15:54 <micahg> Should PPU/certain packagesets be granted Ubuntu membership by default?
15:55 <cyphermox> no, we should reject Laney's proposition explicitly, I think
15:55 <micahg> ok
15:55 <cyphermox> or I can close the voting, reject, and we reconvene and further specify it?
15:56 <cyphermox> I'm +0, btw, because it should be more specific; this depends on packagesets/packages
15:56 <bdmurray> Are we saying the vote subject is about what is in the iki page?
15:56 <micahg> you're right, we should vote on what was proposed since the proponent isn't here
15:56 <micahg> we can then vote on follow up pieces if we want
15:57 <cyphermox> bdmurray: the vote subject probably should be the specific thing Laney added as a topic?
15:57 <bdmurray> the email he links to says "it's about whether we
15:57 <bdmurray> should give these applicants membership implicitly and only use our
15:57 <bdmurray> right to not give membership when it is needed."
15:57 <cyphermox> it's super unclear, that's the problem
15:58 <bdmurray> alright
15:58 <cyphermox> it's a case-by-case basis and we're trying to codify that
15:58 <cyphermox> +0
15:58 <meetingology> +0 received from cyphermox
15:58 <cyphermox> xnox: ?
15:58 <bdmurray> I feel like this has been outstanding for quite some time.
15:58 <cyphermox> bdmurray: yes
15:59 <cyphermox> bdmurray: I'm not against voting on the specific cases now
15:59 <cyphermox> or if everyone agrees that Laney meant what we were saying before
15:59 <cyphermox> (basically, that we give it by default, unless we have a reason not to (ie. not sustained)
15:59 <bdmurray> I don't want to make that assumption.
16:00 * bdmurray spoke too soon
16:00 <cyphermox> bdmurray: I understand what you mean
16:02 <cyphermox> xnox: bdmurray: are you voting or do you think we should refine it first?
16:04 <xnox> i'm for: contributing, motu, core -> implies membership. the rest do not.
16:05 <cyphermox> xnox: that's a strong -1 then, and PPU/packageset requesters should apply for contributing explicitly?
16:05 <xnox> yeah.
16:05 <bdmurray> I guess it needs some refining.
16:05 <cyphermox> ok, let's see if we can convey this properly in the logs
16:05 <cyphermox> #endvote
16:05 <meetingology> Voting ended on: Should uploaders be granted Ubuntu membership by default
16:05 <meetingology> Votes for:0 Votes against:1 Abstentions:1
16:05 <meetingology> Motion denied
16:05 <cyphermox> #rejected
16:06 <cyphermox> should we refine this now? have we already done so and vote on a different, more specific topic?
16:09 <bdmurray> I think Laney should be involved in the refinement.
16:11 <cyphermox> ok, then
16:11 <cyphermox> #action cyphermox to update wiki for refinement of Laney's proposition
16:11 * meetingology cyphermox to update wiki for refinement of Laney's proposition
16:11 <cyphermox> #topic AOB?
16:12 <cyphermox> anyone has something else to discuss today?
16:13 <bdmurray> nope
16:13 <cyphermox> ok
16:13 <cyphermox> #topic Chair selection for the next meeting
16:13 <cyphermox> micahg: your turn according to the wiki list
16:13 <cyphermox> unless you know you won't be there
16:13 <micahg> ok :)
16:14 <micahg> no, I should be there
16:14 <cyphermox> #action micahg to chair next meeting
16:14 * meetingology micahg to chair next meeting
16:14 <micahg> which reminds me, I need to send the doodle poll for meeting times
16:14 <micahg> might as well action that..
16:14 <cyphermox> #action micahg to send doodle poll for meeting times
16:14 * meetingology micahg to send doodle poll for meeting times
16:14 <micahg> thanks :)
16:14 <cyphermox> #endmeeting