15:04 <Laney> #startmeeting DMB 2015-09-28
15:04 <meetingology> Meeting started Mon Sep 28 15:04:26 2015 UTC.  The chair is Laney. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:04 <meetingology> 
15:04 <meetingology> Available commands: action commands idea info link nick
15:04 <Laney> #topic Review of previous action items
15:04 <Laney> #subtopic bdmurray to setup a pad for the dmb to collaborate on response for noskcaj
15:05 <Laney> any news?
15:05 <bdmurray> I ended up creating a bzr branch
15:05 <Laney> I missed that
15:05 <Laney> does it have anything useful in?
15:06 <bdmurray> I don't think so.
15:06 <Laney> what's next then?
15:06 <bdmurray> Nope, nothing in it.
15:08 <bdmurray> I think "micahg to get Noskcaj feedback"
15:08 <Laney> bit concerned that this drags on
15:09 <bdmurray> well we could start adding our own feedback then
15:09 <Laney> right
15:09 <Laney> I didn't -1 the application but those who did could start to work on it...
15:10 <Laney> xnox: that includes you
15:11 <Laney> #subtopic Laney to start an onboarding page for new dmb members
15:11 <Laney> I didn't do this yet :(
15:11 <Laney> I am kind of annoyed at myself for not getting around to it
15:11 <Laney> and I will put it on my calendar for friday afternoon
15:12 <Laney> done
15:12 <Laney> #action laney stop slacking and write onboarding page
15:12 * meetingology laney stop slacking and write onboarding page
15:12 <Laney> #subtopic michag to confirm if mozc packageset change happened
15:13 <Laney> did, yes?
15:13 <Laney> Archive Upload Rights for ubuntu-input-methods-dev: archive 'primary', package set 'input-methods' in wily
15:13 <Laney> #subtopic michag to follow up with Unit193 about their application and a meeting date
15:13 <Laney> NFI
15:13 <Laney> #action michag to follow up with Unit193 about their application and a meeting date
15:13 * meetingology michag to follow up with Unit193 about their application and a meeting date
15:14 <bdmurray> I seem to recall that happening but not the outcome.
15:16 <Laney> can't find any mail anyway
15:16 <Laney> #topic PPU application: ShuiLu Pi for ubuntukylin-default-settings
15:16 <Laney> pishuilu: hey, it's now your turn
15:16 <Laney> can you introduce yourself and your application?
15:16 <pishuilu> ok
15:16 <Laney> #chair bdmurray
15:16 <meetingology> Current chairs: Laney bdmurray
15:16 <Laney> (brb)
15:17 <pishuilu> I am a member of Ubuntu Kylin team.
15:17 <pishuilu> I maintain ubuntukylin-default-settings package.
15:18 <pishuilu> This package contains a number of system configurations.
15:19 <pishuilu> For example, firefox search engine and start page, default language for installer images, fix zip fie display of garbage characters
15:19 <pishuilu> etc
15:20 <cyphermox> Do you have plans to start maintaining other packages in ubuntukylin, or other packages in general?
15:20 <xnox> pishuilu: have you come across something that you wanted to customize, but it wasn't in fact customizable at all? Ie. impossible to set some kind of a setting, cause there is no such setting. And how did you resolve such requests?
15:21 <pishuilu> cyphermox: Now I maintain ubuntukylin-default-settings and ubiquity-slideshow-ubuntukylin package
15:22 <pishuilu> Later will also maintain other Ubuntu Kylin packages
15:24 <bdmurray> pishuilu: Could you answer xnox's question?
15:24 <pishuilu> xnox: Sometimes I should create a script to execute
15:25 <pishuilu> shell script
15:26 <pishuilu> Like fix bug LP: #1462848 (fix zip file display of garbage characters)
15:26 <ubottu> Launchpad bug 1462848 in Ubuntu Kylin "The name of the expanded files for zip file display of garbage characters" [Undecided,New] https://launchpad.net/bugs/1462848
15:30 <bdmurray> pishuilu: Have you followed the work in bug 1422290 which seems like it may be a proper fix?
15:30 <ubottu> bug 1422290 in unzip (Ubuntu) "Default charsets handling for Windows archives in CJKV+th locale" [Medium,Triaged] https://launchpad.net/bugs/1422290
15:30 * xnox ponders if my question got through
15:30 <xnox> pishuilu: have you come across something that you wanted to customize, but it wasn't in fact customizable at all? Ie. impossible to set some kind of a setting, cause there is no such setting. And how did you resolve such requests?
15:30 <pishuilu> cyphermox: But I can't maintain all Ubuntu Kylin packages. some packages will be maintained by other colleagues.
15:31 <cyphermox> of course
15:34 <bdmurray> pishuilu: have you seen the other questions asked of you by xnox and myself?
15:34 <pishuilu> bdmurray: I don't follow  bug 1422290. I fix some questions which is not fixed by upstream. If upstream fix this bug ,I will undo this configuration.
15:34 <ubottu> bug 1422290 in unzip (Ubuntu) "Default charsets handling for Windows archives in CJKV+th locale" [Medium,Triaged] https://launchpad.net/bugs/1422290
15:37 <pishuilu> xnox: sorry , I miss your question.
15:37 <xnox> pishuilu: have you come across something that you wanted to customize, but it wasn't in fact customizable at all? Ie. impossible to set some kind of a setting, cause there is no such setting. And how did you resolve such requests?
15:38 <pishuilu> ok
15:38 * stgraber waves (my phone lied to me)
15:39 <pishuilu> xnox: I think if it wasn't in fact customizable at all, so this bug is not for this package.
15:40 <pishuilu> xnox: This package function is system configuration.
15:40 <xnox> pishuilu: so you never modified anything in ubuntu, or request to be modified in ubuntu to customize stuff??
15:43 <pishuilu> xnox: I mean configuration is not modifying some package source.
15:44 <pishuilu> xnox: For exmaple, replace the specific icon
15:45 <pishuilu> configure defaults.list of applications etc.
15:50 <bdmurray> pishuilu: Could you comment on happyaron's caveat regarding a need "to be more careful"?
15:51 <pishuilu> xnox: You mean that modify some package source and submit patches to upstream?
15:52 <pishuilu> bdmurray: ok
15:54 <pishuilu> bdmurray: happyaron's caveat mean : when I fix a bug ,I should consider a problem more comprehensively
15:54 <bdmurray> pishuilu: And what steps are you taking to do that?
15:57 <pishuilu> When I fix a bug , first I should think this bug's influence of the whole system
15:58 <pishuilu> so I can consider a problem more comprehensively
15:59 <bdmurray> Can you give us an example of how you've done that?
16:00 <pishuilu> Details should be considered in all kinds of unexpected circumstances
16:01 <pishuilu> For example , fix bug 1462848
16:01 <ubottu> bug 1462848 in Ubuntu Kylin "The name of the expanded files for zip file display of garbage characters" [Undecided,New] https://launchpad.net/bugs/1462848
16:03 <Laney> (I have one when you're finished)
16:03 <Laney> (then we should wrap up as we're over time already)
16:03 <pishuilu> I didn't consider the previous zh_CN outside
16:05 <pishuilu> Laney: I am sorry. Spent so much time !
16:07 <Laney> It's okay
16:07 <Laney> bdmurray: you want to ask more?
16:07 <pishuilu> I should consider zh_CN,zh_TW,zh_HK etc.
16:08 <bdmurray> Laney: no, that's okay
16:09 <Laney> ty
16:09 <Laney> pishuilu: What testing do you do on the package before asking for it to be uploaded?
16:09 <Laney> Do you test it on a non Chinese system for example?
16:11 <pishuilu> Laney: I test it on Chinese system.
16:12 <pishuilu> Because Ubuntu Kylin provide for the use of Chinese users
16:12 <Laney> I'm worried about cases where I have normal Ubuntu and Ubuntu Kylin installed at the same time
16:12 <Laney> like if I have a Chinese friend who uses my computer
16:13 <Laney> I don't want the Kylin settings to break anything on my account
16:14 <pishuilu> Laney: I see what you mean
16:16 <pishuilu> Laney: I should make some configurations  effect only in zh_CN.
16:17 <Laney> yes, you can also look at the $DESKTOP_SESSION environment variable
16:17 <Laney> it's also valid to be chinese and not use kylin :)
16:18 <pishuilu> Laney:OK, I know.
16:18 <pishuilu> Thanks.
16:18 <Laney> ok, thanks
16:18 <Laney> !dmb-ping
16:18 <ubottu> cyphermox, infinity, Laney, micahg, xnox, bdmurray, stgraber: DMB ping
16:18 <Laney> anyone else?
16:18 <Laney> or vote?
16:19 <xnox> i lost wifi
16:19 * xnox is back
16:20 <Laney> hello?
16:20 <bdmurray> I have no more questions.
16:23 <Laney> #vote grant ShuiLu Pi upload rights for ubuntukylin-default-settings
16:23 <meetingology> Please vote on: grant ShuiLu Pi upload rights for ubuntukylin-default-settings
16:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:26 <xnox> +1
16:26 <meetingology> +1 received from xnox
16:27 <bdmurray> +1
16:27 <meetingology> +1 received from bdmurray
16:28 <Laney> +1
16:28 <meetingology> +1 received from Laney
16:28 <stgraber> +1 [happy to see that the package is no longer overwriting paths owned by other packages but doing clean diverts now, otherwise would have -1]
16:28 <meetingology> +1 [happy to see that the package is no longer overwriting paths owned by other packages but doing clean diverts now, otherwise would have -1] received from stgraber
16:29 <Laney> Would like to see a bit more consideration given to co-existing with other flavours
16:30 <pishuilu> Laney: OK
16:30 <Laney> and probably a review procedure
16:30 <Laney> like, don't commit any changes without another team member approving them
16:31 <Laney> anyway...
16:31 <Laney> #endvote
16:31 <meetingology> Voting ended on: grant ShuiLu Pi upload rights for ubuntukylin-default-settings
16:31 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:31 <meetingology> Motion carried
16:31 <Laney> stgraber: you ok to action?
16:31 <stgraber> sure
16:32 <stgraber> done
16:32 <Laney> thanks
16:33 <Laney> pishuilu: https://wiki.ubuntu.com/MOTU/New <- good page to read
16:33 <Laney> and please ask if you have any questions at all
16:33 <pishuilu> OK ,I know. Thanks very much.
16:35 <Laney> #topic AOB
16:36 <Laney> can all of you please respond to this old thread?
16:36 <Laney> https://lists.ubuntu.com/archives/devel-permissions/2015-August/000815.html
16:37 <Laney> #endmeeting