15:06 <bdmurray> #startmeeting
15:06 <meetingology> Meeting started Mon Aug  3 15:06:00 2015 UTC.  The chair is bdmurray. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:06 <meetingology> 
15:06 <meetingology> Available commands: action commands idea info link nick
15:06 <bdmurray> #topic Review of previous action items
15:07 <bdmurray> micahg_work: How is getting Noskcaj feeback going?
15:07 <micahg_work> not great, I haven't had time to compile, if someone else has time, I'd be willing to hand that off, otherwise, I will try again to get it done over the next 2 weeks
15:08 <bdmurray> micahg_work: Could you elaborate on what is required so people know what they are getting into?
15:09 <micahg_work> basically a summary of what the reasons were why the DMB wasn't in favor of granting Xubuntu packageset and MOTU status as well as requesting and compiling any additional information from DMB members on the subject
15:09 <bdmurray> okay, is there anybody else who could take that on?
15:09 <micahg_work> *in favor at this time
15:11 <micahg_work> bdmurray, you suggested starting a pad where can can collaborate on a response, would you be up for doing that and DMB members can add things at their leisure
15:11 <micahg_work> *where we cab
15:11 <micahg_work> *can
15:11 <bdmurray> sure
15:12 <Laney> you'll have to chivvy people along
15:12 <micahg_work> then, I or someone else can compile the responses from the ML as well and hopefully once the ball is rolling, we'll be able to take care of this quickly
15:12 <bdmurray> #action bdmurray to setup a pad for the dmb to collaborate on response for noskcaj
15:12 * meetingology bdmurray to setup a pad for the dmb to collaborate on response for noskcaj
15:12 <micahg_work> yes, I know, but if the pad is there, it's easier to do that
15:12 <Laney> I can almost guarantee nobody will do anything proactively
15:12 <Laney> :( :( :(
15:12 <Laney> ): ): ):
15:13 <bdmurray> Laney: Do you think that is something we should discuss?
15:14 <Laney> not really
15:15 <bdmurray> okay, moving on then
15:15 <bdmurray> micahg_work: What about the election results, is that taken care of?
15:16 <micahg_work> #link https://lists.ubuntu.com/archives/technical-board/2015-July/002132.html
15:16 <micahg_work> only thing I think is left is team changes, TB seems not to have responded
15:17 <Laney> I think JFDI
15:17 <micahg_work> sure, you poked stgraber already :)
15:17 <Laney> sure did
15:17 <Laney> one thing that comes to mind is...
15:17 <Laney> we have 0 onboarding process
15:17 <Laney> I wonder if we could do something there
15:18 <Laney> or should..?
15:18 <micahg_work> well, there are the DMB wiki pages, we try to document the processes
15:18 <cyphermox> depends, approvals don't typically span multiple weeks
15:18 <micahg_work> were you referring to DMB members of developers?
15:18 <cyphermox> ie. I like to believe getting Noskca feedback is an exception rather than the rule
15:18 <micahg_work> s/of/or/
15:19 <Laney> DMB
15:19 <cyphermox> I read this as onboarding a new member in the DMB
15:20 <Laney> sure we could say "go away and read all of the public documentation"
15:20 <Laney> but there are some things which might not be in there
15:20 <Laney> like... useful resources to check on someone's history (sponsorship tracker thing)
15:20 <Laney> how to manipulate packagesets (edit-acl)
15:21 <Laney> where the code to update the auto-packagesets is
15:21 <cyphermox> yes, that could certainly help
15:21 <Laney> umm, how we vote to +4 and if it doesn't reach that then defer to email
15:21 <Laney> when you can JFDI a packageset change (if it matches the description)
15:22 <bdmurray> and last week or so there was discussion about which team to add a per package uploader to so they could target bugs to a release and vote for the dmb
15:22 <Laney> which teams to add new devs to
15:22 <Laney> exactly
15:22 <micahg_work> managing seed based packagesets and what constitutes a reason not to update
15:22 <Laney> plenty of stuff
15:22 <Laney> how to do a vote for a new member
15:23 <micahg_work> maybe we should create a wiki page of wishlist wiki pages
15:23 <Laney> I was just thinking DMB/New unless it becomes too mad
15:24 <bdmurray> Laney: that sounds good to me
15:24 <Laney> the DD-PPU thing
15:24 <Laney> I think we've grown a lot of mostly opaque process
15:24 <Laney> anyway, action me to start it
15:25 <bdmurray> #action Laney to start an onboarding page for new dmb members
15:25 * meetingology Laney to start an onboarding page for new dmb members
15:25 <bdmurray> it looked like the dmb-ping was already updated, correct?
15:26 <Laney> /query ubottu !dmb-ping
15:26 <micahg_work> yes, Unit193 took care of that for us
15:26 <Laney> FFS
15:26 <Laney> dell guy is here, sorry
15:27 <bdmurray> and corey bryant is in the ubuntu-server-dev team now, so that's done.
15:27 <Laney> I'll be back in however long it takes to change a keyboard
15:27 <Laney> please discuss the thing, I think it's quite clear but I'll help later if I can
15:27 <Laney> ttyl
15:28 <micahg_work> I think I missed an action item which Laney took care of, updating the input-methods packageset, I'm not sure if mozc made it in, I saw the l-s upload
15:28 <micahg_work> I'll take care of that later if it hasn't been
15:28 <bdmurray> #action micahg_work to confim if mozc packageset change happened.
15:28 * meetingology micahg_work to confim if mozc packageset change happened.
15:29 <bdmurray> #topic PPU/Packageset uploader applications and membership by default
15:29 <bdmurray> What's this about?
15:30 <cyphermox> what teams we put people into in the PPU case, I believe
15:31 <bdmurray> micahg_work: So I'd added teward to ubuntu-dev and you indicated that wasn't what we should do?
15:31 <micahg_work> so, I'm not sure how it started, there was a question about teward not being in ubuntu-dev, in previous cases where people had ubuntu membership + PPU, we've added them to ubuntu-dev, I'm not sure if that was the impetus for the discussion or something else, I called this practice into question as it didn't seem appropriate as dev membership grants voting rights for dev related things which should require some level of active involvement
15:31 <micahg_work> in the Ubuntu dev community
15:32 <micahg_work> *which IMHO
15:34 <teward> micahg_work: this was started by bdmurray's bot tagging a debdiff as 'patch' and subscribing sponsors for an nginx bug
15:34 <teward> i have PPU rights for nginx, so sponsorship subscription was irrelevant and unnecessary at the time
15:34 <teward> i pinged bdmurray to request removal of sponsors on that bug as it wasn't one that needed the sponsors' attention
15:34 <micahg_work> also, the only time there's a difference is PPU for individual packages as packagesets and other dev group membership implicitly grant ubuntu-dev membership
15:34 <teward> that's the beginning of the case in question.
15:35 <bdmurray> teward: thanks for the reminder. micahg_work did you have more to add?
15:35 <teward> I didn't bother tracking much of the specifics after that time.
15:35 <teward> bdmurray: you're welcome.  *returns to lurk mode*
15:35 <micahg_work> ah, then this is my fault, I never made an icon for ubuntu-uploaders
15:35 <micahg_work> that would have solved that particular issue
15:36 <bdmurray> ?
15:36 <bdmurray> how's that?
15:36 <micahg_work> oh, wait
15:36 <micahg_work> well, it would help anyone who's using that LP addon
15:37 <bdmurray> micahg_work: this is a launchpadlib script
15:37 <micahg_work> I'm not sure if the sponsoring page actually needs to be updated to recognize ubuntu-uploaders or if it just uses the archive ACLs
15:38 <micahg_work> I think the point or order on which team by default should be discussed still regardless
15:38 <micahg_work> s/or/of/
15:38 <bdmurray> agreed
15:39 <bdmurray> micahg_work: so this person is an ubuntu-member and has PPU - should they be added to ubuntu-dev?
15:40 <micahg_work> that's another point of contention I suppose, we've done it in the past, I don't personally agree with it
15:40 <micahg_work> I think the bar of significant and sustained dev contribution makes sense for having dev voting rights vs significant and sustained Ubuntu contribution
15:41 <bdmurray> And somebody with PPU doesn't have significant and sustained dev contribution?
15:42 <micahg_work> not necessarily, that's why we split out uploaders from dev, I thought the idea was the lower that bar (not the technical bar of understanding packaging) to make package maintenance more accessible for people that care about specific packages that might not need to be updated frequently
15:43 <micahg_work> well, that's how I remember it at lesat
15:43 <micahg_work> s/lesat/least/
15:44 <micahg_work> if people were contributing significantly, they were welcome to apply for dev membership at the same time, but I was under the impression that it was not the default for PPU (only)
15:44 <bdmurray> okay, is this something we can work on as a part of the onboarding documentation?
15:45 <bdmurray> micahg_work: do you recall about what year these discussions took place?
15:45 <micahg_work> I think it was within the last 2 years, I can find the references a bit later
15:46 <micahg_work> actually, uploaders team was created 2014-01-13 (thank you Launchpad)
15:46 <micahg_work> so, would be right around then
15:47 <bdmurray> Okay, I'll look into the discussion around that then and send an email to the team. Does that sound good?
15:47 <micahg_work> yep, we should probably clarify (and maybe re-announce) the policy once we decide on it, I think we were expecting many more people applying for PPU
15:49 <bdmurray> #action bdmurray to find discussion about PPU and ubuntu-dev membership
15:49 * meetingology bdmurray to find discussion about PPU and ubuntu-dev membership
15:49 <xnox> my understanding that PPU does imply ubuntu membership.
15:49 <xnox> one has to sign the code of conduct to be part of ubuntu-dev, and that's by default expected.
15:50 <micahg_work> I think the same should be required of uploaders
15:50 <xnox> and i don't want to underestimate the PPU contributions. PPU libreoffice, or PPU upstart, or PPU systemd are huge amounts of work and complexity.
15:50 <xnox> micahg_work: and that is the case today.
15:50 <micahg_work> it's not necessarily exclusive, just not the default IMHO
15:51 <xnox> micahg_work: you can dig up the threads way back, when DMB chased up, pinged and kicked out everyone out of the ubuntu membership (via ubuntu-dev) that didn't satify requires (e.g. code of conduct signed etc.) and from then on it became the default.
15:51 <xnox> do you remember that process way back then?
15:51 <xnox> (before my time, as far as i recall correctly, or maybe not)
15:52 <micahg_work> the applicant is welcome to apply for membership when applying for PPU if they feel they've made significant and sustained dev contributions, the idea was to allow those who have the technical know-how but don't necessarily have the time to commit for significant and sustained contribution to be able to contribute as well
15:52 <micahg_work> xnox, hrm, that's quite a while back, I can dig a bit, sure
15:53 <xnox> my understanding of status quo, was that all PPUs are applying for membership, and can choose for membership requirements to be lifted if they so request (and thus ask for PPU-sans-memberhip) Granted that's not obvious on the application page.
15:53 <xnox> however, i wonder if that became obsolete.
15:54 <xnox> most PPU-sans-membership no longer apply, and instead use CI train/airline/silo stuff.
15:54 <xnox> thus imho, it's a historical artifact we should forget about =)
15:55 <micahg_work> that's for Canonical people, the policy was meant for the community at large
15:56 <bdmurray> we are running a bit short on time, how about we dig a bit and take it to email?
15:56 <micahg_work> I can think that one appropriate application is DMs in Debian, PPU w/out membership would be a natural extension if they care about their packages, but don't do much in Ubuntu
15:56 <micahg_work> bdmurray, yes, that sounds good
15:57 <bdmurray> I think somebody should follow up with Unit193 regarding their application. Any volunteers?
15:57 <micahg_work> bdmurray, yes, I can
15:57 <bdmurray> #action micahg_work to follow up with Unit193 about their application
15:57 * meetingology micahg_work to follow up with Unit193 about their application
15:57 <micahg_work> I know the timing of our meetings was a bit hard
15:58 <bdmurray> #topic any other business
15:58 <bdmurray> Anything else?
16:00 <bdmurray> Alright, thanks for everyone.
16:00 <bdmurray> #endmeeting