19:05 <micahg_work> #startmeeting DMB
19:05 <meetingology> Meeting started Mon Jul 20 19:05:52 2015 UTC.  The chair is micahg_work. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:05 <meetingology> 
19:05 <meetingology> Available commands: action commands idea info link nick
19:06 <micahg_work> Welcome to the DMB meeting
19:06 <micahg_work> #topic Review previous action items
19:07 <micahg_work> #subtopic Laney get with CC to get the voting rules documented
19:07 <micahg_work> I believe this was done
19:07 <micahg_work> #subtopic micahg to get Noskcaj feedback
19:07 <micahg_work> I still need to do this
19:07 <micahg_work> #subtopic micahg to call for nominations to fill soon to be empty DMB seat
19:07 <micahg_work> this was done as well as the election
19:08 <micahg_work> #topic Confirm DMB election result
19:08 <cyphermox> yep
19:08 <micahg_work> anyone have the results link handy?
19:08 <cyphermox> http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:08 <cyphermox> sorry, [LINK] http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:09 <micahg_work> thanks
19:09 <cyphermox> ugh, whatever it is ^
19:09 <micahg_work> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:09 <micahg_work> #vote DMB to affirm election results at http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:09 <meetingology> Please vote on: DMB to affirm election results at http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:09 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:09 <micahg_work> +1
19:09 <meetingology> +1 received from micahg_work
19:09 <cyphermox> +1
19:09 <meetingology> +1 received from cyphermox
19:10 <xnox> +1
19:10 <meetingology> +1 received from xnox
19:10 <micahg_work> We have a +1 from Laney as well
19:11 <micahg_work> bdmurray, ^^
19:11 <bdmurray> +1
19:11 <meetingology> +1 received from bdmurray
19:11 <micahg_work> #endvote
19:11 <meetingology> Voting ended on: DMB to affirm election results at http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f7044c9c0a0f68b6
19:11 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:11 <meetingology> Motion carried
19:11 <cyphermox> infinity: you've been confirmed as a new DMB member
19:11 <micahg_work> Congrats to infinity on being elected to the DMB to fill the remainder of ScottK's term
19:11 <micahg_work> well
19:11 <micahg_work> technically I think we now forward to TB and they have to approve :)
19:12 <cyphermox> bah ;)
19:12 <micahg_work> #action micahg to send E-Mail to TB with election results and DMB affirmation and ask for approval/team changes
19:12 * meetingology micahg to send E-Mail to TB with election results and DMB affirmation and ask for approval/team changes
19:13 <micahg_work> paperwork...
19:13 <ScottK> Don't forget to update the dmb ping.
19:13 <micahg_work> hrm, Laney isn't here for the next item...
19:14 <micahg_work> #action micahg to ask IRC team to update dmb-ping once team updates happen
19:14 * meetingology micahg to ask IRC team to update dmb-ping once team updates happen
19:15 <micahg_work> let's start with applications
19:15 * micahg_work is looking for Unit193 quickly
19:16 <micahg_work> ok, moving to coreycb since he's here
19:17 <coreycb> o/
19:17 <coreycb> Hi
19:17 <micahg_work> #topic applications for ubuntu-server upload rights for Corey Bryant
19:17 <micahg_work> #link https://wiki.ubuntu.com/CoreyBryant/UbuntuServerDeveloperApplication
19:22 <bdmurray> coreycb: Could you tell us a bit about yourself?
19:22 <xnox> micahg: seems to have network problems.
19:22 <coreycb> Sure
19:22 <micahg_work> yes, sorry
19:23 <xnox> coreycb: how do you envision openstack moving to python3 only? python3 only in Ubuntu?
19:23 <coreycb> I work on OpenStack packaging and it's dependencies for Ubuntu.
19:23 <coreycb> well we've started to migrate the python clients to python3
19:24 <coreycb> So it's in the works, and upstream is also working to move to python3
19:24 <coreycb> A little more about myself..
19:25 <doko> wily will be 3.5 as the default
19:25 <coreycb> I've been packaging since early 2014
19:25 <coreycb> and have since started to take over a lot of the SRUs
19:25 <coreycb> and have contributed a decent amount to the new release (liberty)
19:26 <coreycb> so having upload rights would be a big help for streamlining our process, and take some load off of zul and jamespage
19:27 <infinity> coreycb: Would be a better question for Chuck or James, but I'll trust you to answer honestly: On average, when they're sponsoring for you, how often would you say they find issues you need to fix?
19:28 <coreycb> infinity, less than 5% I'd say
19:28 <coreycb> typically I consult with them before issues come up
19:29 <infinity> coreycb: And, I assume, with upload rights, that process won't change?  You'll still ask for input from your peers if something seems a bit off or needs another set of eyes?
19:29 <xnox> coreycb: could you describe in general terms what stages a package goes through from upload by developer, until it reaches the users of the development release wily? why might it not reach those users?
19:30 <coreycb> infinity, definitely
19:30 <coreycb> xnox, sure
19:30 <coreycb> well most packages start in debian obviously
19:30 <coreycb> and we have to do a lot of syncs and merges with debian
19:31 <coreycb> and once those packages are in universe we need to get them into main for many of the openstack packages, the supported ones
19:31 <coreycb> when uploading, we'll upload to wily-proposed
19:32 <coreycb> and the packages then move to wily-updates (post release)
19:32 <coreycb> or straight to wily pocket pre-release
19:32 <xnox> ok.
19:32 <infinity> coreycb: I think he was asking for all the proposed -> ??, ??, ?? -> release steps in between. ;)
19:33 <xnox> coreycb: and why/how things might not end up in the wily pocket pre-release?
19:33 <xnox> (second part of the question)
19:33 <coreycb> xnox, right so issues might occur with autopkgtesting
19:33 <coreycb> in migration to proposed
19:34 <coreycb> we'd need to evaulate various issues that could occur in update excuses
19:34 <xnox> ok. sounds good.
19:36 <coreycb> infinity, so yeah wily-proposed to -> wily-updates -> cloud archive might be what you're looking for
19:36 <xnox> coreycb: in update excuses what does "missing build on amd64" mean? is that a problem for a pure-python package (arch:all)?
19:36 <infinity> coreycb: So, historically, openstack packages have suffered two major issues in proposed-migration.  One just being new deps that cause a transition/blockage and need MIRs and the like to sort out.  You've been really good about keeping on top of that (thanks).
19:36 <infinity> coreycb: The other major issue is that sometimes autopkgtest regressions go unnoticed/unresolved for weeks.  Do you have a plan to make sure that happens less often, and how?
19:37 * xnox is mostly asking silly questions cause i naver worked/sponsored coreycb thus try to probe where on contributor - core-dev spectrum the applicant is.
19:37 <coreycb> xnox, no I don't think that's an issue for a pure python package since it's interpreted
19:37 <xnox> coreycb: what does FTBFS mean?
19:37 <coreycb> fails to build from source
19:37 <infinity> coreycb: xnox's question was (unintentionally?) a trick question, BTW, since amd64 is the arch that builds arch:all packages in vivid and later. :)
19:38 <doko> do you known how to fix it?
19:38 <coreycb> doko, ftbfs?
19:38 <doko> heh, yes
19:38 <xnox> coreycb: ... thus there would be no binary .deb of a said python package if it fails to build from source.
19:39 <coreycb> doko, it probably depends, but recently I diagnosed an ftbfs in the cloud archive for liberty and tests were failing due to a missing dep
19:39 <doko> and how do you become aware of packages that ftbfs which you don't upload yourself?
19:39 <coreycb> doko, well in that case it was the cloud archive so we have a mailing list for that
19:40 <coreycb> doko, I think here -- http://qa.ubuntuwire.org/ftbfs/
19:40 <xnox> coreycb: "no I don't think that's an issue for a pure python package since it's interpreted" this is wrong by the way. "missing build on amd64" means .deb was never created for this package, and it means it never got build and will not propagate. It could be that it is failing to build from source (like you said bugs/errors in testsuite etc) or it could be in dep-wait state (build dependencies not satisfied). When in dep-wait state launchpad
19:40 <xnox> doesn't even attempt to build the packages.
19:40 <bdmurray> micahg_work: I don't we need Laney for the input-methods discussion
19:40 <xnox> coreycb: and yeah, tricky cause amd64 compiles _all.deb packages for us (as infinity said)
19:41 <xnox> in willy.
19:41 <micahg_work> bdmurray, right, I noticed the comment in his email and I'm ready to bring it up once we're done with this topic
19:42 <coreycb> infinity, sorry I missed your qeustion
19:42 <infinity> coreycb: S'ok, you're kinda getting slammed from all sides here. :P
19:43 <xnox> infinity: but so far the answers are handled well, for the archive rights application is for.
19:43 <xnox> imho.
19:43 <coreycb> infinity, re autopkgtest regressions.  setting time aside each week to evaluate things like component mismatches, or update excuses, or bug triaging is something I need to do.
19:43 <micahg_work> coreycb, on that topic, Laney noticed that your last two uploads seem to be stuck in dependency wait status, have you been working on resolving that?
19:43 <coreycb> infinity, :)
19:44 <xnox> coreycb: have you ever participated in a transition? e.g. migration to a new major version of something rather (python, boost, gcc, or any other smaller libraries)?
19:44 <coreycb> micahg_work, yes, well liberty is a new release now so it's really in some of the busiest parts of the openstack packaging release lifecycle
19:44 <coreycb> micahg_work, so some things do need attention but yeah it's a balance, and we have a list of done and to-do :)
19:46 <coreycb> xnox, If I understand your question, we're about to do that with openstack actually, as they're moving to a new versioning scheme
19:46 <coreycb> xnox, so we'll need to add an epoch to the version
19:47 <xnox> coreycb: ack. sounds good.
19:47 <xnox> coreycb: you might find transition tracker useful for that. It takes syntax to mark things as good/bad and then one can easily track progress of such things.
19:48 <micahg_work> coreycb, right, I understand there are chicken and egg issues, I was wondering if you've followed up at all and if so, what's happening with those packages' dependencies
19:48 <xnox> E.g. here is the tracker for upcomming libstdc++ abi transition http://people.canonical.com/~ubuntu-archive/transitions/html/libstdc++6.html
19:48 <coreycb> xnox, thanks I'll look into that
19:48 <coreycb> micahg_work, did you have one in particular?
19:49 <coreycb> micahg_work, we probably have some MIRs being settled
19:49 <micahg_work> https://launchpad.net/ubuntu/+source/heat/1:5.0.0~b1-0ubuntu1/+build/7628909
19:49 <micahg_work> https://launchpad.net/ubuntu/+source/ceilometer/1:5.0.0~b1-0ubuntu2/+build/7635433
19:50 <coreycb> micahg_work, heat is waiting on python-designateclient which we have an MIR open for
19:50 <coreycb> and is dependent on a new python-cliff which is working it's way through from debian
19:52 <coreycb> micahg_work, ceilometer is waiting on python-awsauth, we have an MIR open for that too
19:56 <micahg_work> so, heat needs the new python-cliff or python-designateclient?
19:58 <coreycb> heat needs python-designateclient and python-designateclient needs python-cliff, but I don't see cliff in component mismatches so maybe it's ok.  I need to check rmadison to see what version we haven ow.
19:58 <coreycb> s/ow/now
19:59 <coreycb> micahg_work, ah.
20:00 <coreycb> micahg_work, I believe we have a new version of python-designateclient in debian we need to sync
20:01 <micahg_work> coreycb, so, is this a requirement of the MIR or of heat?
20:02 <micahg_work> (new version that is)
20:02 <coreycb> micahg_work, no actually sorry I think I'm just confusing things
20:02 <micahg_work> ok
20:05 <coreycb> micahg_work, I'm not sure why python-designateclient isn't in main yet.  The MIR's been fix committed.
20:05 <coreycb> it appears to be building ok
20:05 <coreycb> I might just need to poke the release team
20:06 <micahg_work> right, I was wondering if you or your team regularly follow up on those
20:06 <coreycb> micahg_work, we do yes, I'm starting to
20:06 <micahg_work> great
20:06 <micahg_work> ok, any other questions
20:07 <coreycb> micahg_work, none from me :)
20:08 <micahg_work> #vote Corey Bryant (coreycb) to get upload rights to the Ubuntu Server packageset
20:08 <meetingology> Please vote on: Corey Bryant (coreycb) to get upload rights to the Ubuntu Server packageset
20:08 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:09 <bdmurray> +1
20:09 <meetingology> +1 received from bdmurray
20:09 <xnox> +1
20:09 <meetingology> +1 received from xnox
20:09 <cyphermox> +1
20:09 <meetingology> +1 received from cyphermox
20:10 <micahg_work> +1
20:10 <meetingology> +1 received from micahg_work
20:11 <micahg_work> #endvote
20:11 <meetingology> Voting ended on: Corey Bryant (coreycb) to get upload rights to the Ubuntu Server packageset
20:11 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:11 <meetingology> Motion carried
20:11 <micahg_work> coreycb, congrats
20:11 <xnox> =)
20:11 <coreycb> thank you very much!
20:11 <cyphermox> coreycb: congrats!
20:11 <coreycb> I appreciate your time and questions, thanks again.
20:12 <micahg_work> #action micahg or other DMB member to add coreycb to Ubuntu Server uploaders
20:12 * meetingology micahg or other DMB member to add coreycb to Ubuntu Server uploaders
20:13 <micahg_work> ok, let's quickly go through the input methods item
20:13 <bdmurray> +1
20:13 <bdmurray> was I too quick?
20:14 <micahg_work> #topic input-methods packageset criteria change
20:14 <micahg_work> #link https://lists.ubuntu.com/archives/devel-permissions/2015-July/000811.html
20:14 <micahg_work> are we ready for a vote?
20:14 * bdmurray is
20:14 <cyphermox> I am
20:15 <micahg_work> #vote New input methods packageset criteria based on Laney's suggestion in https://lists.ubuntu.com/archives/devel-permissions/2015-July/000811.html
20:15 <meetingology> Please vote on: New input methods packageset criteria based on Laney's suggestion in https://lists.ubuntu.com/archives/devel-permissions/2015-July/000811.html
20:15 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:15 <xnox> against what should i run sed -r -ne 's/^im:([^:]*:)*(.*)$/\2/p'
20:15 <xnox> > >> >language-selector-*/data/pkg_depends | sort -u ?
20:15 * xnox wants to double check sanity
20:16 <micahg_work> run it in a dir that where you grab the language selector source IIRC
20:17 <xnox> +1
20:17 <meetingology> +1 received from xnox
20:17 <bdmurray> +1
20:17 <meetingology> +1 received from bdmurray
20:17 <xnox> checked that and the rest of the request.
20:17 <cyphermox> +1
20:17 <meetingology> +1 received from cyphermox
20:18 <micahg_work> +1
20:18 <meetingology> +1 received from micahg_work
20:18 <micahg_work> and we have a +1 from Laney as well
20:18 <micahg_work> #endvote
20:18 <meetingology> Voting ended on: New input methods packageset criteria based on Laney's suggestion in https://lists.ubuntu.com/archives/devel-permissions/2015-July/000811.html
20:18 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:18 <meetingology> Motion carried
20:18 <micahg_work> #topic AOB
20:20 <micahg_work> #info The DMB would like to thank Scott Kitterman for his years of service on the DMB.
20:21 <micahg_work> next chair is bdmurray
20:21 <micahg_work> #endmeeting