17:02 <mhall119> #startmeeting Ubuntu Community Council meeting
17:02 <meetingology> Meeting started Thu May 21 17:02:41 2015 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:02 <meetingology> 
17:02 <meetingology> Available commands: action commands idea info link nick
17:02 <mhall119> Agenda: https://wiki.ubuntu.com/CommunityCouncilAgenda
17:02 <cprofitt> hello all
17:03 <elfy> o/
17:03 <mhall119> #chair czajkowski cprofitt elfy pleia2
17:03 <meetingology> Current chairs: cprofitt czajkowski elfy mhall119 pleia2
17:03 <mhall119> it seems I remember the meetingology commands
17:03 <elfy> always useful
17:03 <mhall119> we have nothing on our Agenda wiki for today
17:04 <mhall119> is there anybody around who has a topic they would like to discuss with the Community Council?
17:04 <elfy> ummm mhall119
17:04 <elfy> Forums Council 17:00UTC 21st May / Core Apps/Phone 17:30UTC 21st May
17:04 <elfy> that's today ;)
17:04 <popey> Yeah mhall119!
17:04 <mhall119> elfy: ah, that's down further on the page, sorry I didn't see it
17:04 <elfy> :D
17:04 * popey rolls mhall119's mouse wheel a bit
17:04 <mhall119> #topic Forums Council check-in
17:05 <mhall119> anybody from the Forums Council here today?
17:05 <elfy> I went and found the hat especially ...
17:05 <cprofitt> popey: :-)
17:05 <popey> suits you
17:06 <elfy> only me mhall119 :)
17:07 <elfy> pretty much all's good
17:07 <mhall119> elfy: how has the forums activity been since the last checkin?
17:07 <mhall119> elfy: any specific events or activities to share?
17:07 <elfy> pretty much static month by month
17:08 <elfy> we've just finished trying to get people involved in nominating themselves for mod team
17:08 <mhall119> elfy: how successful was that?
17:08 <elfy> that's not gone well really, not sure what we're going to do about that
17:08 <elfy> pretty much the same as everywhere - hard to get people to want to 'leader' up
17:09 <mhall119> what did you do to attract people?
17:09 <elfy> threads - public and in the area members can see, blog post
17:10 <czajkowski> elfy: and in general have the the FC seen an increase in users or is it just static ?
17:10 <mhall119> elfy: how about directly asking people who you think would be a good mod if you can nominate them
17:10 <mhall119> ?
17:10 <elfy> czajkowski: mostly static - get increases at release time
17:11 <elfy> mhall119: that is an option open to us still - but we're trying to make it a bit more open
17:11 <mhall119> elfy: ack, but sometimes having a personal invite makes people more willing, we identified that in one of the UOS sessions earlier in the month
17:12 <elfy> yes - and that's the way the forum has done it for 10 years
17:12 <mhall119> ah, ok, so a public call is something new that's being tried?
17:12 <elfy> yea
17:12 <mhall119> ok
17:13 <mhall119> elfy: any highlights or praises you'd like to give?
17:13 <elfy> well - not brand new, we tried a while back - same
17:13 <elfy> we're thinking on next steps
17:14 <elfy> we still get people applying for membership via us - that's still working
17:14 <cprofitt> elfy: what do you think might be causing people to now want to step up and be a moderator?
17:14 <cprofitt> not
17:15 * mhall119 guesses inertia is the most likely cause
17:15 <elfy> cprofitt: not sure - could be the process, could be them seeing the 'troublesome' ones
17:15 <elfy> and that mhall119
17:16 <elfy> the new supermod group's making transition for people to FC much easier all round
17:16 <mhall119> elfy: is there anything the CC can do to help with recruiting mods, or anything else for the Forums?
17:16 <elfy> not with Mods no
17:16 <elfy> as far as anything else - we're pretty good thanks
17:17 <elfy> rt's are always a bit of an issue - but other than bumping old ones
17:17 <elfy> things sitting around for 6 months or more get to be annoying
17:17 <elfy> just finding one ...
17:17 <czajkowski> elfy: is there anything outstanding on rt or in general the CC can help with ?
17:18 <elfy> https://rt.ubuntu.com/Ticket/Display.html?id=25642
17:18 <mhall119> we can try and bump priority on RTs, or at least get some action on old ones
17:18 <elfy> I opened that last October -seems that all that's required is edit a config file
17:18 <elfy> we of course don't have that access anymore
17:19 <czajkowski> ugh
17:19 <czajkowski> mhall119: surely we can get some bump on that RT
17:19 <czajkowski> October is a long time ago
17:19 <mhall119> yup, I'll take an action item to do that
17:20 <mhall119> #action mhall119 to request a response to RT#25642 for the Forums Council
17:20 * meetingology mhall119 to request a response to RT#25642 for the Forums Council
17:20 <elfy> 24227 - April last - mods can't set their own passwords
17:21 <elfy> generally though - positive
17:21 <czajkowski> elfy: as in april just gone ?
17:21 <mhall119> elfy: you said 24228 was solved, is 24227 still open?
17:21 <elfy> oh - sorry we're in May ... 2015
17:22 <elfy> 24228 is nothing to do with us afaik
17:22 <mhall119> #action mhall119 request a response to RT#24227 for Forums Council
17:22 * meetingology mhall119 request a response to RT#24227 for Forums Council
17:22 <mhall119> elfy: ok
17:23 <mhall119> elfy: which is the most urgent?
17:23 <elfy> 24227
17:23 <mhall119> ok, I'll push for that one first
17:23 <elfy> but I think this is tied up with http/https/sso - knotty problem
17:23 <mhall119> elfy: anything else the FC is blocked on or waiting on?
17:24 <elfy> nope
17:24 <mhall119> anything else the FC would like to discuss during this meeting?
17:24 <elfy> well - waiting, but I'd not be worrying about recent ones
17:24 <elfy> nope - I'm good thanks mhall119
17:24 <elfy> I can take the hat off now ;)
17:25 <mhall119> elfy: if you get to where you feel you've waited long enough, ask the CC to escelate it
17:25 <elfy> yep
17:25 <mhall119> you don't need to wait for the next checkin :)
17:25 <elfy> well no - but they hang around for so long we forget lol
17:26 <mhall119> cprofitt: czajkowski pleia2 anything else to talk to the FC about?
17:26 <czajkowski> narp all good
17:27 <cprofitt> I am good
17:27 <mhall119> thanks elfy for representing the FC today
17:27 <czajkowski> elfy: shout earlir if the FC need help with RTs
17:27 <elfy> czajkowski: :~)
17:27 <czajkowski> seems crazy waiting that long
17:28 <elfy> hard to know what else they're up to - mostly just a note on the ticket 'soon'orsomething helps
17:28 <elfy> syrup under space bar apparently ...
17:29 <mhall119> #topic Core Apps checkin
17:29 <mhall119> popey: your turn
17:29 <popey> o/
17:29 <elfy> well if everyone is good - we can move on to popey fidgeting in the corner :)
17:29 <popey> Yo, wassup?
17:29 <elfy> hi popey :)
17:29 <popey> I was passing time providing support in #ubuntu :)
17:30 <popey> <uncomfortable silence>
17:30 <elfy> oh yes - words
17:30 <elfy> so - anything awesome you can tell us about Phone :)
17:30 <mhall119> popey: ok, first off then, any notable activity on the core apps?
17:31 * mhall119 asks knowing there is
17:31 <elfy> lol
17:31 <popey> Ok, so we had UOS between last time we spoke and now
17:31 <popey> Had a bunch of sessions for core apps
17:31 <popey> Lots of discussion and planning done for the coming months.
17:32 <popey> However, there's one overriding issue which I want to braindump at you.
17:32 <popey> if you don't mind.
17:32 <elfy> go for it
17:32 <popey> Contribution is down, and it's quite hard to get more people involved and I have some theories why.
17:32 <popey> 1) Some aspects (such as writing autopilot tests) are not exciting but incredibly dull, and hard to 'sell'
17:33 <popey> 2) many people don't have a device.
17:33 <popey> 1 we can work on, we can make the tests easier to write
17:33 <popey> we can also find those strange people who like writing them
17:33 * popey looks at balloons
17:33 <popey> However, 2 is a bit harder.
17:33 <cprofitt> yeah, I was a bit disappointed when I found my nexus 7 could not help test
17:33 <elfy> if they were easy I would
17:33 <popey> The knock on effect of people not having a device is that they don't feel empowered to help in many ways
17:33 <popey> and they don't feel like they're scratching an itch
17:34 <popey> e.g. "Why would I work on the Ubuntu music app on ubuntu phone, when I have an android phone"
17:34 <popey> In the past, the desktop was 'easier' to get contributions to, because anyone could install it on any system
17:34 <popey> The fact that we need to port to specific devices actually makes it hard to get devices for people
17:34 <popey> especially when in some regions (USA) there's limited options (bq and meizu devices don't work well over there on all of their frequencies for example)
17:35 <popey> Is this making sense?
17:35 <mhall119> popey: do you forsee that getting easier once we have a usable Unity 8 desktop?
17:35 <czajkowski> popey: it is
17:35 <elfy> popey: yep
17:35 <popey> Ok.
17:35 <popey> Well, there's a few things that will help.
17:35 <popey> more devices being available, and having a better end user experience helps
17:35 <popey> as people will be more inclined to use them as their daily driver
17:36 <popey> if you use it daily and you notice janky things, you're way more likely to file bugs / patches / translations / documentation
17:36 <popey> we have seen this on the ubuntu-phone list
17:36 <popey> there's people writing their own documentation, prototyping apps, translating things etc
17:36 <popey> all things we used to get lots of contributions for on the desktop
17:36 <popey> but at a MUCH smaller scale
17:37 <popey> because few people have the devices. and those that do, don't use it daily, so don't see the issues, or don't feel motivated to fix them
17:37 <popey> Now, this leads ot a bit of a chicken and egg issue.
17:37 <popey> I feel like ubuntu phone is where ubuntu desktop was in ~2005
17:37 <popey> works well for a subset of users, on specific hardware.
17:38 <popey> Oh, and another thing!
17:38 <popey> many regular contributors to ubuntu are students - people who traditionally have limited desposable income
17:38 <popey> so they often (generalising here) make the best of the equipment they have
17:39 <czajkowski> popey: it's a daft idea but why not organise some some of phone jam - where you or others bring along hand sets and people play with them and use them and file bugs. New users = new bugs and new users = new ideas on the phone
17:39 <czajkowski> people come and get to meet one another
17:39 <popey> and are more inclined to fix things because "It's my only PC". whereas everyone (mostly) already has a smartphone - even students with low / no / income
17:39 <czajkowski> and you get some community interaction
17:39 <popey> Well.
17:39 <popey> Good idea to have events.
17:39 <popey> I will certainly note that.
17:40 <popey> However, right now, bugs we are not short of :)
17:40 <mhall119> we have encouraged people to bring their devices to loco team events
17:40 <mhall119> but that doesn't let others use it as a daily driver
17:40 <czajkowski> well it's more about interaction and if you provide the devices then people can get involved
17:40 <czajkowski> popey: perhaps for a student meet up you could give away one to the person who files the most bugs, or writes the best test case
17:40 <czajkowski> put bounty on it
17:41 <popey> hmm. incentivising
17:41 <popey> you know how I feel about that :)
17:41 <czajkowski> popey: I do :)
17:41 <czajkowski> popey: next co working day bring devices and let people play and run the tests on them!
17:41 <popey> like I say, bugs we have. contributions we don't
17:42 <mhall119> I know in the past we have used the community donations to send devices to core apps developers, but we haven't expanded it to more general phone users/contributors
17:42 <popey> people often say "it doesn't do X or Y" and I already have the bug on my screen for them
17:42 <mhall119> even for core apps devs, we were bending the guidelines for them
17:42 <popey> I would love to have a bunch of devices i could take somewhere and get people to contribute
17:42 <mhall119> as many were not (yet) Ubuntu Members
17:43 <popey> Going back to the previous question, I do believe that things will get easier as we have snappy desktop in 15.10
17:43 <popey> and converged device coming this year
17:43 <mhall119> right, it won't give a phone use experience, but it will at least make it easier for people to run the apps themselves
17:43 <popey> both of those should have an impact and we should make certain to capture those poeple who are interested in contributing
17:43 <mhall119> popey: is there anything we can do to encourage people to use core apps on current desktops?
17:44 <czajkowski> popey: mhall119 could a loco team apply for funnds via the fund to buy phones for their team to get more involved?
17:44 <popey> yes and no
17:44 <czajkowski> Perhaps the perception is you have to be a core dev to get a phone
17:44 <popey> so to mhall119, yes, i need to delete all the core apps wiki page and replace it with a pretty page on developer.ubuntu.com :)
17:45 <mhall119> czajkowski: I would think so, yes, but they would need to show that it would be money well spent
17:45 <popey> i dont want to buy a bunch of phones to sit in a drawer somewhere
17:45 <mhall119> ^^ that
17:46 <mhall119> we've loaned devices to loco teams for use in events, but the expectation was that it would come back to Canonical afterwards so it can be loaned to someone else
17:46 <czajkowski> nods
17:46 <elfy> popey: got to run here - I'll read up in a bit - thanks :)
17:46 <mhall119> thanks elfy
17:46 <czajkowski> I do know some locos are very proactive in QA and might enjoy this
17:46 <czajkowski> perhaps they don;t know they could avail of the fund
17:46 <czajkowski> maybe one thing they'd have to do is provide a bi weekly report of their work ?
17:47 <popey> elfy: thanks
17:47 <mhall119> czajkowski: yeah, and I think they would need regular in-person meetups in order for more than just one person to take advantage of the device
17:47 <popey> Again, QA isn't really what we need. We have people testing stuff. It's fixers we need. IMO
17:48 <mhall119> popey: is it time for another recruitment drive for Core Apps?
17:48 <popey> yes
17:48 <popey> so, todo list:-
17:48 <popey> 1) make a better home page on developer.ubuntu.com
17:48 <mhall119> ok, the hack days seemed to work reasonably well for that in the past
17:48 <popey> 2) Better articulate the things we need
17:48 <popey> 3) recruit
17:48 <mhall119> popey: ack
17:48 <popey> hack days were variable
17:49 <mhall119> popey: what part of that can the CC help with?
17:49 <popey> I'll make a start on 1 and 2
17:49 <popey> Don't think anything (yet)
17:49 <mhall119> popey: has it helped to bring some of those core app devs to sprints?
17:49 <mhall119> I know it's highly motivating to the ones that go, but what about in recruiting new devs?
17:49 <popey> yeah, absolutely
17:50 <popey> not sure I understand the question
17:50 <popey> inviting community people to sprints is a mixed blessing
17:50 <popey> "Here, come along with us and hack on ubuntu" vs "Here, spend a week of your vacation working for no pay"
17:51 <mhall119> is that kind of involvement with Canonical something that helps motivate people to get involved, or does it only motivate people who are already involved?
17:51 <popey> I think it's motivating and fun for students
17:51 <popey> less so for people with families / careers
17:51 <mhall119> ack
17:51 <popey> ergo we should target students ㋛
17:52 <popey> exams are now, summer holidays coming for many
17:52 <popey> now is the time to strike
17:52 <mhall119> popey: what about a GSoC project for this?
17:52 <czajkowski> popey: contact unis that offer mobile dev courses and see if they'd like a semester project
17:52 <popey> too late for GSOC I think?
17:53 <mhall119> maybe
17:53 <mhall119> not sure if Google would approve it anywya
17:53 <popey> czajkowski: yeah, will add that to my list
17:54 <mhall119> popey: changing gears a bit, is there anything blocking or disrupting contributions from the people you already have?
17:54 <popey> Yes. Not having enough other contributors.
17:54 <mhall119> heh
17:54 <popey> People to review code for example
17:54 <czajkowski> popey: I know we can only build for ubuntu devices there are no cross platform options out there yet
17:54 <popey> I'm not kidding
17:54 <popey> czajkowski: would be nice if the SDK ran on other platforms, but it doesn't right now
17:54 <mhall119> popey: do you still have people from Canonical helping with code reviews?
17:54 <czajkowski> but have peple thought about going to many more mobile conferecens and talking about the Ubuntu phone theer to get developers who work on xamarin ios and android interested
17:55 <popey> mhall119: I poke people now and then yes
17:55 <czajkowski> popey: I type slowly :(
17:55 <popey> czajkowski: we do go to conferences. not many, but targetted, dpm was at one this week doing exactly that :)
17:55 * czajkowski attends many many mobile events, but no sign of Ubuntu at them
17:55 <czajkowski> and they're not just for android or iOS
17:56 <czajkowski> anyways
17:56 <mhall119> yes, that is something we are trying to do more of within the community team at canonical
17:56 <mhall119> we've also been developing materials for community contributors to use at such conferences
17:56 <popey> we have to target events carefully.
17:56 <popey> we don't have a huge budget for events
17:56 <popey> and many are just not appropriate
17:56 <mhall119> yeah, a lot of mobile events seem very businessey
17:58 <mhall119> having the SDK working on Windows and OSX would certainly help, but I think the technical difficulties on that are too high for it to be realistic right now
17:58 <popey> yup
17:58 <popey> its even hard to run it other linux distros
17:59 <mhall119> I would like to see more of Ubuntu at mobile dev conferences though, perhaps we should go over our material again to make sure it's ready for non-canonicalers to use
17:59 <mhall119> ok, our hour is just about up, is there anything else you wanted to bring up or ask for assistance with popey ?
17:59 <popey> I think we'll be in better shape by the end of the year as we'll have more devices in more regions and converged device.
17:59 <popey> Nope
18:00 <mhall119> popey: any highlights or praises you want to give?
18:00 <popey> Not now, I'll save that :)
18:00 <mhall119> :)
18:00 <mhall119> czajkowski: cprofitt anything else for popey?
18:01 <czajkowski> narp all good
18:01 <cprofitt> no thank you
18:01 <mhall119> #topic Any other business
18:01 <popey> thanks for the tips and advice everyone
18:01 <mhall119> ok, *now* is there anybody here who wants to bring up a topic that wasn't on the agenda?
18:02 <popey> can I go home now? :)
18:02 <czajkowski> chooo chooo
18:02 <mhall119> popey: don't like working from the office?
18:02 <czajkowski> mhall119: no he prefers co working :D
18:03 <mhall119> alright, last call for topics
18:03 <czajkowski> AOB anyone ?
18:03 <mhall119> czajkowski: well co-working gives him chocolate pains
18:03 <mhall119> #endmeeting