16:00 <coreycb> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Apr  7 16:00:17 2015 UTC.  The chair is coreycb. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <beisner> o/
16:00 <rharper> o/
16:00 <matsubara> o/
16:00 <caribou> o/
16:00 <smb> o/
16:00 <strikov> o/
16:00 <coreycb> Hello everone and welcome to the weekly ubuntu-server meeting
16:00 <coreycb> #topic Review ACTION points from previous meeting
16:01 <coreycb> there was one action item from last week - James Page to provide feedback on bugs 1425288 and 1425128
16:01 <ubottu> bug 1425128 in linux (Ubuntu Trusty) "bcache causes task hang with 3.13 kernel" [Medium,Incomplete] https://launchpad.net/bugs/1425128
16:01 <ubottu> bug 1425288 in linux (Ubuntu) "kernel NULL pointer dereference during bcache cache_set_flush call" [High,Incomplete] https://launchpad.net/bugs/1425288
16:01 <smb> I do not recall any updates there
16:01 <coreycb> ok smb, and jamespage is likely busy as he is sprinting
16:01 <coreycb> I'll keep this one as an action
16:02 <coreycb> #action James Page to provide feedback on bugs 1425288 and 1425128
16:02 * meetingology James Page to provide feedback on bugs 1425288 and 1425128
16:02 <smb> ok, though so will I next week (sprinting) ;)
16:02 <coreycb> sigh
16:02 <coreycb> #topic Vivid Development
16:02 <coreycb> #link https://wiki.ubuntu.com/VividVervet/ReleaseSchedule
16:03 <coreycb> we're past final beta freeze  and the next milestone is kernel freeze on April 9th.  final freeze is April 16th.  release of 15.04 is April 23rd.
16:04 <coreycb> #subtopic Release Bugs
16:04 <coreycb> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-v-tracking-bug-tasks.html#ubuntu-server
16:05 <coreycb> no new bugs since last week
16:05 <coreycb> dannf, anything new on 1427406?
16:06 <coreycb> smoser, anything new on 1427275?
16:07 <coreycb> juju team is actively working on 1409639
16:08 <coreycb> and looks like utlemming is actively working on 1409639
16:09 <coreycb> ok let's move on
16:09 <coreycb> #subtopic Blueprints
16:09 <coreycb> #link http://status.ubuntu.com/ubuntu-v/group/topic-v-server.html
16:10 <coreycb> this should be a bit greener at this point in the cycle so please update your progress
16:10 <coreycb> #link https://blueprints.launchpad.net/ubuntu/+spec/topic-v-server
16:11 <coreycb> and we should likely start deferring things soon
16:11 <coreycb> #topic Server & Cloud Bugs (caribou)
16:11 <caribou> coreycb: nothing particular this week, thanks
16:11 <coreycb> thanks caribou
16:12 <coreycb> #topic Weekly Updates & Questions for the QA Team (matsubara)
16:12 <matsubara> Nothing new to report. Most of the smoke tests are still failing and I'm not doing a very good job at babysitting them
16:13 <coreycb> matsubara, ok, thanks and good luck with those
16:13 <coreycb> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:13 <smb> Nothing specific this week. Just repeating as a reminder that UE is sprinting next week, so there is a high chance I might miss next weeks irc meeting (and probably same for arges and sforshee )
16:13 <coreycb> smb, ok thanks for the update
16:14 <coreycb> #topic Ubuntu Server Team Events
16:14 <coreycb> any events going on?  I know there are a few sprints going on.
16:15 <coreycb> #topic Open Discussion
16:15 <coreycb> does anyone have anything else they'd like to cover?
16:15 <coreycb> thanks everyone for attending
16:15 <coreycb> #topic Announce next meeting date, time and chair
16:16 <beisner> thx coreycb
16:16 <caribou> thanks coreycb
16:16 <dannf> coreycb: i provided a patch
16:16 <coreycb> Tues April 14th 16:00 UTC
16:16 <dannf> coreycb: in that bug
16:16 <coreycb> dannf, ah ok
16:16 <dannf> coreycb: still blocked on the mariadb side
16:17 <dannf> coreycb: but as for mysql, i'm considering it done from my pov unless someone asks for something
16:18 <coreycb> dannf, ok do you need anything from the server team?
16:18 <dannf> coreycb: review/upload i guess :)
16:19 <dannf> and testing on non-arm64, if you have tests to run
16:19 <coreycb> rbasak, can you handle that?
16:20 <dannf> (and happy to help where i can, not trying to throw it over the wall... completely) :)
16:20 <coreycb> dannf, I'll add an action for rbasak since he had asked for a patch in that bug
16:21 <rbasak> o/
16:21 <rbasak> dannf: I thought the patch wasn't ready to upload to Ubuntu yet?
16:21 <rbasak> If so, I don't feel I have any action I can take here.
16:22 <rbasak> I'd prefer to see the patch adopted upstream - then we can certainly update or cherry-pick it.
16:22 <dannf> rbasak: i'd like upstream to ack it, but they haven't. it's definitely *better* on arm64 than the current version, but i don't have regression tests for other archs
16:23 <rbasak> We can't risk regression on other archs
16:23 <strikov> dannf: do you mean the whole series of patches or just the last one which adds aarch64 to power-related ifdefs?
16:23 <dannf> strikov: entire series
16:24 <dannf> rbasak: right - and is there a way we can regression test other archs in house?
16:24 <rbasak> Beyond the standard test suite? Not that I'm aware of.
16:24 <rbasak> But this kind of fix strikes me as the type that standard regression tests won't catch.
16:26 <rbasak> I guess what I'm expecting is someone to go deep and verify, in whatever way necessary, to a reasonable level that there won't be a regression on another arch.
16:26 <coreycb> thanks for the discussion guys.  I"m going to end the meeting.  I assume you can continue the discussion offline if needed.
16:26 <rbasak> OK, that's fair. Thanks coreycb.
16:26 <coreycb> #endmeeting