15:08 <xnox> #startmeeting A festive Ubuntu Developer Membership Board Meeting
15:08 <meetingology> Meeting started Mon Dec 15 15:08:23 2014 UTC.  The chair is xnox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:08 <meetingology> 
15:08 <meetingology> Available commands: action commands idea info link nick
15:09 <xnox> #action xnox to send notes from last time i've chaired, cause i don't think i did....
15:09 * meetingology xnox to send notes from last time i've chaired, cause i don't think i did....
15:09 <xnox> #topic Thomas Ward nginx-PPU application
15:09 <teward> o/
15:10 <xnox> teward: hello =)
15:10 <xnox> teward: please introduce yourself and your application today =)
15:11 <teward> My name is Thomas Ward, and I am applying for per-package upload rights for the nginx package.  For some time now, I have been working with the nginx package, getting bugs triaged, and working to get security and bug fixes into the package.  Initially in 2012, I started working with the package, taking primary maintainership of the nginx team's PPAs, and later getting Ubuntu Bug Control status to help triage the bugs more effectively.
15:12 <teward> Since then, I have continued working with the package, fixing bugs, maintaining version merges/syncs with assistance from the sponsors, and also worked to get security CVE fixes into the packaging for stable releases.
15:12 <teward> Recently, I've worked with rbasak and others to help get nginx-core, a upstream-modules-only flavor of the nginx binary, into Main, and have been actively on the front lines handling bug triage and maintenance.
15:13 <teward> I am applying for Per-Package Upload rights of the package, as I have worked on the package enough that I believe I am no longer in need of sponsors to check my work and assist in uploading stable release updates and merges to the standard repositories (including -updates).
15:14 <teward> On my application page is a sizable list of links to bugs and stable-release updates, the latest of which is the merge from 1.6.2-4 from Debian Unstable into Vivid, which mdeslaur ended up sponsoring.
15:14 <teward> (There is also another pending merge in the sponsorship queue, for 1.6.2-5 from Unstable as well)
15:15 <teward> I would like the DMB to approve my application for upload rights for the nginx package, so that I may continue to step up and maintain the package in Ubuntu, and I welcome any additional questions the DMB may have.
15:15 <teward> I also apologize for my application being late-filed, my schedule has been very hard on me, which has limited my availability until this point.
15:16 <xnox> ok.
15:17 <xnox> teward: looking at your launchpad profile - why do you have 9 GPG keys?
15:18 <teward> xnox: That's something i've been meaning to fix, I've been extraordinarily busy.  The GPG keys on there have been remnants from where I've had to do my packaging work - either on VPSes I maintain, or in VMs, or on systems that have died.
15:18 <teward> xnox: it's an unfortunate side effect my older laptop had 5 hard drives die on me - a large portion of those keys were on those dead drives.
15:18 <teward> (I'm working cleanup on that today, as this is my first 'free' time to actually dig into those keys)
15:20 <teward> xnox: only two of the keys would be necessary for the account, I have just not gotten around to retiring the older keys
15:21 <teward> xnox: i just deactivated 7 of the keys as they are not present on this system - one or two may get reactivated when I check my dedicated packaging VM for its keys, but the remaining two that are activated (now) are active, one is needed for the LP Email interface for bugs, as it is the email address I work with for that interface (with GPG signatures)
15:22 <xnox> teward: how much are you involved with nginx package maintainance in Debian?
15:23 <bdrung_work> xnox stole my question ;)
15:23 <Laney> This nginx-core idea sounds like something that might be useful there
15:23 <teward> xnox: I actively watch the bugs there, however I have not been heavily involved with the Debian package maintenance - for the most part I focus on Ubuntu, but I do actively triage bugs upstream to them
15:23 <teward> Laney: I discussed it with their maintainers in the past in their IRC channel on OFTC - they've rejected the idea as "ubuntu specific"
15:24 <Laney> um
15:24 <teward> Laney: with NGINX 2.x, it is suggested that pluggable modules, like Apache has, is a planned feature
15:25 <xnox> teward: but what about other things? e.g. patch to make welcome page show "$DEB_VENDOR" in the docs, instead of hard-coded strings Debian and/or Ubuntu? that would minimise delta.
15:25 <xnox> (although i'm guessing branding patch was not from you)
15:25 <teward> xnox: no, that patch was not from me.
15:26 <teward> xnox: by the 'welcome page' i assume you mean the welcome page included in the debian/ directory, which is where the version-specific welcome pages originate?
15:27 <xnox> teward: yes.
15:27 <teward> xnox: I would be willing to investigate adding that to the Ubuntu branding patch, yes, that would decrease the delta.
15:28 <teward> xnox: however, that would still be a delta - upstream in Debian, I would have to propose that to them, if they make the change that would indeed decrease the delta.
15:29 <Laney> oh I see, they're conflicting packages
15:29 <teward> xnox: however, if Debian refuses that change, it remains a delta.
15:31 <xnox> bdrung_work: bdmurray: Laney: do you have questions?
15:32 <teward> xnox: we'd still have the delta because of lines 21 through 25 in the Debian-origin of that page - we can easily put the strings into the page for Debian or Ubuntu via $DEB_VENDOR (I believe), however, there remains a delta from lines 22 through 25 for the page, hardcoding the Debian 'report-bug' system for that.  (That would be the remaining delta on that page)
15:32 <Laney> if you contribute there then in time you will be 'Debian'
15:32 <Laney> i.e. able to make changes directly
15:32 <Laney> no other comments
15:32 <teward> (My apologies for the late reply, my net kicked out for a couple seconds)
15:33 <bdrung_work> regarding the branding patch, you could even have two different index pages for debian and ubuntu and install the one based on $DEB_VENDOR
15:33 <bdmurray> I don't have any questions.
15:34 <xnox> teward: can you, in your own words, describe security update planning and release? what happens when, etc.
15:35 <bdrung_work> teward, i have one suggestion for the branding change to src/core/nginx.h: Upstream's build system could gain a --branding or --distro switch to set the distribution (which will then be added to NGINX_VER
15:38 <teward> xnox: currently, the process for security bugs in NGINX on my radar is as follows: either Debian or the CVE tracker from the Security team will show a CVE being marked affecting the package, and I will begin finding the upstream ticket for it, or the Debian-included changes in their git repository (which are available relatively soon after upstream releases the fix).  I usually will have a bug filed for that issue in Launchpad as a
15:38 <teward> tracker, and I grab the changes from either Debian or Upstream.  From there, I typically grab the updates and work with the Security team to update the packaging to include the fix.
15:38 * xnox ponders if teward is still kicked out of irc.
15:38 <teward> xnox: sorry, long response
15:38 <xnox> teward: ah, i was.
15:39 <teward> xnox: I do watch the upstream announcements list, and Debian changes, like a hawk - within a couple days of the fix being available in either upstream or Debian, I've grabbed it and am working on debdiffs for security team review and inclusion
15:39 <teward> (schedule permitting, of course)
15:40 <teward> I am also no stranger to #ubuntu-hardened, poking the security team to review when there's a security issue in the nginx package that needs attention :)
15:41 <teward> xnox: as for how Upstream handles security issues, I am not familiar with their internal process, I do however grab the fixes as soon as they're available on my radar, usually once Debian git includes it in their repository, sometimes sooner.
15:41 <xnox> bdrung_work: bdmurray: Laney: ready to vote?
15:41 <teward> bdrung_work: I will look into it, thank you for the recommendation.
15:41 <Laney> Sure
15:42 <bdrung_work> teward, are you interested in getting more involved in Debian, for example, getting commit access to the Debian git repository?
15:43 <teward> bdrung_work: I have had that on my radar as well, and an interested in eventually gaining access there.  (however they have a good number of maintainers who commit the fixes long before I get to them)
15:44 <teward> my schedule being as it has been lately, however, has prevented me from fully investigating that.
15:44 * bdrung_work is ready to vote
15:48 <bdrung_work> teward, i encourage you to get more involved into Debian and to reduce the diff between Debian and Ubuntu
15:50 <teward> bdrung_work: I will take your encouragement under advisement, and will strive to be more involved with the Debian packaging of nginx as well, and work to hopefully reduce the delta between Debian and Ubuntu.
15:52 <Laney> xnox: ?
15:55 <xnox> #vote teward ppu for nginx
15:55 <meetingology> Please vote on: teward ppu for nginx
15:55 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:55 <Laney> +1
15:55 <meetingology> +1 received from Laney
15:56 <bdmurray> +1
15:56 <meetingology> +1 received from bdmurray
15:57 <Laney> xnox bdrung_work
15:59 <xnox> +1
15:59 <meetingology> +1 received from xnox
16:01 * Laney drums fingers
16:02 <xnox> well....
16:02 <xnox> Laney: end vote, end meeting take it to email?
16:02 * xnox needs to go soon.
16:04 <bdrung_work> +1
16:04 <meetingology> +1 received from bdrung_work
16:04 <bdrung_work> sorry, i was interrupted
16:07 <xnox> #endvote
16:07 <meetingology> Voting ended on: teward ppu for nginx
16:07 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:07 <meetingology> Motion carried
16:07 <xnox> teward: congrats (i think) and we will send meeting notes & action the rights later, we will send you an email.
16:07 <xnox> teward: thanks a lot for attending! =)
16:08 <teward> xnox: Thank you all for granting my application, and taking the time out of your busy days for little old me.  :)
16:08 <bdmurray> teward: congratulations
16:08 <teward> bdmurray: thank you  :)
16:11 <xnox> #endmeeting