17:02 <dholbach> #startmeeting
17:02 <meetingology> Meeting started Thu Nov 20 17:02:10 2014 UTC.  The chair is dholbach. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:02 <meetingology> 
17:02 <meetingology> Available commands: action commands idea info link nick
17:02 <Laney> goooooo team
17:02 <didrocks> Laney: \o/
17:02 <mhall119> o/
17:02 <dholbach> #chair cprofitt czajkowski mhall119 YokoZar pleia2
17:02 <meetingology> Current chairs: YokoZar cprofitt czajkowski dholbach mhall119 pleia2
17:02 <dholbach> #topic Catching up with the Desktop team
17:02 <elfy> easily forgotten is elfy :(
17:03 <dholbach> didrocks, Laney: thanks for turning up! how are you doing? how's the desktop?
17:03 <dholbach> #chair elfy
17:03 <meetingology> Current chairs: YokoZar cprofitt czajkowski dholbach elfy mhall119 pleia2
17:03 <YokoZar> Welcome
17:03 <czajkowski> Aloha :)
17:03 <didrocks> dholbach: we're good! Wrapping up blueprints after UOS
17:03 <didrocks> got quite some nice sessions, especially the Q&A with the community
17:04 <dholbach> what kept you guys busy in the last time?
17:04 <didrocks> dholbach: I wasn't there the last time, so not sure when it was exactly, like a month or so?
17:04 <dholbach> hum? I'm not sure I understand - you mean when the CC met with the Desktop team the last time?
17:05 <dholbach> it could easily have been 5-6 months since we last met(?) - I can't quite remember
17:05 <didrocks> dholbach: right, I was on holidays I guess, so unsure when it was (don't want to go back in time too far)
17:05 <didrocks> ah ok :)
17:05 <dholbach> right :)
17:05 <Laney> Phone system settings, bugs, 14.10 release, GTK Mir backend, ...
17:05 <Laney> More recently gnome updates + merges too, normal stuff I think
17:05 <Laney> Some work on the unity 8 desktop stuff
17:06 <didrocks> yeah, part of the team is working on getting some bits of gnome 3.14 updated
17:06 <Laney> UDTC ;-)
17:06 <didrocks> (and gtk with their new theme system)
17:06 <dholbach> how is the unity8 desktop coming on?
17:06 <didrocks> of course, desktop developer story as Laney told :)
17:06 <dholbach> will the new gtk mean that we can update to the newest in gnome?
17:06 <mhall119> Laney: I know there's been work to more cleanly separate upstream Gnome from Unity's needs, so that Ubuntu GNOME for example doesn't have conflicts. How has that work been going, is it completed or almost there?
17:06 <didrocks> unity8: it's coming up nicely, if you saw recent posts, there is even some prototypes for multi-windows management with unity8
17:07 <mhall119> I saw that :)
17:07 <didrocks> we have a blueprint and some WIs for that image: https://blueprints.launchpad.net/ubuntu/+spec/desktop-1504-desktop-apps-on-mir
17:07 <mhall119> was that from this UOS?
17:07 <didrocks> the goal is to have all those apps running and working in the unity8 image by 15.04
17:07 <didrocks> we didn't really have a session at UOS as it's a JFDI
17:07 <mhall119> an ambitious goal
17:08 <YokoZar> In the past there was a bit of a thorny issue where our derived-from-gnome packages were still using the gnome-* package namespace (and you couldn't easily get a more gnomey-gnome from packages), leading to some upset community folks.  Has this migration been basically completely done now?
17:08 <didrocks> but basically we want people to be able to create touch apps and tests from this image
17:08 <didrocks> hence Qtcreator
17:08 <YokoZar> mhall119 basically beat me to that question
17:08 <didrocks> and having importants apps
17:08 <mhall119> YokoZar: type smaller bits :)
17:08 <didrocks> so GNOME - Unity separation
17:08 <didrocks> I doubts there will be more work on this until we switch to unity8 by default and dropp unity7 support
17:09 <didrocks> there has been a fair share of decoupling
17:09 <didrocks> to enable the ubuntu gnome team to update more on latest gnome version
17:09 <YokoZar> Is Unity8 happening next release?
17:09 <Laney> We'll be able to get to 3.14 I think
17:09 <didrocks> YokoZar: we all wish, but a more realistic goal is by next LTS
17:09 <mhall119> YokoZar: not default next release, no
17:09 <didrocks> we will propose it as an option first anyway
17:10 <didrocks> and then, when users will be convinced that unity 8 is better than unity 7
17:10 <didrocks> we will switch
17:10 <mhall119> didrocks: is the plan to keep Unity NEXT as a separate build, or will Unity 8 be an installable session on top of a regular install?
17:10 <mhall119> in 15.04
17:10 <didrocks> as Laney told, we are going to get Gnome 3.14 this cycle
17:10 <didrocks> which is the current Gnome stable release
17:10 <didrocks> mhall119: it's already available in a session on top of the regular one actually
17:10 <mhall119> current, but usn't 3.16 coming soon?
17:10 <didrocks> the separate build is just for people to try it more easily
17:11 <didrocks> mhall119: soon being next April
17:11 <YokoZar> didrocks: We do have 15.10 before 16.04 LTS as well.  Is that the time to drop unity7 so we can fully deal with this?  I'd hate to leave ubuntu-gnome stranded for another LTS
17:11 <mhall119> didrocks: good to know, thanks
17:11 <mhall119> didrocks: so, same as our next release :)
17:11 <Laney> Who says they are stranded?
17:11 <didrocks> mhall119: right :)
17:11 <YokoZar> Well, alternative is package separation work of course
17:11 <Laney> It would be extremely bad to fork every gnome package
17:12 <YokoZar> No argument there
17:12 <mhall119> do we have many gnome-* packages left that have Unity-specific changes which break GNOME?
17:12 <cprofitt> YokoZar: I agree I would not like to see Ubuntu Gnome left is a bad position through another LTS
17:12 <didrocks> they can do it, but it's a fair amount of work
17:12 <didrocks> mhall119: well, there is gtk for example, what prevented update to 3.14 last cycle is that they rewrote the theme engine for example
17:13 <didrocks> so the ubuntu theme is being redone identical with the new css rules as of now
17:13 <YokoZar> I'm just worried about a situation where the not-gnome gnome-* packages linger because it was easier to remove them after dropping unity-7 but then we never get around to dropping unity-7 till release after LTS and so the separation work doesn't get done
17:13 <didrocks> so, it's not only "unity", it's "ubuntu" as a whole
17:13 <mhall119> didrocks: so is it more a case of "newest upstream breaks Unity" and now "Unity patches break newest upstream"?
17:13 <mhall119> ok
17:13 <didrocks> mhall119: exactly
17:13 <didrocks> s/now/not/ I infer :)
17:14 <mhall119> yes
17:14 <dholbach> how are things going with the developer desktop? :)
17:15 <mhall119> so that answers my questions and concerns about that, how about you YokoZar?
17:15 <didrocks> we are starting to get a nice community and external contributors
17:15 <YokoZar> didrocks: I suspect adapting the Ubuntu theme to work with latest Gnome is work the ubuntu-gnome folks are happy to do, whereas poking around with unity-specific patches maybe less so ;)
17:15 <didrocks> YokoZar: hum, I doubt, they are using the upstream adwaita theme, not the ubuntu one
17:15 <didrocks> YokoZar: so, they are not really concerned about it
17:15 <YokoZar> ahh ok
17:16 <Laney> It's more things like adapting UIs where Unity wants them to be different from the GNOME HIG which is in the way of updating
17:16 <didrocks> yeah, so this cycle, we should have new ides supported for developers
17:16 <mhall119> "ubuntu one" == "humanity" right?
17:16 <didrocks> new environments as well
17:16 <Laney> Not really so much distro patches
17:16 <Laney> IMO
17:16 <didrocks> and not protection for people using pip/ruby on their systems :)
17:16 <didrocks> mhall119: well, we don't have headbars in our theme
17:16 <didrocks> and some applications have empty menus with headbars
17:17 <YokoZar> I have this fantasy of Ubuntu being in Gnome's good graces again
17:17 <YokoZar> mhall119: I'm happy, though we should check in next release.
17:17 <didrocks> so, it's broken in xfce, under unity…
17:17 <YokoZar> (I kid ~ "good graces")
17:17 <mhall119> YokoZar: +1
17:17 <Laney> bleh
17:17 <Laney> It's like the fantasy of an "Ubuntu and Debian" relationship
17:17 <cprofitt> I would like to see that too YokoZar
17:17 <Laney> really it's many to many
17:17 <YokoZar> Exactly
17:17 <cprofitt> +1 Laney
17:17 <YokoZar> There is no Emperor of Gnome whose ring we can kiss :p
17:19 <czajkowski> lol
17:19 <mhall119> is there anythign the CC can to do assign the desktop team's work, either with Unity 8 or the Ubuntu<->GNOME relation?
17:19 <didrocks> dholbach: so, if you can read in the interleaved discussions, yeah, things are going great on the developer desktop :)
17:19 <mhall119> s/assign/assist/
17:19 * mhall119 can't type today
17:20 <mhall119> (which is bad, because I'm coding today)
17:20 <didrocks> mhall119: maybe some call for testing/trying the Unity 8 image?
17:20 <didrocks> we know it can't be used on a daily bases
17:20 <didrocks> and it's a tablet ui for now
17:20 <didrocks> but we will be thrilled to have feedback, like on social media for instance
17:20 <mhall119> didrocks: we can help promote that if there's a coordinated plan to help people get started and report problems
17:20 <Laney> I saw mzanetti posted a video of some windowing support on G+
17:20 <didrocks> and I think the core apps guys will be delighted to have early feedbacks on their applications running on a desktop :)
17:20 <mhall119> didrocks: not a tablet UI for long, once mzanetti's patch lands
17:21 <didrocks> right!
17:21 <dholbach> very nice
17:21 <didrocks> mhall119: we can build some plan around it and use the community team as a proxy?
17:21 <mhall119> didrocks: community team and CC both can assist with getting the word out
17:21 <didrocks> to spread the world with the loco council :)
17:22 <didrocks> nice
17:22 <czajkowski> didrocks: good idea
17:22 * mhall119 apologizes to everyone he just volunteered to do stuff
17:22 <czajkowski> I'm the LoCo council will like that
17:22 <didrocks> volounteering other people, that's always the way to go ;)
17:23 <mhall119> it's the Ubuntu way ;)
17:24 <dholbach> speaking of help - where do you feel the Desktop team would need most help right now?
17:24 <didrocks> if we can get some people will to contribute testing and updating the new GNOME in particular on #ubuntu-desktop, that would be awesome
17:24 <didrocks> who*
17:24 <didrocks> want*
17:25 <didrocks> ECANTTYPE tonight as well :)
17:25 <mhall119> didrocks: we just need some specifics about what to test, how to test it, and how to report results
17:25 <didrocks> I'm always personnaly welcoming feedback and patches on UDTC (the developer desktop)
17:25 <didrocks> we will make some call for help and contribution publically on this next week
17:25 <mhall119> a vague "test some things" isn't going to get us very far
17:25 * elfy suggests that balloons would be the one to co-ordinate testing
17:25 <didrocks> mhall119: most of the coordination is done through #ubuntu-desktop
17:26 <mhall119> didrocks: better to gave documentation, if we can get it
17:26 <didrocks> so people jumping on IRC and telling they want to help, we can then redirect to what is needed at that point in time
17:26 <mhall119> you're only on IRC 22.5 hours a day, afterall
17:26 <didrocks> the thing is that between one week to the next one, it's not the same thing to test
17:26 <didrocks> also, we resumed using WI and blueprints
17:27 <didrocks> so, if people wants to help the desktop team, there is http://status.ubuntu.com/ubuntu-v/canonical-desktop-team.html
17:27 <mhall119> I understand, but docs still work better and get more contributors, so if we can have them that would be great
17:27 <didrocks> here are some WI that are not assigned
17:27 <didrocks> they are free to grab and more specific
17:28 <dholbach> great... I'm done with questions - does anyone else have any more questions?
17:28 * mhall119 has none
17:28 <cprofitt> I have no more.
17:29 <dholbach> thanks a lot didrocks and Laney!
17:29 <mhall119> thank you both
17:29 <elfy> thanks didrocks Laney
17:29 <dholbach> .
17:29 <didrocks> thanks everyone! :)
17:29 <dholbach> #topic Catching up with the DMB
17:29 <cprofitt> yes, thank you everyone.
17:29 <Laney> thanks, hi
17:29 <dholbach> welcome again Laney :)
17:30 <dholbach> anyone else from the DMB around? :)
17:30 <Laney> dunno, to find out you do this:
17:30 <Laney> !dmb-ping
17:30 <ubottu> bdrung, ScottK, Laney, micahg, xnox, bdmurray, stgraber: DMB ping
17:30 <xnox> Laney: hola
17:30 <xnox> dholbach: hi
17:30 <Laney> tada!
17:31 <mhall119> hello xnox, nice to see you're still around :)
17:31 <dholbach> wow, I didn't know that command :)
17:31 <xnox> mhall119: i beg your pardon, how dare you?! =) nah, all is cool.
17:31 <mhall119> :)
17:31 <bdmurray> hi
17:32 <dholbach> how are you? how are things with the DMB?
17:33 <Laney> Same ol'
17:33 <YokoZar> Heh
17:33 <Laney> We have meetings, we approve most people, impossible to get people to reply to email threads
17:33 <Laney> :P
17:33 <dholbach> ah yes, I remember we talked about the mail situation the last time
17:34 <mhall119> Laney: applicants or DMB members?
17:34 <dholbach> do you feel things have improved there?
17:34 <YokoZar> Is our rate of developer growth about the same as it's always been?
17:34 <Laney> members, no
17:34 <dholbach> or is it also "same ol'"?
17:34 <Laney> It's pretty slow now
17:34 <Laney> CI train removed one reason people used to have for applying I think
17:35 <Laney> but the new system won't be as backdoory so we may see it come back a bit
17:35 <Laney> ("CI airline")
17:35 <Laney> I estimate we have someone at 3 out of every 4 meetings
17:36 <dholbach> do you know if people who get their changes auto-landed apply for membership very often?
17:36 <Laney> I know that they don't do that through us
17:37 <Laney> at least I can't think of anyone like that
17:37 <dholbach> ok
17:38 <Laney> DMB has never been a popular route for membership anyway
17:38 <dholbach> how about the voting-by-email situation? does this go better than it used to?
17:38 <Laney> No
17:39 <Laney> We have three threads ongoing now, hard to get the board to reply
17:39 <czajkowski> :/
17:39 <Laney> I think we might have to start refusing to handle any application on email
17:39 <dholbach> maybe somebody should use the "dmb-ping" command on IRC more often :-)
17:39 <Laney> but our meeting times are crap for people not in the US or Europe
17:39 <dholbach> right, that makes sense
17:39 <Laney> The two email applicants are in Asia and Australasia
17:40 <Laney> so.
17:40 <czajkowski> Laney: could you review applicants in the meeting online and post them results or do you need the applicants there in person ?
17:40 <Laney> It's the interview aspect
17:40 <dholbach> but the meeting time slot could be used for that, no?
17:40 <czajkowski> or else make a once off special meeting when -meeting is free and everyone comes online early/late and reviews the applicatns ?
17:40 <Laney> Only if the applicant is there
17:40 <czajkowski> not saying it's needed every month but may deal with people not answering emails :)
17:41 <dholbach> but you could use the meeting time for sending the mail
17:41 <Laney> you'd think
17:41 <czajkowski> dholbach: +!
17:41 <dholbach> writing the mail
17:41 <dholbach> that should really be possible
17:41 <dholbach> :)
17:41 <Laney> https://lists.ubuntu.com/archives/devel-permissions/2014-November/thread.html
17:41 <Laney> Might not be talking to the right person. :)
17:42 <dholbach> I wasn't blaming you in the slightest
17:42 <Laney> I know, I'm just saying that I don't know what solutions I can offer
17:42 <dholbach> right
17:43 <czajkowski> Laney: perhaps try dholbach suggestio of mail during meeting and add it to the agenda and see if that helps?
17:43 <czajkowski> Laney: do you usually have enough board members on hand at a meeting ?
17:43 <Laney> Could try that
17:43 <Laney> here's 10 minutes of silence, go email
17:44 <dholbach> yes, that'd be nice
17:44 <Laney> We usually scrape 4 people
17:44 <czajkowski> Laney: so do you think you need more members on the board also ?
17:44 <czajkowski> Laney: try adn see and let us know :)
17:44 <czajkowski> please
17:44 <mhall119> or regional boards like we did for Ubuntu membership?
17:45 <czajkowski> not sure that would help the DMB given some areas are higher than others for developers
17:45 <mhall119> true, but there might be enough current members for a asian/oceana board
17:45 <dholbach> I know that it's not easy to make up your mind and that with the MC we had long email debates as well
17:46 <dholbach> but it's nice if everyone tries hard to keep the ball rolling
17:46 <YokoZar> Reasonable
17:46 <dholbach> and not keep the applicants waiting unnecesarily
17:46 <Laney> I know that everyone understands this
17:47 <Laney> Still somehow it never gets to the top
17:47 <dholbach> thanks a lot for your help, Laney
17:48 <mhall119> thanks Laney, hopefull the "send email during meeting time" will help
17:48 <YokoZar> Thank you Laney
17:48 <dholbach> does anyone have any other questions?
17:48 <elfy> not me
17:48 <Laney> I want to discuss/inform about you about something in private
17:48 <Laney> do you have a channel?
17:49 <czajkowski> Laney: yes let me dm
17:49 <dholbach> all rightie... anything else?
17:49 <dholbach> #topic Any other business?
17:50 <czajkowski> I think we should at some point
17:50 <czajkowski> address the issues being brought up on community list
17:50 <czajkowski> should we have a dediated meeting to it ?
17:50 <mhall119> which one(s)?
17:51 <czajkowski> mhall119: the long threads going on right now re governance
17:51 <elfy> czajkowski: I'd say yes
17:51 <dholbach> I responded O:-)
17:51 <mhall119> ah, those, I'm not sure the discussions have progressed to the point where we can make any decisions yet, so a dedicated meeting in the near future might be best
17:51 <dholbach> yeah, might be a good idea
17:52 <dholbach> maybe let's give the discussion another week?
17:52 <czajkowski> mhall119: well I think people need to understand it's also ok to bring these discussions to us
17:52 <YokoZar> Agreed ~tabling, I gotta go soon
17:52 <elfy> czajkowski: yep
17:52 <czajkowski> blog posts and mailing lsits arent always the best way to engage
17:52 <mhall119> czajkowski: we (the CC) can also join hte discussion in the ML
17:52 <czajkowski> and many of the comments from people are leaving people alienated
17:52 <czajkowski> which isn;t good
17:52 <czajkowski> mhall119: some have already
17:52 <czajkowski> mhall119: but this is also a forum for discussion!
17:53 <mhall119> I know, I just wanted to restate that
17:53 <czajkowski> ok I propose we have an irc meeting next week
17:53 <czajkowski> instead of our weekly G+
17:53 <mhall119> same bat time, same bat channel?
17:53 <czajkowski> and that way the community can take part and also it's logged so people read it
17:53 <czajkowski> yes
17:53 <czajkowski> and we post it to the fridge
17:53 <mhall119> oh wait, that's Thanksgiving day in the USA
17:53 <dholbach> we just need to announce it
17:53 <czajkowski> so people can see and also know the date/time
17:53 <czajkowski> :/
17:54 <czajkowski> ok so December 4th ?as a large chunk of the CC are USA
17:54 <mhall119> do we have catch-ups scheduled for the 4th already?
17:54 <elfy> yes
17:54 <dholbach> (all right... I need to rush now - but you should all be irc meeting chairs, so you can end the meeting as well)
17:54 <dholbach> see you!
17:54 <czajkowski> mhall119: possibly but I think this topic is worth rescheduling don't you ?
17:54 <mhall119> thanks dholbach
17:55 <elfy> edubuntu and lubuntu
17:55 <mhall119> czajkowski: that's fine, I'm also okay to have this discussion +/- 1 hour from that meeting
17:55 <mhall119> but I know that might not work for others
17:55 <czajkowski> mhall119: much alter in EU then
17:55 <czajkowski> :)
17:55 <czajkowski> timezones eh
17:55 <elfy> :)
17:55 <mhall119> we should get rid of those
17:55 <czajkowski> elfy: can you contact and ask them to reschedule please?
17:55 * mhall119 adds that to the CC agenda
17:56 <czajkowski> and then we can use the dec 4th meeting to discuss issues
17:56 <elfy> czajkowski: well I can mail them - I never get replies from the majority of people
17:56 <czajkowski> lets also see if we can get sabdfl to the meeting also
17:57 <mhall119> czajkowski: we'll be doing this on IRC right, not a hangout?
17:57 <pleia2> fwiw, thanksgiving I am around
17:57 <czajkowski> mhall119: aye
17:57 <mhall119> ok
17:57 <mhall119> pleia2: you shouldn't be :-P
17:58 <pleia2> I get caught up on my ubuntu work during work holidays :)
17:58 <pleia2> it's just MJ and me, not really a big holiday for us
17:58 <mhall119> more turkey to go around then
17:58 <czajkowski> right AOB folks ?
17:58 <elfy> not from me
17:59 <czajkowski> #action elfy contact boards and reschedule 4 Dec meeting
17:59 * meetingology elfy contact boards and reschedule 4 Dec meeting
17:59 <mhall119> none from me
17:59 <czajkowski> #action CC to have a meeting on 4Th December to discuss latest threads on Ubuntu Governance
17:59 * meetingology CC to have a meeting on 4Th December to discuss latest threads on Ubuntu Governance
17:59 <pleia2> thanks czajkowski
17:59 <czajkowski> #endmeeting