15:10 <xnox> #startmeeting Developer Membership Board Meeting 2014-11-17
15:10 <meetingology> Meeting started Mon Nov 17 15:10:32 2014 UTC.  The chair is xnox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:10 <meetingology> 
15:10 <meetingology> Available commands: action commands idea info link nick
15:10 <xnox> From roll call - Laney, bdrung_work, ScottK, stgraber and xnox are present.
15:11 <xnox> absent bdmurray and micahg
15:11 * xnox action to send micahg reminder about meeting and whether he still plans to participate in them
15:11 <xnox> #action xnox to send micahg reminder about meeting and whether he still plans to participate in them
15:11 * meetingology xnox to send micahg reminder about meeting and whether he still plans to participate in them
15:12 <xnox> #topic Core Developer Application mitya57
15:12 <mitya57> o/
15:12 <xnox> mitya57: hello! How are you today? =)
15:12 <mitya57> Fine, thanks. Though I am on an unreliable wlan connection, so if I suddenly disappear, blame Moscow University wifi :)
15:13 <xnox> mitya57: gotcha, will prepare the pitch forks
15:13 <xnox> mitya57: could please introduce yourself and your application today briefly? =)
15:13 <mitya57> :)
15:14 <mitya57> Well, I am Dmitry Shachnev, 20 year old, math student, python/c++/js programmer, etc
15:14 <mitya57> Actually I have prepared something to paste
15:14 <mitya57> Things I will do:
15:14 <mitya57> - Maintaining "my" packages. Look at http://qa.debian.org/developer.php?login=mitya57
15:14 <mitya57> for the incomplete list of them.
15:14 <mitya57> - Doing changes in other packages that "my" packages need (recent example:
15:14 <mitya57> new gnome-flashback release needed a patch dropped in gnome-menus).
15:14 <mitya57> - Doing some QA work (fixing FTBFS, autopkgtests failures, uninstallable packages, etc).
15:14 <mitya57> - Doing myself and sponsoring syncs, merges from Debian and bug fixes.
15:14 <mitya57> - Continuing my work in l10n and docs teams.
15:15 <mitya57> Things I won't do:
15:15 <mitya57> - Adding Ubuntu delta that is not a fix for important bug to packages
15:15 <mitya57> without existing delta.
15:15 <mitya57> - Include patches that haven't been forwarded, without a heavy reason.
15:15 <mitya57> Things I won't do:
15:15 <mitya57> - Adding Ubuntu delta that is not a fix for important bug to packages
15:15 <mitya57> without existing delta.
15:15 <mitya57> - Include patches that haven't been forwarded, without a heavy reason.
15:15 <mitya57> err
15:15 <mitya57> Things I won't do despite being Qt (co)maintainer:
15:15 <mitya57> - Touch Ubuntu Touch stuff (for now) :)
15:15 <mitya57> - Touch KDE stuff (unless I start using it myself).
15:15 <mitya57> (unless I am asked to do that, once Kubuntu guys asked me to sponsor
15:15 <mitya57> a few uploads for them).
15:15 <mitya57> ✈ EOF
15:16 <mitya57> ^ that needs | uniq
15:17 <Laney> Actually touch people are a bit better about people uploading that stuff now
15:18 <Laney> If you see something which FTBFS, then fix/(MP and upload) is valid and I don't think you should be afraid of doing that
15:19 <mitya57> I think if I ever want to contribute to something touch-related, I will go the MP/autoland way instead.
15:19 <Laney> That's best if you can wait
15:19 <Laney> s/autoland/CI train/ these days, but core-devs have power to use that anyway
15:20 <mitya57> CI train is what I meant. And MPs usually need to be approved by someone else.
15:20 <Laney> nod
15:21 <ScottK> FWIW, I've seen enough of mitya57's work that I don't need to ask any questions.
15:21 <ScottK> JFTR, you should also feel completely free to ignore CI train and just upload stuff.
15:24 <Laney> I'm good now
15:24 <xnox> mitya57: what's your favourite parts of C++ and JS? least?
15:24 <Riddell> I also am all for mitya57's application, he's doing good stuff in Qt maintainance and working nicely with Debian Qt KDE team too
15:26 <mitya57> xnox: C++. I don't much like programming anything that runs in a browser.
15:26 <mitya57> (though I have to do that many times)
15:26 <xnox> mitya57: ok.
15:27 <xnox> #vote should mitya57 be granted core developer status in Ubuntu?
15:27 <meetingology> Please vote on: should mitya57 be granted core developer status in Ubuntu?
15:27 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:27 <Laney> +1
15:27 <meetingology> +1 received from Laney
15:27 <ScottK> +1
15:27 <meetingology> +1 received from ScottK
15:27 <bdrung_work> +1
15:27 <meetingology> +1 received from bdrung_work
15:27 <xnox> +1
15:27 <meetingology> +1 received from xnox
15:28 <bdrung_work> mitya57, interesting to see Qt and GNOME flashback in the list of packages.
15:29 <mitya57> Qt is something I like a lot (actually I've even contributed ~20 patches upstream), and GNOME Flashback is a thing I was asked to take over by someone else.
15:29 <stgraber> +1
15:29 <meetingology> +1 received from stgraber
15:29 <bdrung_work> mitya57, what do you run on your desktop?
15:29 <mitya57> GNOME Shell
15:29 <xnox> #endvote
15:29 <meetingology> Voting ended on: should mitya57 be granted core developer status in Ubuntu?
15:29 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:29 <meetingology> Motion carried
15:30 <xnox> mitya57: congrats, you are a core dev now =)
15:30 <mitya57> Thanks to you all!
15:30 <ScottK> mitya57: Yes, congratulations.  It's about time.
15:30 <Laney> Good stuff
15:31 <xnox> I've added you to the team, now. And will deal with other post-meeting things later.
15:31 <mitya57> The first thing I'll do is sponsor my own three items in the sponsorship queue :)
15:31 <xnox> ;-)
15:31 <xnox> #topic Any other business
15:31 <Laney> I put an item on the agenda
15:31 <mitya57> Thanks to xnox for being so fast
15:32 <xnox> Laney: which is...? "Extend DD PPU to cover DM too (Laney)" not sure what that means?
15:32 <ScottK> Makes sense to me.
15:32 * ScottK says yes.
15:33 * xnox requests verbosity++
15:33 <Laney> #topic it and then I'll say
15:33 <xnox> #topic Extend DD PPU to cover DM too (Laney)
15:33 <xnox> Laney: floor is yours
15:33 <Laney> I don't know how to link to the heading but https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess has a section for DDs who want to apply for upload rights to their packages
15:34 <Laney> Currently you have to be an actual full fat DD
15:34 <Laney> I was reminded by Laibsch's thread on devel-permissions, as he is a DM, that I wanted to see if we could make this be DM or DD.
15:35 <Laney> then we could s/Developer/Uploader/ or something
15:35 <ScottK> You can be a skinny DD as well.  Beard is not required either.
15:35 <xnox> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
15:35 <xnox> #url https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
15:35 <xnox> #help
15:35 * xnox gives up
15:36 <bdrung_work> ScottK, you should have told me before growing a beard and eating many sweets. ;)
15:36 <Laney> I cannot imagine bdrung_work with a beard
15:36 <Laney> Anyway
15:36 <Laney> Questions?
15:36 <ScottK> Seems reasonable to me.
15:37 <xnox> Laney: so looking at current uploading DMs in https://ftp-master.debian.org/dm.txt the list is not that large
15:37 * bdrung_work is fine with expanding the DD PPU to DM
15:38 * ScottK suggests a vote.
15:38 <Laney> You'll still have to be approved normally one time
15:38 <Laney> But then can extend it by mail later on
15:38 <Laney> Yeah
15:38 <bdrung_work> xnox, this file has 165 persons listed
15:38 <ScottK> Compared to 1,000 DDs, it's not so many.
15:39 <xnox> bdrung_work: some of them already have PPU rights in Ubuntu or will not want to seek them.
15:39 <xnox> ScottK: well ~500 or so active.
15:39 <ScottK> True.
15:39 <xnox> whithin past year.
15:39 <Laney> what's the concern?
15:40 <xnox> So, imho any Debian Developer is an Ubuntu Developer.
15:40 <xnox> however DMs are inherently less trusted within Debian itself.
15:41 <ScottK> They are approximately equally trusted for specific packages however.
15:41 <xnox> I do not feel that extending DMs to be PPUs is justified as is. There are no gurantees said people pass/know debian policies & procedures (both legal/dfsg and technical)
15:41 <ScottK> The approximation being they can't upload through New.
15:41 <xnox> how can one assert it would be easy enough for them to pick up Ubuntu quarks?
15:42 <xnox> from the DMs that I have sponsored, I've been monitoring and spotting clearly broken uploads into Debian. =(
15:42 <ScottK> xnox: If you'd seen some of the "not very good" stuff I see uploaded in Debian as a member of the FTP Team, you'd be much less sanguine about what DDs know.
15:42 <xnox> (sponsored - that is granted DM rights)
15:42 <xnox> ScottK: rolf =)
15:42 <ScottK> It's true.
15:42 <Laney> These people have to go through one round with the DMB
15:42 <xnox> Laney: yeah,
15:42 <Laney> at which we will check their understanding of Ubuntu things
15:42 <xnox> ok.
15:43 <xnox> I don't have any other questions, is everyone ready to vote on this?
15:43 <ScottK> \o
15:43 <Laney> I can only think of pocock and now Laibsch who actually take advantage of it atm
15:43 <Laney> Let's go
15:44 * bdrung_work is ready.
15:44 <xnox> #vote Extend DD PPU requirement to cover DMs too
15:44 <meetingology> Please vote on: Extend DD PPU requirement to cover DMs too
15:44 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:44 <ScottK> +1
15:44 <meetingology> +1 received from ScottK
15:44 <xnox> -1
15:44 <meetingology> -1 received from xnox
15:44 <bdrung_work> +1
15:44 <meetingology> +1 received from bdrung_work
15:44 <Laney> +1
15:44 <meetingology> +1 received from Laney
15:45 <xnox> stgraber: ?
15:47 <stgraber> +1
15:47 <meetingology> +1 received from stgraber
15:48 <xnox> #endvote
15:48 <meetingology> Voting ended on: Extend DD PPU requirement to cover DMs too
15:48 <meetingology> Votes for:4 Votes against:1 Abstentions:0
15:48 <meetingology> Motion carried
15:48 * xnox is not sure if this motion is actually carried or not, and whether we need bdmurray and/or micah's vote here
15:48 <xnox> Laney: ? ^
15:48 <Laney> 4x+1 = carried
15:48 <xnox> yeah
15:49 <xnox> cool
15:49 <xnox> thought about it after typing - the outcome is without a daubt.
15:49 <Laney> My phone just alarmed to remind me about DMB
15:49 <xnox> so
15:49 <bdrung_work> Laney, no, +4 in sum is needed
15:49 <Laney> No
15:49 <Laney> It's why we can vote on applicants without everyone present
15:50 <Laney> If something gets to +4 then -3 still leaves you with +1
15:50 <bdrung_work> yes
15:51 <xnox> #topic Any Other Business take #2
15:51 <xnox> ....unless we want to continue discussing politics and voting systems
15:52 <ScottK> So did we agree it passed?
15:52 <Laney> There are 3 threads ongoing, please reply to them
15:52 <bdrung_work> if someone from the absent members give a +1, it passes
15:52 <xnox> ScottK: i believe it has passed, as the absolute majority is in favour.
15:52 <xnox> ScottK: and there is no tie, even with extra votes from bdmurray & mica
15:53 <ScottK> OK.
15:53 <ScottK> I thought so too, but I wanted to make sure there's no confusion.
15:53 <ScottK> bdrung_work seems to disagree.
15:53 <xnox> Laney: what threats?
15:53 <bdrung_work> if we use the same voting mechanism that we use for applicant
15:54 <xnox> bdrung_work: given that we operate on 50%+1 majority (aka 1:1 majority) the outcome is without a daubt, and we do not require an 2:1 majority for applicant voting.
15:54 <Laney> 1) Laibsch PPU 2) Noskcaj MOTU 3) input-methods packageset
15:54 * bdrung_work has to leave now.
15:55 <xnox> bdrung_work: however, I'd like to know bdmurray's opinion.
15:55 <xnox> Laney: isn't 1 & 2 requested to be processed via email
15:55 <Laney> yes
15:55 * xnox looks at the input-methods packageset
15:55 <Laney> that's why I said please reply to the threads :)
15:55 <xnox> i have not actually followed that thread.
15:55 <bdrung_work> xnox, the +4 requirement was to enable more fine grained declines (by voting +0 or -1)
15:58 <xnox> Laney: i'll follow up on the email threats later over email.
15:58 <Laney> ty
15:58 <xnox> bdmurray: ditto needs follow up on the mailing list.
15:58 <xnox> i guess that's it for today?
15:58 <Laney> I think we had a similar conversation about voting systems a couple of years ago
15:58 <Laney> maybe I remember the outcome wrong
15:58 <Laney> would be helpful for bdrung to find the conclusion
15:59 <Laney> (it went to the TB back then)
16:01 <xnox> meh ok.
16:02 <Laney> maybe #action him :)
16:02 <xnox> #action cjwatson: as a returning officer: given 7 voters, and "Votes for:4 Votes against:1 Abstentions:0" collected to date, is the outcome without a doubt or do we need extra +1 votes?
16:02 * meetingology cjwatson: as a returning officer: given 7 voters, and "Votes for:4 Votes against:1 Abstentions:0" collected to date, is the outcome without a doubt or do we need extra +1 votes?
16:02 <Laney> *cough* or bdmurray could just vote
16:03 <Laney> a "returning officer"?
16:03 <xnox> Laney: yes, a standard practice in traditional british voting and polling mechanisms, where ex-members are invited to oversee the process as independent party ;-)
16:04 <Laney> Haha.
16:04 * xnox thinks cjwatson would be an excellent returning officer given the history of the boards and committees he has been on (including the DMB)
16:04 <Laney> We could just dig up the old thread
16:04 <xnox> anyway, we are past the hour, follow up on the irc
16:05 <xnox> #endmeeting