15:01 <slangasek> #startmeeting
15:01 <meetingology> Meeting started Thu Sep 25 15:01:12 2014 UTC. The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:01 <meetingology>
15:01 <meetingology> Available commands: action commands idea info link nick
15:01 <slangasek> [TOPIC] lightning round
15:01 <slangasek> $ echo $(shuf -e barry doko stgraber jodh bdmurray slangasek cjwatson caribou infinity mvo bhuey sil2100 robru)
15:01 <slangasek> robru infinity mvo cjwatson stgraber doko bdmurray bhuey barry sil2100 slangasek jodh caribou
15:01 <slangasek> robru: you're first!
15:02 <slangasek> robru: too slow!
15:02 <slangasek> infinity:
15:02 <infinity> Typing...
15:02 <robru> ah sorry, not ready anyway
15:02 <slangasek> :)
15:03 <infinity> - Helped with some evil partner package reviews
15:03 <infinity> - Meetings (several!) with people about $customer doing silly things with firmware
15:03 <infinity> - Working on updating PPC packages
15:03 <infinity> - Working on Utopic Beta 2 release
15:03 <infinity> [...]
15:03 <infinity> POssibly also stuff, and/or things.
15:04 <slangasek> infinity: '(done)' ?
15:04 * mvo was wondering the same
15:05 <infinity> slangasek: Oh, sure.
15:05 <mvo> apt:
15:05 <mvo> - Debug regression (Bug#762160)
15:05 <mvo> - Release cve-2014-6273 (http.cc buffer overflow)
15:05 <mvo> - Work on droping privs for the apt download methods
15:05 <mvo> - Work on feature/acq-trans for more robustness in acquire
15:05 <mvo> click:
15:05 <infinity> slangasek: That was the [...]
15:05 <mvo> - Debug pycurl/gnutls issue with search.apps.ubuntu.com and send RT
15:05 <ubottu> ** RESERVED ** This candidate has been reserved by an organization or individual that will use it when announcing a new security problem. When the candidate has been publicized, the details for this candidate will be provided. (http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-6273)
15:05 <mvo> ticket, blocks using pycurl for searches
15:05 <mvo> - lp:~mvo/click/click-check-libs (find non sdk libs and warn about them)
15:05 <mvo> - lp:~mvo/click/lp1245826-multiple-hookfiles (support multiple files
15:05 <mvo> for a given hook)
15:05 <mvo> - lp:~mvo/click/acquire (more work on acquire support)
15:05 <mvo> - lp:~mvo/click/repository (ported to licurl, stuck with gnutls issue)
15:05 <mvo> - lp:~mvo/click/sso (ported to libcurl, stuck with gnutls issue)
15:05 <slangasek> infinity: heh :)
15:05 <mvo> - upload click-bin-path hook (to add stuff to PATH) to utopic
15:05 <mvo> python-apt:
15:05 <mvo> - Review/merge Colins ubuntu-rtm fix (thanks!)
15:05 <mvo> software-properties:
15:05 <mvo> - Review/merge Colins patch, upload new version
15:05 <mvo> system-image:
15:05 <mvo> - Discussion about leaner download backend
15:05 <mvo> - lp:~mvo/ubuntu-system-image/pycurl
15:05 <mvo> (done)
15:05 <cjwatson> GRUB update in unstable, adding x32 and ppc64el support (ppc64el support replaced our previous cross-compiler hack).
15:05 <cjwatson> man-db release to add high-precision timestamp support, speed up mandb / man -K, and stop using debconf in the trigger. Trawled through Ubuntu bugs about the last part, clearing out >140, and prepared SRUs (bug 1372673).
15:05 <ubottu> bug 1372673 in man-db (Ubuntu Trusty) "excessive debconf use when triggered" [High,Fix committed] https://launchpad.net/bugs/1372673
15:06 <cjwatson> Fixed livecd-rootfs to tolerate dpkg-dev no longer being on the image.
15:06 <cjwatson> netcfg SRU for bug 1350302.
15:06 <ubottu> bug 1350302 in MAAS "Deploying node with di on armhf/keystone can't find BOOTIF" [Critical,Incomplete] https://launchpad.net/bugs/1350302
15:06 <cjwatson> Fixed add-apt-repository on ubuntu-rtm.
15:06 <sil2100> Eeek!
15:06 <cjwatson> Fixed UbuntuKylin image builds to contain the proper Ubiquity slideshow (bug 1372731).
15:06 <ubottu> bug 1372731 in Ubuntu Kylin "the slideshow for ubuntu kylin utopic beta-2 rc is ubuntu's slideshow" [Critical,Fix released] https://launchpad.net/bugs/1372731
15:06 <cjwatson> Various ad-hoc copies to reduce the number of uninstallables reported by proposed-migration for ubuntu-rtm/14.09.
15:06 <cjwatson> Tracked down a click autopkgtest regression (fortunately never hit -proposed).
15:06 <cjwatson> Devirtualised/otherwise-configured 10 new silos in each of ubuntu and ubuntu-rtm for the CI Train folks.
15:06 <cjwatson> Proposed branch for bug 1364327. Took ages because I first had to get my local autopkgtest/qemu environment sorted out, which involved upgrading to utopic ...
15:06 <ubottu> bug 1364327 in click (Ubuntu) "Title: Custom prefix/postfix to the generated click chroots" [High,In progress] https://launchpad.net/bugs/1364327
15:06 <cjwatson> Working on an OpenSSL backport stack for ppc64el. In patch hell; send ice cream.
15:06 <cjwatson> ..
15:06 <stgraber> - A lot more internal work and meetings..
15:06 <stgraber> - Figured out all the details for upcoming trips (vacation, LinuxCon,
15:06 <stgraber> Plumbers, Client sprint, Server sprint).
15:06 <stgraber> - Released LXC 1.0.6 with 85 bugfixes by 24 individual contributors.
15:06 <stgraber> - Went through the LXC patch backlog, reviewed and committed everything.
15:06 <stgraber> - Worked on fixing the LXC init script situation in preparation for 1.1~alpha2
15:06 <stgraber> (to be released tomorrow ideally).
15:06 <stgraber> - Implemented a fix for uid/gid consistency on system images (touch only at
15:06 <stgraber> the moment).
15:06 <stgraber> (DONE)
15:06 * sil2100 is here if anything
15:07 <sil2100> Did I miss my turn?
15:07 <cjwatson> sil2100: nope, you're after barry
15:07 <infinity> cjwatson: Oh, nice, so we're going to drop the cross-hack in Ubuntu too, I assume?
15:07 <sil2100> Thanks
15:07 <bdmurray> updated daisy (r529) handle AssertionError raised by apport on invalid keys in a report fixes OOPS-ce96293a10a1987c516e4ed968fa715e
15:07 <bdmurray> submitted RT to get retracer log files from staging retracers
15:07 <bdmurray> submitted RT 75272 regarding nodetool access
15:07 <bdmurray> had daisy retracers really updated to r528
15:07 <bdmurray> pushed merge proposal with daisy-retracer charm change to create version_info.py
15:07 <bdmurray> pushed daisy r531 which logs the version of daisy to the retracer log files
15:07 <cjwatson> infinity: already have. but it doesn't quite work apparently, needs -mno-vsx -mno-altivec or asm hacks, pfsmorigo is on it
15:07 <bdmurray> updated and tested daisy charm change to generate version_info.py
15:07 <bdmurray> worked with thedac to remove coredumps from swift as there are more items in swift than the retracing queue
15:07 <bdmurray> research into if duplicate OOPSes are an issue in the Error Tracker and how to fix it
15:07 <bdmurray> created a graph of .new missing versus foreign origin packages
15:07 <bdmurray> submitted apport bug 1372612 regarding Ubuntu RTM and origin issue
15:07 <bdmurray> reported and testing of apport bug 1373154 regarding ExecutableTimestamp and MarkForUpload being True
15:07 <ubottu> bug 1362496 in base-files (Ubuntu-rtm 14.09) "duplicate for #1372612 LSB release and /etc/os-release still say "Utopic", needs to be RTM" [High,Triaged] https://launchpad.net/bugs/1362496
15:07 <ubottu> bug 1373154 in apport (Ubuntu) "reporting of crashes for programs that don't match the file on disk is happening" [High,New] https://launchpad.net/bugs/1373154
15:07 <bdmurray> SRU verification of bug LP: #1309447
15:07 <ubottu> Launchpad bug 1309447 in ubuntu-release-upgrader (Ubuntu Trusty) "Unicode decode error during upgrade to 14.04 if sources.list contains non-ascii characters and locale is non-US" [High,In progress] https://launchpad.net/bugs/1309447
15:07 <bdmurray> ✔ done
15:08 <cjwatson> infinity: (so, cough, it's possible the final beta may not be bootable on ppc64el ...)
15:08 <infinity> cjwatson: Oh. Fun.
15:09 <infinity> cjwatson: Good thing I hadn't tested yet.
15:10 <slangasek> bhuey: hi, your turn
15:10 <bhuey> ok
15:10 <bhuey> -read both ubuntu-policy.pdf and packaging tutorial documents
15:10 <bhuey> -got X11 working in all containers for TCK testing
15:10 <bhuey> -successfully ran TCK inside containers for precise/trusty/utopic
15:10 <bhuey> -general clean up of container configurations TCK instances
15:10 <bhuey> -begin general creation of container creation scripts so that the entire test environment csn be replicated
15:10 <bhuey> -began looking at bugs that needs to be fixed by Oct 20th
15:10 <bhuey> (done)
15:10 <barry> debuntu: LP: #1371291, debian bug #762142, syncpackage python-concurrent.futures (to fix ftbfs), LP: #1367907, LP: #1290847 (both for python34 sru, awaiting doko's feedback). reviewed py3 swiftclient packaging and uploaded websocket-client 0.18.0 for internal users.
15:10 <ubottu> Launchpad bug 1371291 in python-eventlet (Ubuntu) "FTBFS caused by PEP 466" [Undecided,Triaged] https://launchpad.net/bugs/1371291
15:10 <ubottu> Debian bug 762142 in python-concurrent.futures "python-concurrent.futures: FTBFS on i386" [Important,Fixed] http://bugs.debian.org/762142
15:10 <ubottu> Launchpad bug 1367907 in python3.4 (Ubuntu) "Segfault in gc with cyclic trash" [High,In progress] https://launchpad.net/bugs/1367907
15:10 <ubottu> Launchpad bug 1290847 in python3.4 (Ubuntu) "pyvenv fails due to mising ensurepip module" [Undecided,Fix released] https://launchpad.net/bugs/1290847
15:10 <barry> phone: system-image 2.4-0ubuntu1 slogging through ci-train for utopic and rtm. internal discussions. testing/review/excitement over mvo's pycurl branch. LP: #1369717. LP: #1370586.
15:10 <ubottu> Launchpad bug 1369717 in Ubuntu system image "Remove system-image-cli --dbus" [High,Fix committed] https://launchpad.net/bugs/1369717
15:11 <ubottu> Launchpad bug 1370586 in Ubuntu system image "Add synchronous method to determine if there are known updates" [High,In progress] https://launchpad.net/bugs/1370586
15:11 <barry> other: git'n it
15:11 <barry> -- done --
15:11 <sil2100> o/
15:11 <slangasek> so now that bhuey has read policy, the rest of our meeting today can be to quiz him on it ;)
15:11 <sil2100> - Filling in the standing FFe for utopic Ubuntu Touch packages (LP: #1371635)
15:11 <sil2100> - Refactoring some of the commit-log syncing scripts
15:11 <ubottu> Launchpad bug 1371635 in Ubuntu "[FFe] standing freeze exception in utopic for Ubuntu Touch-specific packages" [Undecided,Triaged] https://launchpad.net/bugs/1371635
15:11 <sil2100> - Landing team work, preparing landing e-mails
15:11 <bhuey> slangasek: shit
15:11 <sil2100> - CI Train maintenance and feature:
15:11 <sil2100> * Testing binary copy sync functionality
15:11 <sil2100> * Improve error verbosity in some cases for sync rebuilds
15:11 <sil2100> * Cleaning up left-over jenkins jobs
15:11 <sil2100> * Refactoring parts of the build job to enable better testing
15:11 <sil2100> * Add basic unit tests for the sync functionality
15:11 <sil2100> * Make the ~rtm addition to the version number optional
15:11 <sil2100> * Fixing a new small bug that caused the spreadsheet to malfunction
15:11 <sil2100> - Reviewing and testing bugfixing merge for appmenu-qt5
15:12 <sil2100> - Fixing/unbricking testing device
15:12 <sil2100> - Writing announcement e-mails
15:12 <sil2100> - Making sure the documentation of RTM landings is up-to-date
15:12 <sil2100> - Debugging issues with commit-log generation scripts
15:12 <sil2100> - Discussions regarding getting rid of the spreadsheet (finally!)
15:12 <sil2100> (done)
15:12 <robru> ok, i'm ready now, can i go?
15:12 <slangasek> robru: sure
15:13 <robru> Train:
15:13 <robru> - Adapted 'citrain' (silo installation script) to work on RTM
15:13 <robru> - Updated citrain spreadsheet, jenkins backend, and dashboard to recognize the 10 new silos
15:13 <robru> - Began test-drive reimplementation of cupstream2distro/silomanager.py, with the intention to fix the utter disgusting lack of encapsulation, such that other bits of citrain no longer need to have knowledge of the custom json format used to maintain each silo's state (this will make it easier/possible to back citrain onto the airline ticket system when the
15:13 <robru> time comes)
15:13 <robru> - Fixed the deploy job to correctly assign pre-prod silos, making it possible to test things outside of production
15:13 <robru> - Stopped the prepare job from being able to delete packages from the PPA, which it was often doing erroneously and deleting packages that had been through hours of scarce QA approval
15:13 <robru> - Implemented a generic signal / unhandled exception handler, which is capable of a) logging and b) saving the signal/exception message to the silo status, such that the dashboard can now report when a job exits uncleanly, so we no longer have the situation where the dashboard reports 'Building...' even if something has actually gone horribly wrong
15:13 <robru> - Cleaned up the use of subprocess module, so that the testsuite no longer spews random crap on STDOUT, making it a lot easier to see a clean, successful test run
15:13 <robru> NFSS:
15:13 <robru> - Added veebers' new js module to lp:ubuntu-assets and got it approved by oatman
15:13 <robru> (done)
15:13 <slangasek> sil2100: FFe> did everything work out wrt touch packages in the auto-accept list?
15:13 <infinity> bhuey: A binary package leaves my dput travelling three versions per epoch, when is it appropriate to use Conflicts versus Breaks, and does the answer change when drunk?
15:13 <sil2100> slangasek: I think it did, since we didn't see any further problems
15:13 <barry> infinity: binNMU
15:14 <cjwatson> infinity: consider a spherical manual page
15:14 <infinity> cjwatson: I actually ell oh elled.
15:14 <infinity> cjwatson: And, for some reason, I read that in Bill Bailey's voice.
15:16 <slangasek> * business meeting up in Seattle yesterday, the jet lag is horrible
15:16 <slangasek> * review of a number of impending partner packages
15:16 <slangasek> * working to move a number click apps out of the rootfs into a default "custom" tarball (bug #1367332)
15:16 <ubottu> Error: Launchpad bug 1367332 could not be found
15:16 <slangasek> * progress on a console-setup merge with Colin's help; the package may be uploadable this year
15:16 <slangasek> * created new silos at LT's request
15:16 <slangasek> * LT/CI meetings to discuss next steps on CI Airline (e.g., ditching the spreadsheet)
15:16 <slangasek> (done)
15:16 <bhuey> infinity: yes, only when also taking opiates with alcohol
15:16 <jodh> * upstart:
15:16 <jodh> - investigating bug 1371651.
15:16 <ubottu> bug 1371651 in lightdm (Ubuntu) "Daily does not boot into graphical interface after installation" [Critical,Confirmed] https://launchpad.net/bugs/1371651
15:16 <jodh> - A respectful prod to all upstart devs to take a look at the
15:16 <jodh> following if they get a chance :-):
15:16 <jodh> https://code.launchpad.net/~jamesodhunt/upstart/bug-1360208/+merge/234869
15:17 <jodh> * system-image
15:17 <jodh> - Good progress - root is now r/o with a writeable overlay.
15:17 <slangasek> if a ~ falls in the middle of your version, does it make a sound
15:17 <jodh> - More tweaks to lp:~ubuntu-foundations-team/+junk/create-ubuntu-core-image.
15:17 <jodh> - Split lp:~ubuntu-foundations-team/+junk/system-image-rootfs into 2:
15:17 <jodh> - lp:~ubuntu-foundations-team/+junk/ubuntu-core-config [1]
15:17 <jodh> - lp:~ubuntu-foundations-team/+junk/initramfs-tools-ubuntu-core [2]
15:17 <jodh> - Currently testing recent changes to [2].
15:17 <jodh> * misc:
15:17 <jodh> - procenv is now running for lucid as well as all newer supported releases:
15:17 <jodh> https://code.launchpad.net/~jamesodhunt/+recipe/procenv-daily-ubuntu-lucid
15:17 <jodh> ⭈
15:18 <slangasek> jodh: bug #1371651> do we know what /changed/ to cause this problem?
15:18 <ubottu> bug 1371651 in lightdm (Ubuntu) "Daily does not boot into graphical interface after installation" [Critical,Confirmed] https://launchpad.net/bugs/1371651
15:18 <slangasek> (it was the kernel, wasn't it!)
15:19 <jodh> slangasek: no - I've asked jibel to check packages differences, but I don't think it's upstart.
15:19 <slangasek> I agree
15:19 <infinity> slangasek: No one seems entirely sure who to blame just yet, though the kernel seems a likely candidate.
15:19 <slangasek> plymouth has been uploaded recently (twice in the past 8 days), but those changes should also not have had an effect
15:20 <infinity> (Or, the whole process is just amazingly fragile, and the fault lies in all the players together, plus it was Wednesday)
15:20 <jodh> well as I noted on the bug, we do see plymouth crashing in the logs but that might be due to fb issues which are also causing the failure of upstart to emit the plymouth-ready event.
15:20 <slangasek> right, in which case --> kernel
15:21 <jodh> slangasek: right, jibel is trying to track down apw I believe.
15:21 <slangasek> has anyone asked apw about it?
15:21 <slangasek> ok :)
15:21 <infinity> The part where "it works with systemd" (while also obviously not being directly an upstart bug) kinda points to the fragility argument.
15:22 <jibel> slangasek, apw is working on it
15:22 <jodh> infinity: but has anyone tried uselessd yet? :)
15:22 <slangasek> infinity: on systemd we don't have any flicker-free boot integration
15:23 <apw> the state the machine ends up in when this is reproduced seems to indicate everything is in order, and running service lightdm start sorts it out (i believe)
15:23 <apw> w
15:23 <apw> which leans towards a userspace race in my eyes, but i am waiting on some installs
15:24 <slangasek> apw: if the plymouth-ready signal isn't being emitted because of a kernel-induced plymouth crash, that's not really a matter of a race
15:24 <slangasek> anyway, seems like this is in hand so we can discuss it on better channels post-meeting
15:24 <slangasek> [TOPIC] AOB
15:24 <slangasek> anything else today?
15:24 <slangasek> I've been failing to tag people to do the weekly talk-about-what-you're-working-on thing
15:25 <slangasek> does somebody want to volunteer to do one next week?
15:25 <jodh> apw: fwics, if you remove "quiet splash", the problem is not recreatable but would value other trying it (I've asked a few times on the bug :-)
15:25 <bdmurray> cjwatson: regarding bug 1372673, it looks like you found most of the duplicates. Did you check other packages though?
15:25 <ubottu> bug 1372673 in man-db (Ubuntu Trusty) "excessive debconf use when triggered" [High,Fix committed] https://launchpad.net/bugs/1372673
15:26 <cjwatson> bdmurray: nope, I don't have a mechanical search for it and some of the problems are subtly different
15:26 <cjwatson> so I had only finite time
15:27 <cjwatson> bdmurray: I'm certain I found all the duplicates on man-db - the others that look similar are actually cropping up in postinst configure instead which is different
15:27 <slangasek> no volunteers? :)
15:27 <cjwatson> you have to hunt for debconf failures immediately following "Processing triggers for man-db" or translations thereof
15:27 <slangasek> you don't have to prepare anything... (in fact it's better if you don't!...) you just have to talk about what you're working on
15:28 <robru> slangasek: i volunteer for the week of the washington sprint so this meeting won't be so painfully early for me ;-)
15:28 <bdmurray> cjwatson: okay, I may have a look around and then check with you
15:28 <cjwatson> ok sure
15:28 <slangasek> robru: invest in coffee
15:28 <robru> slangasek: just say NO to drugs ;-)
15:28 <cjwatson> our coffee machine wasn't working this morning /o\
15:29 <slangasek> robru: you can balance it out with bhuey's opiate-laced alcohol
15:29 * ogra_ listens up
15:29 <bdmurray> I've moved away from machines to an aeropress now.
15:29 <cjwatson> slangasek: guess I can if everyone else is running away; it's been a while for me
15:29 <cjwatson> (next week)
15:29 <slangasek> cjwatson: thanks :)
15:30 <slangasek> #action cjwatson to do a what-I'm-working-on presentation next week
15:30 * meetingology cjwatson to do a what-I'm-working-on presentation next week
15:30 <slangasek> bdmurray: this is only impressive if you also have a button to deliver the prepared cup of coffee to your desk via pneumatic tube
15:31 <cjwatson> slangasek: have you seen Wallace and Gromit or is that too much of a British thing?
15:31 <slangasek> cjwatson: yes, quite familiar with it :)
15:31 <slangasek> (the last movie even had a theatrical release in the US!)
15:32 <slangasek> er, I think
15:32 <slangasek> oh right, Chicken Run was technically not W&G, just Aardman
15:32 <bdmurray> I agree with your thought
15:32 <slangasek> anyway, speaking of which
15:32 * slangasek slinks away from the desk to get more coffee
15:32 <slangasek> #endmeeting