15:04 <Laney> #startmeeting DMB
15:04 <meetingology> Meeting started Mon Jun  2 15:04:18 2014 UTC.  The chair is Laney. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:04 <meetingology> 
15:04 <meetingology> Available commands: action commands idea info link nick
15:04 <Laney> #topic Action items
15:04 <ScottK> Sorta here. In transit.
15:04 <Laney> Hrm, they were cleared or never added to gthe agenda
15:05 <Laney> Anyway, AFAIK it was just creating the virt set which xnox did
15:05 <Laney> with stgraber's help
15:05 <Laney> stgraber: want to run your eagle eye over the team's configuration?
15:06 <stgraber> Laney: yep, doing that now
15:06 <Laney> cheers
15:07 <Laney> let's do this application thing
15:07 <stgraber> there are problems, fixing
15:07 <Laney> #topic MOTU application: Rohan Garg
15:07 <Laney> hi shadeslayer
15:07 <shadeslayer> hi everyone! :)
15:07 <Laney> could you introuce yourself?
15:07 <stgraber> Laney: for the record, the DMB should never be a member of a packaging team, core-dev should always be a member (without an expiry) and existing members should have a two years expiry (instead of 1)
15:07 <Laney> xnox: ^^^^^
15:09 <stgraber> also, members should be allowed to self-renew after 730 (instead of re-apply after 365)
15:09 <shadeslayer> Sure, I'm Rohan Garg, I've been contributing to Kubuntu for nearly 4 years now ( launchpad indicates that my first upload was in earl 2010 ), mostly involved in the packaging side, though I occassionaly also contribute bug fixes to KDE
15:09 <stgraber> Laney: all fixed
15:09 <shadeslayer> I'm currently a member of Kubuntu Dev, which allows me upload rights to most of KDE SC, however, I'd also like to contribute to the wider array of KDE packages and libraries that KDE builds upon in the ubuntu universe
15:09 <Laney> stgraber: thanks
15:10 <shadeslayer> wiki page https://wiki.ubuntu.com/shadeslayer
15:11 <shadeslayer> https://wiki.ubuntu.com/shadeslayer/MOTUDeveloperApplication
15:12 <Riddell> I support rohan, he's a top notch contributor and it would be great to have him easily able to help throughout universe land
15:12 <Laney> but if it's not going to happen (if 4 people won't be there) I'd appreciate someone letting shadeslayer know and SMSing me
15:12 <Laney> ffs sorry
15:12 <stgraber> :)
15:12 <Laney> I'm suffering from extreme latency
15:12 <Laney> currently in a cafe
15:13 <Laney> okay seems a bit better now
15:13 <Laney> shadeslayer: thanks for the intro, good to see nice endorsements
15:15 <Laney> do you plan on working on anything outside of non-seeded KDE stuff? :)
15:15 <Laney> like sponsoring ;-)
15:15 <shadeslayer> if it's within my domain, I can lend a hand sure
15:16 <Riddell> he's also a merging master
15:16 <stgraber> I guess that's the main point of that application right since you're already a member of kubuntu-dev and ubuntu-qt5-dev which I guess cover most of the existing kde packages
15:16 <Laney> much stuff in the queue is fairly general
15:16 <shadeslayer> for eg. I can understand basic autotools as well
15:17 <shadeslayer> and moderately complex cmake things
15:17 <Laney> exactly, like merges (although they are tiresome to review)
15:17 <shadeslayer> true ^_^
15:17 <Laney> (since you end up redoing the work)
15:19 <shadeslayer> so sure, I can help with the sponsoring as when I have time :) , though I'll probably need some reminding every now and then ;)
15:20 <Laney> do you work directly in debian-qt-kde?
15:21 <shadeslayer> when the occassion calls for it, I've sent bug reports upstream, these days I'm working with maxy ( a debian DD ) to get delta reduced between debian and ubuntu KDE packages
15:22 <stgraber> shadeslayer: are you subscribed to ubuntu-devel-announce?
15:23 <shadeslayer> I think so
15:24 <shadeslayer> FWIW some examples of my work done in Debian https://bugs.debian.org/cgi-bin/pkgreport.cgi?archive=both;dist=unstable;submitter=rohangarg%40kubuntu.org
15:24 <stgraber> shadeslayer: do you know how to check if a given package affects a particular Ubuntu image?
15:24 <shadeslayer> stgraber: you mean if it's seeded? seeded-in-ubuntu packagename
15:25 <stgraber> shadeslayer: yep, good answer :)
15:25 <shadeslayer> :)
15:26 <Laney> anyone got any more questions?
15:26 * Laney is done
15:26 <Laney> bdrung_work: ScottK:
15:26 <stgraber> shadeslayer: so say we are Tuesday of alpha-2 week, you want to sponsor a vlc merge, can you do it without any worries or should you refrain?
15:26 <bdrung_work> finally seeded-in-ubuntu is talked of :)
15:26 <stgraber> shadeslayer: consider that this is for the 14.10 cycle
15:29 <shadeslayer> stgraber: if it's a bug fix release, I don't see a issue ( though maybe inform the Mythbuntu folks )
15:30 <stgraber> shadeslayer: ok. Asking is always the safe way to go about this kind of things :)
15:30 <shadeslayer> if it's a release with features, that /might/ cause potential bugs for Mythbuntu ISO's
15:30 <shadeslayer> then collaborate with mythbuntu, get it tested in a PPA, and then land
15:31 <stgraber> this was a trick question though as Mythbuntu is LTS-only and so doesn't really care about 14.10. For any other seeded package during a milestone week, it's usually expected to either refrain or talk to the affected flavors.
15:31 <stgraber> Laney: no further question
15:31 <Laney> thanks
15:31 <Laney> bdrung_work: anything?
15:31 <shadeslayer> you trickster you :P , but yeah, I'd just poke the relevant Mythbuntu folks
15:31 <bdrung_work> Laney, yes, one
15:32 <ScottK> No questions
15:32 <Laney> go go go
15:32 <bdrung_work> shadeslayer, do you plan to become a DD or to join the Debian KDE team to directly commit your changes to their git repositories?
15:33 <bdrung_work> IMO that's the simplest way to keep the diff between Debian and Ubuntu small
15:33 * apachelogger puts cookies that might be considered bribe cookies in the channel
15:34 <shadeslayer> I honestly don't know, usually I apply for upload permissions when I get annoyed that I can't fix stuff that annoys me or users, so far nothing like that has happened, when that happens, I'll probably apply :P
15:34 <Laney> you can usually get team membership without upload rights
15:34 <Laney> it lets you stage things directly in the vcs
15:35 <Laney> (referring to alioth teams)
15:35 <Laney> bdrung_work: anything more?
15:36 <bdrung_work> no
15:36 <bdrung_work> everything else was covered
15:36 <Laney> thanks
15:36 <shadeslayer> well, usually there's very little friction when I send a patch to a DD in the debian qt kde team, so haven't been frustrated enough to apply for the team
15:36 * Laney nods
15:36 <Laney> It just turns "send a patch" into "commit a patch" :)
15:36 <apachelogger> (random note regarding debian cooperation: there has been ongoing discussion about actually putting kubuntu package maintenance into the debian repos as to reduce merge overhead to somewhere close to nil)
15:36 <Laney> #vote Should shadeslayer join ~motu?
15:36 <meetingology> Please vote on: Should shadeslayer join ~motu?
15:36 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:36 <stgraber> +1
15:36 <meetingology> +1 received from stgraber
15:37 <bdrung_work> +1
15:37 <meetingology> +1 received from bdrung_work
15:37 <Laney> +1 good endorsements, good work, good answers - thanks!
15:37 <meetingology> +1 good endorsements, good work, good answers - thanks! received from Laney
15:37 <Laney> ScottK: want to vote for realz?
15:37 <Laney> well anwyay, he already voted +1 in an email
15:37 <Laney> so...
15:37 <Laney> #endvote
15:37 <meetingology> Voting ended on: Should shadeslayer join ~motu?
15:37 <meetingology> Votes for:3 Votes against:0 Abstentions:0
15:37 <meetingology> Motion carried
15:38 <Laney> well done ;)
15:38 <Laney> #action Laney to add shadeslayer to ~motu
15:38 * meetingology Laney to add shadeslayer to ~motu
15:38 <Laney> #topic AOB
15:39 <Laney> going
15:39 <Laney> going
15:39 <shadeslayer> thanks!
15:40 <bdrung_work> shadeslayer, congrats!
15:40 <Laney> gone
15:40 <Laney> thanks all!
15:40 <stgraber> shadeslayer: congrats!
15:40 <Laney> #endmeeting