19:08 <xnox> #startmeeting Ubuntu Developer Membership Board Meeting
19:08 <meetingology> Meeting started Mon May 19 19:08:13 2014 UTC. The chair is xnox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:08 <meetingology>
19:08 <meetingology> Available commands: action commands idea info link nick
19:08 <xnox> #topic Review of previous action items
19:08 <xnox> #subtopic Action: add stokachu to core-dev team
19:08 <xnox> I think this was competed.
19:08 <xnox> #subtopic Other
19:08 <xnox> any other actions that we have pending?
19:09 <bdmurray> nope
19:09 <xnox> i thought so as well.
19:10 <xnox> bkeresea doesn't seem to be online. in that case. moving on.
19:10 <xnox> #topic Establishment of the Virtualization package set
19:10 <xnox> We have one applicant for a virtualization package set, yet such package set has not been created yet.
19:10 <xnox> A following list of packages was proposed by Laney, which without daubt can be considered to form virtualisation package set:
19:10 <xnox> xen, xen-api, xen-api-libs, qemu, libvirt
19:11 <xnox> bdmurray: bdrung: smb: would you agree?
19:11 <xnox> and if yes, shall we vote/ratify that, or simply discuss smb's application assuming such a package set?
19:11 <smb> xnox, for if we include xen-api then blktap may be added too
19:12 <smb> That was part of the the xen-api bundle of things
19:12 <bdrung> xnox: i agree that all these packages belong to virtualization.
19:12 <bdmurray> that sounds good to me
19:13 <xnox> #vote create virtualisation packageset consisting off: xen, xen-api, xen-api-libs, qemu, libvirt and blktap
19:13 <meetingology> Please vote on: create virtualisation packageset consisting off: xen, xen-api, xen-api-libs, qemu, libvirt and blktap
19:13 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:13 <xnox> +1
19:13 <meetingology> +1 received from xnox
19:13 <bdmurray> +1
19:13 <meetingology> +1 received from bdmurray
19:14 <bdrung> +1
19:14 <meetingology> +1 received from bdrung
19:16 <xnox> #endvote
19:16 <meetingology> Voting ended on: create virtualisation packageset consisting off: xen, xen-api, xen-api-libs, qemu, libvirt and blktap
19:16 <meetingology> Votes for:3 Votes against:0 Abstentions:0
19:16 <meetingology> Motion carried
19:16 <xnox> I think that's all votes we can get, and I believe above would be inline with stgraber/Laney as well.
19:16 <xnox> In that case going forward.
19:16 <smb> I would assume at least from stgraber
19:17 <xnox> #topic Virualisation Packageset Uploader application (smb)
19:18 <xnox> smb: hello =) can you briefly introduce yourself and talk a little bit about the work you do with above mentioned packages?
19:18 <smb> xnox, sure if you can bear with me being a bit slower at typeing :)
19:19 <smb> So I am Stefan Bader, working for the kernel team and through being kind of interface for the server team, started to care for the user-space side of virtualization, too
19:21 <smb> Most of the work I did was on the Xen package, where I went ahead and created the packaging of Xen-4.4 for Trusty (before that the Xen-4.3 version was also done to quite some degree). I also try to establish us to do upstream stable minor releases for Xen.
19:22 <smb> The other packages I touched more or less often for bug-fixes and libvirt for some improvements related to Xen as well.
19:22 <smb> I think that about is it...
19:24 <smb> Oh, maybe to add that usually I try to send improvements and additions to upstream (sometimes that is less simple than other times)
19:25 <xnox> smb: as far as I know xen apis, are very tightly coupled, thus on upgrade one cannot skip major releases. What is your vision to support XEN upgrades from e.g. LTS -> LTS? Are you planning to provide xen-hwe-* (like kernels)?
19:27 <smb> xnox, At least for the experience between Precise and Trusty the main issue was the toolstack which got deprecated. But the upgrade from 4.1 to 4.4 was doable without major issues
19:28 <smb> Only drawback were xend managed domains, but I provided a conversion script. Unfortunately that has to be called manually and is not working automatically as I initially intended.
19:29 <smb> Basically when upgrading from P to T there will be a strong push towards changing toolstacks as in the next version of Xen xm is really removed
19:29 <xnox> i see. Sounds good.
19:31 <xnox> smb: i see that xen package is ahead and not in-sync with debian. Are you planning to stay diverged from Debian? Or for example collaborate on the upgrade strategies.
19:32 <smb> xnox, I was trying to collaborate with Debian, though that is ... err... difficult
19:32 <smb> IOW hard to get feedback from the Maintainer there
19:33 <smb> I would rather not deviate (too much)
19:33 <bdrung> smb: have you tried to join the Debian Xen Team?
19:33 <smb> bdrung, No, not yet. There was an attempt by someone at Citrix but with not much success yet either
19:35 <xnox> smb: i see, happens.
19:36 <xnox> bdrung: bdmurray: any other questions?
19:37 <bdrung> smb: what's your experience with other package maintainers?
19:37 <bdmurray> xnox: no, I don't have any questions
19:37 <smb> xnox, libvirt and xen kernel parts receive better upstreaming. And for the kernel we usually try to keep multiple kernel versions working with each hypervisor (which actually is the answer to your previous question)
19:38 <smb> Feedback and acceptance is quite good there.
19:39 <smb> Well and also Xen parts which are not related to Debian packaging
19:40 <bdrung> smb: for example, libvirt is diverted from debian. Have you tried to join the libvirt team to join forces?
19:42 <smb> bdrung, No, actually I submit all changes that applicable for all to upstream directly. I think from my part there is probably one or two changes related to Debian. But yeah, it would maybe mae sense to discuss these with Debian developers too
19:43 <bdrung> smb: it is beneficial to become co-maintainer and get access to Debian git repository. This way you could push fixes and prepare new releases.
19:44 <xnox> smb: i find sending patches to BTS, even after already applied in ubuntu, helps. if they are taken then next merge/rebase will be easier, otherwise, well you do commit to maintain them =)
19:45 <smb> I agree it should probably be done even in hindsight (libvirt), Probably I should give them a go in this cycle
19:45 <bdrung> sending patches to the BTS as small chunks is always good. it can take very long until they are applied, but better late than never.
19:47 <xnox> I think we have discussed your position enough in-depth. So I'll call for votes.
19:47 <xnox> #vote Should Stefan Bader become Virtualisation Packageset Uploader?
19:47 <meetingology> Please vote on: Should Stefan Bader become Virtualisation Packageset Uploader?
19:47 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:47 <bdrung> +1
19:47 <meetingology> +1 received from bdrung
19:48 <bdmurray> +1
19:48 <meetingology> +1 received from bdmurray
19:48 <xnox> +1
19:48 <meetingology> +1 received from xnox
19:48 <xnox> #endvote
19:48 <meetingology> Voting ended on: Should Stefan Bader become Virtualisation Packageset Uploader?
19:48 <meetingology> Votes for:3 Votes against:0 Abstentions:0
19:48 <meetingology> Motion carried
19:48 <xnox> smb: congrats =)
19:48 <smb> thank you
19:48 <smb> :)
19:48 <xnox> #action Add Virtualisation packageset
19:48 * meetingology Add Virtualisation packageset
19:48 <bdrung> smb: Herzlichen Glückwunsch!
19:48 <xnox> #action Add smb as uploader to Virtualisation packageset
19:48 * meetingology Add smb as uploader to Virtualisation packageset
19:49 <smb> bdrung, Danke
19:49 <xnox> bdrung: bdmurray: anybody wants to take up on the above actions? =)
19:50 <xnox> otherwise, i'll try to follow-up on performing them.
19:52 <xnox> #topic Any other business =)
19:52 <bdrung> note for the vote: smb got +1 from stgraber and Laney via email.
19:52 <xnox> #topic Any other business
19:52 <xnox> bdrung: right, yes, i failed to mention that.
19:52 * xnox is not sure why the topic is not changing.
19:52 <xnox> Is there any other business?
19:52 <bdrung> otherwise we wouldn't had met the required +4
19:53 <xnox> bdrung: right, i thought quorum is +3. Noted.
19:53 <xnox> Next meeting is 2nd of June 15:00 UTC. Next chair is Laney. And I will not be able to make that meeting.
19:54 <xnox> Also we need to finish up / conclude sil2100 application via email.
19:54 <bdrung> xnox: we are seven in total and therefore need +4.
19:56 <xnox> I'll send a reminder about bkeresea application, which appears to have been stalled.
19:56 <bdmurray> xnox: its stalled because he has missed a couple of meetings
19:56 <xnox> bdmurray: i see. Is the time not convenient, or does he not want to proceed with application anymore? should it be handled via email then?!
19:56 <bdmurray> xnox: If I recall correctly its been two different meeting times
19:58 <xnox> bdmurray: i see.
19:58 <xnox> I guess that's it for today.
19:58 <xnox> #endmeeting