16:01 <arosales> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue Apr 22 16:01:59 2014 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:02 <arosales> #topic Review ACTION points from previous meeting
16:02 <coreycb> o/
16:02 <arosales> #info https://wiki.ubuntu.com/ServerTeam/Meeting
16:02 <matsubara> o/
16:02 <arosales> #info no previous action items
16:03 <lutostag> o/
16:03 <arosales> #topic Trusty Development
16:03 <arosales> #link https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule
16:03 <zul> uh...done? :)
16:03 <arosales> actually we are done as zul says :-)
16:03 <rharper> =)
16:03 <arosales> good release for everyone :-)
16:03 <arosales> not sure if we have gotten a name for "U" cycle yet
16:04 <arosales> moving on to next topic then
16:04 <arosales> #subtopic Release Bugs
16:04 <arosales> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-t-tracking-bug-tasks.html#ubuntu-server
16:05 <arosales> critical https://bugs.launchpad.net/juju-core/+bug/1304135
16:05 <ubottu> Launchpad bug 1304135 in juju-core (Ubuntu Trusty) "panic: runtime error: index out of range" [Critical,Triaged]
16:05 <arosales> looks like it should be in 1.18.1 of juju-core
16:06 <arosales> jamespag`: do we need to sru that?
16:06 <coreycb> arosales, he's on vacation unless he's lurking
16:06 <arosales> any other server folks available to help with SRUs?
16:07 <arosales> rsync also looks fixed https://bugs.launchpad.net/ubuntu/+source/rsync/+bug/1307230
16:07 <ubottu> Launchpad bug 1307230 in rsync (Ubuntu Trusty) "3.1.0 daemon infinite loop when no matched user in secrets" [High,Triaged]
16:07 <arosales> but still has a task for Trusty
16:07 <smoser> i can help with sru, and so can other ubuntu devs.
16:07 <arosales> gaughen, smoser: anyone from server on the SRU team this cycle?
16:07 <arosales> smoser: thanks just calling out the ones under the rls server tracking page.
16:08 <arosales> samba bug https://bugs.launchpad.net/ubuntu/+source/samba4/+bug/1308657
16:08 <ubottu> Launchpad bug 1308657 in samba4 (Ubuntu Trusty) "Ubuntu 13.10 to 14.04: failed to upgrade libsmbclient:amd64 with libsmbclient:i386 installed." [High,Triaged]
16:08 <arosales> looks like it is assisgned to Michael Vogt
16:08 <arosales> maas: https://bugs.launchpad.net/maas/+bug/1310844
16:08 <ubottu> Launchpad bug 1310844 in maas (Ubuntu Trusty) "find_ip_via_arp() results in unpredictable, and in some cases, incorrect IP addresses" [High,Triaged]
16:09 <arosales> still needs triaged but kirkland's got a branch out for review.
16:09 <arosales> any maas folks or again ubuntu devs available for a review ?
16:10 <arosales> https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1310846 looks related
16:10 <ubottu> Launchpad bug 1310846 in maas (Ubuntu Trusty) "amt template gives up way too easily" [High,Triaged]
16:10 <arosales> smoser:  gaughen ^
16:10 <lutostag> I guess that might fall into my lap
16:11 <arosales> thanks lutostag
16:11 <arosales> and it looks like jamespag` has https://bugs.launchpad.net/ubuntu/+source/ceph/+bug/1278466 in progress
16:11 <ubottu> Launchpad bug 1278466 in ceph (Ubuntu Trusty) "[FFe] ceph firefly stable release" [High,In progress]
16:11 <matsubara> arosales, that maas bug has been mp'ed and reviewed by gmb here: https://code.launchpad.net/~kirkland/maas/1310844/+merge/216647
16:11 <arosales> so that covers the high/critical bugs under server on the rls tracking page
16:11 <smoser> lutostag, well, first to maas upstream, then back to ubuntu.
16:11 <matsubara> well, still missing tests but gmb is on it, fwiw
16:12 <arosales> ah good to know matsubara, thanks for the info.
16:12 <arosales> any other bugs to discuss?
16:12 <arosales> #subtopic Blueprints
16:12 <arosales> all blueprints are done right :-)
16:13 <arosales> lets see
16:13 <arosales> #link http://status.ubuntu.com/ubuntu-t/group/topic-t-servercloud-overview.html
16:13 <arosales> 84% done
16:14 <arosales> gaughen, smoser should these be deferred, or are folks going to continue working on them until 14.04.1?
16:14 <gaughen> arosales, there are a couple that need updating. smoser for one
16:14 <gaughen> arosales, the ceph tasks are still relevant.
16:14 <arosales> gaughen are you going to be making new blueprints for the u-cycle though
16:14 <gaughen> arosales, yes, we've already started and by we I mean jamespag`
16:15 <arosales> I suspect a lot are still valid, but just wanted to see how server is going to track them
16:15 <arosales> gaughen: so is the plan to defer all t-cycle blueprints as new u-cycle ones are made?
16:15 <gaughen> arosales, we've started making new ones. as the new ones appear we're moving stuff
16:15 <smoser> well, we probably should deferfor process sake.
16:15 <smoser> they can still be worked on, but htere is no poitn in tracking them under T release.
16:16 <arosales> smoser: ack and thanks
16:16 <gaughen> arosales, but like I said the ceph stuff is still open because as soon as they land firefly we'll sru the update in
16:16 <gaughen> smoser, true
16:16 <arosales> #action: team defer t-cycle blueprints. Put relevent tasks into new u-cycle blueprints (note http://status.ubuntu.com/ubuntu-t/group/topic-t-servercloud-overview.html is 84% done)
16:16 * meetingology : team defer t-cycle blueprints. Put relevent tasks into new u-cycle blueprints (note http://status.ubuntu.com/ubuntu-t/group/topic-t-servercloud-overview.html is 84% done)
16:17 <arosales> #topic Server & Cloud Bugs (caribou)
16:17 <arosales> caribou any other bugs to cover?
16:18 <arosales> #topic Weekly Updates & Questions for the QA Team (psivaa)
16:18 <arosales> psivaa: any udpats from QA team
16:18 * arosales suspects folks are resting from release, last week
16:18 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:19 <smb> I have been working on a hot fix for Precise drbd8 today (as always the real test won't happen before production). Can someone have a peek review at the debdiff in https://bugs.launchpad.net/ubuntu/+source/drbd8/+bug/1185756. Two positive testings but maybe we want to wait for the testing of the guy from comment #61 (if that happens) before rushing it out.
16:19 <ubottu> Launchpad bug 1185756 in drbd8 (Ubuntu Precise) "drbd8-utils not compatible with linux-lts-raring kernel in 12.04" [High,Fix released]
16:19 <smb> Apart from that, nothing else if there are no questions.
16:19 <arosales> smoser: ^
16:20 <arosales> smb: also gcc-go wise in trusty these two bugs have been consistantly causing seg faults in juju
16:20 <arosales> #link https://bugs.launchpad.net/ubuntu/+source/gccgo-go/+bug/1275620
16:20 <ubottu> Launchpad bug 1275620 in gccgo-go (Ubuntu) "gccgo-go segfaults, something related to alternatives" [High,Fix committed]
16:20 <arosales> #link https://bugs.launchpad.net/ubuntu/+source/gccgo-4.9/+bug/1304754
16:20 <ubottu> Launchpad bug 1304754 in gccgo-4.9 (Ubuntu) "gccgo on ppc64el using split stacks when not supported" [Medium,Confirmed]
16:20 <arosales> seem to be related
16:20 <smoser> smb, i'll look
16:21 <arosales> #action smoser to review debdiff in https://bugs.launchpad.net/ubuntu/+source/drbd8/+bug/1185756
16:21 * meetingology smoser to review debdiff in https://bugs.launchpad.net/ubuntu/+source/drbd8/+bug/1185756
16:21 <ubottu> Launchpad bug 1185756 in drbd8 (Ubuntu Precise) "drbd8-utils not compatible with linux-lts-raring kernel in 12.04" [High,Fix released]
16:21 <arosales> #link https://bugs.launchpad.net/ubuntu/+source/drbd8/+bug/1185756
16:21 <arosales> smb, if any kernel folks could take a look at those seg faults that would be much appreciated
16:21 <smb> arosales, I will have a look at the go bugs.
16:21 <arosales> smb: thanks
16:21 <arosales> #topic Ubuntu Server Team Events
16:21 <smb> arosales, I have a feeling there were dicussions related at least the the second one
16:22 <arosales> smb: ya the power community is looking into it, but no fixes yet.
16:22 <arosales> Any upcoming server team events?
16:22 <arosales> #topic Open Discussion
16:22 <arosales> Any other topics?
16:23 <psivaa> arosales: sorry missed your ping. nothing from us this week too
16:24 <arosales> psivaa: ack
16:24 <arosales> #topic Announce next meeting date and time
16:24 <arosales> NEXT MEETING: Tuesday 2014-04-29 at 1600 UTC
16:24 <rbasak> Thanks arosales!
16:24 <arosales> thanks for participating folks
16:24 <arosales> #endmeeting