17:02 <czajkowski> #startmeeting
17:02 <meetingology> Meeting started Thu Mar 6 17:02:29 2014 UTC. The chair is czajkowski. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:02 <meetingology>
17:02 <meetingology> Available commands: action commands idea info link nick
17:02 <dholbach> kees, mdeslaur, slangasek, stgraber: around?
17:02 <czajkowski> #topic catch up with the Tech Board.
17:02 <slangasek> dholbach: on the phone, but meaning to be around
17:02 <mdeslaur> sure, I'm here
17:03 <czajkowski> slangasek: mdeslaur howdy folks
17:03 <slangasek> heya
17:03 <mdeslaur> hi
17:03 <czajkowski> So how are things in the TB going ?
17:03 <czajkowski> care to give us an update ?
17:03 * pitti waves hello
17:04 <slangasek> seems pretty low-key, really
17:04 <slangasek> not much demand for our services :-)
17:05 <pitti> I joined a few mins late, was there any question to the TB already?
17:05 <dholbach> for those of you who haven't been around in the last meeting - the CC catches up with governance and community teams as part of our meeting to see how things are going and to have a look at "operations" from a bit of a distance :)
17:05 <pitti> ah
17:05 <dholbach> pitti, just generally asking how things have been going :)
17:05 <pitti> well, we actually skipped the last few meetings due to not having any agenda
17:05 <pitti> on the meetings we did have, things are usually going well, the biggest recent hiccup was the late re-election of the TB itself
17:06 <pitti> but the day-to-day business is usually MREs and the like
17:06 <dholbach> so the new TB members have settled in well in their low-key new activity? :)
17:06 <czajkowski> pitti: yes we are sorry about that
17:06 <pitti> it's been a while since we have had a long and difficult technical discussion
17:06 <pleia2> o/
17:06 <pitti> czajkowski: no worries, nobody's fault in particular
17:06 <czajkowski> and hopefully we won't let it go that late again, the issues there was so many boards expiring at the same time, including the CC.
17:06 <czajkowski> is it worth having a meeting even when there is a blank agenda so people can catch up
17:07 <YokoZar> pitti: This is perhaps due to the LTS nature of Trusty making all reasonable decisions of this nature done well in advance, yes?
17:07 <czajkowski> does the community know they can reach out to the TB ?
17:07 <pitti> we used to have a lot more topics, but that was in the days when ubuntu was driven a lot more by UDSes and community
17:07 <dholbach> so when there's been long discussions and difficult decisions, how did you feel it generally went?
17:07 <pitti> and also because there is not that much major change going on in the non-phone-y bits
17:07 <pitti> YokoZar: yeah, that too
17:08 <pitti> dholbach: as they should go, really; I remember discussions like "should we install binary drivers by default", the OpenSSL vs. GPL debate, etc.
17:08 <czajkowski> pitti: so how do you feel it is driven now considering we have online uds
17:08 <pitti> we had a thorough discussion, voting, annoucned it to the devel crowd, and there generally hasn't been any negative feedback about those
17:08 <czajkowski> which is great to see
17:09 <dholbach> pitti, sure - I was just wondering if you were happy with that kind of discussions (so no major delays, everyone weighing in, decision making process is sufficiently refined, etc.)
17:09 <pitti> dholbach: oh yes; we could have had some speedier discussions for sure, but that's just the nature of timezones and (often) email-based communication, so not much to complain from my side
17:10 <czajkowski> nods
17:10 <dholbach> cool
17:10 <YokoZar> We put the TB on a 2 year cycle as well as the CC, do you guys feel it's correct for them to be replaced mid-way through an LTS cycle or should we move the elections to, say, just after the next LTS release rather than a few months before?
17:10 <dholbach> I guess that's similar for the CC as well :)
17:10 <pitti> czajkowski: as I said, the desktop/server bits don't have a lot of structural change these days, so nothing that bubbles up to the TB
17:10 <YokoZar> (we had a similar argument ~ the CC itself)
17:10 <pitti> what I am missing a bit is to discuss technical architecture of the phone
17:11 <czajkowski> pitti: ah interesting
17:11 <czajkowski> where does that currently take place?
17:11 <dholbach> pitti, do you have an example of what you feel would have warranted a discussion with the TB?
17:11 <pitti> there's the ubuntu-phone@ ML and such
17:11 <dholbach> (just to get an idea)
17:11 <pitti> and most of the design decisions etc. are just fine
17:12 <pitti> the main thing that comes to my mind is that in retrospect we should have discussed how to build the image-based upgrades without breaking /etc/ so hard
17:12 <czajkowski> pitti: so you're saying you agree with them, but you'd like to see the TB perhaps involved more in the discussion or be involved more ?
17:12 <pleia2> pitti: any thoughts from the tb regarding the init system stuff? (mark kind of announced it after debian made their decision "pending community discussion")
17:12 <pleia2> seems like something the tb should have weighed in on first
17:12 <pitti> pleia2: ah, I deliberately didn't bring that up -- but yes, that'll most certainly be a bigger discussion that comes in the next cycle :)
17:13 * pleia2 troublemaker :)
17:13 <pitti> pleia2: well, we will
17:13 * pleia2 nods
17:14 <dholbach> to be fair, Mark said "I will ask the Ubuntu tech board (many of whom do not work for Canonical) to review the position" :)
17:14 <pleia2> yeah
17:14 <pitti> czajkowski: yes, but this is the main issue I have really; and it's always easy to say in hindsight "we should have discussed that more", but not that easy to plan in advance
17:14 <dholbach> but yeah :)
17:15 <pitti> czajkowski: so I don't want to stress that too much really; but I think we need a version 2 of that, and thus maybe the TB is a good forum to discuss that new design
17:15 <pitti> but yeah, in general I think it's working ok
17:15 <czajkowski> pitti: I agree
17:15 <czajkowski> so perhaps this is something we can raise and see if we can drive some discussion over to yo folks to get your experience in
17:15 <dholbach> how much of the discussion happens on the mailing list and how much in meetings? do non-TB members weigh in as well?
17:16 <czajkowski> and ask dholbach pointed out sabdfl did say he would ask the TB
17:16 <pitti> pleia2: I'm sure cjwatson and slangasek have a super-huge desire to discuss upstart vs. systemd soon :-) (it's not like they wasted many months of their lifetime thinking about it already..)
17:16 <mdeslaur> hehe
17:16 <pleia2> pitti: yeah, I followed the debian discussions
17:16 <pitti> dholbach: historically, most in meetings due to the synchronous nature
17:17 <pitti> dholbach: these days, small things like MRE requests or the LTS lifetimes are happening mostly over email as that's more practical
17:17 <pitti> dholbach: and yes, we have non-TB members posting to the list
17:17 <dholbach> yeah, that makes perfect sense
17:17 <cjwatson> pitti: it's on the vUDS schedule I believe
17:17 <pitti> cjwatson: ah, "fun" :)
17:17 <pleia2> cjwatson: ah, great
17:18 <sabdfl> hi all, sorry to be late
17:19 <dholbach> so it sounds like the TB processes are well-oiled machinery... is there anything which has been on your collective minds to be changed at some stage? or things which have repeatedly been put on the backburner?
17:19 * pitti scratches head, nothing comes to my mind from the last 2 years really
17:19 <dholbach> even better :)
17:19 <YokoZar> I'll reraise my question from earlier, as I believe it got skipped: We put the TB on a 2 year cycle as well as the CC, do you guys feel it's correct for them to be replaced mid-way through an LTS cycle or should we move the elections to, say, just after the next LTS release rather than a few months before?
17:20 <pitti> I think the OpenSSL vs. GPL debate came up several times
17:20 <pleia2> oh, so the CC kept having meetings that had no agenda for a while, which is when we started doing these check-ins, I wonder if something similar might be useful for TB and dev teams?
17:20 <slangasek> YokoZar: I have no strong opinion on this... more important is to not leave a gap, as we did last fall
17:20 <pitti> YokoZar: ah, I didn't think that was aimed at TB; as the elections were supposed to happen much much earlier, it would have even been during saucy I believe
17:21 <YokoZar> Right around saucy release
17:21 <YokoZar> was original schedule I think
17:21 <pleia2> yeah
17:21 <pitti> YokoZar: I actually think it's quite a good time, as traditionally during the LTS cycles there's not that much to decide
17:22 <YokoZar> pitti: hypothetically, though, if we replace the entire board it might make a bunch of new decisions
17:22 <czajkowski> pitti: thanks for the udpate this has been great to her and nice to see a healthy TB
17:22 <czajkowski> pleia2: indeed and I wondered if doing somehting similar for the TB would be useful for them to get to have more discussion here
17:23 <czajkowski> YokoZar: same could be said for any board at any given time tbh
17:23 <pitti> YokoZar: yes, but that could happen at any point?
17:23 <YokoZar> czajkowski: pitti: for sure, but would it be "less bad" after an LTS rather than before?
17:23 <pitti> so yes, if we elect a board that makes silly decisions, something went wrong before that
17:23 <pitti> YokoZar: yes, perhaps
17:23 <dholbach> did anyone see pleia2's question? I personally think it might be worth trying
17:24 <pitti> YokoZar: but then a new board would actually be thrown into a time when there's potentially many discussions to make, which might be more overwhelming for new members?
17:24 <czajkowski> pitti: mdeslaur slangasek how about whe you've a blank agenda, still having a meeting
17:24 <czajkowski> so people can see a discussion and join
17:24 <czajkowski> we've started doing this and it's been very useful
17:24 <mdeslaur> that's what we've done so far
17:25 <YokoZar> Not sure how frequent it is for "lay folk" to pop into TB meetings and raise an issue, but it does happen with CC meetings from time to time
17:25 <czajkowski> or you could arrange a catch up wth groups the tb has an interst in
17:25 <pitti> we usually do
17:25 <pitti> wait a bit
17:25 <pitti> then say "nothing to discuss" and end it again
17:25 <pitti> YokoZar: it does happen quite often; in fact that's the norm, as these days the TB rarely raises issues by themselves
17:25 <pitti> i. e. someone adds an agenda item and then usually appears in the meeting
17:26 <dholbach> great - as others have said... I'm quite happy with how the TB is working - I'm done with questions :)
17:26 <dholbach> keep up the good work everyone! :)
17:26 <YokoZar> pitti: so perhaps around a time when it's too late to reasonably change things in the LTS cycle, but before hecticness of post-release. Like around the next UDS we're having.
17:26 <pleia2> thanks pitti :)
17:26 <YokoZar> What if elections were considerably before terms starting?
17:26 <pitti> YokoZar: yeah, sounds good
17:27 <YokoZar> Like we vote around now, and incoming members start their term after LTS release
17:27 <pitti> YokoZar: I don't like that very much, I must say; I think it's good for the old board to have a last meeting after the election to hand over, but not much more
17:27 <pitti> but I don't have a strong opinion on that
17:28 <YokoZar> Relatedly, I am encouraged by the lack of strong opinions regarding our election rules, it means our politics aren't particularly "politics" ;)
17:28 <czajkowski> any other questions folks before we wrap up
17:28 * sabdfl is still reading the scrollback
17:28 <pitti> YokoZar: or that things are mostly going well and all that's left to do is finetuning :)
17:28 <czajkowski> YokoZar: you just like running polls! admit it :P
17:30 <YokoZar> This is not an "admission" any more than one confesses to liking the sunrise
17:30 <pleia2> hehe
17:32 <sabdfl> regarding init
17:32 <sabdfl> if the TB has a strong opinion different to the broad roadmap of "adopting systemd on an appropriate schedule" then i'm very open to hearing it
17:33 <pitti> sabdfl: probably the wrong place here, but FWIW, I agree to you
17:34 <pitti> sabdfl: seeing how much recent action there is in Debian towards adding native systemd packagse to stuff, I think in a year or so we'll have this robust enough
17:34 <pitti> sabdfl: with RHEL7 moving to systemd the server world ought to catch up quickly
17:34 <sabdfl> my commentary was not to subvert the TB, but to express that there is no ideological attachment to code that 'belongs' to Canonical
17:34 <pitti> the desktop world pretty much worked two years ago already, but our concern was the server back then
17:34 <sabdfl> we'll move where works best, and i trust the TB to map that out
17:34 <pitti> so for me it's not a question of "if", but "when/how"
17:35 <YokoZar> So, not understanding much of ubuntu-phone, how specific are the phone-related technical decisions that we can expect in the future?
17:35 <pitti> as long-term it seems much better to follow Debian than eternally diverging
17:35 <pitti> YokoZar: they are actually meant to become less and less phone specific over time
17:35 <pitti> YokoZar: "convergence"
17:35 <slangasek> pitti: I don't believe that RHEL7 is doing anything that we'll significantly be able to leverage; too much of this is integration work which doesn't translate
17:36 <slangasek> but I'm not sure the CC meeting is the place to have this discussion :)
17:36 <pitti> YokoZar: i. e. the phone is by and large a playground (excuse the wording, sabdfl) for trying out new technology like upgrades or display server
17:36 <pitti> without the need for backwards compat
17:36 <YokoZar> Yes, I imagined that was the eventual goal of any reasonable implementation.
17:36 <YokoZar> I would hope phone would soon be "absorbed" into the rest of Ubuntu governance smoothly
17:36 <pitti> YokoZar: yes, AFAIUI that's the plan
17:37 <sabdfl> this was a particularly difficult thing to watch unfold, since in a sense we were never consulted on an issue with major consequences for us, and we're a member of the family
17:37 <sabdfl> but then, some would argue we had great representation at the table, only wearing different hats
17:37 <sabdfl> nothing more from me, thanks TB for checking in
17:37 <pitti> the phone has laid a lot of new approaches to both technology (like Mir) and methods (like CI)
17:37 <YokoZar> And, say, phone community == ubuntu community and phone tech decisions == ubuntu tech decisions with the same relevant governance
17:37 <pitti> and they are certainly meant to be used on desktop in the future as well
17:38 <pitti> in practice they are still quite separated these days, but I think that's mostly due to the LTS
17:38 <pitti> e. g. we can't/shouldn't land things like Mir/Unity 8 now
17:38 <pitti> and likewise can't turn our upgrade mechanics upside down now
17:39 <czajkowski> pitti: I like those honest decisisons where we admit things aren't ready even when we wish they were
17:39 <YokoZar> Do you think the archive itself might continue some of this delta? I vaguely worry about a future where we have, say, the arm arch for desktop packages have a lot of phone-specific deltas with a separate decision tree from the rest of the distro
17:40 <czajkowski> any other comments folks before we wrap it up
17:40 <mdeslaur> there is no archive delta for the phone at the moment
17:40 <dholbach> YokoZar, that sounds like a summary for the work leading up to the next LTS - bringing unity8 to the desktop and making the convergence happen :)
17:40 <mdeslaur> it's just using a different version of unity
17:41 <pitti> YokoZar: yes, it's less along the lines of architecture and more of package selection
17:41 <pitti> unity8-desktop-session-{mir,x11} in trusty :)
17:41 <pitti> I expect that to become the default soon
17:41 <pitti> i. e. convergence to make a leap in 14.10
17:41 <YokoZar> mdeslaur: Right, and perhaps if we do convergence especially "wrong" in the future we might have different versions of a lot of things on phone vs desktop
17:42 <pitti> sabdfl: btw, any chance we can get the u name before the release? it's needed in a couple of places, and last time we had to do a number of SRUs due to that
17:42 <YokoZar> ugh
17:42 <YokoZar> I'll follow up with him (he left)
17:42 <YokoZar> Though
17:42 <YokoZar> I have hounded him with that question before
17:42 <pitti> ah
17:42 <YokoZar> I suspect hearing it from the TB as well might help
17:43 <czajkowski> ok thanks folks
17:43 <dholbach> thanks a lot everyone!
17:43 <mdeslaur> thanks!
17:43 <pitti> thanks everyone!
17:43 <YokoZar> Mark WILL delay the full name as long as possible for marketing/other purposes though
17:43 <YokoZar> Thank you folks
17:44 <dholbach> Do we have any other business?
17:44 <czajkowski> #action YokoZar Mail Mark re U name for the TB to use for opening up next release
17:44 * meetingology YokoZar Mail Mark re U name for the TB to use for opening up next release
17:44 <czajkowski> #endmeeting