16:32 <jdstrand> #startmeeting
16:32 <meetingology> Meeting started Mon Jan 13 16:32:21 2014 UTC. The chair is jdstrand. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:32 <meetingology>
16:32 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:32 <jdstrand> The meeting agenda can be found at:
16:32 <jdstrand> [LINK] https://wiki.ubuntu.com/SecurityTeam/Meeting
16:32 <jdstrand> [TOPIC] Weekly stand-up report
16:32 <jdstrand> I'll go first
16:32 <chrisccoulson> hi!
16:32 <jdstrand> I'm on triage this week
16:33 <jdstrand> I'm working on several updates: openjdk-7 will either go out today or tomorrow. unfortunately, upstream dropped some arm assembly bits so the update wil regress on performance for arm
16:34 <jdstrand> I'll do an SRU if they add them back, but I'm not particularly worried at this point because even with the assembly bits, the performance is not great
16:34 <mdeslaur> nothing much we can do about that
16:34 <jdstrand> (ie, I don't think there is much performance sensitive openjdk arm out there)
16:34 <jdstrand> yeah
16:35 <jdstrand> I'm also working on openstack. I got slowed down a bit last week cause I had to start writing patches
16:35 <jdstrand> I've also got work items as time allows
16:35 <jdstrand> mdeslaur: you're up
16:35 <mdeslaur> I'm on community this week
16:35 <mdeslaur> I'm currently testing some updates
16:35 <mdeslaur> I'll be releasing memcached this afternoon
16:36 <mdeslaur> and have a couple more lined up, and will continue going down the list, etc.
16:36 <mdeslaur> that's it!
16:36 <mdeslaur> sbeattie: you're yp
16:36 <sbeattie> I'm on apparmor this week
16:37 <sbeattie> I need to do a bit more prep before discussing the userspace dfa stuff with jjohansen
16:37 <sbeattie> I also need to do a bit of prep before the upstream meeting this week.
16:37 <sbeattie> as well as continue the ongoing testing work and review of patches
16:37 <sbeattie> that's it for me, tyhicks?
16:38 <tyhicks> I'm preparing an apparmor trusty upload right now with dbus eavesdropping policy support and a stack of parser improvements from sbeattie and jjohansen
16:38 <tyhicks> after that, I'll go back to kdbus
16:39 <tyhicks> I need to triage a couple ecryptfs bugs this week
16:39 <tyhicks> I've got a few other work items that I sprinkle in as time permits, but I'm not sure what I'll get to
16:39 <tyhicks> that's it for me
16:40 <tyhicks> jjohansen: you're up
16:42 <jjohansen> I'm working on apparmor again this week. I've got some dfa test coordination with sbeattie, some upstream meeting prep to do, a bug to look at (sorry need to did the # back out), and more revisions on the ipc and stacking work
16:44 <jjohansen> thats it for me
16:44 <jjohansen> sarnold: your up
16:45 <sarnold> I'm in the happy place this week, though I've got some leftover bits of community that I didn't finish last week that I'll get to this week -- typo3-src, wireshark, and libotr2 updates
16:46 <sarnold> I've also got a MIR for beanstalk, currently that's blocking progress elsewhere, so that'll be a top priority this week
16:46 <jdstrand> sarnold: fyi, currently it ftbfs according to foundations)
16:46 <sarnold> if there's time left over it'd be nice to get caught up on apparmorpatches again
16:46 <sarnold> jdstrand: oh that could complicate things :) thanks
16:47 <jdstrand> I think it got reassigned to the server team
16:47 <jdstrand> anyhoo, it's all in the bug
16:47 <sarnold> anyway I think that's it for me, chrisccoulson?
16:48 <chrisccoulson> i'm working on oxide this week ;)
16:48 <chrisccoulson> i've uploaded builds here now - https://launchpad.net/~phablet-team/+archive/ppa, although there's a couple of problems with these
16:49 <chrisccoulson> (all builds crash if the egl libs aren't installed, and there's another runtime link error with the arm build)
16:49 <chrisccoulson> should be fixed by http://bazaar.launchpad.net/~oxide-developers/oxide/oxide.trunk/revision/305 though
16:49 <jdstrand> chrisccoulson: oh, both?
16:49 <chrisccoulson> jdstrand, both issues? i'm currently working on the other one
16:50 <jdstrand> chrisccoulson: ie, after r305 is built, then we'll have armhf builds?
16:50 <jdstrand> I see
16:50 <chrisccoulson> jdstrand, hopefully. i'm pretty determined to have a working arm build by tomorrow :)
16:50 <jdstrand> that would be awesome :)
16:50 <chrisccoulson> and then i shall be able to carry on with my other tasks
16:50 <chrisccoulson> oh, i spent friday afternoon investigating bug 1267893. that was fun ;)
16:50 <ubottu> bug 1267893 in Oxide "Shutdown crash due to possible mesa race at startup" [Critical,Triaged] https://launchpad.net/bugs/1267893
16:51 <chrisccoulson> i think that's me done
16:52 <jdstrand> [TOPIC] Highlighted packages
16:52 <jdstrand> The Ubuntu Security team will highlight some community-supported packages that might be good candidates for updating and or triaging. If you would like to help Ubuntu and not sure where to start, this is a great way to do so.
16:52 <jdstrand> See https://wiki.ubuntu.com/SecurityTeam/UpdateProcedures for details and if you have any questions, feel free to ask in #ubuntu-security. To find out other ways of helping out, please see https://wiki.ubuntu.com/SecurityTeam/GettingInvolved.
16:52 <jdstrand> http://people.canonical.com/~ubuntu-security/cve/pkg/ircd-hybrid.html
16:52 <jdstrand> http://people.canonical.com/~ubuntu-security/cve/pkg/dcraw.html
16:52 <jdstrand> http://people.canonical.com/~ubuntu-security/cve/pkg/znc.html
16:52 <jdstrand> http://people.canonical.com/~ubuntu-security/cve/pkg/libtar.html
16:52 <jdstrand> http://people.canonical.com/~ubuntu-security/cve/pkg/python-virtualenv.html
16:52 <jdstrand> [TOPIC] Miscellaneous and Questions
16:53 <jdstrand> So, now that we've settled in after being away for the holidays, I was curious about the status of our major work
16:54 <jdstrand> chrisccoulson: based on what you just said, it sounds like we'll have armhf builds this week (awesome). That should unblock that work for everyone, correct? can you comment on when you think benchmarking, CI and uploads to Ubuntu will happen?
16:56 * jdstrand notes that feature freeze is Feb 20th, and our oxide and apparmor work fall under that
16:57 * jjohansen runs screaming back to bed
17:01 <jdstrand> ok, we'll come back to chrisccoulson later
17:01 <chrisccoulson> oh, sorry, i was talking in another channel
17:01 <chrisccoulson> armhf builds this week - yes
17:01 <chrisccoulson> uploads to ubuntu - i'm waiting on qt5.2 landing for that
17:02 <chrisccoulson> CI - i need to respond to an email for that actually :)
17:02 <chrisccoulson> and benchmarking can start whenever i guess
17:03 <jdstrand> chrisccoulson: once the armhf builds work-- can you run the benchmarks on armhf for oxide and qtwebkit and send them to the the phablet list? (phablet because the builds aren't in a public ppa yet)
17:04 <chrisccoulson> jdstrand, sure, no problem
17:04 <jdstrand> chrisccoulson: the test-oxide click package has the links to some identified benchmark testsuites from conversations from months ago
17:05 <jdstrand> so I think it is just a matter of installing that and clicking on the links
17:05 <jdstrand> chrisccoulson: thanks
17:05 <jdstrand> [ACTION] chrisccoulson to benchmark oxide and qtwebkit once armhf builds work
17:05 * meetingology chrisccoulson to benchmark oxide and qtwebkit once armhf builds work
17:05 <jdstrand> [ACTION] chrisccoulson to send results of benchmarks to list
17:05 * meetingology chrisccoulson to send results of benchmarks to list
17:06 <jdstrand> tyhicks: as for apparmor and the emulator-- your apparmor upload you are preparing-- is that all that is needed to turn on apparmor in the emulator?
17:06 <tyhicks> jdstrand: yes, that should be all that is needed
17:07 <tyhicks> (obviously, there will be one other upload to remove the apparmor=0 from the boot args)
17:07 <jdstrand> yeah
17:07 <jdstrand> thanks
17:08 <jdstrand> tyhicks: what is the status of the yama work?
17:09 <tyhicks> jdstrand: the work itself is all done - I have been trying to find a way to run the autopilot tests with yama enabled
17:09 <tyhicks> jdstrand: I saw an email to the phone list last week that said that the autopilot tests now pass in the emulator, so that's promising
17:10 <jdstrand> tyhicks: you might coordinate with xnox (he has been working on emulator working with autopilot) and perhaps sergiusens and/or the qa team
17:10 <jdstrand> yeah
17:11 <jdstrand> tyhicks: you mentioned the kdbus investigation will be picked up again this week. I'm guessing there isn't anything new to report since the last meeting on it?
17:12 <tyhicks> jdstrand: no, nothing really new at the moment
17:12 <jdstrand> ack
17:14 <jdstrand> jjohansen, sbeattie: I've seen lots of patches on different apparmor related items (which is great! the parser improvements in particular are going to really help the emulator work) but I'm not clear on the status of ipc and stacking. aiui from previous meetings, ipc should land first, with stacking later.
17:15 <jdstrand> jjohansen, sbeattie: I know sbeattie is working on testing, etc to support jjohansen's work-- how are we on ipc? on stacking?
17:15 <jjohansen> jdstrand: they are in the your machine will die in a firey oops state atm
17:15 <jdstrand> (for the feature and its testing)
17:17 <jjohansen> jdstrand: I am trying to get something up to a ppa this week but, there is no point if you can't even boot it
17:17 <jdstrand> jjohansen: ok. so, are these just bugs (that granted, may take some time to fix) or is it more than that? (eg, design, implementation, etc to be done)
17:18 <jjohansen> there is design iteration and some implementation to be done
17:18 <jdstrand> ok. ack on not uploading broken stuff to the ppa
17:18 <jdstrand> thanks for the updates
17:19 <jdstrand> Does anyone have any other questions or items to discuss?
17:23 <jdstrand> mdeslaur, sbeattie, tyhicks, jjohansen, sarnold, ChrisCoulson: thanks!
17:23 <jdstrand> #endmeeting