22:00 <pleia2> #startmeeting
22:00 <meetingology> Meeting started Fri Dec  6 22:00:15 2013 UTC.  The chair is pleia2. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:00 <meetingology> 
22:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
22:00 <godbyk> Hello, everyone.
22:00 <pleia2> #chair godbyk
22:00 <meetingology> Current chairs: godbyk pleia2
22:00 <dsmythies> Hello.
22:00 * belkinsa is here for the meeting
22:00 <knome> o/
22:00 <GunnarHj> me to
22:01 <GunnarHj> o
22:01 <pleia2> #link https://wiki.ubuntu.com/DocumentationTeam/MeetingAgenda
22:01 <pleia2> meeting agenda :)
22:01 <knome> pleia2, pure links are #linkified without #link
22:01 <pleia2> dsmythies: ok to start off with your items from the blueprint?
22:01 <pleia2> #chair dsmythies
22:01 <meetingology> Current chairs: dsmythies godbyk pleia2
22:02 <pleia2> knome: neat
22:02 <eagles0513875> hey all :)
22:02 <eagles0513875> hey belkinsa
22:03 <pleia2> #topic Inter-group collaboration / cooperation
22:03 <eagles0513875> hey pleia2
22:03 <pleia2> so if everyone wants to browse to the blueprint: https://blueprints.launchpad.net/ubuntu/+spec/community-1311-docteam-roundtable
22:03 <pleia2> dsmythies left a bunch of comments on this topic :)
22:03 <pleia2> eagles0513875: welcome to the meeting!
22:04 <pleia2> there was a possible solution and a work around for the translations workflow that currently leaves the server docs behind, any comments?
22:04 <dsmythies> I am looking for help with this one: "For the DeskTop help documentation, there is a jpeg file that includes the entity of the release name. This file has not been updated since Quantal, because nobody in the doc team knows the procedure. "
22:05 <knome> is it used anywhere?
22:05 <pleia2> (I don't really know much about translations, so I don't really understand the workings here)
22:05 <pleia2> dsmythies: I can take an action item to figure that out
22:06 <godbyk> dsmythies: Which file is it?
22:06 <dsmythies> O.K. thanks.
22:06 <pleia2> #action pleia2 to figure out where the release name jpg comes from
22:06 * meetingology pleia2 to figure out where the release name jpg comes from
22:06 <dsmythies> I supply the file name in a moment...
22:06 <pleia2> thanks :)
22:07 <knome> aiui, the "workaround" mentioned in the blueprint is *the* solution
22:07 <godbyk> dsmythies: ./ubuntu-help/C/figures/ubuntu-quantal.jpg?
22:07 <knome> you *need* to update the package from project at doc string freeze
22:07 <knome> though the translations could be done against the product
22:08 <godbyk> https://help.ubuntu.com/13.10/ubuntu-help/figures/ubuntu-quantal.jpg
22:08 <knome> which would mean translators could start working on the translations as soon as the strings change in the product
22:08 <knome> then all of that would be pushed in the package (at least on the translation freeze)
22:09 <dsmythies> ./ubuntu-help/C/figures/ubuntu-quantal.jpg? yes. thanks.
22:09 <dsmythies> you *need* to update the package from project at doc string freeze: Yes, thanks.
22:10 <knome> (and/)or the translation string freeze, if the translations are done against the project
22:11 <GunnarHj> Could the package be updated more frequently, to make it easier for the translators, and also make it easy for everyone to follow the progress with the docs?
22:11 <knome> if the translations are done against the project, there is no reason why it couldn't be done with every push
22:12 <knome> as long as people update the .pot file(s)
22:12 <dsmythies> I could update help.ubuntu.com more often if people want.
22:13 <dsmythies> We don't typically update the .pot file often.
22:13 <knome> that would be the solution though
22:13 <belkinsa> May I ask what is a .pot file is?
22:13 <knome> belkinsa, a translation template file
22:13 <belkinsa> Thank you.
22:13 <godbyk> belkinsa: It's the 'translation template' file. It contains the list of text that the translations should translate.
22:14 <knome> the issue with updating the .pot file often is that people who are translating actively might translate many strings that are dropped from the final version as further fixes and additions are made
22:15 <knome> the issue with not updating the .pot file often is that a lot of new strings become translatable at the same time
22:15 <knome> and it might be a burden that the translators can't handle, especially if that happens really close to the release
22:16 <GunnarHj> knome: The sooner we do our part, the better - still applies, right?
22:16 <knome> sure
22:16 <dsmythies> I agree, but tranlations drag on, and we want to be able to publish later trnalations without folding back in a new .pot file, if possible.
22:17 <pleia2> yeah, the docs evolve through the cycle so we don't want people translating *similar* strings 5 times because we keep changing wording
22:17 <pleia2> I believe strings that remain between releases remain translated, right?
22:17 <GunnarHj> pleia2: But, to be honest, how often does that happen?
22:17 <godbyk> That's the basic reason why we have a string freeze.
22:17 <knome> one of the things you can do is keep reviewing the strings before they land in the docs to make sure they are of high quality and do not need changing
22:17 <knome> pleia2, yes.
22:18 <pleia2> GunnarHj: historically, not often because there was one guy working on docs :) but we're reviving the team
22:18 <GunnarHj> pleia2: Ok, point taken. ;-)
22:18 <knome> documentators should take care of their wording.
22:18 <knome> if they mess it up, that's too bad, but it shouldn't happen again and again
22:18 <pleia2> GunnarHj: it may be a non-issue, but I just don't know yet
22:19 <knome> you probably want to talk with the translators to hear what they think
22:19 <dsmythies> O.K., lets move on.
22:19 <belkinsa> I agree on that.
22:19 <knome> they might either appreciate all-at-once or do not mind about having to translate certain strings multiple times
22:20 <pleia2> do we want to talk about upstream issues? (see the blueprint)
22:20 <godbyk> Upstream issues referring to gnome-docs or something else?
22:20 <pleia2> "During the 13.10 cycle, the docs (both the serverguide and Ubuntu DeskTop help) uncovered a number of issues where the root causes are really upstream GNOME yelp issues."
22:20 <pleia2> etc
22:20 <pleia2> so I'm thinking yes :)
22:20 <godbyk> pleia2: Ah! Gotcha.
22:21 <godbyk> Yeah, one problem we encountered early on was that some docs have conditional text in them.
22:21 <dsmythies> Yesm gnome stuff. I think Shaune McCance
22:21 <godbyk> The text varies depending on if you view the docs in Unity or GNOME Shell or LXDE, etc.
22:21 <knome> Comment from Little Girl with my apologies if this is in the wrong place - feel free to delete or move it (2013-11-03): ...
22:21 <knome> see the blueprint! :)
22:21 <godbyk> And there was a bug where the Yelp app wouldn't detect Unity properly.
22:21 <godbyk> So it'd always display GNOME Shell docs instead of Unity docs.
22:22 <GunnarHj> Has anyone filed a yelp bug?
22:22 <godbyk> I think we got the Unity bug patched and fixed, however. Did that patch make its way into the 13.10 repositories, dsmythies? Or were there other Yelp issues, too?
22:22 <pleia2> knome: ah yes! good catch, LittleGirl chatted with Shaun
22:22 <godbyk> GunnarHj: I filed the one about Unity (along with a patch).
22:22 <dsmythies> Yes, I filed upstream bug reports
22:22 <pleia2> bottom of blueprint whiteboard
22:23 <dsmythies> One upstream bug is fixed, but the fixed has yet to propagate down.
22:24 <GunnarHj> Not much more to talk about now then, or?
22:24 <godbyk> Okay. Who do we pester to get it propagated down?
22:25 <dsmythies> I do not know, and am not certain that is hasn't. I don't know what revision number to look for.
22:27 <godbyk> dsmythies: Ah, I found the upstream bugs you sent me in an email:
22:27 <godbyk> https://bugzilla.gnome.org/show_bug.cgi?id=709951
22:27 <godbyk> https://bugzilla.gnome.org/show_bug.cgi?id=709943
22:27 <godbyk> https://bugzilla.gnome.org/show_bug.cgi?id=709941
22:27 <ubottu> Gnome bug 709951 in yelp-build "yelp build ignores conditionals when creating file copy list" [Normal,Resolved: fixed]
22:27 <ubottu> Gnome bug 709943 in DocBook "yelp-xsl/xslt/common/html.xsl missing a fundamental docbook tag conversion" [Normal,Unconfirmed]
22:27 <ubottu> Gnome bug 709941 in yelp-build "html looks for yelp-code.png which is not there" [Normal,Unconfirmed]
22:27 <GunnarHj> Robert Ancell seems to have updated yelp (ubuntu) with upstream news lately.
22:27 <godbyk> I'll take a look at those again.
22:28 <dsmythies> 709943 has a workaround.
22:28 <dsmythies> 709941 is not the end of the world.
22:29 <dsmythies> godbyk: If you could help woth communications with Shaun? He seems to help from the gnome side sometimes.
22:30 <godbyk> dsmythies: Yeah, I'll get into it.
22:30 <dsmythies> Thanks.
22:30 <pleia2> \o/
22:31 <pleia2> ok, I think that's it for the blueprint topics, looks like we talked about the others during the vuds session
22:31 <pleia2> #topic What's new - should cover 12.04->14.04 (GunnarHj)
22:32 <pleia2> GunnarHj: can you share some thoughts here?
22:32 <GunnarHj> I think that most people stick with LTS, so it would make sense that the "What's new" page covers everything since last LTS.
22:32 <godbyk> dsmythies: You can find a yelp-code.png file at /usr/share/yelp-xsl/icons/hicolor/watermarks/yelp-code.png provided by the yelp-xsl Ubuntu package. (Just FYI.)
22:33 <pleia2> GunnarHj: yeah, that makes sense
22:33 <GunnarHj> That's the whole point from my side. ;-)
22:33 <godbyk> We could split it into two sections, too. "Since [previous LTS]" and "Since [previous release]".
22:33 <pleia2> godbyk: yeah
22:34 <belkinsa> That works.
22:34 <GunnarHj> godbyk: +1
22:34 <dsmythies> godbyk: I know, but we don't actually want a watermakr at all.
22:34 <pleia2> #topic Sync with gnome-user-docs early
22:34 <knome> dsmythies, add an empty png
22:34 <godbyk> dsmythies: Ah, okay. I see what you're saying then.
22:34 <dsmythies> I did, last cycle.
22:35 <GunnarHj> Me again... I think we should do that sync as early as possible, so we then have sufficient time to review the result and finalize ubuntu-docs.
22:35 <godbyk> GunnarHj: +1
22:35 <dsmythies> +1
22:35 <godbyk> Last cycle we didn't even finish syncing. :-(
22:35 <GunnarHj> There is no reason to fear very much late GNOME changes anyway.
22:36 <belkinsa> GunnerHj: +1
22:36 <pleia2> hooray, consensus :)
22:36 <godbyk> GunnarHj: Especially since I think we may be lagging behind a GNOME release for 14.04.
22:36 <GunnarHj> godbyk: Precisely
22:36 <knome> no, Trustily
22:37 <pleia2> do we want to decide upon a date (or month) for this?
22:37 <pleia2> knome :P
22:37 <knome> ASAP = now?
22:37 <GunnarHj> knome: +1
22:37 <godbyk> Do you know which version of GNOME we're using for 14.04?
22:37 <godbyk> (Not that I expect it'll change things too much for us anyway...)
22:38 <GunnarHj> Mostly 3.8, but as regards gnome-control-center, which heavily affects the docs, 3.6.
22:38 <godbyk> GunnarHj: Okay, thanks.
22:38 <dsmythies> End of January target?
22:39 <godbyk> dsmythies: Seems reasonable.
22:39 <godbyk> Then we can start modifying everything that's Ubuntu-specific.
22:39 <pleia2> ok great
22:39 <pleia2> #topic Community Help Wiki (knome)
22:39 <pleia2> https://help.ubuntu.com/community/FrontPageRefresh
22:39 <pleia2> ooh pretty :)
22:40 <knome> yep, i've worked on that for a replacement for the community help wiki
22:40 <belkinsa> It's cleaner for sure.
22:40 <GunnarHj> Indeed great work so far. :)
22:40 <knome> in addition, i've created https://help.ubuntu.com/community/OtherResources (WIP) for the purposes of replacing the signpost
22:41 <knome> all feedback is welcome.
22:41 <belkinsa> I think the Other Resources page is a better choice then that signpost, since it lists the links that people may be looking form
22:41 <belkinsa> for*.
22:42 <knome> it doesn't need to be an exhaustive list of all URLs in the internet
22:42 <knome> just some of the most used/useful ones
22:42 <belkinsa> I agree.
22:42 <knome> the people can find the useless ones without our help, believe me
22:42 <belkinsa> Enough for people to get started.
22:42 <pleia2> lol
22:42 <knome> and that's basically it
22:42 <pleia2> ok, thanks knome :)
22:43 <knome> this is not the agenda, but...
22:43 <knome> i'd like to become an admin in the community help wiki
22:43 <GunnarHj> Possibly we should try to find a *short* list of other resources that we recommend.
22:44 <belkinsa> +1
22:44 <knome> GunnarHj, yep, also https://help.ubuntu.com/community/ExternalGuides is linked from that page
22:44 <knome> so there is plenty of links
22:44 <belkinsa> #link https://wiki.ubuntu.com/DocumentationTeam
22:44 <knome> and tbh, how much else do we need than;
22:44 <pleia2> knome: right, I'll send a +1 to the list on that (I'm not a wiki admin, but there are precious few of them, so anything will help I think)
22:44 <GunnarHj> knome: Possibly too many of them...
22:44 <knome> askubuntu, ubuntu forums, mailing list, irc, manpages, guides
22:44 <knome> and flavor support links
22:45 <knome> GunnarHj, sure, i agree, but that's a content problem, and not the main area of my interest :)
22:45 <belkinsa> Those is enough, I think.
22:45 <knome> (don't get me wrong...)
22:45 <belkinsa> are*
22:45 <godbyk> I'm fairly ignorant of how the Ubuntu wiki is set up. What superpowers do wiki admins have?
22:45 <knome> GunnarHj, delete/move pages/attachments
22:45 <knome> godbyk, ^
22:45 <belkinsa> Renaming too
22:46 <knome> well doesn't that equal to move? :)
22:46 <GunnarHj> knome: To make a difference, we should point at resources with good quality. People know how to google anyway.
22:46 <belkinsa> Somewhat
22:46 <knome> GunnarHj, yep.
22:46 <knome> GunnarHj, same problem around the help wiki though; some of the content in there is not quality content either
22:47 <godbyk> knome: Ah, okay. Thanks.
22:47 <GunnarHj> knome: True.
22:47 <knome> from my pov, once we get https://help.ubuntu.com/community/OtherResources finished, we can drop https://help.ubuntu.com/community/FrontPageRefresh as the front page
22:47 <belkinsa> Yeah, developers just don't doc, they just develop.
22:47 <knome> and then we can keep on reviewing and enhancing it
22:48 <knome> slickymaster expressed his concerns of the topic list gettting too long
22:48 <knome> but i don't think i know the wiki enough to judge if there is something we could drop or not.
22:49 <belkinsa> Most of us don't have that skill.
22:49 <belkinsa> Technical skill, I mean.
22:49 <knome> i guess the right way to go forward is to keep on digging deeper in the wiki and clean up page by page.
22:49 * pleia2 nods
22:50 <GunnarHj> I think we should encourage knome to keep on his work with front page and other resources. It will be a step in the right direction IMO.
22:50 <knome> what will ultimately tell us what's useful and what not
22:50 * belkinsa nods
22:50 <godbyk> Can we get any statistics as to how many visits each wiki page gets?
22:50 <belkinsa> +1 on that idea
22:50 <godbyk> That'd help us focus our efforts there, I think.
22:50 <pleia2> we can ask IS
22:51 <knome> #action knome to finish OtherResources and then send an email to the -doc list to propose the new frontpage layout
22:51 * meetingology knome to finish OtherResources and then send an email to the -doc list to propose the new frontpage layout
22:51 <belkinsa> Also it could tell us how many are using the wiki also
22:51 <pleia2> I suppose I can submit a ticket to see about that (they LOVE me, I bug them all day long!)
22:51 <knome> same here
22:51 <knome> hey littlegirl
22:51 <pleia2> #action pleia2 to ask Canonical IS about getting help wiki stats
22:51 * meetingology pleia2 to ask Canonical IS about getting help wiki stats
22:52 <pleia2> #topic Redundancy of Community Wiki and Other Forms of Support (belkinsa)
22:52 <pleia2> is there more to discuss here?
22:52 <godbyk> Or have we already covered this sufficiently on the mailing list?
22:52 <belkinsa> I think we may of covered it well on the mailing list.
22:53 <pleia2> ok, cool
22:53 <pleia2> #topic Any other business
22:53 * belkinsa raises my hand
22:53 <pleia2> anything else to chat about at this time?
22:53 <belkinsa> I have one
22:53 <pleia2> belkinsa: go for it
22:54 <belkinsa> Do we think we need some form of blog posting to tell others in the community what the Doc Team is doing?  To get more folks in.
22:54 <pleia2> historically we've just done it via personal blogs that go to planet
22:54 <belkinsa> Even maybe getting developers to have some form of docs for the programs.
22:54 <godbyk> belkinsa: We could, but before we do, we should probably have a list of tasks that are ready for people to work on.
22:55 <belkinsa> Right.
22:55 <pleia2> I'm inclined to keep it that way now, the idea of adding another resource to update because we have too many resources to update ourselves makes me worried though
22:55 <belkinsa> Oh, right.  That issue.
22:55 <pleia2> hehe
22:55 <godbyk> :)
22:55 <belkinsa> Never mind then.
22:55 <GunnarHj> Any effort to make the developers at least think of the docs aspect is welcome.
22:55 <pleia2> oh, so we could send task announcements to our ubuntu-doc list and them submit them to the ubuntu-weekly-newsletter for inclusion
22:56 <pleia2> there is an "Other Community News" section they would fit nicely into :)
22:56 <belkinsa> Sure, that works.
22:56 <pleia2> yay
22:56 <belkinsa> I guess I was really looking for that.
22:56 <pleia2> perfect, thanks for the idea
22:56 <belkinsa> Not a problem.
22:56 <knome> the real question is
22:57 <pleia2> does anyone read UWN? ;P
22:57 <knome> who would write an article to be sent to the newsletter and/or the planet
22:57 <pleia2> hah right, that
22:57 <belkinsa> I do.
22:57 * godbyk nominates knome!
22:57 <pleia2> w00t
22:57 <knome> godbyk, no thanks at this point, but i might do that later. thanks for the nomination ;)
22:57 <belkinsa> But stats would be nice for UWN.
22:57 <godbyk> knome: It was worth a shot! ;-)
22:58 <knome> always.
22:58 <knome> i'll keep it in mind though
22:58 <knome> it's been a while since i've posted
22:58 <belkinsa> And the article idea is a good one too.
22:58 <pleia2> ok, anything else?
22:59 <pleia2> thanks everyone :)
22:59 <godbyk> Should we set up a poll for another meeting in January?
23:00 <pleia2> godbyk: yeah
23:00 <belkinsa> Not a problem and yes.
23:00 <dsmythies> no, nothing else from me. bye.
23:00 <pleia2> #action pleia2 to set up poll for january meeting
23:00 * meetingology pleia2 to set up poll for january meeting
23:00 <pleia2> happy holidays, all :)
23:00 <pleia2> #endmeeting