19:04 <micahg-work> #startmeeting Ubuntu Developer Membership Board
19:04 <meetingology> Meeting started Mon Dec  2 19:04:09 2013 UTC.  The chair is micahg-work. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:04 <meetingology> 
19:04 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:04 <micahg-work> Welcome to the DMB meeting
19:04 <ScottK> I pinged barry on #u-devel.
19:04 * barry waves
19:05 <micahg-work> #topic Review of previous action items
19:05 <Laney> the agenda is false?
19:05 <micahg-work> yes
19:05 <micahg-work> well
19:05 <Laney> oh, the top says micahg-work and the bottom says ScottK
19:06 <ScottK> Since micahg-work already started, he wins.
19:06 <micahg-work> we skipped the last meeting due to no agenda
19:06 <micahg-work> so, I thought it was my turn...
19:06 <ScottK> Go for it.
19:07 <barry> take it away, eric the orchestra leader
19:07 <micahg-work> #subtopic micahg to restructure PPU teams.
19:07 <micahg-work> carried
19:07 <micahg-work> #topic Per Package Uploader Applications
19:08 <micahg-work> #subtopic PPU for Timo Jyrinki
19:08 <micahg-work> #link https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU
19:08 <micahg-work> Mirv, care to introduce yourself?
19:09 <Mirv> sure. it reads better on the wiki page, but a Debian Developer and Ubuntu Member currently working in integrating some of the Ubuntu Touch packages and also working on Qt 5 packaging
19:09 <Mirv> ie. part of the 'landing team' who orchestrate what pieces of Touch land next to the archives
19:10 <Mirv> and I added a sorted version of the package list today to the page, in case the Qt 5 package set would be wanted to be defined separately for other people after me
19:11 <ScottK> I think it would be useful to discuss the application in terms of Qt5 and other stuff as I think they present different challenges.
19:13 <Mirv> for the 'Other packages', all but qtcreator are part of the canonicalupstream2distro system, where I currently have privilege to have a new version copied to archives, but I currently need an 'ack' from core dev if there are any packaging changes
19:13 <Mirv> which is the same deal as for the other non-coredevs on the team
19:13 <ScottK> Qt Creator is a bit of a special case on it's own.
19:15 <barry> Mirv: so, are you suggesting two package sets, with qtcreator* as separate?
19:16 <barry> i.e. qtcreator* not in a package set
19:16 <Mirv> barry: I wasn't sure how you prefer defining package sets vs. just listing a big list per developer. in the longer term it would make sense to have two package sets defined, one for Qt 5 and one for cu2d.
19:16 <Mirv> and leave qtcreator out of those both sets
19:17 <Mirv> since robru and sil2100 may be interested in the cu2d ones later, and mitya57 in the Qt 5 set
19:17 <Laney> I was thinking about the idea of a cu2d set
19:17 <Laney> Not sure what others would have to say about that
19:18 <micahg-work> are they related in any way other than that they're in cu2d?
19:18 <Laney> They impose consistent packaging
19:18 <barry> certainly seems like the qt5 pkgset makse sense
19:18 <Mirv> micahg-work: not otherwise but that Canonical is upstream for all of them. there are several stacks and also more packages besides those I've listed initially.
19:18 <ScottK> I think Qt Creator should not be in the Qt5 package set, but a separate PPU right.
19:19 <Laney> None of our tools would work for assessing contributions to them though
19:19 <Mirv> and yes, cu2d packages have consistent packaging via bzr split mode, so bzr bd always works and packaging is included inline
19:19 <micahg-work> so, cu2d is like a MOTU equivalent for Canonical upstream packages?
19:20 <micahg-work> * a cu2d packageset
19:20 <micahg-work> hrm, let's table that for now
19:20 <Laney> umm, I only expect it would be appropriate for people on the team that wrangles that stuff
19:21 <Laney> ok
19:21 <Laney> would be interesting for someone to come back to us with a proposal on it I guess
19:21 <micahg-work> yes, that sounds like a good idea
19:22 <micahg-work> #info Anyone interested in a packageset for cu2d packages should feel free to make a proposal to the DMB
19:23 <micahg-work> Mirv, so, have you had any issues trying to push the qt stuff through Debian?
19:24 <ScottK> Fortunately he knows someone on the Debian FTP team so Qt5 stuff seems to make it through New pretty quickly.
19:24 <Mirv> micahg-work: mostly it has worked fine so that I've eg. given basis of some module packaging, they've tweaked it further and I've synced back. they've obviously rejected some stuff they don't want, like we have a policy breaking qtbase multi-arch thing that was added part of the arm64 work.
19:24 <micahg-work> that's always nice :)
19:25 <ScottK> There's also issues with Canonical using private headers that Debian chooses not to expose.
19:25 <Mirv> I just got people stop to use qtsensors-private so that can be again synced for Debian
19:26 <ScottK> Excellent.
19:26 <Mirv> qtbase and qtdeclarative private headers are going to stay in Debian too
19:26 <ScottK> That's the kind of progress I like to hear about.
19:26 <ScottK> (for the others - Debian is only packaging private headers needed to build other Qt5 modules).
19:26 <stgraber> Mirv: are you subscribed to ubuntu-devel-announce?
19:27 <ScottK> Also on the Ubuntu side, the packaging is maintained with the Kubuntu team in bzr branches in the Kubuntu namespaces using our normal processes.
19:27 <micahg-work> that's good to hear as well
19:27 <ScottK> AFAICT, Ubuntu - Kubuntu stuff is all good at the moment.
19:29 <Laney> Cool, that all sounds nice
19:29 <Mirv> stgraber: I should be, but I'm just subscribing my canonica address too since I think they might be filtered to a folder on my private e-mail
19:30 <ScottK> Mirv: You said the Ubuntu SDK stuff is being split out of the Qt Creator source?
19:30 <Laney> How did you choose which 'other' packages to list?
19:31 <ScottK> When will that be done and where does it go?
19:31 <Mirv> ScottK: yes, it's split now, qtcreator has no Ubuntu bits and the qtcreator-plugin-ubuntu source package uses qtcreator-dev that was crafted to the former
19:31 <ScottK> Excellent.
19:31 <Mirv> Laney: I went through the cu2d stacks and selected those I work often on (sdk stack like ui-toolkit) and those with Qt/QML modules
19:32 <Laney> OK, and you say you got some Qt stuff in sync but https://launchpad.net/~timo-jyrinki/+synchronised-packages doesn't appear to list that
19:32 <Laney> has it not happened yet?
19:33 <Laney> (or did someone else do the actual syncing?)
19:34 <Mirv> Laney: like synced from Debian as is? any *opensource-src packages that don't have ubuntu version number ar such.
19:34 <Mirv> I've not requested any syncs as such, and used the word 'sync' also in the sense that I've synced the ~kubuntu-packagers branches to be identical or near identical to Debian packaging. I still need something to build the PPA packages from.
19:34 <ScottK> I can vouch for the fact that a lot of work by Mirv and mitya57 has been done to sync or minimize differences.
19:35 <ScottK> Also some of the work will need to wait for Qt5 5.2 to land.
19:35 <ScottK> (nothing to do with packaging - some of the Canonical upstream stuff had regressions with 5.1)
19:36 <Laney> ok then, thanks, was looking for things being uploaded to Debian & then synced
19:36 <Laney> guess that will happen with time
19:36 * Laney is done
19:38 <stgraber> Mirv: some of the packages you're applying for upload rights for are seeded, how can you tell which image they are likely to impact and when to refrain from uploading?
19:41 <Mirv> stgraber: well I think those are seeded in the touch images, and currently we're in full manual mode so the landing team meetings decide when to allow uploads or not. we also run tests on each package manually before upload (copy), and in case of some not listed like indicators the cu2d runs desktop tests always.
19:41 <stgraber> that's not answering my question ;)
19:42 <stgraber> soon enough some of those packages will be in images other than touch (if they aren't already), we have a tool that can let you know which, what is it?
19:43 <Mirv> ah.. I've really only looked at lp:~ubuntu-core-dev/ubuntu-seeds branches when needed, rmadison I think does not list seed information
19:43 <stgraber> correct, rmadison doesn't and ubuntu-seeds is a pain to parse if you're called germinate
19:43 <stgraber> we have a tool called seeded-in-ubuntu for that
19:43 <Mirv> nice, making a note
19:45 <stgraber> in general we try to use proposed-migration blocks around milestones to prevent accidental changes to the images, it's however always a good idea to think twice when uploading around those times and use seeded-in-ubuntu to make sure your change won't affect one of the products that's about to release
19:45 <micahg-work> While we've reduced the amount of time and packages that are frozen, cedrtain uploads freezes can still impact others, so it's good to check during those periods and be aware
19:45 <micahg-work> *certain uploads during freezes
19:45 <Laney> Even proposed blocks get annoying if you want to put a bugfix in and there's already an upload
19:45 * Mirv continues writing notes
19:46 <micahg-work> indeed
19:46 <Laney> What happens with "allowing uploads" when Kubuntu wants to do a change?
19:47 <Laney> Not strictly related to this application, I understand. ;-)
19:48 <Mirv> and we already have this situation that was observed that xubuntu started including ubuntu-system-settings (not sure how intentionally) which pulls eg. ubuntu-ui-toolkit
19:48 <Laney> well, they didn't want to make a change to it
19:48 <Laney> I mean if there's some patch to cherry-pick or whatever
19:49 * micahg-work wonders why Xubuntu did that (with his xubuntu-dev hat on), guessing it was pulled in by something else
19:49 <Laney> some alternate recommends following thing
19:49 <Laney> from an indicator IIRC
19:50 <stgraber> micahg-work: yeah, we had a time where a bunch of indicators would recommend some packages in the wrong order which indirectly included ubuntu-system-settings
19:50 <micahg-work> Xubuntu isn't pulling it in at the moment according to seeded-in-ubunut
19:50 <stgraber> micahg-work: I had them fix those recommends and I believe it did the trick for most images, not sure if something was missing for xubuntu though
19:50 <micahg-work> yeah, I hope to audit the Xubuntu seed sometime soon for stuff like that
19:50 <Mirv> Laney: for this cycle Kubuntu is not going to have much interest yet in Qt 5, but that will definitely change in the next one. Qt uploads should probably be co-operated/acked, a discussion that should continue in the next UDS.
19:51 <ScottK> Mirv: We do plan to start packaging KF5 modules this cycle, so we do need to be coordinated.
19:52 <Mirv> ScottK: ok.
19:52 <Laney> OK, can discuss that outside of the meeting
19:55 <micahg-work> #voters stgraber ScottK Laney micahg-work barry tumbleweed
19:55 <meetingology> Current voters: Laney ScottK barry micahg-work stgraber tumbleweed
19:55 <micahg-work> #vote Create Qt5 packageset for initial packages listed on https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU and grant upload rights to Mirv and kubuntu-dev
19:55 <meetingology> Please vote on: Create Qt5 packageset for initial packages listed on https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU and grant upload rights to Mirv and kubuntu-dev
19:55 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:55 <micahg-work> #voters bdrung
19:55 <meetingology> Current voters: Laney ScottK barry bdrung micahg-work stgraber tumbleweed
19:56 <barry> +1
19:56 <meetingology> +1 received from barry
19:56 <ScottK> +1
19:56 <meetingology> +1 received from ScottK
19:56 <Laney> We need a description
19:56 <Laney> but yes
19:56 <Laney> +1
19:56 <meetingology> +1 received from Laney
19:57 <tumbleweed> +1
19:57 <meetingology> +1 received from tumbleweed
19:57 <micahg-work> hrm, right, description
19:57 <micahg-work> +1
19:57 <meetingology> +1 received from micahg-work
19:58 <stgraber> +1
19:58 <meetingology> +1 received from stgraber
19:58 <ScottK> Packages for source developed by http://qt-project.org/ - list to follow.
19:58 <micahg-work> #endvote
19:58 <meetingology> Voting ended on: Create Qt5 packageset for initial packages listed on https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU and grant upload rights to Mirv and kubuntu-dev
19:58 <meetingology> Votes for:6 Votes against:0 Abstentions:0
19:58 <meetingology> Motion carried
19:58 <ScottK> Mirv: congratulations.
19:59 <micahg-work> everyone ok with ScottK's description?
19:59 <Laney> It doesn't need the list part
19:59 <Laney> but yeah
19:59 <Mirv> thank you
19:59 <Laney> (the list is the set of packages in the set)
19:59 <ScottK> OK.
19:59 <barry> wfm
19:59 <micahg-work> #info description for Qt5 packageset: Packages for source developed by http://qt-project.org/
20:00 <micahg-work> #vote Timo Jyrinki to get PPU for qtcreator
20:00 <meetingology> Please vote on: Timo Jyrinki to get PPU for qtcreator
20:00 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:00 <ScottK> +1
20:00 <meetingology> +1 received from ScottK
20:00 <stgraber> +1
20:00 <meetingology> +1 received from stgraber
20:00 <barry> +1
20:00 <meetingology> +1 received from barry
20:00 <Laney> +1
20:00 <meetingology> +1 received from Laney
20:00 <tumbleweed> +1
20:00 <meetingology> +1 received from tumbleweed
20:01 <micahg-work> +1
20:01 <meetingology> +1 received from micahg-work
20:01 <ScottK> BTW, the initial set of packages should be all the ones in Mirv's list that end in opensource-src.
20:01 <micahg-work> #endvote
20:01 <meetingology> Voting ended on: Timo Jyrinki to get PPU for qtcreator
20:01 <meetingology> Votes for:6 Votes against:0 Abstentions:0
20:01 <meetingology> Motion carried
20:01 <Mirv> yes, and it's also separately listed below in alphabetical order
20:01 <micahg-work> #vote  Timo Jyrinki to get PPU for qtcreator-plugin-ubuntu u1db-qt ubuntu-ui-toolkit ubuntu-ui-extras dee-qt poppler-qml-plugin qtpowerd qtubuntu-camera qtubuntu-media qtvideo-node qtubuntu qtubuntu-sensors content-hub music-hub qml-friends libhud-qt qmenumodel qtorganizer5-eds history-service telephony-service address-book-app dialer-app messaging-app unity-webapps-qml
20:01 <meetingology> Please vote on: Timo Jyrinki to get PPU for qtcreator-plugin-ubuntu u1db-qt ubuntu-ui-toolkit ubuntu-ui-extras dee-qt poppler-qml-plugin qtpowerd qtubuntu-camera qtubuntu-media qtvideo-node qtubuntu qtubuntu-sensors content-hub music-hub qml-friends libhud-qt qmenumodel qtorganizer5-eds history-service telephony-service address-book-app dialer-app messaging-app unity-webapps-qml
20:01 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:03 <barry> +1
20:03 <meetingology> +1 received from barry
20:04 <ScottK> +0 I don't see much in the way of endorsements for this work and I'm not sure I understand the implications of PPU for CI packages to easily judge.
20:04 <meetingology> +0 I don't see much in the way of endorsements for this work and I'm not sure I understand the implications of PPU for CI packages to easily judge. received from ScottK
20:05 <stgraber> +0 I have to agree with ScottK here + the current cu2d process makes it very hard to get a good feel about an applicant
20:05 <meetingology> +0 I have to agree with ScottK here + the current cu2d process makes it very hard to get a good feel about an applicant received from stgraber
20:05 <micahg-work> +0 same as ScottK
20:05 <meetingology> +0 same as ScottK received from micahg-work
20:05 <tumbleweed> +0 all of that
20:05 <meetingology> +0 all of that received from tumbleweed
20:06 <micahg-work> #endvote
20:06 <meetingology> Voting ended on: Timo Jyrinki to get PPU for qtcreator-plugin-ubuntu u1db-qt ubuntu-ui-toolkit ubuntu-ui-extras dee-qt poppler-qml-plugin qtpowerd qtubuntu-camera qtubuntu-media qtvideo-node qtubuntu qtubuntu-sensors content-hub music-hub qml-friends libhud-qt qmenumodel qtorganizer5-eds history-service telephony-service address-book-app dialer-app messaging-app unity-webapps-qml
20:06 <meetingology> Votes for:1 Votes against:0 Abstentions:4
20:06 <meetingology> Motion carried
20:07 <Mirv> (didrocks is the cu2d person who asked me to add those packages and endorsed that part)
20:07 <micahg-work> that's not quite right, motion not carried
20:07 <Laney> I think you guys should work on a proposal for granting cu2d upload rights
20:07 <Mirv> okay
20:07 <Laney> we'll be quite happy to consider it
20:07 <micahg-work> #info Vote on PPU for other packages did not pass (requires +4)
20:08 <micahg-work> yes, please
20:08 <Mirv> it's not very well formed indeed, especially since cu2d in itself is not that familiar to most. the idea is to reduce the need to get the 'acks'.
20:08 <Mirv> I'll chat with didrocks
20:10 <micahg-work> #topic any other business
20:10 <micahg-work> we're already 10 minutes over, so anything else to discuss?
20:10 <Mirv> (if you'll excuse me, I've pressure applied that I need to get to sleep)
20:10 <barry> just thinking it would probably be best to skip the dec 30 meeting, but we can take that to email
20:10 <micahg-work> Mirv, thanks, and congratulations
20:11 <Mirv> thanks all, see you again with the cu2d at some point
20:11 <tumbleweed> there's re-election, but that's still a way off
20:11 <tumbleweed> just reminding people
20:12 <micahg-work> #action discuss Dec 30 meeting on ML
20:12 * meetingology discuss Dec 30 meeting on ML
20:12 <micahg-work> #info DMB elections coming up early next year
20:13 <Laney> oh yeah, that's interesting
20:14 <Laney> can do the call first half of january though, so still a way off
20:14 <micahg-work> right, that's why I didn't action it
20:17 <micahg-work> #action stgraber to get DMB owned qt5 packageset created with the following packages: qt3d-opensource-src qtbase-opensource-src qtconnectivity-opensource-src qtdeclarative-opensource-src qtdoc-opensource-src qtfeedback-opensource-src qtgraphicaleffects-opensource-src qtimageformats-opensource-src qtjsbackend-opensource-src qtlocation-opensource-src qtmultimedia-opensource-src qtpim-opensource-src qtquick1-opensource-src qtquickcontrols-o
20:17 * meetingology stgraber to get DMB owned qt5 packageset created with the following packages: qt3d-opensource-src qtbase-opensource-src qtconnectivity-opensource-src qtdeclarative-opensource-src qtdoc-opensource-src qtfeedback-opensource-src qtgraphicaleffects-opensource-src qtimageformats-opensource-src qtjsbackend-opensource-src qtlocation-opensource-src qtmultimedia-opensource-src qtpim-opensource-src qtquick1-opensource-src qtquickcontrols-o
20:17 <micahg-work> pensource-src qtscript-opensource-src qtsensors-opensource-src qtserialport-opensource-src qtsvg-opensource-src qtsystems-opensource-src qttools-opensource-src qttranslations-opensource-src qtwebkit-opensource-src qtx11extras-opensource-src qtxmlpatterns-opensource-src
20:17 <micahg-work> hrm, that failed
20:18 <micahg-work> #undo
20:18 <meetingology> Removing item from minutes: <MeetBot.items.Action object at 0x16dc050>
20:18 <micahg-work> #action stgraber to create qt5 packageset with packages listed at https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU
20:18 * meetingology stgraber to create qt5 packageset with packages listed at https://wiki.ubuntu.com/TimoJyrinki/DeveloperApplication-PPU
20:19 <micahg-work> #action micahg to create LP team for qt5 packageset uploaders with initial members of Mirv and kubuntu-dev
20:19 * meetingology micahg to create LP team for qt5 packageset uploaders with initial members of Mirv and kubuntu-dev
20:19 <micahg-work> #action stgraber to get PPU added for Mirv to qtcreator
20:19 * meetingology stgraber to get PPU added for Mirv to qtcreator
20:19 <micahg-work> I think that's enough for now
20:19 <micahg-work> #endmeeting