16:04 <roaksoax> #startmeeting ubuntu-server-team
16:04 <meetingology> Meeting started Tue Sep 24 16:04:39 2013 UTC. The chair is roaksoax. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:04 <meetingology>
16:04 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:04 <roaksoax> #topic Review ACTION points from previous meeting
16:04 <roaksoax> smoser look at / assign bug 1206872 and bug 1156932
16:04 <ubottu> bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Incomplete] https://launchpad.net/bugs/1206872
16:04 <ubottu> bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed] https://launchpad.net/bugs/1156932
16:04 <roaksoax> any updates?
16:05 <smoser> no updates. :-(
16:05 <smoser> please re-action
16:05 <roaksoax> ack!
16:06 * roaksoax smoser look at / assign bug 1206872 and bug 1156932
16:06 <ubottu> bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Incomplete] https://launchpad.net/bugs/1206872
16:06 <ubottu> bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed] https://launchpad.net/bugs/1156932
16:06 <roaksoax> [ACTION] smoser look at / assign bug 1206872 and bug 1156932
16:06 * meetingology smoser look at / assign bug 1206872 and bug 1156932
16:06 <roaksoax> #topic Saucy Development
16:06 <roaksoax> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:06 <roaksoax> so there's our release schedule
16:07 <roaksoax> #subtopic Release Bugs
16:07 <roaksoax> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:07 <roaksoax> bug #1208455
16:07 <ubottu> bug 1208455 in linux (Ubuntu Saucy) "general protection fault running apt-get inside double nested kvm VM" [High,In progress] https://launchpad.net/bugs/1208455
16:08 <roaksoax> smoser: any updates?
16:08 <roaksoax> err
16:08 <roaksoax> smb:
16:08 <hallyn> (smb is not in today, and he didn't mention his one)
16:08 <roaksoax> ah seems that smb is not here today
16:08 <hallyn> (not in right now that is)
16:08 <roaksoax> alright moving on
16:08 <roaksoax> bug #1213915
16:08 <ubottu> bug 1213915 in ceph (Ubuntu Saucy) "Please demote ceph-mds and ceph-fs-common to universe" [High,New] https://launchpad.net/bugs/1213915
16:08 <roaksoax> i guess we wll see progress as soon as an archive admin can make it happen
16:09 <roaksoax> bug #1206872
16:09 <ubottu> bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Incomplete] https://launchpad.net/bugs/1206872
16:09 <roaksoax> anyone from the server team willing to take on that one
16:09 <roaksoax> zul: ? maybe you since you've previously touched samba
16:09 <roaksoax> (or used to)
16:10 <zul> i can look i guess
16:10 <roaksoax> thank you
16:10 <roaksoax> bug #1156932
16:10 <ubottu> bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed] https://launchpad.net/bugs/1156932
16:10 <zul> no progress
16:10 <roaksoax> ack! thanks
16:10 <roaksoax> bug #1199791
16:10 <ubottu> bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged] https://launchpad.net/bugs/1199791
16:10 <roaksoax> zul: what about this oen?
16:11 <zul> no progress
16:11 <roaksoax> bug #1210054
16:11 <ubottu> bug 1210054 in juju-core (Ubuntu Saucy) "juju terminate-machine with local provider doesn't destroy machine" [High,Triaged] https://launchpad.net/bugs/1210054
16:11 <roaksoax> jamespage: any updates?
16:11 <jamespage> not yet
16:11 <roaksoax> or maybe arosales knows of someone who should take care of this one instead
16:11 <roaksoax> alrighty
16:11 <roaksoax> bug #1223010
16:11 <ubottu> bug 1223010 in keystone (Ubuntu Saucy) "Use oauthlib rather than oauth." [High,Triaged] https://launchpad.net/bugs/1223010
16:11 <roaksoax> zul: ?>
16:12 <arosales> roaksoax, I can investigate bug 1210054 for an owner
16:12 <zul> looked at it i dont think thats going to make it in for saucy
16:12 <roaksoax> arosales: awesom,e thank you
16:12 <roaksoax> zul: uhmm is it too big of a change?
16:12 <zul> roaksoax: yeah
16:12 <arosales> hallyn, if you have an opportunity could you also throw in a comment in bug 1210054 ?
16:12 <ubottu> bug 1210054 in juju-core (Ubuntu Saucy) "juju terminate-machine with local provider doesn't destroy machine" [High,Triaged] https://launchpad.net/bugs/1210054
16:13 <hallyn> uh, sure
16:13 <arosales> hallyn, thanks
16:13 <roaksoax> zul: ok boomer
16:14 <roaksoax> bug 1226871
16:14 <ubottu> bug 1226871 in python-troveclient (Ubuntu Saucy) "python-troveclient lists XS-Testsuite but packages no tests" [High,Triaged] https://launchpad.net/bugs/1226871
16:14 <roaksoax> adam_g: any updates?
16:14 <adam_g> roaksoax, in progress. have a branch up for review to lp:~ubuntu-server-dev/python-troveclient/havana
16:15 <roaksoax> perfect! thank you!
16:15 <adam_g> https://code.launchpad.net/~gandelman-a/ubuntu/saucy/python-troveclient/1226871/+merge/187113
16:15 <roaksoax> volunteers to review are welcome :)
16:15 <roaksoax> bug 1227153
16:15 <ubottu> bug 1227153 in cinder (Ubuntu Saucy) "cinder missing build-depends on python-netaddr" [Medium,Triaged] https://launchpad.net/bugs/1227153
16:15 <roaksoax> this one should be an easy one
16:15 <roaksoax> zul: ^^
16:16 <roaksoax> same as bug #1227167
16:16 <ubottu> bug 1227167 in python-cliff (Ubuntu Saucy) "python-cliff needs to raise Build-Depends on pyparsing to 2.0.0" [Medium,Triaged] https://launchpad.net/bugs/1227167
16:16 <roaksoax> bug #1227353
16:16 <zul> roaksoax: fixed, fixed
16:16 <ubottu> bug 1227353 in maas (Ubuntu Saucy) "Please promote maas-dns, maas-dhcp to main" [Undecided,New] https://launchpad.net/bugs/1227353
16:16 <roaksoax> waiting for archive admin
16:16 <roaksoax> zul: thanks! please update appropriately
16:16 <roaksoax> #subtopic Blueprints
16:16 <roaksoax> #link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:17 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-charmhelper2
16:17 <roaksoax> arosales: any updates you would like to share?
16:18 <arosales> roaksoax, hm . . .
16:18 <roaksoax> since marco doens't seem to be around
16:19 <arosales> roaksoax, I think mathew wedgwood has been working on an api for charm helpers
16:19 <arosales> roaksoax, but for charm-tools marcoceppi is working on a 1.0 release and juju/stable currently has that and he is working on getting that into saucy, if possible
16:19 <roaksoax> awesome! thanks for the update
16:19 <arosales> roaksoax, that should cover charm tools and helper updates
16:20 <roaksoax> perfect!
16:20 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-2-delivery
16:20 <roaksoax> jamespage: any updates?
16:20 <arosales> roaksoax, I'll follow up on [marcoceppi] Update charm tools to promote best practices wrt stubbing/libraries WITH TESTS: TODO with marco on the charmhelper2 bp
16:20 <jamespage> roaksoax, all going OK - FFe for 1.16 applied for
16:20 <roaksoax> arosales: thank you!
16:20 <roaksoax> jamespage: awesome!
16:21 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2
16:21 <roaksoax> no new progress
16:21 <roaksoax> james is taking care of percona charm
16:21 <roaksoax> i still have to work on the haproxy stuff (but past 3 weeks in training so couldn't move forward)
16:21 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-ceph
16:21 <roaksoax> jamespage: ^^
16:22 <jamespage> roaksoax, all good - apart from the radosgw agents for geo-replication
16:22 <jamespage> I've not had time to look in detail but they look a bit early days for 13.10 inclusion
16:23 <roaksoax> i guess we just have to keep an eye on it
16:23 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-simplestreams
16:23 <roaksoax> smoser: updates?
16:23 <smoser> i'll update now.
16:24 <roaksoax> smoser: thank you!
16:24 <roaksoax> but there seems to be good progress and things looking great
16:24 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-qa
16:24 <roaksoax> zul: ^^ any updates?
16:24 <zul> ill update it
16:24 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-havana
16:24 <roaksoax> same as ^^ if there's updates please
16:25 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-mongodb
16:25 <zul> ditto
16:25 <roaksoax> jamespage: so we still blocked with mongodb?
16:25 <jamespage> roaksoax, yeah - it won't make main this cycle
16:25 <roaksoax> alrighty
16:25 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms
16:25 <roaksoax> adam_g: any updates?
16:26 <roaksoax> in me meantime:
16:26 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-virtstack
16:26 <roaksoax> hallyn: any updateS?
16:27 <hallyn> not really, all going well
16:27 <roaksoax> perfect!
16:27 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-archive
16:27 <roaksoax> jamespage: how's the CA looking?
16:28 <jamespage> roaksoax, OK
16:28 <jamespage> I've been testing today with whats in staging
16:28 <roaksoax> the cloud-tools pocket is WIP, and things are lookging good too
16:28 <roaksoax> awesome!
16:29 <jamespage> mainly hitting charm compat issues due to name changes quantum-> neutron
16:29 <jamespage> but niggles
16:29 <roaksoax> alriught, so that's easy to fix i guess then
16:29 <roaksoax> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-hypervisor
16:29 <roaksoax> finalle
16:29 <roaksoax> zul: ^^
16:29 <zul> needs updating
16:29 <roaksoax> tjamls!
16:30 <roaksoax> thanks
16:30 <roaksoax> #topic Weekly Updates & Questions for the QA Team (psivaa)
16:30 <roaksoax> psivaa: any updates for us?
16:30 <psivaa> no update from us
16:30 <psivaa> hallyn fixed the lxc bug already :)
16:30 <roaksoax> awesome!
16:30 <roaksoax> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:30 * hallyn raises his hand
16:31 <roaksoax> smb is not around
16:31 <hallyn> smb says,
16:31 <hallyn> he's working on the raring xen mre,
16:31 <hallyn> and he is looking at bug 1185756 but needs to set up an environment to reproduce in
16:31 <ubottu> bug 1185756 in drbd8 (Ubuntu Precise) "drbd8-utils not compatible with linux-lts-raring kernel in 12.04" [High,Confirmed] https://launchpad.net/bugs/1185756
16:31 <hallyn> (that's all)
16:31 <roaksoax> awesome thank you!
16:31 <roaksoax> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:31 <roaksoax> rbasak in holidays.. anyone might have something?
16:33 <roaksoax> i guess not
16:33 <roaksoax> #topic Ubuntu Server Team Events
16:33 <roaksoax> any event's coming up other than ODS in november?
16:33 <zul> openstack in action in montreal on the oct 8
16:33 <roaksoax> zul: yaay you representing us then?
16:34 <zul> roaksoax: im not giving any presenation but ill be there
16:34 <roaksoax> cool
16:34 <arosales> roaksoax, we had jcastro and maroceppi at Ohio Texas Linux Fest and LinuxCon, respectively these past weekends
16:34 <arosales> roaksoax, charm school this Friday
16:34 <arosales> Charm School: How to submit your bundle for the charm championship :-)
16:34 <arosales> more details @ https://juju.ubuntu.com/events/
16:34 <roaksoax> that's great!
16:35 <roaksoax> hurray for jcastro and marcoceppi
16:35 <roaksoax> so let;'s mover on
16:35 <roaksoax> move on*
16:35 <roaksoax> #topic Open Discussion
16:35 <roaksoax> anyone hjas anything to add?
16:35 <arosales> roaksoax, I also updated the agenda before the meeting to have a new item.
16:35 <arosales> roaksoax, if you referesh https://wiki.ubuntu.com/ServerTeam/Meeting
16:36 <arosales> do you see "Server & Cloud Bugs (caribou)"
16:36 <roaksoax> arosales: now i SEE
16:36 <roaksoax> see*
16:36 <roaksoax> #topic Server & Cloud Bugs (caribou)
16:36 <arosales> I need to add that to the copy/paste commands now that I think of it
16:36 <roaksoax> caribou: any updates?
16:36 * arosales updates copy/paste now . . .
16:36 <roaksoax> arosales: :)
16:36 <caribou> well, this is mostly an introduction for this week
16:37 <caribou> just some specific cloud & server bugs which would need some attention from CTS engineering team
16:37 <caribou> but I don't have anything specific for this week, thanks
16:37 <roaksoax> caribou: please go for it if you have any
16:37 <roaksoax> ok
16:37 <roaksoax> perfect then!
16:37 <roaksoax> #topic Announce next meeting date and time
16:38 <roaksoax> same day time
16:38 <arosales> thanks caribou
16:38 <roaksoax> thanks all for coming
16:38 <arosales> roaksoax, thanks for chairing
16:38 <roaksoax> #endmeeting