16:00 <smoser> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Aug 20 16:00:33 2013 UTC.  The chair is smoser. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00 <adam_g> o/
16:00 <smoser> hello all and welcome to this weeks exciting adventure that we like to call the Ubuntu Server Team Weekly Meeting.
16:01 <smoser> #topic Review ACTION points from previous meeting
16:01 <smoser> wow. we had no shortage of actions from last weeks meeting
16:01 <smoser> arosales to update Juju blueprints
16:02 <smoser> no arosoles atm, moving on
16:02 <smoser> roaksoax to clean-up iscsitarget packaging for 12.04.3
16:02 <smoser> hallyn_ to confirm iscsitarget packaging done
16:02 <smoser> roaksoax, hallyn_ ?
16:02 <hallyn_> jamespage did that :)
16:02 <hallyn_> (did the packaging - i confirm :)
16:02 <smoser> k. good
16:02 <smoser> Daviey to review 'dlm' in new queue for Saucy
16:02 <jamespage> \o/
16:03 <smoser> Daviey, ?
16:03 <roaksoax> smoser: seems that jamespage took care of it
16:03 <smoser> zul to follow up on mariadb/percona making it into Saucy
16:03 <jamespage> roaksoax, yeah - I was on a roll for dkms updates...
16:03 <smoser> hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:03 <hallyn_> that's less stable than i realized.  haven't progressed much
16:04 <Daviey> smoser: done
16:04 <smb> I think distracted would be a better word :)
16:04 <smoser> arosales to update Juju blueprints
16:04 <hallyn_> (haven't gotten xen 4.3 to work for me at all)
16:04 <arosales> smoser, in progress for vUDS coming up
16:04 <Daviey> smoser: dlm reviewed and accepted
16:04 <smoser> ok. i'll push the xen item to next weke also
16:04 * smoser hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:04 <smoser> #action hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:04 * meetingology hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:04 <jamespage> smoser, you missed "jamespage to clean-up openvswitch packaging for 12.04.3 "
16:05 <smoser> status ?
16:05 <Daviey> jamespage: I started reviewing that for SRU, but not yet complete
16:05 <jamespage> well as you ask :-)
16:05 <jamespage> decided to take a different approach
16:05 <jamespage> its actually only the dkms package thats not compatible
16:06 <jamespage> and the user-space tools we have in 12.04 should be compatibile with a dkms module from raring
16:06 <smoser> cool
16:06 <jamespage> so we are going to backport lts-raring variants of the openvswitch-datapath-* modules to 12.04
16:06 <jamespage> Daviey is reviewing
16:06 <smoser> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:07 <smoser> feature freeze is 29th.
16:07 <smoser> i personally would like to see a cloud images beta1.
16:07 <smoser> utlemming, can we just plan on that ?
16:08 <utlemming> smosser: sure, I think that is a great idea
16:08 <smoser> as always, please get / have blueprints in order.
16:08 <utlemming> smoser: I'll plan on that happening
16:08 <smoser> k.
16:08 <smoser> anyone have anything else here ? or do we move to release bugs now ?
16:09 <smoser> #subtopic Release Bugs
16:09 <smoser> hm..
16:09 <smoser> #topic Release Bugs
16:10 <smoser> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:11 <smoser> bug 1175028 seems in fix-committed.
16:11 <ubottu> bug 1175028 in mongodb (Ubuntu Saucy) "Mongodb links GPL code with SSL" [Critical,Fix committed] https://launchpad.net/bugs/1175028
16:11 <smoser> bug 1208455.
16:11 <ubottu> bug 1208455 in linux (Ubuntu Saucy) "general protection fault running apt-get inside double nested kvm VM" [High,In progress] https://launchpad.net/bugs/1208455
16:11 <hallyn_> smb: ^
16:12 <smoser> it looks like smb has some movement on that as recently as 18 hours ago
16:12 <smb> hallyn_, Working on it
16:12 <smoser> moving on.
16:12 <hallyn_> +1
16:12 <smoser> bug 1213915
16:12 <ubottu> bug 1213915 in ceph (Ubuntu Saucy) "Please demote ceph-mds and ceph-fs-common to universe" [High,New] https://launchpad.net/bugs/1213915
16:12 <smoser> i'm geussing mr jamespage has that under control.
16:12 <smoser> bug
16:12 <smoser> 1156932
16:12 <jamespage> meh - waiting for a archive-admin
16:12 <smoser> bug 1156932
16:12 <ubottu> bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed] https://launchpad.net/bugs/1156932
16:13 <jamespage> oh -thats a nice one
16:14 <jamespage> not sure its a 'High' tho
16:15 <smoser> i guess we should push that a bit upstream.
16:15 <smoser> there aren't work arounds other than "don't do that"
16:15 <jamespage> zul, any chance upstream will do something about that - its possible to have a broken nova api call right now
16:15 <zul> ill look
16:16 <smoser> ah. you can, Aaron Rosen's comment is quite good.
16:16 <smoser> i agree, not High.
16:16 <smoser> bug 1206872
16:16 <ubottu> bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Confirmed] https://launchpad.net/bugs/1206872
16:17 <smoser> i'll assume matthias has that.
16:17 <jamespage> I started looking at the merge for that
16:17 <smoser> ok. good.
16:17 <jamespage> but got uncomfortable as slangasek's upstart/init goodness appeared to get dropped
16:17 <jamespage> so I pinged him then forgot - my bad
16:18 <smoser> you're syaing its reported fixed in debian ?
16:18 <smoser> oh. yeah, i see that.
16:18 <smoser> k. never mind.
16:18 <smoser> nmoving on.
16:18 <smoser> jamespage, please do ping slangasek again.
16:18 <smoser> bug 1199791
16:18 <jamespage> smoser, will do
16:18 <ubottu> bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged] https://launchpad.net/bugs/1199791
16:19 <smoser> zul you have athat in hand ?
16:19 <smoser> bug 1203828
16:19 <ubottu> bug 1203828 in mysql-5.5 (Ubuntu Saucy) "mysql 5.5.32, 5.1.70 security update tracking bug" [Medium,Confirmed] https://launchpad.net/bugs/1203828
16:21 <smoser> mdeslaur, ^? is that under control
16:21 <smoser> bug 1203828
16:21 <ubottu> bug 1203828 in mysql-5.5 (Ubuntu Saucy) "mysql 5.5.32, 5.1.70 security update tracking bug" [Medium,Confirmed] https://launchpad.net/bugs/1203828
16:21 <smoser> bah
16:21 <smoser> bug 1170393
16:21 <ubottu> bug 1170393 in neutron (Ubuntu Saucy) "Quantum services should be respawned by upstart if necessary" [Medium,Fix committed] https://launchpad.net/bugs/1170393
16:22 <smoser> bug 1188069
16:22 <ubottu> bug 1188069 in apache2 (Ubuntu Saucy) "apache2 mod_rewrite CVE 2013-1862" [Low,Confirmed] https://launchpad.net/bugs/1188069
16:22 <smoser> that one is fix-committed, so moving on.
16:22 <smoser> leave that to security team.
16:22 <smoser> bug 1180397
16:22 <ubottu> bug 1180397 in xen (Ubuntu Saucy) "Xen stable update to 4.2.2" [Low,In progress] https://launchpad.net/bugs/1180397
16:23 <smb> I need to check with infinity to get those moving one by one
16:23 <smoser> k. thank you smb.
16:23 <smb> Oh well actually rather would aboid that for S
16:23 <smb> And go 4.3
16:23 <smoser> yeah.
16:23 <smoser> you can update the bug subject. you're the opener, smb
16:23 <smoser> bug 1031680
16:23 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:24 <smoser> that one doesn't hae anyone assigned.
16:24 <smoser> hm..
16:25 <smoser> rbasak, could youjust take a look at that offline
16:25 <smoser> make sure its not just getting missed
16:25 <smoser> #topic Blueprints
16:25 <smoser> link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:26 <mdeslaur> smoser: I'm not currently working on the mysql package...if someone from the server team can take a look, I'd appreciate it, else it will have to wait until I get back from vacation
16:26 <smoser> hm.. there is a lot of rred there, and we are near feature freeze.
16:26 <smoser> mdeslaur, thanks for the follow up.
16:27 <smoser> i think i'm generally just going to ask everyon e(and myself to take a look at your blueprints andensure that they're in a reasonable state)
16:27 <hallyn_> yup, with ff a week away...
16:27 <smoser> #topic Weekly Updates & Questions for the QA Team (plars)
16:28 <plars> -> psivaa
16:28 <smoser> plars, anything ?
16:28 <psivaa> no updates from the qa side
16:28 <smoser> k.
16:28 <smoser> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:28 <smb> Currently working on bug 1208455 which jodh reported. But also would really want xen 4.3 to get into Saucy but the window closes. I do not think it would have a real impact on anything but xen-api, xen-api-libs and blktap. All tree look to be parts of the xen cloud platform (open source xen-server) from Citrix. And all three are FTBS even without the xen update. They only exist in the archive as they got pocket-copied over from previous re
16:28 <smb> leases.
16:28 <ubottu> bug 1208455 in linux (Ubuntu Saucy) "general protection fault running apt-get inside double nested kvm VM" [High,In progress] https://launchpad.net/bugs/1208455
16:28 <smoser> double nested ?
16:29 <slangasek> s/double //
16:29 <smb> smoser, yeah, in the end he uses 3 levels
16:29 <smb> But the problem actually can be seen in the 2nd level already
16:30 <smoser> wow.
16:30 <smb> slangasek, So yeah, probably should remove the double there
16:30 <slangasek> well, the three levels we care about are host, outer VM, inner VM
16:30 <smb> smoser, Better do not ask _what_ he does, cause I don't know :)
16:30 <slangasek> to be clear
16:30 <jodh> smoser: ftr, all I'm trying to do is create a kvm instance that is controllable from the autopkgtest env. Just so happens that when I create my instance, there are already 2 instances behind me ;)
16:31 <slangasek> smb: jenkins dispatches vms; integration tests for upstart requires booting under a test harness; thus, nested vms are required
16:31 <slangasek> or else jenkins needs to dispatch to bare metal instead
16:31 <rbasak> tbh, I think bug 1031680 will get missed. It's more in depth as it seems, and needs to be dealt with with care.
16:31 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:31 <ogra_> note that this bug seems to hold up an important fix for touch images
16:31 <slangasek> ogra_: that's a separate discussion that I need to have with rsalveti today
16:31 <ogra_> (the kvm one)
16:32 <ogra_> ah, k
16:32 <rbasak> Fundamentally it's an upstream bug, which tries to understand apt in a broken way, and fixing it is considerable upstream work.
16:32 <smoser> slangasek, presumably a workaround would be to disable kvm
16:32 <rbasak> A workaround is available.
16:32 <rbasak> Not breaking compatibility is the difficult part.
16:32 <slangasek> smoser: running qemu without paravirt? hmmmm
16:32 <smoser> other than being painfully slow, that would workaround the bug.
16:32 <slangasek> hadn't considered that
16:32 <slangasek> well, "painfully slow" is the status quo
16:32 <ogra_> speed is overrated :)
16:33 <slangasek> we need to be able to do fast upstart integration tests
16:33 <smoser> orders of magnitude performance affected i suspect.
16:33 <smoser> yeah. its not a fix.
16:33 <slangasek> if it's too slow, we can bypass it by running them locally instead
16:33 <smoser> its a workaround
16:33 <smoser> anyway.
16:33 <slangasek> it's around, but it doesn't work for us ;)
16:33 <smb> So far it seems that at least with Q and R as host and not running 64bit qemu on 32 bit guest things are more stable for me
16:34 <smb> smoser, and that is with kvm enabled
16:34 <smoser> oh wow. running 64 bit qemu in 32 bit guest ?
16:34 <slangasek> ermm I hope that's not the way we're doing it
16:34 <smoser> it just gets better and better :)
16:35 <slangasek> jodh: ^^ are you really running 64-bit inner guest on a 32-bit outer guest?  If so, don't
16:35 <ogra_> wow, that means we could also have arm64 under armhf :)
16:35 <smb> slangasek, That was what jodh  was doing
16:35 <jodh> smb: do we have a handle yet as to what is causing the kernel crashes? Does this need to be raised on lkml?
16:35 <jodh> slangasek: no, I am not :)
16:35 <slangasek> ok
16:35 <smoser> i'm gonna move on here, and assume that slangasek, smb, and jodh can figure it out.
16:35 <jodh> slangasek: well, not knowingly. But the distinction between 'qemu', 'kvm' and all the sym link horror of the multiple binaries might be doing stuff...
16:35 <smb> jodh, You were using qemu-system-x86_64 in the guest that was i386
16:36 <jodh> smb: I was using what was provided by 'kvm'.
16:36 <slangasek> should we maybe take this elsewhere and not derail the meeting in progress? :)
16:36 <jodh> which is what autopkgtest does
16:36 <smoser> yeah, please take up in #ubuntu-server.
16:36 <smb> slangasek, agree to take it away
16:36 * smoser is interested, but this is a bit long here.
16:36 <smoser> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:37 <smoser> rbasak, do we have a kernel that we could put in the cloud iamges ? i tihnk we hvae no maas images for ephemerla for saucy at the moment due to lack of sufficent kernel...
16:37 <smoser> i suppose i should have a bug on that, but i do not.
16:37 <utlemming> smoser: the saucy ephemeral arm images are back to normal now...it was a qemu bug
16:37 <rbasak> smoser: we have a generic kernel now
16:38 <rbasak> That would do.
16:38 <smoser> utlemming, oh? ok. that is good. well i will raise bug if there is an issue.
16:38 <rbasak> I'll need to check exact status, but the general plan is to have lpae and non-lpae variants
16:38 <smoser> what is the 'generic' kernel ?
16:38 <smoser> just actually 'generic' like on other arch ?
16:38 <utlemming> I think there is going to be some issues since we are using the OMAP kernel with the OMAP loaders.
16:38 <rbasak> Yes, but there are a limited number of platforms that support it. Hopefully that number will grow
16:38 <utlemming> rbasak: we should sync tomorrow morning on this
16:39 <rbasak> ack
16:39 <smoser> cool. thanks rbasak utlemming .
16:39 <smoser> +1 for growing number of platforms
16:39 <smoser> #topic Ubuntu Server Team Events
16:39 <smoser> anyone have anything here?
16:39 <zul> vuds is next week
16:39 <smoser> oh yeah.
16:39 <smoser> that
16:39 <smoser> :)
16:39 <smoser> and feature freeze too
16:39 <zul> and  i move at the same time
16:41 <smoser> so .. if anyone is looking
16:41 <smoser> http://paste.ubuntu.com/6007053/
16:41 <smoser> is a list of openstack proposals that ubuntu members have submitted.
16:42 <smoser> i fyou think those are interested and have openstack voting rights (ie, you are an openstack community member), then vote
16:42 <smoser> you can generically vote for speakers at http://www.openstack.org/rate/Presentation/how-to-monetise-your-openstack-cloud-service
16:42 <smoser> gah
16:43 <smoser> click VOTE HERE at http://www.openstack.org/summit/openstack-summit-hong-kong-2013/
16:43 <smoser> http://www.openstack.org/summit/openstack-summit-hong-kong-2013/
16:43 * smoser cut and paste fail
16:43 <smoser> #topic Open Discussion
16:43 <smoser> anyone have anything her e?
16:44 <smoser> k
16:44 <smoser> #topic Announce next meeting date and time
16:44 <smoser> tune in next week at Tuesday 2013-08-27 at 1600 UTC for the continuing saga of ubuntu server development.
16:44 <arosales> smoser, thanks for chairing
16:44 <smoser> #endmeeting