16:02 <arosales> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Aug 13 16:02:27 2013 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02 <arosales> Hello, looks like we have jamespage, hallyn_ rbasak and Daviey here for the Server team meeting
16:03 <jamespage> o/
16:03 <arosales> feel free to wave if others are here
16:03 <arosales> #topic Review ACTION points from previous meeting
16:03 <roaksoax> o/ (wihyt internet connectivity problems)
16:03 * arosales rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy.
16:04 <rbasak> It's landed.
16:04 <arosales> rbasak, Daviey ^
16:04 <rbasak> Daviey: to deploy?
16:04 <rbasak> IIRC, there was a problem with the environment it's running in
16:04 <arosales> hmm so there still be an action for Daviey
16:05 <rbasak> Oh no, it looks like it's working.
16:05 <rbasak> http://reqorts.qa.ubuntu.com/reports/ubuntu-server/merges.html
16:05 <arosales> ah ok
16:05 * arosales arosales to review Juju blueprints with owners after OSCON.
16:05 <arosales> :-/
16:05 <arosales> still an action for me
16:05 <Daviey> rbasak: deployed?
16:05 <arosales> #action arosales to update Juju blueprints
16:05 * meetingology arosales to update Juju blueprints
16:05 <rbasak> Daviey: yeah, looks good. Thanks!
16:05 <arosales> #topic Saucy Development
16:06 <arosales> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:06 <arosales> so we have 12.04.3 coming up
16:06 <arosales> Aug 22nd
16:06 <arosales> jamespage, any actions for server for 12.04.3?
16:07 <jamespage> thats like 9 days ware
16:07 <jamespage> arosales, hrm yes
16:07 <arosales> any we need to call out here?
16:07 <jamespage> arosales, we need to sweepup on dkms packages
16:07 <arosales> volunteers?
16:07 <jamespage> Daviey, smb: was anything agreed in-conjunction with the kernel team in this area?
16:08 <Daviey> jamespage: I believe not
16:08 <rbasak> I spoke to the kernel team at their sprint. AIUI, we (server team) need to fix the relevant packages. I think we need to improve the messaging over defaults and things, which I will follow up on.
16:08 <smb> jamespage, Not that we agreed more that telling you they are broken (or better jibl does)
16:08 <jamespage> https://jenkins.qa.ubuntu.com/view/DKMS/view/Precise%20Proposed%20-generic-lts-raring/
16:08 <smb> We have been looking at some of them during the sprint
16:08 <jamespage> they are broken
16:09 <jamespage> OK _ I'll pickup openvswitch is someone else can grab iscsitarget
16:09 <jamespage> (iscsitarget should be a little easier/lower impact)
16:09 <arosales> iscsitarget up for grabs, get it while its hot
16:10 <smb> jamespage, I am pretty sure I did update openvswitch
16:10 <jamespage> smb, for the 3.11 kernel in saucy right?
16:10 <smb> Though in Saucy
16:10 <smb> yeah
16:10 <jamespage> smb, saucy has 1.10.1 which is pretty close for 3.10 support
16:10 <jamespage> precise has 1.4 which is way off
16:10 <arosales> #action jamespage to clean-up  openvswitch packaging for 12.04.3
16:10 * meetingology jamespage to clean-up  openvswitch packaging for 12.04.3
16:11 <arosales> jamespage, is that the correct action item?
16:11 <jamespage> arosales, yep
16:11 <arosales> ok any takes for iscsitarget?
16:11 <arosales> jamespage thanks for volunteering for openvswitch
16:11 <arosales> roaksoax, ?
16:12 <arosales> roaksoax, I'll assign to you for now just so it has an owner, please feel free to delegate as necessary
16:12 <arosales> #action roaksoax to clean-up iscsitarget packaging for 12.04.3
16:12 * meetingology roaksoax to clean-up iscsitarget packaging for 12.04.3
16:12 <roaksoax> arosales: here! (sorry having inet issues)
16:13 <hallyn_> (i'll note down to take a look later this week if it's still open)
16:13 <arosales> hallyn_, thanks
16:13 <arosales> #action hallyn_ to confirm iscsitarget packaging done
16:13 * meetingology hallyn_ to confirm iscsitarget packaging done
16:13 <arosales> so for Saucy
16:13 <arosales> we have feature freeze coming up
16:14 <arosales> do folks have in all MIR requests, and large package updates?
16:14 <arosales> jamespage, Daviey know of any items we need to review here?
16:14 <arosales> FF is on Aug 29 for 13.10, btw
16:15 <roaksoax> i need processing from the new queue for 'dlm'
16:15 <roaksoax> Daviey: if you could please review that it would be greatly appreciated
16:15 <jamespage> zul, Daviey: whats the status on mariadb/percona
16:15 <arosales> #action Daviey to review 'dlm' in new queue for Saucy
16:15 * meetingology Daviey to review 'dlm' in new queue for Saucy
16:15 <jamespage> any chance they will make that date?
16:16 <Daviey> roaksoax: Please ping me after the meeting, OTP
16:16 <zul> jamespage:  unchanged afaik
16:16 <arosales> zul, so unlikely to make it, or should we push in the next couple of weeks?
16:16 <arosales> zul ok to action you with a follow up?
16:16 <zul> arosales:  yeah
16:16 <arosales> #action zul to follow up on  mariadb/percona making it into Saucy
16:16 * meetingology zul to follow up on  mariadb/percona making it into Saucy
16:16 <arosales> zul, thanks
16:17 <arosales> any Saucy packages we should discuss here?
16:17 <arosales> any other, that is.
16:17 <Daviey> zul: Can you grab me about that action pls?  Need to fill you in.
16:17 <zul> Daviey:  ack
16:18 <arosales> I'll take it that covers the ones, and we should be able to catch others in the upcoming bugs and blueprint review.
16:18 <arosales> #subtopic Release Bugs
16:18 <arosales> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:19 <arosales> going down the list sorted by importance being at the top for ubuntu-server
16:19 <arosales> we have 13 bugs
16:19 <arosales> http://launchpad.net/bugs/1175028
16:19 <ubottu> Launchpad bug 1175028 in mongodb (Ubuntu Saucy) "Mongodb links GPL code with SSL" [Critical,Fix committed]
16:19 <arosales> ah sorry that is fix commited
16:20 <jamespage> yeah - almost there with that
16:20 <arosales> http://launchpad.net/bugs/1084028 in progress
16:20 <ubottu> Launchpad bug 1084028 in openvswitch (Ubuntu Saucy) "openvswitch based interfaces not started in time during boot" [High,In progress]
16:20 <jamespage> that won't make it this cycle now
16:20 <arosales> jamespage, ah :-/ ok, but thanks for the update.
16:20 <arosales> http://launchpad.net/bugs/1156932
16:20 <ubottu> Launchpad bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed]
16:21 <arosales> zul,  ^
16:21 <arosales> looks confirmed
16:21 <arosales> but not certain what the current status is for Saucy
16:21 <arosales> actually needs an owner
16:22 <arosales> zul, would that be something you can look into?
16:22 <zul> arosales:  erm...yeah
16:23 <arosales> zul, feel free to pass or reassign if necessary. Just thought it should have an owner with the tags and priority on the bug.
16:23 <arosales> zul, thanks
16:23 <arosales> https://bugs.launchpad.net/ubuntu/+source/nova/+bug/1199791
16:23 <ubottu> Launchpad bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged]
16:23 <arosales> next one is yours too zul.
16:23 <zul> arosales:  need to do that
16:23 <arosales> zul thanks
16:24 <arosales> https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1206872
16:24 <ubottu> Launchpad bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Confirmed]
16:24 <arosales> samba
16:24 * zul whistles
16:24 <jamespage> that needs a merge from debian
16:25 <jamespage> any volunteers?
16:25 <jamespage> I'd leave the aarch64 updates for the reporter :-)
16:25 <arosales> rbasak, your sharpening your debian skills right
16:25 <arosales> :-)
16:25 <rbasak> I'd love to do it, but I'm concerned that I have too much on my todo list right now, and won't get round to it.
16:26 <jamespage> OK - I'll stick it on my list for this week - I've done it a few times now
16:26 <jamespage> that should keep the overheads down
16:26 <arosales> jamespage, thanks
16:26 <jamespage> if I disappear for any reason someone else can pick it up
16:26 <arosales> jamespage, sounds good
16:27 <zul> jamespage:  just stick your todo list somewhere before you go
16:27 <arosales> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1208455
16:27 <jamespage> zul, ok
16:27 <ubottu> Launchpad bug 1208455 in linux (Ubuntu Saucy) "general protection fault running apt-get inside double nested kvm VM" [High,In progress]
16:27 <arosales> no owner for saucy
16:27 <arosales> hallyn_, any suggestions ^
16:27 <hallyn_> arosales: it's a kernel bug, i'd expect jsalisbury or smb would be interested int aking it
16:28 <smb> I think we were sort of waiting for james hunt
16:28 <smb> Now that 3.11 hit the archive he may test with all 3 on 3.11
16:29 <arosales> smb, thnks, sounds like it is still moving
16:29 <hallyn_> arosales: i generally find those bugs don't need an owner next to them for kernel team to watch them closely, fwiw
16:29 * arosales will finish up the medium bugs and then we can move on. Just wanted to step through the bugs as we approach FF.
16:29 <arosales> hallyn_, ack thanks
16:29 <arosales> https://bugs.launchpad.net/ubuntu/+source/python-quantumclient/+bug/1170849
16:29 <ubottu> Launchpad bug 1170849 in python-quantumclient (Ubuntu Saucy) "Cliff 1.3.2 is not available " [Medium,Triaged]
16:30 <arosales> looks like adam_g commented here
16:30 <arosales> troubles reproducing, awaiting reporter feedback
16:30 <arosales> hmm
16:30 <arosales> https://bugs.launchpad.net/ubuntu/+source/openvswitch/+bug/1189408
16:30 <jamespage> its a trunk testing PPA bug - marked invalid
16:30 <ubottu> Launchpad bug 1189408 in openvswitch (Ubuntu) "1.10 FTBFS on powerpc (lacp test failure)" [Medium,New]
16:31 <arosales> I thought powerpc was gonig away
16:31 <jamespage> arosales, thats non critical - I took the saucy task off just now
16:31 <hallyn_> i think it's coming back :)
16:31 <arosales> jamespage, thanks on both bugs
16:31 <arosales> https://bugs.launchpad.net/ubuntu/+source/mysql-5.5/+bug/1203828
16:31 <ubottu> Launchpad bug 1203828 in mysql-5.5 (Ubuntu Saucy) "mysql 5.5.32, 5.1.70 security update tracking bug" [Medium,Confirmed]
16:32 <arosales> do these get picked up auto-magically or do we need some one to manually intervene for Saucy?
16:32 * arosales wonder if the security team picks these up. . .  .
16:32 <jamespage> they do
16:32 <rbasak> I think so. They just fall into our triage list.
16:32 <arosales> ack
16:32 <arosales> that closes out the medium or >
16:33 <arosales> thanks for stepping through that :-)
16:33 <arosales> #subtopic Blueprints
16:33 <arosales> #link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:33 <arosales> burndown looks crazy
16:34 <arosales> overall we are in the red :-/
16:34 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-charmhelper2 needs some attention with marco returns
16:34 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2
16:34 <jamespage> alot of that is in progress or done
16:34 * arosales hitting red BPs
16:34 <arosales> jamespage, thanks
16:34 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-hypervisor
16:35 <arosales> 0%
16:35 <arosales> zul, ^
16:35 <zul> gah i need to update that
16:35 <arosales> zul ok thanks
16:35 <hallyn_> arosales: remind me, are these things being measured against completion in august, or in october?
16:36 <arosales> hallyn_, October
16:36 <hallyn_> ok
16:36 <arosales> at least that is what the series goal is set to
16:36 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-hypervisor
16:36 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-ceph
16:36 <arosales> sorry wrong paste
16:37 <arosales> jamespage, looks like cep is on track for August
16:37 <jamespage> arosales, looking OK
16:37 <jamespage> dumping rc in saucy
16:37 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-webscale ok too?
16:37 <jamespage> that sounds odd
16:37 <jamespage> arosales, no
16:37 <arosales> ya got a couple blocked
16:37 <arosales> sorry nginx is blocked
16:37 <jamespage> arosales, thats to late now
16:38 <jamespage> arosales, I'm going to cancel that entire blueprint
16:38 <arosales> jamespage, wan to postpone the rest of the work items?
16:38 <arosales> or still a bit too early for that?
16:38 <jamespage> its kicked around for two cycles now so can't be that important
16:38 <jamespage> utlemming, are you likely to find time to work on the webscale WI for nginx?
16:39 <arosales> utlemming, also got some work items out for you in cloud-init in https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-init
16:39 <utlemming> jamepage: not for webscale
16:39 <jamespage> utlemming, guessed so
16:39 <jamespage> arosales, I've deferred that entire blueprint
16:39 <arosales> jamespage, perhaps we can find some more cycles outside of server to do some more "web scale" packaging. I know it would be a plus to get more packages charms use into the archive
16:39 <utlemming> jamepages: for the ci work, I have done some stuff
16:40 <utlemming> jamespage: I just need to update that
16:40 <arosales> utlemming, when you have an opp could you also update the cloud init BP?
16:40 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-qa
16:40 <utlemming> arosales: sure thing
16:40 <arosales> utlemming, thanks
16:40 <arosales> zul, looks to be in progress
16:40 <arosales> got a few TODOs there though still
16:41 <arosales> Daviey, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-interlock
16:41 <arosales> jamespage, mongo looking ok
16:41 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-mongodb
16:42 <jamespage> arosales, ok-ish
16:42 <jamespage> the MIR is proving challenging tbh
16:42 <arosales> ya, you fought a pretty good battle around the licensing though
16:42 <arosales> thanks for your work there.
16:42 <jamespage> arosales, that should be sorted by 5th sept
16:42 <arosales> simplestreams, probably need to wait for smoser on that
16:42 <jamespage> upstream are also engaging on the MIR stuff as well re security team concerns
16:43 <arosales> jamespage, good to hear
16:43 <arosales> ah good to know
16:43 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-contributor-onramp needs an update by jcastro
16:43 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-charm-testing needs an update by marco when he returns
16:43 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms
16:44 <jamespage> we should DONE quite a few this week on the openstack-charms work
16:44 <jamespage> redux is going nicely
16:44 <jamespage> then we can get on with feature work
16:44 <arosales> ah, nice
16:44 <arosales> hallyn_, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-virtstack
16:45 <arosales> looks to be progressing . . .
16:45 <hallyn_> some thigns will surely be postponed yet
16:45 <arosales> ok
16:45 <arosales> nick needs to upate https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-docs when he returns
16:45 <hallyn_> but i don't want to count anything out that i haven't already markdd so
16:45 <arosales> thanks for keeping it updated hallyn_
16:45 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-archive has progress too
16:45 <hallyn_> np (did it 3 mins ago :)
16:46 <arosales> hallyn_, ha saw it coming :-)
16:46 <arosales> smart man
16:46 <arosales> utlemming, could you udpate https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-vagrant
16:46 <arosales> ok so hopefully as openstack charms get done a lot more will come out of red
16:47 <arosales> and with updates
16:47 <utlemming> arosales: ack, doing that now
16:47 <arosales> utlemming, thanks
16:47 <arosales> moving on
16:47 <arosales> #topic Ubuntu Server Team Events
16:47 <arosales> vUDS coming up at the end of August
16:47 <arosales> http://uds.ubuntu.com/
16:47 <arosales> #link http://uds.ubuntu.com/
16:47 <arosales> #topic Weekly Updates & Questions for the QA Team (plars)
16:48 <plars> redirect -> psivaa
16:48 <psivaa> no updates from QA though
16:48 <arosales> plars, psivaa thanks
16:48 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:48 <smb> In order to prepare for uploading Xen 4.3 I started to upload packages
16:48 <smb> that rdepend on xen stuff to my ppa. Most of them looked ok. I still
16:48 <smb> would have to check nova. Is anybody doing actually using xen from
16:48 <smb> openstack who could easily test things?
16:48 <smb> The bigger problem seems to be xen-api / xen-api-libs which add a
16:48 <smb> dependency to blktap-dev which include libblktapctl.
16:48 <smb> Unfortunately Xen also has a lib of the same name (maybe the same
16:48 <smb> but older source?) which I had to package (or at least thought) into
16:48 <smb> libxen because otherwise libvirt would not be able to build the libxl
16:48 <smb> driver. Not sure which way to go there right now. Anybody knows whom
16:48 <smb> of the Citrix guys would be to contact. Still Mike?
16:49 <arosales> hallyn_, any opinions ^
16:49 <jamespage> smb, mike is still good for contact point I think
16:49 <hallyn_> arosales: no, i always defer on xen to zul and smb
16:50 <arosales> zul any time to test xen on nova?
16:50 <arosales> or just contacts for smb?
16:50 <arosales> Daviey, ^
16:50 <smb> zul, Or is that maybe also the xen-api guys?
16:51 <hallyn_> on friday i should be able to test xen on nova, fwiw, but i don't know about the citrix guys
16:51 <hallyn_> (and i'll have to wipe my lxc on nova setup to do it :)
16:52 <arosales> hallyn_, thanks, could you coordinate with smb and zul
16:52 <smb> hallyn_, Ok, maybe I have a solution for the xen-api problem by then. Maybe ping me before you go
16:52 <arosales> #action hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:52 * meetingology hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:52 <hallyn_> smb: yup
16:52 <arosales> hallyn_, thanks
16:52 <arosales> smb, any other topics?
16:52 <zul> arosales:   not til the end of the month
16:53 <arosales> zul, ack. Please pass on any contacts that may be helpful to smb or hallyn_
16:53 * zul is still stuck in the middle of nowhere
16:53 <zul> arosales: ack
16:53 <arosales> smb, I'll proceed since time is running short please feel free to interject if you had other topics.
16:53 <arosales> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:54 <rbasak> We have highbank buildds! Build speeds for armhf should be much improved now.
16:54 <rbasak> https://launchpad.net/builders if you'd like to gaze at the small army of them.
16:55 <rbasak> https://lists.ubuntu.com/archives/ubuntu-devel/2013-August/037564.html for Colin's announcement.
16:55 <arosales> rbasak, good stuff
16:55 <rbasak> Nothing else to report. Any questions for me?
16:55 <arosales> rbasak, thanks for the update
16:55 <arosales> #topic Open Discussion
16:56 <arosales> I forgot to mention there will be a charm school this Friday
16:57 <arosales> #topic Open Discussion
16:57 <arosales> sorry wrong past
16:57 <arosales> #topic Announce next meeting date and time
16:57 <arosales> NEXT MEETING: Tuesday 2013-08-20 at 1600 UTC - #ubuntu-meeting
16:57 <arosales> #endmeeting