16:00 <adam_g> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Jul 16 16:00:08 2013 UTC.  The chair is adam_g. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00 <adam_g> hi all
16:00 <adam_g> #topic Review ACTION points from previous meeting
16:01 <adam_g> arosales to carry out post-meeting procedure (minutes, etc) documented at https://wiki.ubuntu.com/ServerTeam/KnowledgeBase for meeting of 25 June
16:01 <adam_g> arosales, any update?
16:01 <arosales> adam_g, https://wiki.ubuntu.com/MeetingLogs/Server/20130625
16:02 <adam_g> arosales, cool.
16:02 <adam_g> Daviey to speak to Percona about Saucy inclusion
16:03 <adam_g> Daviey, any update on percona in saucy?
16:03 <Daviey> adam_g: I have emailed them
16:03 <arosales> adam_g, a couple of week late :-/ but finally got there.  I'll be sure to get it out to the list and blog next time I chair (apologies).
16:03 <Daviey> awaiting response
16:03 <Daviey> adam_g: feel free to remove that from the agenda
16:03 <Daviey> it's inhand
16:04 <adam_g> Daviey, ack
16:04 <adam_g> rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:04 <rbasak> I've got the script ready to go, just need to integrate with lp:ubuntu-reports now
16:05 <adam_g> rbasak, cool. is there a merge proposal somewhere yet?
16:05 <rbasak> No - Daviey took me through the code earlier so I know what to do now. You should see one this week.
16:05 <Daviey> super
16:05 <adam_g> sweet
16:06 <adam_g> i'll leave it on the agenda
16:06 <adam_g> #ACTION rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:06 * meetingology rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:06 <adam_g> zul has willfully volunteered to review and document what is blocking server related saucy-proposed migration excuses, with joy.
16:06 <zul> no joy...apache2 is still making its way through debian and sqlalchemy needs to be done as well
16:07 <Daviey> following -release channel, apache2 is making progress
16:07 <Daviey> as is php5 (thanks to rbasak)
16:08 <adam_g> ok, ill leave that there as well.
16:08 <rbasak> php5 seems to have reverse build depends blocking migration to saucy now :-(
16:08 <adam_g> moving on?
16:08 <rbasak> Some may just need rebuilds
16:09 <adam_g> #topic Saucy Development
16:09 <adam_g> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:09 <adam_g> Daviey, you want the mic for this?
16:10 <Daviey> ok!
16:10 <Daviey> bug 1196921 is feeling wedged
16:10 <ubottu> bug 1196921 in vim (Ubuntu Saucy) "updating packages to lua5.2 in main" [High,Confirmed] https://launchpad.net/bugs/1196921
16:11 <Daviey> rrdtool is our problem
16:11 <Daviey> Does someone want to volunteer to look at that?
16:11 <Daviey> might be trivial...
16:11 <jamespage> ill do it
16:12 <Daviey> jamespage: maybe someone else? :)
16:12 <yolanda> Daviey, if it's an easy one i can volunteer
16:12 <jamespage> if no-one else can
16:12 <Daviey> yolanda: Super!  Have a look at it and see what it involves?
16:12 <yolanda> sure
16:13 <Daviey> bug 1183634
16:13 <ubottu> bug 1183634 in cheetah (Ubuntu Saucy) "cheetah pkg does not depend on markdown, but egg requires.txt does" [High,Triaged] https://launchpad.net/bugs/1183634
16:13 <Daviey> adam_g: ^
16:13 <jamespage> that should be won't fix
16:13 <jamespage> once the MIR goes though no?
16:13 <adam_g> Daviey, should be good. both python-markdown and python-tidylib got promoted okay to main. just need a new cheetah that Depends on them, and dropping of our patch there
16:14 <Daviey> adam_g: super, so next upload?
16:14 <adam_g> Daviey, yup. stuff got promoted just recently, ill propose a new cheetah package todya
16:14 <Daviey> supr
16:14 <Daviey> bug 1199791
16:14 <ubottu> bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged] https://launchpad.net/bugs/1199791
16:14 <Daviey> zul: ^ ?
16:15 <Daviey> bug 1190038, adam_g ?
16:15 <ubottu> bug 1190038 in keystone (Ubuntu Saucy) "keystone-all fails to start: : The Keystone paste configuration file keystone-paste.ini could not be found." [High,Fix committed] https://launchpad.net/bugs/1190038
16:15 <zul> Daviey:  ugh
16:15 <adam_g> Daviey, fix committed pending a new keystone upload
16:15 <Daviey> super
16:16 <Daviey> rbasak: bug 1031680  ?
16:16 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:16 <Daviey> adam_g: bug 1197163 ?
16:16 <ubottu> bug 1197163 in nova (Ubuntu Saucy) "nova-xvpvncproxy installs no upstart job" [High,Fix committed] https://launchpad.net/bugs/1197163
16:16 <rbasak> I've not looked at that.
16:16 <adam_g> Daviey, fix committed pending a new nova upload
16:16 <Daviey> rbasak: Oh, i thought you were looking at that one, sorry
16:16 <smoser> o/
16:17 <Daviey> smoser: are you looking at bug 1031680 ?
16:17 <rbasak> I'll add it to my list to at least look at. I can't remember if we can make progress on it or not.
16:17 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:17 <smoser> no. i wasn't. i was just saying hello.
16:17 <Daviey> Oh, everyone say hello to smoser please
16:17 <Daviey> Hello smoser.
16:18 <rbasak> Hi smoser!
16:18 <Daviey> jamespage: bug 1170393 ?
16:18 <smoser> hi everyone.
16:18 * jamespage waits for ubottu
16:18 <jamespage> bug 1170393
16:19 <jamespage> tap tap
16:19 <jamespage> is this thing on
16:19 <Daviey> jamespage: "Quantum services should be respawned by upstart if necessary"
16:19 <jamespage> on my todo list still - want to get the neutron name change out of the way first
16:19 <Daviey> Good thinking
16:19 <jamespage> there are also some new agents to enable
16:19 <Daviey> do we have a decent transition path?
16:19 <zul> Daviey:  its in progress
16:20 <jamespage> zul has made a start but its pretty ugly for existing configuration
16:20 <Daviey> jamespage: ISTR you were looking at bug 1196979 ?
16:20 <Daviey> jamespage: ugh
16:20 <Daviey> "[MIR] libasm4-java (b-d of jarjar)"
16:20 <jamespage> mhfjknjsnfdcs
16:20 <jamespage> forgot about that one
16:20 * zul hopes openstack will never rename a project again
16:20 <jamespage> sorry
16:21 <Daviey> super
16:21 <jamespage> I think that will probably wash through in Debian first - I'll go talk with a few folks in the debian-java team
16:21 <Daviey> Any other issues pertinent ?
16:21 <jamespage> zul, you got the sqlalchemy stuff stored now
16:21 <rbasak> I'd like to flag https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1199318. I tried to target it for Saucy but apparantly I still can't do that unless I'm missing something.
16:21 <jamespage> or is that still all held iup in proposed?
16:22 <Daviey> rbasak: ugh, i think you need to be core to target.  How silly.
16:22 <ubottu> bug 1170393 in quantum (Ubuntu Saucy) "Quantum services should be respawned by upstart if necessary" [Medium,Triaged] https://launchpad.net/bugs/1170393
16:22 <ubottu> bug 1196979 in ow-util-ant-tasks (Ubuntu Saucy) "[MIR] libasm4-java (b-d of jarjar)" [Undecided,New] https://launchpad.net/bugs/1196979
16:22 <jamespage> rbasak, approved
16:22 <ubottu> Ubuntu bug 1199318 in apache2 (Ubuntu Saucy) "package apache2-utils 2.2.22-6ubuntu5 failed to install/upgrade: trying to overwrite '/usr/share/apport/package-hooks/apache2.py', which is also in package apache2.2-common 2.2.22-6ubuntu5" [High,Confirmed]
16:22 <zul> jamespage:  its still held up in proposed, but nova builds with 0.7.9+ now
16:22 <Daviey> okay, i think we should see if that one is still an issue when apache finishes it's miration/
16:22 <Daviey> migration*?
16:23 <rbasak> We can wait. Although I have a suspicion the underlying cause will remain.
16:23 <jamespage> I think it will be
16:23 <rbasak> Unless Debian fix it first.
16:23 <jamespage> what are we talking about now? apache2?
16:23 <Daviey> yes
16:23 <jamespage> thats the ubuntu apport hook
16:23 <jamespage> so its our bug
16:23 <rbasak> Ah
16:23 <rbasak> Good point.
16:23 <Daviey> right, but i wanted to see if it is still an issue when apache2 settles down
16:23 <jamespage> just needs the right breaks/replaces
16:24 <rbasak> How'd it manage to move from -common to -utils anyway?
16:24 <jamespage> one second - it looks like its in both?
16:24 <Daviey> lets defer it until next week, when the transition should be solved.
16:24 <rbasak> AIUI, it was in -common before, and is in -utils now.
16:24 <rbasak> And perhaps both though that's not clear.
16:25 <rbasak> We probably want it in -common and not -utils?
16:25 <Daviey> i suspect it did move, and Breaks/Replaces hasn't made sure the old one is uninstalled first.
16:25 <roaksoax> yeah it seems to be a Breaks/Replaces issue
16:25 <jamespage> anyway - lets let rbasak sort that one out
16:26 <Daviey> super
16:26 <Daviey> Move on?
16:26 <adam_g> sure.
16:26 <adam_g> blueprints!
16:26 <adam_g> #link  http://status.ubuntu.com/ubuntu-saucy/group/topic-saucy-servercloud-overview.html
16:26 <adam_g> hmm. thats a bad link
16:26 <Daviey> O RLY
16:27 <Daviey> http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:27 <Daviey> for some reason aucy was removed... *sigh*
16:27 <Daviey> adam_g: can you update the template please?
16:27 <Daviey> (Agenda)
16:27 <adam_g> Daviey, sure
16:28 <Daviey> [james-page] Resolve OpenSSL licensing issues with upstream: INPROGRESS <-- is that now done, jamespage ?
16:28 <jamespage> Daviey, almost
16:28 <jamespage> first part is in
16:28 <jamespage> just waiting for headers to appear on the relevant files
16:28 <jamespage> mongodb MIR may prove problematic
16:28 <Daviey> ok
16:28 <Daviey> ugh
16:28 <jamespage> I need to catchup with jdstand but I've been a bit busy
16:28 <Daviey> understood
16:28 <Daviey> rbasak: [racb] Complete and feed arm porting work back upstream: INPROGRESS ?
16:29 <Daviey> and the other arm work..
16:29 <rbasak> Oddly my double alignment patch doesn't seem to be needed any more. I need to double check.
16:29 <rbasak> I very quickly spoke to Jon Masters about the other patch at Linaro Connect. It sounded like he'd be happy to get it upstreamed as-is.
16:29 <rbasak> I need to follow up on both.
16:29 <Daviey> oh groovy!  If that is something you can look at this week, that will help improve the blueprint completeness :)
16:30 <Daviey> roaksoax: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2 ?
16:30 <Daviey> progress, seems, erm, less than ideal.
16:31 <jamespage> Daviey, we need to get the python redux out of the way first before we start adding new stuff
16:31 <Daviey> utlemming / ivoks: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-webscale .. how is that looking?
16:31 <Daviey> jamespage: what is the current status of redux?
16:32 <jamespage> most shared code is now into charm-helpers trunk
16:32 <utlemming> Daviey: with all the cloud stuff, I haven't even had a reasonable chance to look at it
16:32 <jamespage> glance (roaksoax) cinder (adam_g) and openstack-dashboard (me) all in flight
16:32 <jamespage> but looking good and working on juju-core
16:33 <jamespage> adam_g, anything further to add?
16:33 <adam_g> i expect the remaining python rewrites will all happen quickly with the shared code in one place and functional
16:33 <jamespage> adam_g, agreed
16:33 <Daviey> utlemming: would you be able to do a quick analysis by next week.. that is one work item, and may help guide the rest of the blueprint priority
16:33 <ivoks> Daviey: uh
16:33 <adam_g> with nova-cloud-controller being the most time consuming
16:33 <jamespage> I did the openstack-dashboard one in a few hours this morning
16:33 <utlemming> Daviey: sure, I'll take a look
16:33 <Daviey> utlemming: thanks
16:33 <adam_g> jamespage, cool!  i think swift-storage, nova-compute should be <2 hours easy
16:33 <roaksoax> Daviey: yeah i been concentrated on other things
16:33 <roaksoax> but I'll get there
16:33 <jamespage> adam_g, yeah
16:33 <Daviey> shall we set the goal of having the redux done by EOW/
16:33 <Daviey> ?
16:33 <ivoks> Daviey: sorry, ENOTIME
16:34 <jamespage> actually while we are discussing
16:34 <Daviey> ivoks: understood.. when do you think you will have time?
16:34 <Daviey> ivoks: or should we drop it?
16:34 <ivoks> Daviey: drop it for 13.10
16:34 * jamespage defers
16:34 <adam_g> Daviey, i expect the nova-cloud-controller charm to take a bit longer, there are *many* duplicmate variations that need good testing.
16:34 <adam_g> Daviey, but the others + good progress on nova-c-c should be doable this week for sure
16:35 <Daviey> adam_g: If we set the goal, can you help identify where other people might be able to help?
16:35 <adam_g> uh s/duplicmate/deployment... but i like that new word, duplicmate
16:35 <Daviey> It would be super if we could get it cracked out this week
16:35 <adam_g> sure
16:35 <jamespage> maybe without full test coverage
16:36 <adam_g> ill sync with roaksoax later to see how he is doing on glance, and we can split up the remaning few charms between jamespage, roaksoax and myself
16:36 <jamespage> works for me
16:36 <Daviey> super
16:36 <Daviey> jamespage: yeah, done in principle is the target i think
16:36 <Daviey> QA & testing next week
16:37 <Daviey> zul: milestone h-2 this thurs, how are we looking for uploads?
16:37 <zul> Daviey:  better than yesterday nova is building locally with sqlalchemy 0.7.9
16:38 <Daviey> zul: Are we expecting a fullu functional h-2 in saucy by eow?
16:38 <zul> Daviey:  just trying to get people to look at them now
16:38 <zul> neutron and neurtronclient needs to MIRed again i think dont they
16:38 <Daviey> zul: what needs looking at?
16:38 <zul> nova/cinder/python-ceilometerclent so far
16:39 <Daviey> zul: I suspect neutron needs a ruber stamp, please can you reach out directly to mterry and check?
16:39 <zul> Daviey:  yep
16:39 <Daviey> zul: I'd really like to start getting it into UCA on Monday
16:40 <Daviey> Any other BP stuff from anyone?
16:40 <Daviey> adam_g: move on?
16:40 <jamespage> one more thing BP related
16:40 <jamespage> the one that never show up - ceph
16:40 <Daviey> Ugh
16:40 <jamespage> I stuffed a interim release into https://launchpad.net/~ceph-ubuntu/+archive/edgers
16:40 <adam_g> ... the one that got away
16:41 <jamespage> 0.66
16:41 <jamespage> we are getting pretty close to the dumpling release now (august)
16:41 <jamespage> so its an early preview for testing
16:41 <jamespage> won't land in distro
16:41 <Daviey> ok!
16:42 <Daviey> jamespage: have the BP link to hand?
16:42 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-ceph
16:42 <Daviey> ta
16:42 <adam_g> cool
16:42 <adam_g> #topic Ubuntu Server Team Events
16:42 <adam_g> anything going on?
16:43 <adam_g> OSCON is next week. i know jorge castro will be there, i will at least be at some of the night events and BoFS
16:43 <Daviey> This Friday, openstack birthday being celebrated in London
16:43 <adam_g> i believe there will be an ubuntu server related BOF @ OSCON. ill post the date next meeting
16:44 <Daviey> (http://www.meetup.com/Openstack-London/)
16:44 <adam_g> cool
16:44 <adam_g> moving on?
16:44 <adam_g> #topic Weekly Updates & Questions for the QA Team (plars)
16:45 <psivaa> nothing much apart from this bug for us
16:45 <psivaa> bug #1197484
16:45 <ubottu> bug 1197484 in isc-dhcp (Ubuntu) "Connection requests to saucy server VMs from a hosts fail after fresh VM installs" [High,New] https://launchpad.net/bugs/1197484
16:46 <psivaa> impacting the server smoke tests. jdstrand is working on to reproduce that outside qa lab
16:46 <psivaa> that's all from QA
16:46 <adam_g> psivaa, sounds fun. thanks. let us know if theres anything we can do to help test
16:47 <adam_g> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:47 <smb> Got Xen-4.3 mostly prepared and running and starting to annoy people with sponsoring requests. Started with some libvirt updates to fix xm stack regression and support 4.3 in the xen driver. Right now wondering about how to make upgrades a bit more seamless (fix paths in xend configs add a script to convert xend persistent definitions into libxl ones for libvirt).
16:47 <adam_g> smb, o/
16:47 <smb> Oh and one more thing about xen 4.3: upstream dropped support for i386
16:47 <smb> on the hypervisor. So I dropped that from building. Not sure one can
16:47 <smb> do more in order to give people more warning. In theory the combo of
16:47 <smb> 64bit hypervisor and 32bit dom0 and tools should work but I don't know
16:47 <smb> how that combo would be mapped to debian packaging..
16:47 <smb> Apart from those minor details... any questions for me?
16:48 <adam_g> smb, thanks for the xen update
16:48 <adam_g> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:49 <adam_g> rbasak, anything new to report?
16:49 <rbasak> Nothing new to report, really. mongodb ARM patch status as above.
16:49 <rbasak> I have a golang fix in hand and will upload soon.
16:49 <jamespage> \o/
16:49 <Daviey> \o/
16:49 <adam_g> cool
16:49 <jamespage> apparently stripping go binaires breaks stuff
16:49 <Daviey> oh?
16:50 <rbasak> My reading of Debian policy is that stripping is "should" not "must" so we can drop dh_strip.
16:50 <jamespage> yes
16:50 <rbasak> golang upstream doesn't use the normal toolchain.
16:50 <rbasak> And upstream don't support strip.
16:50 <jamespage> some binaries where already selectively excluded - we are just increasing the scope a bit
16:50 <rbasak> They say it breaks things. Evidently it does.
16:51 <adam_g> #topic Open Discussion
16:51 <rbasak> I think they might be Doing It Wrong, but I don't know enough to argue. They're upstream, it doesn't break policy so we might as well do what they say here. Given the other stuff we have to do with golang, this is trivial I think.
16:52 <Daviey> zul, smoser, roaksoax, adam_g, matsubara: you are al rubbish
16:52 <Daviey> https://wiki.ubuntu.com/ServerTeam/WeeklyDunk/Week29
16:52 <zul> Daviey:  thanks for the vote of confidence
16:52 <jamespage> zul, whats 'Example'? :-)
16:52 <Daviey> https://lists.ubuntu.com/archives/ubuntu-server/2013-July/006679.html
16:52 <jamespage> sounds interesting
16:53 <zul> jamespage:  its my new secret project
16:53 <jamespage> ooooooo
16:53 <Daviey> Anybody not listed that wants to add an entry, feel free!
16:53 <Daviey> More the merry.
16:54 <Daviey> smoser: i take back your suck, you have done yours.
16:54 <Daviey> EOF
16:54 <smoser> of course i suck.
16:54 <adam_g> Daviey, sorry, was out Fri will get updated today
16:54 <zul> Daviey: btw is al rubish my new name
16:54 <Daviey> super, thanks adam_g
16:55 <adam_g> #topic Announce next meeting date and time
16:55 <adam_g> next meeting will be Tuesday July 23rd
16:55 <adam_g> chaired by the honorable James Page
16:56 <roaksoax> THE James Page!
16:56 <Daviey> super, thanks for chairing adam_g
16:56 <arosales> thanks for chairing adam_g
16:56 <adam_g> over-and-out
16:56 <adam_g> #endmeeting