16:00 <yolanda> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Jul  9 16:00:13 2013 UTC.  The chair is yolanda. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00 <Daviey> o/
16:00 <yolanda> #topic Review ACTION points from previous meeting
16:00 <yolanda> arosales to carry out post-meeting procedure (minutes, etc) documented at https://wiki.ubuntu.com/ServerTeam/KnowledgeBase for meeting of 25 June
16:01 <yolanda> any update?
16:01 <jamespage> o/
16:02 <roaksoax> o/
16:02 <yolanda> Daviey to speak to Percona about Saucy inclusion
16:03 <Daviey> yolanda: 25 June still not done.  I'll work with arosales after this
16:03 <Daviey> yolanda: I haven't spoken to percona this week.  Will do THIS week
16:04 <yolanda> ok, let's leave as pending then
16:04 <yolanda> any other pending topics?
16:04 <Daviey> Nope
16:04 <yolanda> #topic Saucy Development
16:04 <yolanda> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:05 <yolanda> #subtopic Release Bugs
16:05 <yolanda> Daviey, any update with that?
16:05 <arosales> sorry, joined a little late
16:05 <arosales> here now
16:05 <Daviey> First.. the Release Schedule
16:05 <Daviey> DebianImportFreeze / Alpha2ish
16:05 <Daviey> Would be good to be up to date on sync's and merges for then.
16:06 <Daviey> rbasak has graciously fixed my delta report
16:06 <arosales> yolanda, I think rbasak put in a new process that he is carrying forward. I will ensure the wiki has the minutes from my chair'ing for historical reasons
16:06 <Daviey> http://people.canonical.com/~rbasak/delta.html
16:06 <rbasak> Note: I haven't cronned that. I generated it earlier.
16:06 <Daviey> We should try over this next week to reduce our delta with Debian
16:07 <yolanda> rbasak, are you doing something automatic?
16:07 <Daviey> #ACTION rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:07 * meetingology rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:07 <rbasak> yolanda: I intend to, but I haven't done it yet.
16:07 <rbasak> ack
16:08 <yolanda> i could help a bit with merges and syncs this week also
16:08 <jamespage> Daviey, +1 to that
16:09 <Daviey> Shall we look at, http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:09 <Daviey> bug 1124384
16:09 <ubottu> bug 1124384 in cloud-init (Ubuntu Saucy) "Configuration reload clears event that others jobs may be waiting on" [High,Confirmed] https://launchpad.net/bugs/1124384
16:09 <Daviey> smoser: Are we expecting a cloud-init upload soon?
16:09 <smoser> yes.
16:09 <Daviey> I noticed that Debian is carrying a delta
16:10 <smoser> that one is fixed in raring ..
16:10 <smoser> oh?
16:10 <Daviey> smoser: http://ftp-master.metadata.debian.org/changelogs//main/c/cloud-init/cloud-init_0.7.2-1_changelog
16:11 <Daviey> Might be worth checking if we can fold anything interesting
16:11 <Daviey> bug 1196921
16:11 <ubottu> bug 1196921 in vim (Ubuntu Saucy) "updating packages to lua5.2 in main" [High,Confirmed] https://launchpad.net/bugs/1196921
16:11 <smoser> yeah. thanks.
16:12 <Daviey> rbasak: You had thoguths on transitions such as this.  Is it worth just uploading a new rrdtool and see what breaks?
16:12 <Daviey> (i feel evil suggesting that)
16:13 <Daviey> adam_g: bug 1183634 ?
16:13 <ubottu> bug 1183634 in cheetah (Ubuntu Saucy) "cheetah pkg does not depend on markdown, but egg requires.txt does" [High,Triaged] https://launchpad.net/bugs/1183634
16:13 <rbasak> Sorry poor connection here
16:13 <adam_g> Daviey, progressing, slowly. security team just started moving on the python-markdown MIR
16:14 <adam_g> Daviey, should be good once thats done
16:14 <Daviey> Super!
16:14 <Daviey> I see they last touched it 20 hours ago.. so making progress
16:15 <Daviey> bug 1170393, jamespage
16:15 <ubottu> bug 1170393 in quantum (Ubuntu Saucy) "Quantum services should be respawned by upstart if necessary" [Medium,Triaged] https://launchpad.net/bugs/1170393
16:15 <jamespage> catching up on openstack this week
16:16 <rbasak> Daviey: I don't follow. It looks like we're up-to-date with Debian on rrdtool?
16:17 <Daviey> rbasak: No, that isn't the problem.. there is a lua transition needed, and that package is marked as depending on it
16:17 <Daviey> Feels very similar to the ruby and mysql issues we had.. Keeps getting deferred, then someone does it blindly.. and that prompts issues to be flushed out.
16:18 <rbasak> Daviey: oh, so a no change rebuild?
16:18 <Daviey> rbasak: yah
16:18 <rbasak> I have less objection to someone blindly doing a no change rebuild, since that shouldn't introduce any new issues that didn't already exist
16:18 <rbasak> If I were doing it I'd test it first though
16:19 <Daviey> ok
16:19 <Daviey> zul: Do you know why apache2 is still held?
16:19 <Daviey> (saucy-proposed)
16:20 <rbasak> There's a big pile of breakages it would cause. I looked today - it looks like almost everything is waiting on Debian
16:20 <zul> Daviey:  yeah one packaging is blocking it, its being fixed in debian
16:20 <Daviey> zul: which package?
16:20 <rbasak> zul: it looked like many more than one to me
16:20 <rbasak> http://people.canonical.com/~ubuntu-archive/proposed-migration/update_output.txt
16:20 <zul> Daviey:  dont remember off the top of my head
16:21 <rbasak> I counted 62 source packages in there
16:21 <zul> uwsgi
16:21 <Daviey> Does someone want to volunteer to get to grips of proposed migration issues this week?
16:22 <Daviey> I'm seeing more server seed issues on excuses.html than we'd like
16:22 <Daviey> zul: Fancy it  ^^ ?
16:23 <zul> Daviey:  sure
16:23 <zul> Daviey:  not really but ill do it
16:23 <Daviey> #ACTION zul has willfully volunteered to review and document what is blocking server related saucy-proposed migration excuses, with joy.
16:23 * meetingology zul has willfully volunteered to review and document what is blocking server related saucy-proposed migration excuses, with joy.
16:23 <yolanda> !
16:24 <yolanda> Daviey, any more bugs to review?
16:24 <Daviey> bug 1196979 , jamespage - can you summarise ?
16:24 <ubottu> bug 1196979 in ow-util-ant-tasks (Ubuntu Saucy) "[MIR] libasm4-java (b-d of jarjar)" [Undecided,New] https://launchpad.net/bugs/1196979
16:24 <jamespage> transition
16:24 <jamespage> I have it on my list
16:24 <Daviey> ok, thanks
16:25 <Daviey> rbasak: bug 1031680 , been a bunch of discussion. Do we have a plan?
16:25 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:26 <rbasak> Daviey: I'm happy with the plan xnox described on the ML. It needs someone to actually do it, though.
16:26 <Daviey> rbasak: ok, thanks.
16:26 <Daviey> Any more bugs?
16:26 <Daviey> Blueprints.. Don't think we need to review them this week.
16:27 <Daviey> Would like to check on.. juju-core, is there any progress on getting an update into saucy ?
16:27 <Daviey> jamespage: ^ ?
16:27 <jamespage> Daviey, I pinged mgz today - 1.1.1 of golang is now in saucy (I jumped the Debian maintainer and pushed a point release in myself)
16:27 <Daviey> Super!
16:28 <jamespage> mgz is going to work on that with davecheney ~soon
16:28 <jamespage> end of this week latest I hope
16:28 <Daviey> A General note.  Please make sure that if you are working on something, anything, it is captured as a WI.
16:28 <jamespage> ^^^ that all is
16:28 <Daviey> There are too many 0% progresses for the cycle and a 100% (!)
16:28 <jamespage> also remember a work item can be a bug linked to a blueprint as well
16:29 <Daviey> EOF, thanks
16:29 <yolanda> ok
16:29 <yolanda> #topic Ubuntu Server Team Events
16:29 <yolanda> i received emails for OpenStack summit and free registration codes
16:30 <yolanda> shall we register so soon?
16:31 <Daviey> yolanda: Yes, do register :)
16:31 <Daviey> I haven't done so yet.
16:31 <yolanda> ok
16:31 <Daviey> But a bunch of ~ubuntu-server people are going to Openstack Summit in Honk Kong, November.
16:31 <Daviey> But a little early to declare it
16:32 <yolanda> any other events?
16:32 <arosales> OSCON coming up at towards the end of the months
16:32 <Daviey> None in the short term, i don't think
16:32 <arosales> OSCON = ~july 22~
16:33 <yolanda> #topic Weekly Updates & Questions for the QA Team (plars)
16:33 <psivaa> I am in for plars for this week
16:33 <psivaa> Just a couple of bugs affecting the smoke tests, jdstrand and apw were working on them
16:33 <psivaa> bug #1197484 and bug #1195710
16:33 <ubottu> bug 1197484 in isc-dhcp (Ubuntu) "Connection requests to saucy server VMs from a precise host fail after fresh VM installs" [High,Incomplete] https://launchpad.net/bugs/1197484
16:33 <psivaa> :)
16:33 <ubottu> bug 1195710 in linux (Ubuntu Saucy) "'Kernel bug - invalid opcode: 0000 [#1] SMP' is reported at 'Preparing linux-image-extra-3.10.0-0-generic' stage of multi-lvm installations of amd64 saucy server " [High,Confirmed] https://launchpad.net/bugs/1195710
16:33 <smb> The last one being worked on by apw
16:34 <psivaa> jdstrand said he will look into the first one
16:34 <yolanda> ok
16:34 <yolanda> anything else for psivaa?
16:34 <psivaa> that's all from us this week
16:35 <yolanda> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:35 <smb> Not much from me. Xen-4.3 is in progress and the usual funny bugs.
16:35 <yolanda> any question for smb?
16:36 <yolanda> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:36 <rbasak> Nothing new to report. Any questions for me?
16:36 <doko> jamespage, are you involved with the Debian go policy?
16:36 <doko> are don't you care?
16:36 <Daviey> rbasak: Looking forward to learning what comes out of Connect when you return :)
16:37 <jamespage> doko, not really but I think i may have to start....
16:37 <yolanda> #topic Open Discussion
16:37 <doko> jamespage, cool, lets chat about this next week
16:37 <yolanda> any other topics to brig?
16:37 <yolanda> bring?
16:38 <jamespage> doko, yes - lets do that
16:38 <yolanda> anything else?
16:39 <yolanda> ok, so let's finish
16:39 <yolanda> #topic Announce next meeting date and time
16:39 <arosales> thanks for chairing yolanda :-)
16:39 <yolanda> next meeting will be on 16th of July
16:39 <yolanda> adam_g will be chairing
16:39 <jamespage> so long as yolanda gets all the paper work out by then :-)
16:40 <yolanda> sure :)
16:40 <yolanda> #endmeeting