16:03 <rbasak> #startmeeting ubuntu-server-team
16:03 <meetingology> Meeting started Tue Jul  2 16:03:09 2013 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03 <meetingology> 
16:03 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:03 <rbasak> #topic Review ACTION points from previous meeting
16:03 <arosales> Daviey set priority on s-cycle BPs
16:03 <arosales> Daviey follow up on missing BPs from overview s-topic
16:04 <rbasak> I don't see last week's meeting logs
16:04 <arosales> rbasak, I just updated the wiki page with those two actions
16:05 <rbasak> https://wiki.ubuntu.com/MeetingLogs/Server/20130625 doesn't exist.
16:05 <Daviey> arosales: Broadsided me :-)
16:05 <rbasak> I'll look at the IRC logs.
16:05 <Daviey> I believe the priorities are all good NOW.. I need to double check they are all on the status tracker.
16:05 <arosales> rbasak, yes sorry I didn't add that there
16:05 <Daviey> Mark it done, will double check following this.
16:05 <arosales> the moin logs are at http://ubottu.com/meetingology/logs/ubuntu-meeting/2013/ubuntu-meeting.2013-06-25-16.00.moin.txt
16:05 <arosales> rbasak, I'll get those added to the wiki
16:06 <rbasak> Thanks
16:06 <rbasak> #action arosales to carry out post-meeting procedure (minutes, etc) documented at https://wiki.ubuntu.com/ServerTeam/KnowledgeBase for meeting of 25 June
16:06 * meetingology arosales to carry out post-meeting procedure (minutes, etc) documented at https://wiki.ubuntu.com/ServerTeam/KnowledgeBase for meeting of 25 June
16:07 <rbasak> Sorry I'm just catching up.
16:07 <arosales> rbasak, thank you
16:07 <rbasak> Daviey follow up on missing BPs from overview s-topic
16:07 <rbasak> Did you just cover that?
16:08 <Daviey> Yes
16:08 <rbasak> OK
16:08 <rbasak> #topic Saucy Development
16:08 <rbasak> #subtopic Release Tracking Bug Tasks
16:08 <rbasak> #link http://reports.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:09 <rbasak> Shall I go through these?
16:09 <Daviey> rbasak: Please do
16:09 <rbasak> Would it be an idea to make sure someone is assigned to each of them?
16:09 <rbasak> bug 1124384
16:09 <ubottu> bug 1124384 in cloud-init (Ubuntu Saucy) "Configuration reload clears event that others jobs may be waiting on" [High,Confirmed] https://launchpad.net/bugs/1124384
16:10 <rbasak> utlemming: any comment? Do you want to follow that through?
16:10 <rbasak> bug 1196921
16:10 <ubottu> bug 1196921 in vim (Ubuntu Saucy) "updating packages to lua5.2 in main" [High,Confirmed] https://launchpad.net/bugs/1196921
16:10 <rbasak> Nobody is assigned at the moment. Any volunteers?
16:11 <Daviey> Looks like 1124384 has become a hard problem, but smoser and utlemming are tracking it.  Not worried it will be resolved
16:11 <Daviey> 1196921 looks like a transition that could be painful.. As it's not a blocking package, i think we can leave it for this week
16:11 <rbasak> bug 1183634
16:11 <ubottu> bug 1183634 in cheetah (Ubuntu Saucy) "cheetah pkg does not depend on markdown, but egg requires.txt does" [High,Triaged] https://launchpad.net/bugs/1183634
16:12 <rbasak> Looks like it's waiting on the MIR team.
16:12 <Daviey> adam_g is tracking that
16:12 <rbasak> bug 1170393
16:12 <ubottu> bug 1170393 in quantum (Ubuntu Saucy) "Quantum services should be respawned by upstart if necessary" [Medium,Triaged] https://launchpad.net/bugs/1170393
16:12 <Daviey> I think 1183634 needs an upload to make it show on c-m list
16:13 <Daviey> jamespage: what am i looking at on that bug?  Shows Won't Fix?
16:13 <jamespage> I'll take that quantum one
16:14 <rbasak> May I assign it, so that we remember for next week?
16:14 <Daviey> jamespage: Why does the recent change show Won't Fix?
16:14 <jamespage> not a clue - rbasak - I've already done that
16:14 * jamespage shrugs
16:14 <rbasak> Thanks!
16:15 <Daviey> Ah, i see.. the development series was thrown away, with a dedicated saucy task
16:15 <rbasak> https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1188069 is security and the security team are tracking it.
16:15 <ubottu> Launchpad bug 1188069 in apache2 (Ubuntu Saucy) "apache2 mod_rewrite CVE 2013-1862" [Low,Confirmed]
16:15 <rbasak> https://bugs.launchpad.net/ubuntu/+source/libasm4-java/+bug/1196979
16:15 <ubottu> Launchpad bug 1196979 in ow-util-ant-tasks (Ubuntu Saucy) "[MIR] libasm4-java (b-d of jarjar)" [Undecided,New]
16:15 <jamespage> anyone want to help with something java-ish
16:15 <jamespage> ?
16:15 <jamespage> ^^
16:15 <jamespage> two packages to transition to asm4 in main
16:15 <jamespage> so we can get rid of asm3
16:16 <Daviey> jamespage: Happen to know why jarjar is in main?
16:16 <jamespage> cglib
16:16 <jamespage> which is one of the things that needs to be transitioned
16:16 <jamespage> I suspect its actually broken right now
16:16 <jamespage> as asm upstream don't version their package namespaces and they are not backwards compat
16:16 <Daviey> ugh!
16:16 <rbasak> https://bugs.launchpad.net/ubuntu/+source/nagios-plugins/+bug/1031680
16:16 <ubottu> Launchpad bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged]
16:17 <Daviey> jamespage: Do you have capacity to triage that?
16:17 <jamespage> nagios or asm4?
16:17 <Daviey> (java one)
16:17 <jamespage> yeah - sure
16:17 <Daviey> ta
16:17 <jamespage> (I discussed with doko earlier in -devel anyways)
16:18 <rbasak> I've been looking at this one. It's a complex issue and there's a workaround (use a different, much simpler plugin). I'm not sure it can be fixed in _this package_ for Saucy without introducing a horrible delta.
16:18 <Daviey> rsome good triage there
16:18 <rbasak> xnox: any comment on that? You targetted it for Saucy.
16:18 <Daviey> rbasak: seems xnox raised it with upstream?
16:18 <rbasak> I raised it.
16:19 <Daviey> Oh sorry.
16:19 <rbasak> The only comment is that we need to provide input since upstream need help. But the only sane way of fixing it is to ditch the plugin and use update-notifier directly, for Ubuntu.
16:19 <Daviey> rbasak: lets wait to see if upstream respond?
16:19 <rbasak> They sort of have.
16:19 <xnox> rbasak: looking... trying to remember.
16:19 <rbasak> " I'm less keen on having
16:19 <rbasak> the behaviour depend on whether or not some tool is available, though; as
16:20 <rbasak> that's problematic with respect to maintenance and support. And I guess
16:20 <rbasak> update-notifier is a bit too Ubuntu-ish to add a hard dependency on
16:20 <rbasak> apt-check ...
16:20 <rbasak> Sorry I thought that'd paste on one line.
16:20 <Daviey> So do we simply recommend using the other tool?
16:20 <rbasak> IMHO, yes.
16:20 <Daviey> WFM
16:20 <rbasak> The alternative isn't packaged, though.
16:20 <Daviey> if it's a drop in feature compatible
16:20 <rbasak> It's not.
16:20 <Daviey> Pah
16:20 <rbasak> But it'll do for 99% of use cases IMHO.
16:21 <rbasak> The existing plugin's interface is very much based on the way it works. It's not really a clean interface.
16:21 <rbasak> How about I take this to the ML?
16:21 <rbasak> https://bugs.launchpad.net/ubuntu/+source/virtinst/+bug/1192290
16:21 <ubottu> Launchpad bug 1192290 in virtinst (Ubuntu Saucy) "virt-install cannot install Raring" [Undecided,Confirmed]
16:22 <Daviey> mdeslaur seems to be working on it
16:22 <rbasak> OK that's all the bugs on that report for us.
16:22 <Daviey> \o/
16:22 <rbasak> #subtopic Blueprints
16:22 <rbasak> #link http://status.ubuntu.com/ubuntu-saucy/group/topic-saucy-servercloud-overview.html
16:23 <rbasak> That link appears to be broken.
16:23 <jamespage> http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:23 <rbasak> Thanks!
16:23 <rbasak> #link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:23 <rbasak> I'll amend the agenda for next time.
16:24 <Daviey> Ta
16:24 <xnox> rbasak: yeah, i only mangled bug statuses to have this bug bubble up for saucy cycle. Ideally it should be resolved one way or the other, but could be regretfully postponed.
16:24 <Daviey> arosales: Are you able to adjust the trend line?
16:24 <arosales> Daviey, unfortunately no
16:24 <arosales> Daviey, a bug report should get the right folks looking at it though
16:25 <arosales> https://bugs.launchpad.net/launchpad-work-items-tracker/+filebug
16:25 <rbasak> xnox: OK, thanks. I'll email the ML with what I think we should do and copy you in.
16:25 <Daviey> utlemming / ivoks: What is servercloud-s-webscale MIR's blocked on?
16:25 <jamespage> that topic is stilling missing bp's btw
16:25 <xnox> rbasak: cool =) back in the day I used to do a lot of nagios/check_mk large scale monitoring.... =)
16:26 <jamespage> Daviey, the MIR's are dependent on the other work items happening first
16:26 <Daviey> jamespage: Will sweep up after this, but we  have enough to track development of what is there for now
16:26 <arosales> jamespage, I think Daviey has an action out to follow up on missing BPs
16:26 <Daviey> jamespage: OIC
16:26 <utlemming> Daviey: er, I am not sure...I'll look into that today. I've been out on vacation
16:27 <Daviey> jamespage: Would you be able to work with zul to help with the direction of servercloud-s-openstack-hypervisor ?
16:27 <jamespage> Daviey, can do
16:27 <Daviey> jamespage: I suspect you are well placed to have some good guidance, based on last Friday
16:27 <jamespage> ack
16:28 <rbasak> Any more on Blueprints?
16:28 <Daviey> roaksoax: What is our zeromq story right now?
16:28 <Daviey> (servercloud-s-openstack-charms-ha-v2)
16:28 <roaksoax> Daviey: have not look at it yet (been busy with charms mainly)
16:28 <Daviey> ok
16:29 <Daviey> Any more news on MariaDB/Percona ?
16:29 <roaksoax> i'll have more information next week
16:29 <zul> Daviey:  they have gone silent
16:29 <Daviey> I saw the ITP in Debian for xtrabackup
16:29 <roaksoax> zul: didn't jcastro mentioned they were going to provide their own charm too?
16:29 <Daviey> Okay, i'll reach out to them this week.
16:29 <zul> roaksoax:  they did but i havent heard anything else
16:30 * Daviey Daviey to speak to Percona about Saucy inclusion
16:30 <Daviey> #ACTION Daviey to speak to Percona about Saucy inclusion
16:30 * meetingology Daviey to speak to Percona about Saucy inclusion
16:30 <rbasak> I'd really like to see the alternatives in this cycle. Otherwise we'll end up not even being able to consider doing anything but supporting mysql for another LTS cycle.
16:31 <Daviey> jamespage: Any news on juju-core snapshot in saucy ?
16:31 <Daviey> rbasak: right
16:31 <jamespage> Daviey, the juju-core team hit some issues end of last week
16:31 <jamespage> should be resolved ~2 days ish
16:32 <Daviey> super
16:32 <Daviey> The rest looks ok, thanks.
16:33 <rbasak> Thanks Daviey!
16:33 <rbasak> #topic Ubuntu Server Team Events
16:33 <rbasak> Linaro Connect is in Dublin next week.
16:33 <rbasak> (I'll be there)
16:33 <rbasak> Any other upcoming events?
16:33 <Daviey> Hmm
16:34 <Daviey> 19th London, Openstack Meetup
16:34 <Daviey> Openstack's 3rd birthday event
16:34 <Daviey> EOF
16:34 <rbasak> #topic Weekly Updates & Questions for the QA Team (plars)
16:34 <rbasak> plars: hello!
16:34 <plars> Hi
16:34 <zul> it seems i am in the wrong part of the world for events
16:34 <plars> Not much to report, except that the server images had some problems today
16:34 <plars> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1196981
16:34 <ubottu> Launchpad bug 1196981 in Ubuntu CD Images "Saucy server installations fail due to dependancy issues on python-newt " [Undecided,Fix released]
16:35 <plars> I believe the release team is looking into it
16:35 <rbasak> Thanks plars! Does anyone have any questions for plars?
16:35 <rbasak> OK.
16:35 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:35 <smb> Hi
16:35 <smb> Not much to report. Currently working on a pre-release-pre-debian version of xen 4.3 to have the pieces together when the release happens. Any issues from server after kernel v3.10 hit the block?
16:36 <rbasak> I still appear to be using a 3.9 based cloud image as of today.
16:36 <rbasak> Any questions for smb?
16:36 <Daviey> jamespage fixed openvswitch, iscisitarget is still broke
16:37 <jamespage> next on my list
16:37 <Daviey> jamespage: is there a bug for iscsi-target?
16:37 <jamespage> yes
16:37 <rbasak> Should we target that for Saucy?
16:37 <jamespage> bug 1195607
16:37 <ubottu> bug 1195607 in iscsitarget (Ubuntu Saucy) "iscsitarget-dkms broken since kernel 3.10.0" [High,Triaged] https://launchpad.net/bugs/1195607
16:37 <jamespage> it already is
16:37 <Daviey> Thanks
16:37 * jamespage wonders about the release bugs list again
16:37 <rbasak> It didn't come up on the tracking page though?
16:38 <Daviey> it's not tagged
16:38 <Daviey> Tags are useless. :-)
16:38 <jamespage> it should not need to be tagged
16:38 <jamespage> it has a release task and its subbed by ubuntu-server
16:38 <rbasak> Other bugs in the report are not tagged.
16:38 <jamespage> that should be sufficient IMHO
16:39 <rbasak> It dosen't look like it's subbed by ubuntu-server to me.
16:39 <rbasak> It doesn't appear in the "May be notified" list
16:40 <rbasak> Can an ~ubuntu-server admin fix that please?
16:41 <rbasak> Daviey? jamespage?
16:41 <jamespage> ack
16:41 <rbasak> Thanks!
16:41 <rbasak> (and to smb!)
16:41 <rbasak> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:41 <rbasak> Nothing new to report. Any questions for me?
16:41 <Daviey> rbasak: Any news on mongo?
16:42 <rbasak> I've not looked at it, sorry.
16:42 <Daviey> no problem
16:42 <Daviey> EOF
16:42 <rbasak> #topic Open Discussion
16:43 <rbasak> Is there anything anybody wants to bring up?
16:43 <rbasak> I do, actually, related to the next item.
16:44 <jamespage> rbasak, congrats btw
16:44 <rbasak> I have a proposal that I hope is constructive. Instead of rotating the chair weekly, how about we rotate the chair once the chair completes the post-meeting procedure?
16:44 <rbasak> Thanks jamespage!
16:44 <jamespage> for those that don't know rbasak is now a MOTU and member of ubuntu-server-dev
16:45 <yolanda> congrats
16:45 <Daviey> +1!
16:45 <rbasak> Thanks :)
16:46 <rbasak> If we do that, then the previous chair will have his notes, and there won't be a delay at the start with confusion over who's chairing. And it's an incentive to get it done :)
16:46 <rbasak> I propose it starts with me, so I might as well volunteer to chair next week unless I get it done.
16:46 <rbasak> #topic Announce next meeting date, time and chair
16:47 <rbasak> The next meeting will be on 9 July at 1600 UTC as usual. I may be absent as I'll be at Linaro Connect. So I hope I'll get it done and yolanda will chair :)
16:47 <rbasak> #endmeeting