15:00 <stgraber> #startmeeting DMB meeting
15:00 <meetingology> Meeting started Mon Jul  1 15:00:44 2013 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00 <meetingology> 
15:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00 <stgraber> #topic Review of previous action items
15:01 <stgraber> everyone read and amend http://pad.ubuntu.com/dmb-ppu-membership-proposal, and sign up for the implementation tasks
15:01 <tumbleweed> that was going to go to the list
15:01 <tumbleweed> but it didn't
15:01 <tumbleweed> come bakc to it after applications? or really take it to the list this time?
15:01 <Laney> I amended it earlier in the hope that we could talk about it today
15:03 <barry> let's take care of the applicant first
15:03 <Laney> yes!
15:03 <stgraber> laney to update DD-PPU process to say that any ubuntu-dev is eligible
15:03 <stgraber> so that was done apparently
15:03 <Laney> 'take care'...
15:04 <Laney> yes, yes it was
15:04 <stgraber> tumbleweed to add louis-bouchard to universe-contributors
15:04 <tumbleweed> done
15:04 <stgraber> good
15:04 <stgraber> #topic MOTU Applications - Robie Basak
15:04 <stgraber> rbasak: ping
15:04 <rbasak> Hello!
15:04 <stgraber> that application is also for server packageset, so we'll vote twice
15:05 <stgraber> rbasak: can you introduce yourself and your application(s)?
15:05 <rbasak> Sure! I'm Robie Basak. I've been working for Canonical on their server team for almost two years. I'm applying for MOTU and ubuntu-server-dev. My application is at https://wiki.ubuntu.com/RobieBasak/ServerDeveloperApplication
15:08 * Daviey is of the opinion that rbasak's application is long since overdue, and he's fed up of his sponsors nagging him to do it himself.
15:09 <Laney> :-)
15:09 <stgraber> so once you are a MOTU you'll be able to upload any universe packages, when around a milestone such as the upcoming alpha-2, can you simply upload any universe package or are there extra things you should check?
15:10 <rbasak> If the package is seeded for a flavour that participates in the alpha, I will need to make sure that the upload doesn't interfere with a spin/respin. I'd check with #ubuntu-release in this case.
15:11 <stgraber> ok, how can you check if a package is seeded by a participating flavour?
15:11 <rbasak> The seeded-in-ubuntu command will tell me that.
15:12 <bdrung> rbasak: looking at http://askubuntu.com/questions/247479/how-do-i-check-whether-a-ppa-package-has-been-tampered-with/247489#247489, are you aware of the tools pull-lp-source and debdiff?
15:13 <rbasak> bdrung: yes, but there are specific reasons I didn't use those for my answer.
15:13 <bdrung> okay
15:14 <rbasak> pull-lp-source will pull from the development version, whereas I thought that people using that answer would be more likely to want to compare against, say, precise, or some upstream source directly. So I didn't feel that it was appropriate to use pull-lp-source there as I thought it was too specific.
15:15 <rbasak> And again to compare an upstream source against (say) a PPA package, then debdiff won't work as there would be no upstream dsc.
15:15 <barry> rbasak: hi.  i have a question about working with upstreams.  how engaged are you with debian and upstreams to forward bugs and fixes?  e.g. is this one a candidate for upstreaming?  https://launchpad.net/ubuntu/+source/mailman/1:2.1.15-1ubuntu1  (wonder how that one caught me eye :)
15:16 <stgraber> rbasak: pull-lp-source <package> <series-pocket or version> :)
15:16 <rbasak> Well that one's a good example I think. In that case upstream is on Launchpad, so I filed upstream by adding the bug task. The dep3 headers reveal all ;)
15:17 <barry> rbasak: nice, thank you!
15:17 <rbasak> stgraber: sure, but it doesn't work for example when comparing a pristine upstream tarball to a PPA.
15:17 <rbasak> For Debian involvement, I usually file as far upstream as possible, and notify Debian if I think it would be of particular use to cherry-pick instead of waiting for a new upstream release.
15:18 <stgraber> rbasak: sure, was just commenting about the "pull-lp-source will pull from the development version" bit
15:18 <rbasak> I did that for an evolution/libical bug, for example.
15:18 <rbasak> stgraber: ah OK. Yeah, I use that quite a bit.
15:18 <barry> rbasak: thanks
15:19 <Laney> rbasak: About your "What I like least in Ubuntu" — who do you think would curate such a list?
15:19 <Laney> It sounds a bit like dholbach's harvest tool - do you know about that?
15:20 <rbasak> I've seen the harvest tool. I think that's the inverse of what I'm saying, though. harvest seems useful to me from an Ubuntu developer's perspective - for stuff that might be worth bundling in with an upload, for example.
15:21 <Laney> I think it's supposed to be both of those things
15:22 <rbasak> For non- Ubuntu developers, they just have a goal. Eg. there's a patch, and they'd like it in. We know about SRU policy, when we might introduce a delta vs. file upstream, etc, but outsiders don't necessarily know that. So I'd like some documentation that is indexed by task like that.
15:22 <Laney> So it's more about documentation than creating task lists?
15:22 <rbasak> Right. Completely about documentation, not about creating task lists at all.
15:23 <Laney> I see; I read it a bit differently
15:23 <Laney> Do you imagine you'll work on it or is it a wishlist? :-)
15:24 <Laney> I imagine it's something that would live on developer.ubuntu.com quite nicely
15:24 <bdrung> rbasak: have you talked with dholbach about improving the documentation?
15:25 <bdrung> i think it could fit into the packaging guide
15:25 <rbasak> Here's an example: bug 1160177 - 51 people affected, there's a patch, but no sign of anyone working to get it into Ubuntu. As a MOTU I'd be able to help, but I'm sure some of those people in the bug could do it too, but there's no single place to point them to that'll show them the SRU policy, how to look upstream, etc.
15:25 <ubottu> bug 1160177 in guake (Ubuntu) "guake starts with abnormal indentation" [Undecided,Confirmed] https://launchpad.net/bugs/1160177
15:25 <Laney> The packaging guide has this knowledge base idea but it's currently a bit lower level than that
15:26 <Laney> I'm sure some contributed articles would be well received
15:26 <rbasak> In that specific example I'm trying to take a technical friend who is affected through the steps - though nothing's on the bug yet.
15:27 <rbasak> I will work on it, but expect it to go pretty slowly. I hope to gain some experience in finding out how things work first. Maybe some blog posts first, see how they go down, and then suggest amendments to the official documentation (packaging guide, developer section on wiki or ubuntu.com, etc)
15:28 <rbasak> By "how things work" I mean how new developers take to my suggested different approach to documentation
15:28 <bdrung> rbasak: have you done any syncs from Debian yet?
15:29 <Laney> I think a high level "how do I do this thing I want to do?" section would be nice
15:29 * Laney yields
15:29 <rbasak> I'm not sure I actually have. I'm aware of requestsync. I came close once, but then found a bug so managed to drop the entire delta and then had to introduce one again.
15:30 <rbasak> I think it's because of the nature of the packages I've worked on so far.
15:30 <rbasak> I've also read the requestsync manpage and realise it's a slightly different process if I have upload rights to the package in question.
15:31 <Laney> The appropriate tool then is 'syncpackage'
15:31 <rbasak> Looks like I'll need to use syncpackage
15:33 <bdrung> rbasak: when introducing a new delta, getting the change into Debian too is recommended. once the change is accepted in Debian (or tribbled through upstream), you can sync the package (with syncpackage as pointed out by Laney)
15:33 <bdrung> rbasak: do have you any plans for Debian beyond forwarding relevant patches?
15:35 <rbasak> I'd like to become a DD in the end. I've got a few new packages I'd like to get into Debian. I've got as far as getting a mentors.d.n account so far.
15:36 <bdrung> nice to hear.
15:36 <rbasak> Unfortunately that side of things is a spare time thing for me, so my progress is much slower than the Ubuntu side that I'm paid to work on full time. But I hope to get there.
15:37 <bdrung> i am confident that you will get there. :)
15:37 <rbasak> Thanks :)
15:39 <stgraber> #voters Laney bdrung barry tumbleweed stgraber
15:39 <meetingology> Current voters: Laney barry bdrung stgraber tumbleweed
15:39 <stgraber> we'll vote twice, first for MOTU then for server
15:39 <stgraber> #vote rbasak for MOTU
15:39 <meetingology> Please vote on: rbasak for MOTU
15:39 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
15:40 <tumbleweed> +1
15:40 <meetingology> +1 received from tumbleweed
15:40 <barry> +1
15:40 <meetingology> +1 received from barry
15:40 <stgraber> +1
15:40 <meetingology> +1 received from stgraber
15:40 <Laney> +1
15:40 <meetingology> +1 received from Laney
15:40 <bdrung> +1
15:40 <meetingology> +1 received from bdrung
15:41 <Daviey> stgraber: ?
15:42 <stgraber> #endvote
15:42 <meetingology> Voting ended on: rbasak for MOTU
15:42 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:42 <meetingology> Motion carried
15:42 <stgraber> #vote rbasak for server packageset PPU
15:42 <meetingology> Please vote on: rbasak for server packageset PPU
15:42 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
15:43 <bdrung> +1
15:43 <meetingology> +1 received from bdrung
15:43 <Laney> +1
15:43 <meetingology> +1 received from Laney
15:43 <tumbleweed> +1
15:43 <meetingology> +1 received from tumbleweed
15:43 <stgraber> +1
15:43 <meetingology> +1 received from stgraber
15:43 <barry> +1
15:43 <meetingology> +1 received from barry
15:43 <stgraber> #endvote
15:43 <meetingology> Voting ended on: rbasak for server packageset PPU
15:43 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:43 <meetingology> Motion carried
15:43 <Daviey> \o/, congrats rbasak. Good effort.
15:43 <rbasak> \o/ thanks all, and for your time!
15:44 <Laney> well done!
15:44 <stgraber> added to both teams
15:51 <stgraber> #topic PPU membership proposal
15:51 <stgraber> Current proposal is here: http://pad.ubuntu.com/dmb-ppu-membership-proposal
15:51 <Laney> if my two proposals accurately reflect the two options then I suggest we do a three way vote
15:51 <Laney> might need to use CIVS or something
15:52 <Laney> just choosing between them and NOTA
15:52 <tumbleweed> no objection
15:53 <Laney> is the first option right?
15:53 <stgraber> Laney: so can we achieve that with 3 votes, 1 for proposal-1, 1 for proposal-2 and 1 for NOTA? picking the option with the highest number of votes that's > 4?
15:54 <tumbleweed> Laney: there are missing details in option 1
15:54 <Laney> I think having it be desktop-core, core and flavours would be good enough and explainable without too much confusion
15:54 <tumbleweed> Laney: sure
15:54 <stgraber> let me grab the list I suggested last time
15:55 <barry> Laney: do you envision this list (of packages/sets to require membership) to change often?
15:55 <Laney> no, I was hoping for it to not change at all
15:55 <Laney> to be clear, that's not my favoured option
15:55 <stgraber> core, desktop-core, flavours, kernel, ubuntu-desktop (same status as flavour), ubuntu-server (same status as flavour) and xorg
15:56 <Laney> kernel and xorg are subsets of core, aren't they?
15:56 <Laney> hmm, no
15:56 <stgraber> there are some overlaps between them, but it's not a subset
15:57 <Laney> well, the packages therein that you care about
15:57 <barry> i just want to make sure that an application knows where to look and can find out exactly whether they'll need to apply for membership also
15:57 <Laney> yes
15:58 <stgraber> barry: yeah, I expect a fairly static list and for us to recheck when we get an application (pre-meeting)
15:58 <Laney> I don't think it's us we should be worrying about
15:59 <stgraber> so should we vote on those three (option-1, option-2 and NOTA)? I have to end the meeting in a minute.
15:59 <barry> Laney: right.  i guess we'll need a what-do-i-apply-for command ;)
15:59 <Laney> I think it's best if I set up a CIVS poll and add everyone as voters
15:59 <Laney> that should work
15:59 <barry> +1
15:59 <stgraber> ok, wfm
15:59 <Laney> action me, I'll do it today
16:00 <stgraber> #action Laney to setup a CIVS poll to choose between the two options (and NOTA) for PPU membership
16:00 * meetingology Laney to setup a CIVS poll to choose between the two options (and NOTA) for PPU membership
16:00 <stgraber> #topic AOB
16:00 <Laney> ta
16:00 <stgraber> Next meeting chair will be ScottK (and Barry after that)
16:00 <stgraber> #endmeeting