16:01 <roaksoax> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue Jun 18 16:01:49 2013 UTC.  The chair is roaksoax. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01 <roaksoax> #topic Review ACTION points from previous meeting
16:02 <roaksoax> (carried over) arosales: create a overview topic bp for servercloud
16:02 <arosales> http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:02 <roaksoax> arosales: o/! ^^
16:02 <arosales> roaksoax, done
16:02 <roaksoax> #link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:02 <Daviey> arosales: hurray!
16:03 <Daviey> super job.
16:03 <roaksoax> moving on: everyone look over blueprints one more time
16:03 <roaksoax> so I'm guessing that we all looked at our BP's once again
16:03 <roaksoax> moving on
16:03 <roaksoax> #action rbasak to follow up on go 1.1. saucy arm issue
16:03 * meetingology rbasak to follow up on go 1.1. saucy arm issue
16:03 <roaksoax> rbasak: any updates?
16:03 <arosales> sorry for the delay on the topic bp
16:04 <Daviey> roaksoax: MAAS is still needing completion ?
16:04 <Daviey> smoser: FPI?
16:04 <roaksoax> Daviey: needs the user stories
16:04 <jamespage> o/
16:05 <smoser> hm.
16:05 <rbasak> Sorry for the delay. I've just been catching up with infinity in #ubuntu-devel.
16:05 <rbasak> His view is that we need to fix golang, and then modify dpkg-shlibdeps to pick up the ELF header slightly differently. So still in progress.
16:06 <roaksoax> ok then
16:06 <roaksoax> let's move on
16:06 <roaksoax> rbasak consider telling hallyn to add a todo item to meeting checklist to remind meeting chair about the wiki page checklist
16:06 <rbasak> Is there any particular need that we need this fixed faster than a proper fix? I have a workaround in mind that may work, but we don't want to spend time on it unless there's an urgent need.
16:06 <rbasak> Done
16:06 <rbasak> I put the reminder at the end of the agenda.
16:06 * smoser moved that from draftingo to review
16:07 <Daviey> and approved.
16:07 <roaksoax> ok, so let's move on
16:07 <roaksoax> #topic Saucy Development
16:07 <roaksoax> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:07 <roaksoax> So I'm guessing that everybody saw the email about the changes in the Release Schedule
16:08 <roaksoax> and FF has been moved to BetaFreeze
16:08 <roaksoax> any other updates anyone would like to raise, or I shall move on to the release bugs
16:09 <roaksoax> #subtopic Release Bugs
16:09 <roaksoax> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:09 <roaksoax> bug #1188788
16:09 <ubottu> bug 1188788 in quantum (Ubuntu Raring) "Meta bug for tracking Openstack 2013.1.2 Stable Update" [Undecided,New] https://launchpad.net/bugs/1188788
16:09 <roaksoax> any updates?
16:10 <roaksoax> adam_g_: ^^
16:10 <roaksoax> zul: ^^
16:10 <Daviey> That i believe is blocked on me.
16:10 <Daviey> Requires SRU review, was superseded by a security upload
16:11 <adam_g_> roaksoax, ya just waiting to get approved out of queue into -proposed
16:12 <roaksoax> Awesome. MAAS bugs #1171418 #1171988  are also waiting to be approved
16:12 <ubottu> bug 1171418 in MAAS 1.2 "MAAS fails to power up machines when trying to install nodes" [High,Fix committed] https://launchpad.net/bugs/1171418
16:12 <roaksoax> bug #1162139
16:12 <ubottu> bug 1162139 in mysql-5.5 (Ubuntu Raring) "mysql-5.5 still built using GCC-4.4, should be built with the default GCC" [High,Triaged] https://launchpad.net/bugs/1162139
16:13 <roaksoax> this seems target to raring and should probably be re-targetted to saucy
16:13 <roaksoax> any thought
16:13 <Daviey> Oh, most certainly
16:13 <rbasak> Debian have agreed to drop the gcc-4.4 build dep now.
16:14 <rbasak> So we either wait for Debian, or jump ahead.
16:14 <roaksoax> rbasak: I believe this would need your verification:
16:15 <roaksoax> bug #1173265
16:15 <ubottu> bug 1173265 in facter (Ubuntu Raring) "facter fails to run from rebuilt source package" [Undecided,Fix committed] https://launchpad.net/bugs/1173265
16:15 <roaksoax> and bug #1170325
16:15 <ubottu> bug 1170325 in facter (Ubuntu Raring) "Facter 1.6.X not considering Qemu/KVM virtual type" [Undecided,Fix committed] https://launchpad.net/bugs/1170325
16:15 <rbasak> The former is easy to verify: it built.
16:15 <rbasak> The latter is trickier. Does anyone have a suitable machine?
16:15 <rbasak> I used a hack to test my proposed upload for quantal and raring, but it doesn't work with precise.
16:16 <roaksoax> boomer, anyone would like to verify that one?
16:17 <roaksoax> in the meantime, bug #1172742
16:17 <ubottu> bug 1172742 in cloud-init (Ubuntu Raring) "maas datasource fails if no user-data" [Medium,Confirmed] https://launchpad.net/bugs/1172742
16:17 <roaksoax> smoser: any updates?
16:18 <roaksoax> alright I guess he might have stepped out for a bit
16:18 <roaksoax> let's move on
16:18 <roaksoax> #subtopic Blueprints
16:18 <roaksoax> #link http://status.ubuntu.com/ubuntu-saucy/group/topic-saucy-servercloud-overview.html
16:19 <roaksoax> #link http://status.ubuntu.com/ubuntu-saucy/group/topic-s-servercloud-overview.html
16:19 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-server-app-banner-updates
16:20 <roaksoax> zul: ^^
16:20 <roaksoax> yolanda: ^^ any updates?
16:20 <zul> no
16:20 <smoser> no updates to that bug.
16:20 <yolanda> i'm dealing with server banners, mostly with dovecot, bind9
16:20 <yolanda> there is a pending MP for dovecot
16:21 <roaksoax> alright
16:21 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-2-delivery
16:21 <roaksoax> jamespage: any updateS?
16:21 <jamespage> roaksoax, not really - Ill be working with the juju team this week to a) get py juju removed from saucy
16:21 <jamespage> and by get the latest juju-core uploaded
16:22 <roaksoax> \o/
16:22 <roaksoax> awesome then!
16:22 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2
16:22 <Daviey> jamespage: shall i just go ahead and remove pyjuju now?
16:22 <jamespage> yeah
16:22 <jamespage> I acked the bug
16:22 <Daviey> ta
16:23 <roaksoax> on the HA stack side, I discussed with the debian maintainer about the new upstream changes and the things that we would need to consider dropping soonish, and he wasn't so keen on doing it now
16:23 <m_3> RIP juju-0.7
16:23 <roaksoax> so it seems that we might keep support for older stuff longer, but will be moving the charms to the newer stack options
16:24 <roaksoax> should be pretty straight forward though
16:24 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-hypervisor
16:24 <roaksoax> zul: ^^ updates?
16:24 <zul> nope
16:24 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-havana
16:24 <zul> working on windows image testing
16:24 <roaksoax> zul: ^^
16:24 <zul> ill update it today
16:25 <roaksoax> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-archive
16:25 <roaksoax> zul: ^^
16:25 <roaksoax> err
16:25 <roaksoax> jamespage: ^^
16:25 <roaksoax> any updates?
16:26 <jamespage> I've started on docs for the SRU process
16:26 <jamespage> but its still wip - should be done this week
16:26 <jamespage> havana cloud archive is open btw
16:26 <roaksoax> awesome!
16:26 <jamespage> which reminds me - we need a blast on getting everything lined up in staging
16:26 <jamespage> http://reqorts.qa.ubuntu.com/reports/ubuntu-server/cloud-archive/havana_versions.html
16:27 <Daviey> Users have started asking about Havana in UCA
16:27 <jamespage> zul, is that something you can coordinate over the next 24 hrs?
16:27 <jamespage> it would be nice to flush something through to proposed on thurs/friday
16:28 <zul> jamespage:  yeah im just finishing off quantum fbtfs today
16:28 <zul> been distracted with other things
16:28 <jamespage> excellent
16:29 <roaksoax> alright! Any other BP
16:29 <roaksoax> alright! Any other BP that any of you would like to discuss?
16:29 <roaksoax> guess not then
16:29 <roaksoax> #topic Ubuntu Server Team Events
16:29 <roaksoax> any upcoming events?
16:30 <Daviey> None. Move on :)
16:30 <arosales> not any in the next weeks
16:30 <arosales> OSCON is the next up on July 22
16:30 <m_3> poolside siesta doesn't count?  harumph
16:31 <roaksoax> heh
16:31 <arosales> m_3, it does if there is an invite
16:31 <arosales> :-)
16:31 <roaksoax> ok, let's move on then
16:31 <roaksoax> #topic Weekly Updates & Questions for the QA Team (plars)
16:31 <roaksoax> plars: any updates?
16:31 <plars> hi
16:31 <plars> yes, one thing I wanted to ask about
16:32 <plars> we recently had some issues with lxc and ceph tests
16:32 <plars> ceph was supposed to be disabled I think, but the job got accidentally recreated when some jenkins refresh scripts ran
16:32 <plars> but had been running fine since then
16:32 <plars> but I think I heard that jamespage said that it was flaky and not to be trusted?
16:32 <jamespage> yes indeed
16:32 <hallyn> yeah it's being pulled
16:33 <plars> lxc is working fine again, but it is a similar situation?
16:33 <hallyn> plars: no it's not a similar situation
16:33 <plars> ok, we'll pull ceph from our scripts that regenerate the jobs too if we're sure we don't want those
16:33 <hallyn> plars: the lxc failures i believe were due to either utah or hw problems
16:33 <plars> is there no replacement?
16:33 <hallyn> plars: I could never reproduce the lxc failures locally
16:33 <plars> ok, fair enough
16:34 <hallyn> plars: this cycle I want to move the distro lxc tests into upstream, and then probably move them out of utah
16:34 <plars> hallyn: you mean as autopkgtests?
16:34 <hallyn> not yet sure what i mean
16:34 <plars> heh
16:34 <hallyn> other than upstream lxc git tree woudl have the tests
16:34 <plars> ok, but I still think it would make sense to run them in the image right? to validate what's installed?
16:35 <hallyn> somehwere, yes
16:35 <hallyn> but it would then amount to pulling down the tree and running make distro-test or something
16:35 <plars> ok, just let me know if there are any changes and I'll remove the ceph tests from our script unless there are plans to update/replace them
16:35 <hallyn> plars: yup, thx
16:35 <plars> that's it from me
16:36 <roaksoax> thank you plars
16:36 <roaksoax> let's move on
16:36 <roaksoax> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:36 <smb> As mentioned last week the Saucy kernel will move to 3.10. If things go like intended the upload will happen end of this week when dkms testing has been done. Repeat: Saucy kernel will be 3.10. And ogasawara has some more notes on dkms testing...
16:36 <Daviey> smb: Do you know where these notes are?
16:36 <ogasawara> so I wanted to inquire if the dkms package the server team cares about has been tested?
16:36 <Daviey> ogasawara: No.
16:36 <smb> Daviey, There ^
16:36 <ogasawara> also, could I get that list of dkms packages you guys care about as well?
16:37 <ogasawara> as I want to pass that along to QA for the automated testing we're trying to set up
16:37 <Daviey> ogasawara: That is super, I will make sure you get the list by EOD>
16:37 <Daviey> Thanks.
16:37 <ogasawara> Daviey: thanks.  will you guys be able to test with the 3.10 kernel before we upload?
16:38 <lifeless> openvswitch-datapath-dkms :)
16:38 <ogasawara> Daviey: or should we just plan to upload and deal with any fallout?
16:38 <jamespage> lifeless, indeed - that won't work
16:38 <jamespage> but I can pick up testing of that
16:38 <Daviey> ogasawara: It would be really nice if between kernel and QA team a simple apt-get install openvswitch-datapath-dkms, could be done
16:38 <jamespage> (and the fixes)
16:38 <ogasawara> Daviey: I was hoping that would be a task you're team would own
16:39 <ogasawara> Daviey: and we provide the test kernel
16:39 <ogasawara> Daviey: https://launchpad.net/~kernel-ppa/+archive/pre-proposed
16:39 <Daviey> ogasawara: I was more hoping that between kernel and QA team it could be done :)
16:39 <ogasawara> Daviey: it would appear we are at an impass :)  maybe we can sort off line.
16:39 <Daviey> But sure, OK.  But going forwards it would be great if it could be handled between your teams
16:40 <ogasawara> Daviey: going forward we indeed will work with QA.  But that will just be for the initial build and install testing.  We'll still look to team and maintainers to fix up any issues.
16:40 <Daviey> ogasawara: right, resolving issues we are happy to do
16:40 <Daviey> but early warning, would be nice if the issues were fed to us from QA/kernel
16:41 <ogasawara> Daviey: so for us to do that now without the automation in place yet, I need your package list
16:41 <Daviey> Yes sir.  But sure, OK - this kernel we'll do.. and get serious about automating it between us.
16:42 <ogasawara> Daviey: thanks
16:42 <Daviey> Superb
16:42 <roaksoax> Awesome outcome. Let's move on then!
16:42 <roaksoax> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:42 <rbasak> Nothing new to report. Just the golang armhf FTBFS in bug 1187722 that is ongoing. Is there any particular need for which we need this fixed faster than the proper fix? I have a workaround in mind that may work, but we don't want to spend time on it unless there's an urgent need.
16:42 <ubottu> bug 1187722 in golang (Ubuntu) "dpkg-shlibdeps fails on armhf ELF binaries that do not define architecture specific information" [High,Confirmed] https://launchpad.net/bugs/1187722
16:43 <rbasak> I'll assume it can wait for a proper fix then?
16:44 <rbasak> Any other questions for me?
16:44 <rbasak> Linaro Connect is 8-12 July BTW. I'll be going.
16:44 <rbasak> I guess no questions then. Thanks roaksoax!
16:44 <roaksoax> thank you!
16:44 <roaksoax> #topic Open Discussion
16:44 <roaksoax> anyone has something to share with us?
16:45 <roaksoax> i guess not
16:45 <roaksoax> #topic Announce next meeting date, time and chair
16:45 <roaksoax> same time and place
16:45 <Daviey> Thanks roaksoax
16:46 <roaksoax> the next chair according to the list is arosales
16:46 <roaksoax> arosales: you';ve been selected to be our chair next week :) Thanks in advance
16:46 <roaksoax> I'll end this
16:46 <roaksoax> #endmeeting