22:00 <bkerensa> #startmeeting Agenda: https://wiki.ubuntu.com/DocumentationTeam/MeetingAgenda
22:00 <meetingology> Meeting started Mon Jun 10 22:00:03 2013 UTC.  The chair is bkerensa. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:00 <meetingology> 
22:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
22:00 <bkerensa> #chair bkerensa
22:00 <meetingology> Current chairs: bkerensa
22:00 <bkerensa> Hello everyone and welcome to the Ubuntu Doc Team Meeting for June 2013 :)
22:00 <GunnarHj> I'm here.
22:00 <bkerensa> Our agenda is in the topic if you have not had a chance to read it yet
22:00 <kotux> hey bkerensa
22:01 <bkerensa> #topic UDS Work Items Health Check
22:01 <bkerensa> So the first thing on our agenda is to check on the progress of UDS 13.05 work items
22:01 <bkerensa> I'm seeing right now we have only one done https://blueprints.launchpad.net/ubuntu/+spec/community-1305-doc-planning
22:02 <bkerensa> any updates from those who have taken items?
22:02 <pleia2> I sent the previous feedback emails to the list a couple weeks ago, hopefully that was helpful
22:03 <bkerensa> My "Review and update current documented processes" work item is nearly finished and I'm about half way done on a rough draft of "Update Getting Started Page"
22:03 <bkerensa> pleia2: excellent
22:03 <godbyk> My item is dependent upon bkerensa's items.
22:03 <bkerensa> :)
22:03 <dsmythies> this page: https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/BuildingDocumentation is reasobaly up to dete
22:03 <bkerensa> So it looks like I need to bang out my work by the end of the weekend
22:03 <bkerensa> :)
22:04 <bkerensa> In regards to the getting started revamp
22:04 <GunnarHj> Is everything "getting started related" included in the first item?
22:04 <bkerensa> do you think its important that we write out entire tutorials on DocBook or try and rely on a third party source for that?
22:05 <godbyk> bkerensa: I'd rely on a third party for the bulk of it, but if you're restricting the docs team to a subset of docbook, I'd note what that subset is.
22:05 <bkerensa> GunnarHj: not really I think that covers some but does not give a A to Z of everything people will need to know to get started and feel somewhat comfortable with the process
22:06 <godbyk> Templates, tips, etc. wouldn't be amiss either.
22:06 <dsmythies> No, 90% of what I have learned is from example of stuff already done. Use 3rd party for anything else.
22:06 <bkerensa> kk
22:06 <GunnarHj> I for one think it's not important to go too deep into DocBook or Mallard. To modify pages you can start with just looking at what the page looks like.
22:06 <bkerensa> I was planning on deferring for example to developer.ubuntu.com for bzr configuration versus re-writing
22:06 <bkerensa> GunnarHj: +1
22:07 <bkerensa> I just think a simple one page getting started with links to relevant tidbits is the best
22:07 <bkerensa> I also think once we get this going we should offer mentoring
22:07 <godbyk> Sort of..
22:07 <kotux> same here, it should be in order too.
22:07 <godbyk> You don't want a getting started page that just links everywhere, though.
22:07 <dsmythies> Yes, suggest you use the serverguide single page as an example.
22:07 <godbyk> Because as a new contributor, I don't want to read reference manuals for bzr, launchpad, docbook, mallard, etc.
22:07 <kotux> godbyk, I'm in a similar situation actually
22:07 <bkerensa> Ok so since this is our next item
22:08 <godbyk> I want some step-by-step guides to get up and running quickly so I can fix the bug or make the improvement that I'm interested in making.
22:08 <bkerensa> #topic  Discuss Collaboration on Final Draft Ubuntu Documentation Getting Started Wiki
22:08 <bkerensa> Why don't we have a etherpad up
22:08 <bkerensa> and I will drop my rough draft in this weekend
22:08 <bkerensa> and then we can polish it off as a team
22:08 <bkerensa> to the point we are all satisfied?
22:09 <godbyk> Sure.
22:09 <dsmythies> O.K.
22:09 <kotux> no prob
22:09 <bkerensa> #action bkerensa to push his rough draft to etherpad this weekend for final team polish effort
22:09 * meetingology bkerensa to push his rough draft to etherpad this weekend for final team polish effort
22:09 <bkerensa> So I also want to have a hard deadline on which we can have it polished and on the wiki
22:09 <bkerensa> can we say deadline being the 30th?
22:10 <GunnarHj> Sounds as a good idea. And I like the idea by godbyk with something that can make people get started quickly.
22:10 <kotux> GunnarHj, so do I.  All those readings are secondary to getting things done.
22:10 <GunnarHj> Feel like you are switching topic a little too fast. ;-)
22:11 <dsmythies> Please refer to the serverguide single page. It allows one to start in minutes. It is really good.
22:11 <kotux> bkerensa, it's a good date. Between 2 weeks to a month is ample time.
22:11 <bkerensa> dsmythies: will do
22:11 <bkerensa> dsmythies: and your input will be appreciated along the way
22:11 <dsmythies> O.K.
22:12 <kotux> dsmythies, the single page is not easy to find through navigation alone. But it's really handy.
22:12 <bkerensa> any more concerns regarding getting started content?
22:13 <GunnarHj> Nope. An etherpad with what you got sounds fine.
22:13 <dsmythies> just for reference for the minutes: https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/UbuntuServerGuide
22:13 <GunnarHj> dsmythies: tnx
22:13 <kotux> It needs a place somewhere in the wiki SOON.
22:14 <dsmythies> Yes it does.
22:14 <bkerensa> ok ready to move to the next item?
22:15 <kotux> ok
22:15 <godbyk> yep
22:15 <dsmythies> yes
22:15 <bkerensa> #topic Ubuntu 13.10 Doc TODO List: What do we want to accomplish in regards to the actual docs we ship
22:15 <bkerensa> ok
22:16 <bkerensa> So what do we want to and need to accomplish this cycle in regards to documentation we ship?
22:16 <bkerensa> What do you consider essential?
22:17 <GunnarHj> Starting working on it in good time before the release is the key point, I think.
22:17 <godbyk> I think it's important that we have up-to-date documentation.
22:17 <kotux> More pictures
22:18 <bkerensa> I think one of my biggest concerns is the screenshots
22:18 <GunnarHj> Another thing is that the GNOME docs must be imported in good time. It looks like we are moving to 3.8...
22:18 <kotux> help.ubuntu.com could be made compatible with mobile.
22:18 <godbyk> GunnarHj: Do we have instructions for importing the Gnome docs?
22:19 <dsmythies> As you know, I work mostly on serverguide, which doesn't actually ship. However, we are considering to post all languages to help.ubuntu.com, just like desktop docs.
22:19 <GunnarHj> I haven't. jbicha did it last time (far too late).
22:19 <godbyk> GunnarHj: Okay. We'll have to figure out how to do that, then.
22:19 <pleia2> I'm inclined to keep our goals for this cycle as minimal as possible as I expect core members of the team will be spending their time onboarding new people
22:19 <GunnarHj> godbyk: right
22:19 <godbyk> pleia2: I agree.
22:20 <dsmythies> there is already a bug report requesting epub format be available. I am not on board, becuase it is another thing to check that it compiles O.K.
22:20 <kotux> dsmythies, ok.  It is a good idea.
22:21 <GunnarHj> dsmythies: Is it really a good idea to mess with yet another XML format?
22:21 <dsmythies> Currently there issues for some langauges. I hope to spend time on the issues.
22:21 <godbyk> dsmythies: I'm not against it per se, but I don't think it should be a high priority at the moment.
22:21 <bkerensa> exactly
22:21 <dsmythies> Gunnar: It already happens, we just don't post it.
22:22 <bkerensa> So
22:22 <GunnarHj> dsmythies: Can you elaborate on that?
22:22 <bkerensa> Do we have someone who can make the screenshot script work?
22:23 <bkerensa> godbyk: would you be willing to ping jbicha and find out about Gnome Doc Imports? Since thats like a majority of where our doc comes from
22:23 <godbyk> bkerensa: Sure.
22:24 <bkerensa> #action godbyk to contact Jeremy Bicha to find out how Gnome-Doc Imports to Ubuntu-Doc works
22:24 * meetingology godbyk to contact Jeremy Bicha to find out how Gnome-Doc Imports to Ubuntu-Doc works
22:24 <phillw> bkerensa: if you use quickshot, it is being worked upon as we speak.
22:24 <dsmythies> The .pot and .po tranlsation cycle already exists for serverguide. We just seem to leave it to the regions to deal with. We have had requests to post the other lanagusges. Desktop already does this
22:24 <godbyk> phillw: I suspect it'll be a while before Quickshot is up and running again, though.
22:24 <bkerensa> phillw: we have in the past used a script but its broken... It would take vanilla screenshots
22:26 <dsmythies> My paln was to post the prelim version of help.ubuntu.com for 13.10 much earlier than I did for 13.04 and provide examples. Without committing the required script changes to the main branch.
22:26 <bkerensa> Well lets re-visit the screenshot issue at another time as I plan for us to have more meetings in advance of release
22:26 <phillw> godbyk: we'll see how Thomas gets on, I have offered an additional python programmer to assist.
22:27 <kotux> I think someone should report on launchpad the non-working script and its current problems.
22:28 <godbyk> kotux: I agree. Filing bugs for our own scripts and other to do items sounds like a good idea.
22:29 <GunnarHj> How do we identify new Ubuntu specific areas for the docs?
22:29 <GunnarHj> (Ubuntu specific = not GNOME)
22:30 <kotux> Organization from the start goes a long way. ;)  That's how I felt while I was sifting through the launchpad bugs the past few days; so many of them (pretty old) did not get the attention they deserved.
22:30 <bkerensa> Shall we move on to the next item?
22:30 <bkerensa> which is bugs
22:30 <bkerensa> :)
22:31 <GunnarHj> I think the question I just asked is important...
22:31 <kotux> can anyone answer GunnarHj?
22:31 <dsmythies> earlier Kevin said: "I think it's important that we have up-to-date documentation." I could not agree more. It is becoming difficult to call help.ubuntu.com the "official documentation".
22:32 <bkerensa> GunnarHj: Well most of Ubuntu uses Gnome system apps
22:32 <dsmythies> ... sorry for my chime in on that one...
22:32 <bkerensa> GunnarHj: if you look at the doc files they have authors and such and most of the gnome doc has gnome authors
22:32 <bkerensa> where the Ubuntu specific is Jeremy or someone else with an @ubuntu.com e-mail
22:32 <GunnarHj> Yes, but Ubuntu is not only GNOME admin tools.
22:32 <bkerensa> but there is not a specific tag necessarily that I know of
22:33 <GunnarHj> If nobody knows a good answer, maybe there is another task that should be put on the blueprint?
22:33 <godbyk> GunnarHj: I'll ask Jeremy about that, too. When we do the import from Gnome, we can probably get the list of files at the same time.
22:34 <kotux> I second that.
22:34 <bkerensa> #action godbyk to check with jbicha to see about identifying Ubuntu specific doc
22:34 * meetingology godbyk to check with jbicha to see about identifying Ubuntu specific doc
22:34 <GunnarHj> godbyk: May be a good start.
22:34 <bkerensa> Ok we have to move along as other people will need this channel ;)
22:34 <bkerensa> #topic Addressing Bug Triage Questions
22:35 <bkerensa> So godbyk wanted to have Ubuntu Doc Bug Triage up for discussion since kotux has been doing an epic amount of tidying of Ubuntu Doc bugs
22:35 <bkerensa> godbyk I will let you start this discussion off
22:36 <godbyk> bkerensa: Thanks.
22:36 <godbyk> kotux and I have been working on the ubuntu-doc bugs lately.
22:36 <godbyk> (Though it's been mostly kotux -- thanks!)
22:36 <godbyk> We just wanted to check in and see if we've been handling them correctly.
22:36 <godbyk> A few questions:
22:36 <kotux> yup.  Yeah, more tidying left to go.
22:37 <godbyk> 1. If a bug is misfiled under ubuntu-doc, and we're not sure where it should be reassigned, how do we handle it?  Assign it to ubuntu generally?
22:37 <godbyk> 2. Are there and project-wide tags or project names that we should use for the various projects that reside under the ubuntu-docs umbrella?
22:37 <godbyk> For example, docs for other *buntu flavors.. do they have different projects or tags?
22:38 <godbyk> I know the serverguide project is separate.
22:38 <bkerensa> jbicha: Quick Q: How did you import gnome doc into ubuntu doc?
22:38 <godbyk> And we've been trying to switch from ubuntu-doc to serverguide as appropriate.
22:38 <godbyk> kotux: Feel free to jump in with other questions you have or issues you've come across.
22:39 <jbicha> bkerensa: sudo apt-get install meld http://meldmerge.org/
22:39 * kotux nods.
22:39 <GunnarHj> As regards the first question: Yes, reassign to Ubuntu if you can't figure out anything more specific.
22:39 <dsmythies> Yes, thanks... for the serverguide added tags. Many bug reports never get seen by serverguide contributors, yet would be easy to fix.
22:40 <jbicha> bkerensa: and then just line up your git checkout of gnome-user-docs with your ubuntu branch
22:41 <bkerensa> jbicha: is there any tagging in docs to let us know what is upstream doc and what is Ubuntu Doc?
22:41 <godbyk> jbicha: Okay, thanks. I may ping you about it again in the future if I run into problems or have more questions about it.
22:41 <kotux> I've seen some bugs reported in non-English languages
22:42 <kotux> Should the descriptions be updated in English?  Google translate comes in quite handy.
22:43 <GunnarHj> kotux: I would ask the bug reporter to add an English description.
22:43 <bkerensa> kotux: so for the bugs your triaging those are being reported on ubuntu-docs because help.ubuntu.com has ambigious footer
22:44 <jbicha> bkerensa: no, meld is really the only clue as to original source
22:44 <bkerensa> ok
22:44 <dsmythies> had an ambigious footer. It has been updated, for 13.04. Both serverguide and desktop.
22:45 <kotux> Right. I've noticed mostly bugs on wiki or system doc.  But some have been reported via apport, which was weird.
22:45 <bkerensa> hmm
22:45 <kotux> well, a handful
22:45 <GunnarHj> As a general approach: As long as you understand what the bug reporter is saying, don't put too much effort on the triaging process. Better to just fix it. ;-)
22:45 <bkerensa> I'm unsure why apport would send to ubuntu-doc
22:46 <kotux> bkerensa, It's a point to ponder.
22:46 <bkerensa> indeeed
22:46 <kotux> GunnarHj, when it comes to fixing, sometimes, I have the impulse to test them.
22:47 <GunnarHj> kotux: That's good, of course. So do I.
22:47 <kotux> But I can't at times.  For instance, I don't have any Ubuntu server in my home to run from.
22:49 <GunnarHj> Aha, you are talking server... I think it's possible to set up a virtual thing for testing, but I'm not able to tell how.
22:49 <bkerensa> If the bugs are erroneously filed on ubuntu-docs they should be flagged incomplete and ubuntu-docs should be dropped and they should be moved to whatever they really effect
22:49 <bkerensa> ideally Ubuntu Bug Squad should be doing this work
22:49 <bkerensa> ;)
22:49 * bkerensa pokes bdmurray
22:50 <bkerensa> but anyways lets get this last item discussed
22:50 <bkerensa> the next team will need the channel
22:50 <kotux> k, thanks for bringing that up bkerensa
22:50 <bkerensa> #topic Discussion surrounding requests to join team
22:50 <bkerensa> So
22:50 <GunnarHj> bkerensa: Uhm.. I don't think that's a good way to use "incomplete".
22:51 <bkerensa> I wanted to quickly discuss how we will continue to direct people in regards to joining the team
22:51 <bkerensa> right now the process is   1. Get some commits in to show your contributions 2. Mail the list 3. Wait for mdke to add you
22:52 <kotux> This is where marketing and publicity come into play.
22:52 <kotux> mdke?
22:52 <godbyk> bkerensa: I think that process is okay for now except step 3 should be replaced with more people having rights to add people to the team.
22:52 <bkerensa> I think having mdke be the gate keeper for that is akward since he is not officially involved in any part of Ubuntu anymore and has not been for some time
22:52 <pleia2> godbyk: +1
22:53 <godbyk> And I'm guessing that the CC doesn't want to keep their role in step 3 either. :)
22:53 <bkerensa> so my thoughts on that are that we could create subteam
22:53 <bkerensa> like
22:53 <pleia2> godbyk: yeah, we want to get off the team asap ;)
22:53 <bkerensa> "Ubuntu Doc Leaders"
22:53 <bkerensa> or something
22:53 <godbyk> bkerensa: Well, that's what the committers team is for, right?
22:53 <bkerensa> and that team could add Ubuntu Doc Committers
22:53 <pleia2> bkerensa: couldn't we just make 3 people admins and be done with it?
22:53 <jbicha> bkerensa: you don't need a subteam to add people, just make people admins
22:53 <godbyk> pleia2: +1
22:54 <dsmythies> As I have mentioned before, do not confuse administrsation with team leader.
22:54 <bkerensa> pleia2: +1
22:54 <bkerensa> jbicha: +1
22:54 <pleia2> I really don't want to see another lp team :)
22:54 <kotux> pleia2: +1
22:54 <bkerensa> pleia2: +1
22:54 <pleia2> good, #agreed!
22:55 <bkerensa> so pleia2 would the CC ideally be ok with Dough Smythies, Kevin and myself to start and see how that goes?
22:55 <kotux> Is there a certain threshold for commits to be eligible?
22:55 <pleia2> bkerensa: let's vote on that now, CC will respect the team's vote
22:55 <godbyk> kotux: There's no hard number at the moment.
22:55 <bkerensa> kotux: not currently
22:55 <godbyk> kotux: The idea is that we just want to know that the person requesting commit rights won't break everything. :)
22:55 <bkerensa> ok
22:55 <bkerensa> so lets get a vote started
22:55 <kotux> godbyk, right.
22:56 <bkerensa> #voters godbyk kotux bkerensa dsmythies pleia2 GunnarHj
22:56 <meetingology> Current voters: GunnarHj bkerensa dsmythies godbyk kotux pleia2
22:56 <GunnarHj> +1
22:56 <kotux> :D
22:56 <dsmythies> Sorry, I am IRC challenged and do not know how to vote. Sounds O.K. to me.
22:56 <godbyk> What are we voting on?
22:56 <bkerensa> #vote Remove mdke and add dsmythies, godbyk and bkerensa to admin for onboarding
22:56 <meetingology> Please vote on: Remove mdke and add dsmythies, godbyk and bkerensa to admin for onboarding
22:56 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
22:57 <bkerensa> +1
22:57 <meetingology> +1 received from bkerensa
22:57 <pleia2> +1
22:57 <meetingology> +1 received from pleia2
22:57 <kotux> +1
22:57 <meetingology> +1 received from kotux
22:57 <godbyk> +1
22:57 <meetingology> +1 received from godbyk
22:57 <dsmythies> +1
22:57 <meetingology> +1 received from dsmythies
22:57 <GunnarHj> +1
22:57 <meetingology> +1 received from GunnarHj
22:57 <bkerensa> #endvote
22:57 <meetingology> Voting ended on: Remove mdke and add dsmythies, godbyk and bkerensa to admin for onboarding
22:57 <meetingology> Votes for:6 Votes against:0 Abstentions:0
22:57 <meetingology> Motion carried
22:58 <bkerensa> ok
22:58 <bkerensa> well that concludes the agenda
22:58 <dsmythies> Thanks everyone...
22:58 * kotux takes a stretch.
22:58 <bkerensa> #endmeeting