15:01 <Laney> #startmeeting
15:01 <meetingology> Meeting started Mon Jun  3 15:01:16 2013 UTC.  The chair is Laney. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:01 <meetingology> 
15:01 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:01 * stgraber waves
15:01 <tumbleweed> o/
15:01 <mitya57> evening
15:02 <mfisch> morning
15:02 <mitya57> :)
15:02 * Laney waits for one more dmber to come out of the woodwork
15:02 <Laney> oh, I guess bdrung already did
15:02 <Laney> ok
15:02 <Laney> someone remind me if the previous action items is current please
15:03 * barry waves
15:03 <bdrung> o/
15:03 <bdrung> we are quorate
15:03 <Laney> https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
15:04 <Laney> ok, since nobody wants to tell me :P
15:04 <Laney> #topic Review of previous action items
15:04 <bdrung> Laney: yes, i did write a short summary. so this action item is done.
15:04 <Laney> #subtopic bdrung to write up a short summary of sweetshark's recent sponsorship
15:04 <Laney> ^
15:04 <Laney> #subtopic barry to conduct sweetshark ppu vote on ubuntu-dmb list
15:04 <Laney> done also
15:04 <Laney> barry: did you send feedback on the outcome?
15:05 <barry> Laney: i did not, but i will do that
15:05 <Laney> merci
15:05 <Laney> #action barry to send outcome of sweetshark ppu vote
15:05 * meetingology barry to send outcome of sweetshark ppu vote
15:05 <Laney> #subtopic all: review separation of ppu from membership
15:06 <Laney> You probably saw that I sent this to the list and put it on http://pad.ubuntu.com/dmb-ppu-membership-proposal
15:06 <stgraber> I saw it, I even think I read it, but I don't remember it and forgot to comment, so I guess I'll have to go through it again... sorry
15:06 <Laney> please make some time to consider it and the questions I posed there
15:06 <Laney> I'd like to get it voted on at the next meeting
15:07 <Laney> the main thing is that I find the discinction between PPU with and without membership and packagesets to be confusing
15:07 <Laney> so I'd appreciate everyone thinking about how that should look
15:08 <Laney> #action everyone read and amend http://pad.ubuntu.com/dmb-ppu-membership-proposal, and sign up for the implementation tasks
15:08 * meetingology everyone read and amend http://pad.ubuntu.com/dmb-ppu-membership-proposal, and sign up for the implementation tasks
15:08 <Laney> #topic Adjusting dynamic PPU to make being a DD and an Ubuntu Developer of any kind the prerequisite, instead of PPU.
15:08 * Laney finds the mail
15:08 <barry> Laney: i vaguely recall responding to that particular issue ;)
15:08 <Laney> https://lists.ubuntu.com/archives/devel-permissions/2013-May/000483.html
15:09 <Laney> barry: you did!
15:10 <Laney> so this is an issue that the DD-PPU thing we approved a while back is maybe too restrictive
15:10 <Laney> it says that people have to be PPU already, but it seems eminently sensible to me that it should just be updated to say that you must be an Ubuntu Developer of any kind
15:10 <Laney> yes?
15:10 <tumbleweed> +1
15:11 <micahg-work> +1
15:11 <bdrung> +1
15:11 <barry> +1
15:11 <stgraber> I believe we already abused that part of the process in the past, can't remember the specific case, but I do remember us granting extra upload rights to a non-PPU member who was in ubuntu-dev for other reasons
15:11 <stgraber> so yeah, +1
15:11 <micahg-work> there are already safeguards in the document about expanding permissions, so I think we're good in that regard
15:11 <Laney> ok
15:11 <micahg-work> hrm
15:11 <micahg-work> Uploading Ubuntu Developer
15:11 <Laney> #action laney to update DD-PPU process to say that any ubuntu-dev is eligible
15:11 * meetingology laney to update DD-PPU process to say that any ubuntu-dev is eligible
15:12 <micahg-work> we can still special case non-uploading if we'd want, but I'd rather have the doc say uploading
15:12 <micahg-work> or something to that extent
15:12 <Laney> I'll let you know when I've changed it so you can review
15:13 <Laney> let's do some applications
15:13 * Laney checks who was first
15:13 <Laney> ok, that's ...
15:13 <bdrung> Laney: could the dynamic-ppu-procedure moved to a wiki page (to be more prominent)?
15:13 <Laney> bdrung: it is already
15:14 <Laney> that's just the "law", but the end-user part is on ApplicationProcess iirc
15:14 <bdrung> Laney: where?
15:14 <Laney> moving on
15:14 <Laney> #topic MOTU Application - Matt Fischer
15:14 * mfisch waves
15:14 <Laney> hi mfisch!
15:14 <Laney> care to give us a quick introduction?
15:14 <mfisch> Sure
15:15 <mfisch> My name is Matt Fischer, I've been working on Ubuntu now for about 18 months in my free time
15:15 <mfisch> My day job is at Canonical, where we work on contracted work for Ubuntu
15:15 <mfisch> like Ubuntu for Android
15:15 <mfisch> but most of my contribs are in my free time
15:16 <mfisch> I mainly work on desktop packages
15:16 <mfisch> since I'm most familiar with them
15:16 <mfisch> I didn't review what other intros were, so I'm out of stuff to say, but I can answer questions ;)
15:17 <Laney> seems fine :P
15:18 <Laney> how comfortable would you say you are with ubuntu development (packaging and process) at this point?
15:18 <Laney> and/or do you know how & where to get help if you need it?
15:18 <mfisch> I'm very comfortable with packaging, that is what I do lots of in my free time and my work time. I am also comfortable with process
15:19 <mfisch> I usually work with a mentor (Robert Ancell) or get help from #ubuntu-desktop on desktop stuff
15:19 <mfisch> more general stuff, I go to #ubuntu-motu
15:20 <mfisch> As for updates and syncs, I'm familiar with the old way (debdiff), the UDD way, and the Ubuntu Desktop way
15:20 <Laney> so as you said, you like to work on desktop stuff - will you be applying to join the ubuntu desktop team any time soon? :-)
15:20 <Laney> MOTU doesn't let you upload a lot of that stuff so you might still need quite a bit of sponsorship
15:20 <mfisch> Laney: yes, I will be applying
15:20 <mfisch> I've spoken to seb about it
15:21 <mfisch> my work tends to be bursty, as I have kids and time is scarce some evenings, but I
15:21 <micahg-work> mfisch, do you have an interest in general universe packages, I see you're mostly doing desktop + gnome
15:21 <Laney> yeah I see on http://ubuntu-dev.alioth.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=*&sponsor_search=name&sponsoree=Matthew+Fischer&sponsoree_search=name  that he's sponsored you a bit
15:21 <mfisch> sorry, I'm trying to work on more desktop stuffd
15:21 * Laney hands the floor over
15:22 <mfisch> micahg-work: yes, but desktop has been a focus because its been easy for me to work with people there
15:22 <mfisch> I have a new universe package and one more on the way from debian
15:22 <mfisch> (dateutils)
15:22 <mfisch> and ubuntu-accomps and friends are universe I think
15:23 <barry> mfisch: just to follow that thread a bit, do you think motu will actually be useful for you right now, assuming you do join the desktop team?  i mean, would desktop + ppu on a handful of additional packages be enough?
15:24 <mfisch> barry: thinking, one sec
15:25 <mfisch> barry: Its true that I've not done many MOTU updates recently, but I still think it would be useful to me. However, my ultimate goal is probably Ubuntu desktop
15:25 <mfisch> I saw MOTU as part of the path to that
15:25 <barry> mfisch: i don't mean to be discouraging in any way, i'm just trying to tease out what your goals are
15:26 <mfisch> barry: Eventually I'd like both. My plan was to apply for desktop in a couple months
15:26 <mfisch> barry: Is experience in desktop packages not applicable for motu?
15:26 <Laney> we certainly want people who want to help out with universe
15:27 <barry> mfisch: oh, i do think it is definitely.  i'm just curious mostly as to why you chose the path you did (emphatically *not* implying you did anything wrong or out of order)
15:28 <mfisch> Ideally these rights can help me at my day job, but mainly I enjoy contributing
15:28 <barry> mfisch: thanks.  i yield the floor to bdrung
15:30 <bdrung> mfisch: do you collaborate with Debian developers?
15:30 <mfisch> bdrung: yes, I've been working with a mentor there to do some new packaging
15:30 <mfisch> bdrung: I could certainly do more
15:32 <Laney> the gnome team is cool ;-)
15:32 <Laney> (if you like svn)
15:32 <Laney> (hahaha)
15:32 <tumbleweed> if you like svn, join the python teams too :P
15:32 <bdrung> mfisch: it's good to see new packages come through Debian.  do you plan do join the Debian gnome team?
15:33 <bdrung> besides svn, it's a pleasure to work with them. :)
15:33 <barry> tumbleweed: well, maybe s/like/tolerate/ :)
15:33 <mfisch> bdrung: to be honest I've not thought about it. I probably should
15:33 <mfisch> I've used svn before, it's not that bad ;)
15:33 <Laney> especially now that we're more synced on GNOME versions there are more opportunities to collaborate with them
15:33 <mfisch> coming from Clearcase it was refreshing
15:34 <mfisch> being synced is a big win
15:34 <bdrung> it reduces maintenance overhead when the package can be kept in sync.
15:34 <mfisch> yes, and makes our lives easier
15:35 * bdrung yield the floor for stgraber.
15:35 <mfisch> and the users lives really
15:35 <stgraber> mfisch: One quick (possibly tricky) question for you. So, let's say we are on the 16th of July and you wish to upload a new version of seahorse. Should you just go ahead and do it or is there a reason why you should refrain?
15:35 <bdrung> mfisch: i encourage you to get more involved in Debian (and to try to reduce diffs)! :)
15:36 <mfisch> stgraber: hmm, I'd check the release schedule first
15:37 <mfisch> looks like a2 is on July 18 (I dont have the schedule memorized), so maybe wait until July 19?
15:37 <mfisch> or not at all, depending on the changes
15:37 <mfisch> or better yet, discuss it in #ubuntu-desktop
15:38 <mfisch> bdrung: I think thats a good idea
15:38 <stgraber> mfisch: right, July 16th is during alpha2. Now, how would you know whether the package will impact anything that's part of that milestone?
15:40 <mfisch> stgraber: I'm not sure if I fully understand your question, but I know what seahorse does and how it's used and can gauge the impact of a change from that
15:41 <mfisch> you can gauge some impact by looking at dependencies if thats what you are asking
15:41 <stgraber> mfisch: so those early milestones are opt-in, which means that depending on who participates in it, you may be clear to upload.
15:41 <stgraber> mfisch: I was wondering how you'd check who's participating in the milestone and how to check whether the package is on their image
15:43 <mfisch> stgraber: I don't know a good way to check that actually
15:43 <mfisch> an easy way I mean
15:43 <stgraber> ok. The tool is seeded-in-ubuntu
15:43 <stgraber> seahorse (from seahorse) is seeded in:
15:43 <stgraber> edubuntu: dvd
15:43 <stgraber> ubuntu-gnome: daily-live
15:43 <stgraber> ubuntu: daily-live, daily-preinstalled
15:43 <stgraber> ubuntukylin: daily-live
15:43 <stgraber> the above output shows you that you'd be fine to upload if none of those flavours take part in the milestone
15:44 <stgraber> otherwise, you should get in touch with the appropriate flavour leads or just through #ubuntu-release
15:44 <mfisch> yeah
15:44 <mfisch> I was just looking at that
15:44 <mfisch> seeded-in-ubuntu seahorse
15:44 <mfisch> I figured ubuntu-dev-tools would have a useful solution
15:45 <stgraber> note that we now tend to add britney (proposed-migration) blocks to prevent most packages from moving from -proposed to -release, so it's likely that the upload wouldn't affect anything, however it's always better to just wait before uploading :)
15:45 <stgraber> Laney: I'm done
15:45 <Laney> merci!
15:45 <Laney> #vote should mfisch join ~motu?
15:45 <meetingology> Please vote on: should mfisch join ~motu?
15:45 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
15:46 <Laney> +1
15:46 <meetingology> +1 received from Laney
15:46 <stgraber> +1
15:46 <meetingology> +1 received from stgraber
15:46 <barry> +1
15:46 <meetingology> +1 received from barry
15:46 <bdrung> +1
15:46 <meetingology> +1 received from bdrung
15:46 <Laney> tumbleweed: ?
15:47 <tumbleweed> +1 [ I'd really have prefered to see more endorsements but I have a fair confidence in mfisch from IRC interaction ]
15:47 <meetingology> +1 [ I'd really have prefered to see more endorsements but I have a fair confidence in mfisch from IRC interaction ] received from tumbleweed
15:49 <micahg-work> +1 [very impressed with no FTBFS on uploads, would have liked more endorsements as well]
15:49 <meetingology> +1 [very impressed with no FTBFS on uploads, would have liked more endorsements as well] received from micahg-work
15:49 <Laney> #endvote
15:49 <meetingology> Voting ended on: should mfisch join ~motu?
15:49 <meetingology> Votes for:6 Votes against:0 Abstentions:0
15:49 <meetingology> Motion carried
15:49 <Laney> mfisch: congrats, welcome to MOTU :-)
15:49 <mfisch> thanks, next time I'll get more endorsements!
15:49 <Laney> look forward to seeing you on #-motu
15:49 <stgraber> mfisch: congrats!
15:49 <Laney> for desktop you don't have to come back to us anyway :P
15:49 <Laney> moving on
15:49 <mfisch> hah, true
15:50 <Laney> #topic MOTU application - Dmitry Shachnev
15:50 <mitya57> o/
15:50 <Laney> mitya57: it's a you
15:50 <Laney> can you give us a quick introduction?
15:50 <mitya57> All of you should already know me (and, in fact, have sponsored something for me :P)
15:50 <mitya57> So I'll start with what I achieved recently (i.e. in spring)
15:50 <Laney> for the historical record, if nothing else :-)
15:51 <mitya57> Well, one line ftr: I'm student of Moscow University, upstream for some python apps like ReText and interested in various random packages in Debuntu
15:52 <mitya57> (continuing copy-pasting now)
15:52 <mitya57> In this spring I did:
15:52 <mitya57> - lots of python packages updates (docutils/sphinx, nose, pyxdg)
15:52 <mitya57> - helped with preparing qt5 (mostly qtbase and qttranslations)
15:52 <mitya57> - broke qt4 and fixed it
15:52 <mitya57> - new mathjax 2.2 and woff-tools
15:53 <mitya57> - ubuntu-packaging-guide updates
15:53 <mitya57> - helped with (breaking the archive by) uploading the new poppler
15:53 <mitya57> My short-term plans include:
15:53 <mitya57> - major python-keyring update, with switching to secretstorage for secret-service backend and pygi for gnomekeyring backend
15:53 <mitya57> - fixing the broken texlive in precise
15:53 <mitya57> - finishing pyqt5 packaging
15:53 <mitya57> - maybe some qt merges
15:53 <mitya57> ^D
15:53 <stgraber> thanks for the introduction
15:54 <stgraber> I'll start with a quick question because I've got to leave for another meeting in 5min, will keep reading this one though so should be able to vote (but not interact much)
15:54 <stgraber> So similar question to that I asked mfisch earlier on. Let's say we are on the 16th of July and you wish to upload a new version of vlc. Should you just go ahead and do it or is there a reason why you should refrain?
15:55 * mitya57 checks the schedule
15:55 * mitya57 checks seeded-in-ubuntu vlc
15:56 <mitya57> it's mythbuntu only, so if the RT sets proper britney hints, I'll go ahead
15:56 <tumbleweed> somebody's been paying attention...
15:56 <stgraber> mitya57: haha, you went right into the trap ;)
15:57 <mitya57> (well, I am not interested in vlc, but if I were I would start by talking with bdrung)
15:57 <stgraber> mitya57: it's correct that it's only seeded by mythbuntu, however do you know how often mythbuntu is actually released?
15:58 <mitya57> I think one can't predict which flavors will participate in which milestone
15:58 <stgraber> you can for mythbuntu ;)
15:58 <mitya57> bad /me
15:58 <mitya57> I now remember that it has only LTS releases...
15:58 <stgraber> correct :)
15:59 <stgraber> so a package seeded only by mythbuntu is always fine to upload during a non-LTS cycle
16:00 <mitya57> yeah
16:00 <Laney> anyone else?
16:01 <micahg-work> o/
16:01 <Laney> go
16:02 <micahg-work> mitya57, so, you mention that there are issues with collaboration with upstreams, do you have any proposals on what MOTU could do to improve on this?
16:02 <mitya57> that was mostly related to gnome, which is for desktop team, not for motu...
16:03 <mitya57> but Ubuntu GNOME devs (jbicha & darkxst) have been doing nice work with collaborating recently
16:04 <mitya57> Myself I'm planning to contribute to https://live.gnome.org/GnomeFlashback packaging
16:05 <mitya57> (some bits already done like recent metacity upload with my patch)
16:05 <Laney> I imagine the GNOME situation will calm itself down as Ubuntu moves on more
16:05 <mitya57> let's hope
16:06 <mitya57> But I think our recent decision to ship 3.6 in R and 3.8 in S was a step back
16:07 <Laney> in terms of finding bugs early?
16:07 <mitya57> In terms of collaborating, and finding bugs too
16:08 <Laney> ah, well as I mentioned earlier it does mean that we can collaborate with the Debian GNOME team more
16:08 <Laney> so that's an upside from my pov
16:08 <mitya57> that's a definite upside, yes
16:09 <micahg-work> mitya57, are you involved with Ubuntu GNOME?
16:09 <mitya57> micahg-work: not so much
16:10 <mitya57> (but I use GNOME, not Unity)
16:10 <mitya57> and sometimes fix bugs when I find them
16:11 <linuxCool> x
16:11 <linuxCool> hello to all
16:11 <linuxCool> when will be start     Ubuntu Security?
16:12 <micahg-work> linuxCool, 20 minutes (we're still in the DMB meeting)
16:12 <Laney> anyone else?
16:13 <demonoid_me> aaa ok sorry :)
16:13 <bdrung> mitya57: are you involved in the Debian GNOME team?
16:13 * Laney takes that as a no
16:13 <Laney> blast
16:14 <mitya57> bdrung: already asked by micahg-work (in short: no)
16:14 <bdrung> he asked for the Ubuntu team.
16:14 <bdrung> i recommend to get more involved in the GNOME teams, as you already collaborate nicely with Debian.
16:14 <mitya57> bdrung: also no more than sending some patches
16:15 <mitya57> In Debian, I'm member of two python teams, javascript team and fonts team
16:16 <Laney> thanks
16:16 <Laney> & now we will vote!
16:16 <Laney> #vote should mitya57 join ~motu?
16:16 <meetingology> Please vote on: should mitya57 join ~motu?
16:16 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
16:16 <Laney> +1 yay
16:16 <meetingology> +1 yay received from Laney
16:16 <barry> +1 happily
16:16 <meetingology> +1 happily received from barry
16:16 <bdrung> +1
16:16 <meetingology> +1 received from bdrung
16:16 <stgraber> +1
16:16 <meetingology> +1 received from stgraber
16:16 <micahg-work> +1
16:16 <meetingology> +1 received from micahg-work
16:16 <tumbleweed> +1
16:16 <meetingology> +1 received from tumbleweed
16:17 <Laney> #endvote
16:17 <meetingology> Voting ended on: should mitya57 join ~motu?
16:17 <meetingology> Votes for:6 Votes against:0 Abstentions:0
16:17 <meetingology> Motion carried
16:17 <Laney> congrats!
16:17 <mitya57> Thanks! \o/
16:17 <dholbach> congratulations mitya57!
16:17 <Laney> #action laney to add mfisch and mitya57 to motu
16:17 * meetingology laney to add mfisch and mitya57 to motu
16:17 <Laney> #topic AOB
16:17 <mitya57> hi dholbach, and thank you!
16:17 <Laney> can someone reply to Daniel Pocock on devel-permissions please?
16:18 <bdrung> mitya57: congrats. one question: do you want to join the ubuntu sponsors team?
16:18 <mitya57> bdrung: yes, I want :)
16:18 <bdrung> nice :)
16:19 <Laney> aaaaaanyone?
16:19 <bdrung> Laney: i can do that if no-one else will want it
16:20 <Laney> doesn't seem like anyone is scrambling
16:20 <Laney> thanks
16:20 <Laney> #action bdrung to reply to Daniel Pocock on devel-permissions
16:20 * meetingology bdrung to reply to Daniel Pocock on devel-permissions
16:20 <Laney> be nice :P
16:20 <bdrung> i will point to my language barrier if i am not :p
16:20 <Laney> wiki says next chair is ScottK
16:21 <Laney> anything else?
16:21 * barry must have missed daniel's message :/
16:21 <tumbleweed> hrm, daniel has 0 uploads in Ubuntu
16:21 <tumbleweed> that makes the reply fairly easy
16:21 <Laney> right
16:21 <bdrung> barry: sent today a few hours ago
16:21 <Laney> but if all of his stuff is in sync and in great condition, ...
16:21 <Laney> anyway
16:21 <Laney> #endmeeting