19:25 <AlanBell> #startmeeting IRC team
19:25 <meetingology> Meeting started Sun May 26 19:25:57 2013 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:25 <meetingology> 
19:25 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:26 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
19:26 <AlanBell> we have missed a couple of meetings, and this one isn't really getting off to a great start :(
19:27 <Tm_T> hmmm
19:27 * knome blows to a vuvuzela to lift up the mood
19:27 <Tm_T> if there's something that require broader participation from IRCC I suppose we can continue via mail with those subject
19:28 <IdleOne> +1
19:28 <IdleOne> m4v still hasn't been made a member :/
19:29 <AlanBell> yes, we can and m4v membership application is something I would really like to do by mail, that has been hanging for far too long
19:29 <Tm_T> agreed
19:29 <AlanBell> #topic Review last meetings action items
19:30 * AlanBell hunts back for the last meeting that wasn't just postponing stuff to the next meeting
19:33 <AlanBell> gosh, it really has been some time
19:34 <AlanBell> I will have a further hunt later for undone action items
19:35 <AlanBell> #topic Open items in the IRCC tracker
19:35 <AlanBell> there has been no activity in the tracker
19:35 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
19:35 <AlanBell> we have no bugs
19:35 <AlanBell> #topic Membership applications
19:36 <AlanBell> we do have a membership application from m4v
19:36 <AlanBell> https://wiki.ubuntu.com/m4v
19:36 <AlanBell> https://launchpad.net/~m4v
19:37 <AlanBell> m4v has been a consistent long term contributor to Ubuntu in particular in the IRC area, and especially on the bot infrastructure
19:37 <bazhang> that should be an insta-pass
19:37 <Unit193> Is he here?
19:38 <AlanBell> I am entirely comfortable that the IRCC is an appropriate membership body for this application
19:38 <bazhang> m4v, not in this channel
19:38 <AlanBell> the wiki page looks good and there are strong testimonials
19:39 <IdleOne> m4v gets my +1
19:39 <IdleOne> please to pass that along on the mailing list :)
19:39 <AlanBell> we will vote on it by email, anyone else got any thoughts to add?
19:40 <Tm_T> +1 for mailinglist
19:40 <lderan> Hello
19:40 <knome> lderan, o/
19:42 <Tm_T> let's move to next topic
19:43 <AlanBell> yup
19:43 <AlanBell> #topic Replace floodbot kick+ban behaviour for webchat users who flood - tsimpson
19:44 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/IRCteamproposal has further details
19:44 <AlanBell> Currently when a webchat user floods the bots will set a ban and kick the user, then forget about them. I think this behaviour is overly defensive and discriminates against webchat users unfairly. It would make more sense if the bots simply set -e for that user (as to apply the existing quiet on webchat users) instead of the +q they normally set.
19:44 <AlanBell> This would require some modification to the floodbot script but, as already treats webchat users who flood differently, it shouldn't be too major.
19:44 <Tm_T> +1 from mew
19:44 <knome> AlanBell, what's -e ?
19:44 <AlanBell> removing the exempt
19:45 <AlanBell> so as I understand it, webchat is +q by default
19:45 <Tm_T> knome: webchat is banned entirely, individuals have +e exempt that allows them to talk at all
19:45 <knome> okay
19:45 <Tm_T> banned, quieted, same effect in this case
19:45 <IdleOne> knome: currently we +q all webchat, then floodbots set +e so they can speak in the channel.
19:45 <knome> sounds fair
19:46 <IdleOne> setting -e would allow them to remain in the channel, but the floodbots would need to let the user know somehow how to get the +e reset.
19:47 <IdleOne> which would mean that when there are no ops around, the ops channel could end up with users waiting a long time and getting frustrated
19:47 <knome> wouldn't the webchat users get +e if they just rejoined?
19:47 <AlanBell> but at the moment they just get banned altogether
19:47 <knome> or would that have to be done manually
19:48 <IdleOne> knome: floodbots track which users have been banned so we would need some sort of mechanism to let floobots know that $user is ok to let back in the channel and be able to speak
19:48 <knome> mhm
19:50 <IdleOne> I don't think it will be a major issue. +1 to setting -e instead of kick/banning
19:50 <AlanBell> yeah, I think the policy suggestion is fine, it just needs someone to tangle with the floodbot code and implement it
19:51 <AlanBell> LJL knows that code, dunno if tsimpson was proposing to do it or not
19:51 <IdleOne> How is the open sourcing of that code coming, if at all?
19:51 <AlanBell> it would be good to get other people familiar with the floodbot code
19:52 <Unit193> Could be just like a quiet, -e and if it continues +b kick, and if not, +e.
19:52 <AlanBell> the code is on launchpad, not much progress since then, LjL wasn't around for some time and it became less of a priority once it was on launchpad (albeit in a private project)
19:54 <AlanBell> https://launchpad.net/floodbot is the project
19:54 <IdleOne> Would it be easier to use supybot with the functionality of the floodbots added?
19:55 <AlanBell> floodbot is written in PHP rather than python, it is 1807 lines of code
19:56 <AlanBell> and does some funky stuff with multiple instances of the bot talking to each other through control channels and sharing updates via a pastebin and other surprising and interesting features
19:57 <IdleOne> short answer: no.
19:57 <LjL> if the floodbots aren't going to set +b on kicked webchat users any longer, are we confident the ops will know how to actually ban them?
19:59 <IdleOne> most of us use scripts to do that
20:01 <LjL> IdleOne: which are webchat-aware?
20:01 <IdleOne> chanserv.py currently defaults to *591c6114@* for webchat
20:02 <LjL> uh?
20:02 <LjL> you mean it bans the ident?
20:02 <IdleOne> correct
20:02 <LjL> well that won't let the floodbots know the user is banned
20:03 <IdleOne> I know
20:03 <IdleOne> which is why those of us who use chanserv.py try not to ban webchat and instead we remove/kick and let floodbot set the ban
20:03 <LjL> then again these days the IP is in the webchat mask, so it's less bad than it used to be. but banning the ident or other funny things one might do don't play nice with the system
20:04 <bazhang> yep
20:04 <bazhang> just a remove
20:04 <LjL> IdleOne: and what do the others do, just ban *!*@gateway/whatever?
20:04 <IdleOne> not sure what auto_bleh does
20:04 <IdleOne> I haven't used it in a long time
20:07 <LjL> anyway to answer your question IdleOne, i don't think anyone has worked on the floodbots to bring them to what could be a releasable state. i know i haven't, and at this point, i really don't think i'm ever going to
20:07 <Tm_T> I have to go, but I support any changes toward equal treatment
20:07 <AlanBell> ok Tm_T
20:07 <IdleOne> LjL: understandable.
20:10 <AlanBell> so, do we think this is still a good idea, a bad idea, or an idea that requires further thought, and a plan for someone to implement it?
20:10 <IdleOne> currently the only one who could implement it is LjL right?
20:12 <IdleOne> I think maybe a better idea would be leave things the way they are but have floodbot send a notice to the channel asking for a live op to set a comment/duration on the ban
20:12 <Unit193> (Autobleh doesn't ban nick or ident, just host.  At least, that's how I set it up.)
20:12 <IdleOne> s/to the channel/to the control channel/
20:12 <LjL> i can comment out the line the says "ban it", but not sure whether it'll have other side effects i'm currently not thinking about. i guess i can just do it and we'll see. i'm not really in the mood to look at it in detail
20:13 <LjL> IdleOne: well it already sends a "-WARNING" that people are supposed to highlight on
20:13 <IdleOne> I would prefer if a live op decides whether to remove the ban or set a time limit on it.
20:13 <IdleOne> LjL: it doesn't tell us the banID though
20:14 <LjL> it doesn't have a clue about the "banID"
20:14 <IdleOne> doesn't ubottu ask floodbot to comment on the ban?
20:14 <LjL> i don't think so
20:14 <IdleOne> ubottu: sens me a PM every time I set a ban
20:14 <ubottu> IdleOne: I am only a bot, please don't think I'm intelligent :)
20:14 <IdleOne> sends*
20:15 <LjL> IdleOne, pretty sure the floodbots are exempted from them
20:15 <LjL> that*
20:16 <IdleOne> Well, fair treatment is all well and good. IF it means possibly breaking the floodbots other behaviors we might want to hold off.
20:21 <AlanBell> yeah, I am not sure about this
20:21 <AlanBell> maybe it could be a banforward rather than a ban
20:21 <AlanBell> but I am not sure how much of a problem this actually is
20:21 <LjL> honestly IdleOne, if you want to talk about this, you might as well talk about removing the webchat +b entirely and just handling webchat users manually. the floodbots introduced automatic handling for this because it was hard to match people's real hostnames with the webchat hostname they obtained
20:21 <LjL> but these days, the hostname for webchat users contains their real IP
20:21 <LjL> so you can just go ban that as needed
20:23 <AlanBell> ok, well it was a proposal from tsimpson, who was around earlier
20:23 <IdleOne> LjL: I didn't see the +b as an issue honestly. I would like it if the floodbots could ask us to set comments on the banID (not a big thing if they don't)
20:23 <IdleOne> just thought it would be a nice feature
20:24 <AlanBell> I think we need to discuss further, perhaps on the mailing list, I am not sure that there are any changes that really need to be made, and if there are, it might not be the one proposed
20:24 <IdleOne> IMO leave things as is. I think we are searching for a tech solution where one isn't needed.
20:25 <LjL> IdleOne: maybe ubottu can do that, the floodbots sure can't as they don't know about banIDs (and if they somehow got ubottu to tell you, it would be annoyingly complicated to deal with it, and there's no reason why ubottu couldn't do it in the first place)
20:25 <AlanBell> OK, I will send a mail to the list later with minutes of this meeting and highlight the discussion around this topic
20:25 <IdleOne> sounds good.
20:26 <LjL> AlanBell: maybe the only problem that should be a real problem that i see is what happens when people got automatically muted for flooding. if the involved person is a webchat user, then they get an automatic ban, and if there's no one around to remove that, they stay banned.
20:26 <AlanBell> yeah, I just don't know if that actually happens much to real people who are not intentionally flooding
20:26 <LjL> AlanBell: as to when ops actually kick someone manually, though... i think they should have a look at the modes being set and the floodbot "-WARNING" and realize
20:28 <LjL> anyway tsimpson may also be able to implement whatever is needed, i'm sure he's among the people most familiar with both the floodbots and ubottu. get his opinion, or just let him work out what seems best
20:28 <AlanBell> yeah :)
20:28 <AlanBell> #topic Any Other Business
20:28 <tsimpson> ubottu does
20:28 <tsimpson> "[ubottu] Please somebody comment on the ban of *!*@static-mum-59.181.90.147.mtnl.net.in in #ubuntu done by FloodBot3, use: @comment 55195 <comment>" eg
20:28 <AlanBell> oh, hi tsimpson
20:28 <tsimpson> \o
20:28 <LjL> tsimpson: ah that's nice, IdleOne's concern is settled then i think
20:29 <IdleOne> so the real problem is humans not listening to the bot when it asks for something
20:29 <LjL> yeah :)
20:29 <AlanBell> yeah, I think maybe a refresher on what messages the bots do that humans should respond to might be good
20:29 <Unit193> AlanBell: Review of the ubuntu-bots bugs?  I'd think [Eir] ones could be closed?
20:31 <AlanBell> #action AlanBell to compile page on bot messages for humans
20:31 * meetingology AlanBell to compile page on bot messages for humans
20:31 <tsimpson> there is only bug #899630 left
20:31 <ubottu> bug 899630 in Ubuntu IRC Bots "[Eir] Enable Eir to check other #$buntu channels for banned users and warn" [Wishlist,Confirmed] https://launchpad.net/bugs/899630
20:31 <tsimpson> that should probably be closed
20:31 <AlanBell> interesting point Unit193
20:31 <AlanBell> https://bugs.launchpad.net/ubuntu-bots
20:32 <AlanBell> bug #899630 is now closed
20:32 <ubottu> bug 899630 in Ubuntu IRC Bots "[Eir] Enable Eir to check other #$buntu channels for banned users and warn" [Wishlist,Won't fix] https://launchpad.net/bugs/899630
20:33 <knome> meetingology is tweaked by lderan! \o/
20:33 <meetingology> knome: Error: "is" is not a valid command.
20:34 <knome> boo.
20:34 <lderan> :P
20:34 <AlanBell> yes, lderan has done some great stuff :) private votes are on the way \o/
20:34 <knome> and the moin output is so much better, it's pretty much ready-to-copy-paste now
20:35 <AlanBell> yup
20:35 <AlanBell> ok, any other stuff before I close this meeting?
20:35 <lderan> :D
20:35 <AlanBell> #endmeeting