16:03 <adam_g> #startmeeting ubuntu-server-team
16:03 <meetingology> Meeting started Tue May 21 16:03:11 2013 UTC.  The chair is adam_g. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03 <meetingology> 
16:03 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:03 <adam_g> hey all
16:03 <jamespage> o/
16:03 <arosales> Hello o/
16:03 <Daviey> \o
16:04 <adam_g> hmm. we had no meeting last week because of UDS, correct?  last minutes i can find are @ https://wiki.ubuntu.com/MeetingLogs/Server/20130423
16:04 <Daviey> Correct
16:04 <adam_g> coolio
16:04 <adam_g> #topic Review ACTION points from previous meeting
16:04 <Daviey> adam_g: I think use the agenda from https://wiki.ubuntu.com/ServerTeam/Meeting
16:05 <smoser> o/
16:06 <adam_g> so, we have no action poitns from last
16:06 <adam_g> Moving on?
16:06 <Daviey> adam_g: see the 3 things in Agenda?
16:06 <Daviey> (carried forward) arosales .. etc?
16:07 <adam_g> Oh, sorry. I was looking at the 20130423 minutes
16:07 <adam_g> arosales, any update: arosales to follow up with Norvald regarding SRU?
16:08 <arosales> ugh, sorry /me still has a todo to follow up with Norvald.
16:08 <adam_g> k
16:08 <arosales> I thought there may be some discussion and vUDS, but I don't think norvald was there.
16:08 <adam_g> #action (carried forward) arosales to follow up with Norvald regarding SRU
16:08 * meetingology (carried forward) arosales to follow up with Norvald regarding SRU
16:09 <adam_g> zul, any updates on the complexity of percona packaging in Ubuntu? i know therew was discussion at UDS
16:10 <zul> adam_g:  not really percona is giong to be working on thier stuff to get into the archive via debian and we will go from there
16:10 <adam_g> zul, cool is there a timeframe for that or relevant workitems/blueprint?
16:11 <Daviey> Yeah, great progress was made with percona at vUDS
16:11 <zul> adam_g:  no but ill update the work items
16:11 <Daviey> I feel confident enough we can remove it from the agenda.
16:11 <adam_g> Daviey, is there an action to remove it or just do not record as a new action for next meeting?
16:11 <Daviey> adam_g: yeah, just drop it on the floor.  No action needed, it'll be in blueprint, right zul? :)
16:12 <zul> right
16:12 <adam_g> k
16:12 <adam_g> smoser to reach out to juju-core and discuss what integration with ubuntu image meta data can be done for Raring.
16:12 <adam_g> smoser, any update? assume it didn't make it for raring, but any update on what is in store for saucy with regard to ubuntu images?
16:13 <smoser> juju-core support for simple streams data is basically in.
16:13 <adam_g> ah!
16:13 <doko> smoser, adam_g: do you know if there is any work planned to integrate the no goyaml into juju-core?
16:13 <TheLordOfTime> o/ (late sorry!)
16:14 <smoser> i don't know.
16:14 <adam_g> smoser, is there anything left to be done at that front that needs to be carried over?
16:14 <smoser> no
16:15 <adam_g> doko, i'd be surprised if they were not already using goyaml but you'd have to check with #juju-dev
16:15 <adam_g> Moving on?
16:15 <Daviey> adam_g: Looks good!
16:15 <adam_g> #TOPIC Saucy Development
16:16 <jamespage> hello saucy salamander!
16:16 <Daviey> Still early in the cycle... and with vUDS last week.. we are getting things sorted.
16:16 <adam_g> well, we're probably all working on merges and syncs for some time now
16:16 <Daviey> jamespage: How are blueprints looking?
16:16 * hallyn hides his behind his back
16:17 <jamespage> hands up who still has blueprints to write up from last week?
16:17 * jamespage puts his hand up
16:17 <hallyn> o/
16:17 <Daviey> We need to make good use of the Blueprint review staus
16:17 * zul does
16:17 <hallyn> i'll get to it this week
16:17 <adam_g> jamespage, is there a URL to get a list of blueprints filtered by the server team for S? was having trouble with this yesterday
16:17 <hallyn> Daviey: what does that mean?
16:17 <jamespage> OK _ so please can drafters sync up with session notes and document work items as well
16:17 <hallyn> yup
16:18 <Daviey> hallyn: see the Design field?
16:18 <jamespage> https://blueprints.launchpad.net/~ubuntu-server/+specs?role=assignee
16:18 <Daviey> Lets pick on, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-mongodb
16:18 <Daviey> See it's Defintion is marked as Review?
16:18 <hallyn> y
16:19 <adam_g> #link https://blueprints.launchpad.net/~ubuntu-server/+specs?role=assignee
16:19 <hallyn> Daviey: so switch that to drafting while working, then discussion when doen?
16:19 <Daviey> hallyn: When the blueprint is at a state where it can be moved forward, mark it as review.. So Scott, James and Myself can take a gander.
16:20 <Daviey> hallyn: Discussion is supposed to be last week.. Drafting is the current status
16:20 <Daviey> Review for, "Please Ack it"
16:20 <hallyn> ok
16:20 <Daviey> "Approved" is commence work
16:21 <jamespage> please can folks try to get stuff into a 'Review' state by the end this week
16:21 <jamespage> Daviey, does that sound reasonable
16:21 <hallyn> yes, sir
16:21 <rbasak> Is that why work items don't yet appear on my own page on status.ubuntu.com?
16:21 <Daviey> jamespage: That sounds a super plan
16:21 <hallyn> tsk tsk
16:21 <Daviey> rbasak: Sounds about right.
16:21 <jamespage> if people want some help then please ping me, smoser or Daviey
16:22 <arosales> Daviey, do we also need a topic for servercloud on status.u.c or should work items for individuals show up?
16:22 <jamespage> where help == guidance != write the spec for you :-)
16:22 <Daviey> arosales: I think we do indeed need a topic
16:22 <Daviey> arosales: I actually thought there were topics, but it looks like they are unrelated
16:23 <arosales> #action arosales to create status.u.c topics
16:23 * meetingology arosales to create status.u.c topics
16:23 <Daviey> arosales: You sir, are a true gent.
16:23 <adam_g> cool
16:23 <arosales> I'll do an "ecosystem" and "overview" topic any others folks are interested in?
16:23 <adam_g> anything else?
16:24 <jamespage> thanks arosales
16:24 <jamespage> oh - I had one more thing
16:24 <adam_g> sure
16:24 <arosales> glad to help where I can
16:24 <jamespage> last cycle each blueprint had a individual assignee and ubuntu-server as the drafter
16:25 <jamespage> this mean that work-items where by default owned by an individual rather than the team
16:25 <jamespage> Daviey, we seem to have switch that this cycle
16:25 <jamespage> so work-items are team owned unless specifically assigned
16:25 <Daviey> jamespage: You are certain that s.u.c won't DTRT?
16:25 * jamespage shrugs
16:26 <Daviey> Maybe i am going barmy, but i'd imagine Assignee to be the main person on the hook for the blueprint?
16:26 <Daviey> ie, default owner of WI
16:26 <jamespage> Daviey, yes - but right now that's ubuntu-server team
16:26 <Daviey> BUT, if we do it the other way (AKA last cycle).. we get a pool of unowned work, which is ~ubuntu-server
16:26 <Daviey> So maybe that makes more sense?
16:27 <jamespage> no - we have a pool of unowned work with the way we have it now
16:27 <Daviey> jamespage: Ah yes.
16:27 <jamespage> I think that is wrong
16:27 <Daviey> jamespage: default to unowned sounds subpar to me.. What do you think?
16:28 <arosales> could Drafter and Assignee be switched?
16:28 <jamespage> sounds like we agree; can people switch them around please for the blueprints they are currently assigned as drafter for
16:28 <Daviey> jamespage: Ok, lets switch it around.  I'll do that for ones i am Approver of
16:28 <jamespage> ta
16:28 <Daviey> jamespage: I'll just bulk it.
16:28 <jamespage> adam_g, OK - I think we are done on that one
16:28 <jamespage> Daviey, ta
16:28 <adam_g> ok
16:29 <adam_g> i assume its too early to review release bugs, eh?
16:29 <Daviey> #ACTION Daviey to switcheroo Assignee & Drafter for Saucy blueprints.
16:29 * meetingology Daviey to switcheroo Assignee & Drafter for Saucy blueprints.
16:29 <Daviey> arosales: yeah, i don't think we have any bugs to worry too much about.
16:29 <Daviey> err, adam_g ^
16:30 <jamespage> adam_g, can you action me to chase down bdmurray about the release tracking report
16:30 <Daviey> zul seems to have identified a bunch of FTBFS and jenkins build failures with Havana on Saucy.. but not pertinent here i don't think
16:30 <adam_g> #topic Ubuntu Server Team Events
16:30 <jamespage> I sware its not working again
16:30 <Daviey> jamespage: release tracking report?
16:30 <jamespage> release bug tracking report
16:30 <Daviey> jamespage: url?
16:31 <jamespage> actually don't bother - its working now - http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html
16:31 <Daviey> rls-s-tracking-bugs.html
16:31 <Daviey> right
16:31 <adam_g> is anyone attending any events worth noting here?
16:32 <arosales> for events m_3 is at http://www.gluecon.com/2013/ this week
16:32 <jamespage> there is an openstack and mysql meetup in london on thursday
16:32 <arosales> I am at http://2013.texaslinuxfest.org/ at the end of the month
16:32 <jamespage> I'm not attending but Daviey is I think
16:32 <Daviey> I am at Openstack London meetup this Thursday
16:32 <Daviey> I am at Mysql London meetup this Thursday
16:32 <jamespage> :-)
16:32 <Daviey> (same building, same time)
16:33 <Daviey> (Say Hi, if you see me.)
16:33 <Daviey> ..
16:33 <adam_g> great
16:33 <Daviey> EOF
16:33 <adam_g> #topic Weekly Updates & Questions for the QA Team (plars)
16:34 <adam_g> plars, hi
16:35 <adam_g> if plars is not making it, anything else QA related?
16:35 <plars> hi, I'm here
16:35 <adam_g> oh! hi :)
16:35 <Daviey> \o/
16:35 <plars> not much, hallyn I think was looking at a bug on lxc?
16:35 <plars> one moment, let me dig up the bug #
16:35 <plars> https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1182540
16:35 <ubottu> Launchpad bug 1182540 in lxc (Ubuntu) "lxc smoke test, test_lxc_apparmor appears to hang on saucy VM" [Undecided,New]
16:36 <plars> I believe you've already talked to psivaa about that though right?
16:36 <hallyn> uh, is that the one hementioned this morning?
16:36 <plars> also, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1181315 is affecting the floodlight test, kernel team is aware and looking into it
16:36 <ubottu> Launchpad bug 1181315 in linux (Ubuntu) "unregister_netdevice: waiting for lo to become free. Usage count = 2' is reported and causing kernel hang when floodlight tests are run using utah" [Medium,Confirmed]
16:36 <plars> hallyn: yep
16:36 <adam_g> #link https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1181315
16:36 <hallyn> i ahdn't seen the open bug
16:37 <adam_g> #link https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1182540
16:37 <ubottu> Launchpad bug 1182540 in lxc (Ubuntu) "lxc smoke test, test_lxc_apparmor appears to hang on saucy VM" [Undecided,New]
16:37 <hallyn> couldn't reproduce with a fresh saucy install
16:37 <Daviey> yolanda: did you send that mail to ubuntu-qa, about dep-8?
16:37 <hallyn> plars: have him ping me if it happens again on next run pls
16:37 <yolanda> Daviey, yes, i also had you and Jamie in CC
16:37 <hallyn> it appeared to be hung on flock
16:37 <plars> hallyn: yes, he's running again to get additional information
16:37 <plars> nothing else from me
16:37 <yolanda> i received a message from ubuntu-qa, telling that is pending of moderation
16:37 <hallyn> plars: thanks
16:38 <Daviey> yolanda: super
16:38 <adam_g> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:38 <adam_g> smb, hello sir
16:38 <Daviey> smb is away
16:38 <adam_g> ah
16:39 <Daviey> I think we can skip this section this week.
16:39 <adam_g> ...and i actually had a question!
16:39 <Daviey> Oh
16:39 <Daviey> apw: Can you help answer a kernel question? :)
16:39 <adam_g> i was just wondering if we knew exactly what kernel requirements are needed to do xen now.
16:39 <apw> Daviey, ?
16:40 <Daviey> apw: adam_g said he had a kernel question.
16:40 <adam_g> was hoping someone could confirm whether a reboot is necessary. we touched on this at UDS but seemed nobody knew for sure
16:40 <apw> adam_g, needed to do xen ?
16:40 <apw> a reboot following what?
16:40 <adam_g> apw, can the vanilla kernel shipped /w ubuntu currently support running a xen hypervisor?
16:40 <Daviey> As far as i a aware, the primary kernel we ship is xen dom0 enabled OOTB
16:41 <apw> the vanilla kernel can be a dom0 kernel yes, obviously you still need to reboot following selecting xen as your hypervisor so it can get underneath the kernel
16:42 <adam_g> apw, thats what i wanted to know, thanks. someone mentioned that was no longer necessary last week.
16:42 <adam_g> thanks
16:42 <Daviey> apw: so that fiddles grub config?
16:42 <adam_g> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:42 <rbasak> Nothing to report. Any questions for me?
16:43 <adam_g> Nothing for rbasak?
16:44 <Daviey> None
16:44 <adam_g> #topic Open Discussion
16:44 <arosales> good blog post by roaksoax for maas juju set up @  http://www.roaksoax.com/2013/05/getting-started-with-maas-and-juju
16:44 <Daviey> +1
16:44 <rbasak> I'd like to draw attention to https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2013-May/014518.html - for those interested in ldap, sssd, etc.
16:44 <Daviey> TheLordOfTime: Hello
16:44 <TheLordOfTime> Daviey:  hiya!
16:45 <TheLordOfTime> if you don't mind me stealing the floor for a few moments... :P
16:45 <rbasak> I'm also still soliciting comments on errors.ubuntu.com on the ubuntu-server list.
16:45 <Daviey> I need to dive out now, but TheLordOfTime wanted to discuss nginx
16:45 <marcoceppi> yay nginx
16:45 <TheLordOfTime> Per https://bugs.launchpad.net/ubuntu/+source/nginx/+bug/1177919/comments/3 there was an informal request to consider nginx for inclusion either on the images or as part of tasksel
16:45 <ubottu> Launchpad bug 1177919 in nginx (Ubuntu) "Merge nginx 1.4.1-1 (universe) from Debian unstable (main)" [Wishlist,Fix released]
16:45 <TheLordOfTime> or some other system.
16:45 <TheLordOfTime> the bug itself is irrelevant, but the comment is what i'm drawing attention to
16:46 <TheLordOfTime> nginx has gotten a lot more widespread use, and it's bugfixing has been a bit faster, namely because i've unofficially adopted it on the ubuntu side
16:46 <TheLordOfTime> i've seen other requests about whether nginx would be included on the images ever, and I've had to answer "I don't know"
16:47 <jamespage> hmm - we did look at this during raring
16:47 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-webscale
16:47 <rbasak> To be clear, are you suggesting nginx together with apache2 in main, or nginx to replace apache2 in main?
16:47 <jamespage> utlemming, around? ^^ any comment on nginx into main
16:47 <TheLordOfTime> rbasak:  i don't remember where the discussion of making nginx part of main went.
16:47 <utlemming> jamespage: yeah...the problem here is that security doesn't seemed to thrilled about it
16:47 <TheLordOfTime> it was a uds talkpoint
16:47 <jamespage> ah - and here again - https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-webscale
16:48 <jamespage> and I'm the drafter
16:48 <adam_g> i'm surprised nginx hasn't been promoted to main by now.
16:48 * jamespage faceplants
16:48 <utlemming> jamespage: the issue is nginx has a long history of CVE's and long standing security issues
16:48 <jamespage> utlemming, that certainly used to be the case - but is that true now?
16:48 <rbasak> I agree that nginx is popular, mature and has widespread use now. Not sure about the security side of things.
16:48 <TheLordOfTime> there are active CVEs.
16:48 <TheLordOfTime> well, last i checked, at least one
16:48 * TheLordOfTime pulls the bug
16:48 <rbasak> It would be nice to have a "lightweight/minimal httpd" in main.
16:49 <TheLordOfTime> this is the last bug I saw: https://bugs.launchpad.net/ubuntu/+source/nginx/+bug/1098654
16:49 <ubottu> Launchpad bug 1098654 in nginx (Ubuntu Raring) "nginx vulnerable to MITM Attack [CVE-2011-4968]" [Low,Confirmed]
16:49 <TheLordOfTime> granted i pulled that from debian and upstream trackers
16:49 <TheLordOfTime> it seems upstream's ignoring it though
16:49 <rbasak> (in addition to the do-everything heavyweight httpd that is apache)
16:49 <TheLordOfTime> rbasak:  i'm bringing it up as a talking point, not from my opinions
16:49 <TheLordOfTime> as we're aware, a common HTTPd deployment is LAMP
16:49 <TheLordOfTime> Apache, MySQL, and PHP
16:50 <TheLordOfTime> nginx has zero OOTB configurations that include PHP
16:50 <rbasak> Just reading that bug now. That seems like a really obscure case.
16:50 <TheLordOfTime> as it depends on php5-fpm (or similar) and proxy_pass-ing to the php5 backend
16:50 <rbasak> Who runs nginx in reverse proxy mode to an https server over an insecure network?
16:50 <TheLordOfTime> whether that's an fcgi wrapper or a php5-fpm running
16:50 <TheLordOfTime> rbasak:  nobody, but that's an example of a known CVE that has gotten zero upstream attention
16:51 <TheLordOfTime> unless I missed a few commits...
16:51 <rbasak> TheLordOfTime: yeah sure. That wasn't aimed at you - I appreciate you bringing it up.
16:51 <TheLordOfTime> rbasak:  no problem :)
16:51 <TheLordOfTime> but lemme go back to my initial "not a good inclusion" argument
16:52 <TheLordOfTime> we're aware LAMP is an easy-to-deploy system because Apache has a loadable module that speaks to php5
16:52 <rbasak> What I'm saying is that I'm not sure that should block an MIR - but I'm not as familiar with MIR policy and history as I'd like, or understand what security policy with that kind of vulnerability would be.
16:52 <TheLordOfTime> nginx doesn't have that, it requires manual configuration to work
16:52 <TheLordOfTime> although the sample default config *does* have a compatible clause that would allow php to work
16:52 <TheLordOfTime> but it's commented out by default
16:53 <rbasak> IMHO, nginx isn't necessarily supposed to have that. Even though I have put PHP behind nginx before.
16:53 <TheLordOfTime> i'm not sure what other points need to be addressed, maybe talk to the security team about their concerns.
16:53 <rbasak> I put some kind of fastcgi thing in the middle, IIRC.
16:53 <TheLordOfTime> rbasak:  it isn't, but debian included a default config with samples that work with Ubuntu/Debian php5-fpm out of the box
16:54 <TheLordOfTime> nginx debian package that is
16:54 <rbasak> OK...so where are we with it?
16:54 <TheLordOfTime> that's the discussion here.
16:54 <TheLordOfTime> personally, I vote to NOT move it to main
16:55 <TheLordOfTime> because the only person actively watching it in Ubuntu is me and maybe a few others
16:55 <TheLordOfTime> (probably mostly me, though...)
16:55 <TheLordOfTime> i also don't want to deal with an extra influx of "how do i configure it for [usecase]" questions
16:55 <TheLordOfTime> as those're bound to flood into existence if we include it on the images.
16:56 <TheLordOfTime> but my point here was to bring the discussion up again
16:56 <TheLordOfTime> i'm curious whether anyone else here has an opinion on moving it to main and/or including on the images.
16:56 <TheLordOfTime> and whether there's concerns from others on it.
16:56 <rbasak> I'm not sure those last two reasons are valid - but we're running out of time.
16:57 <TheLordOfTime> if there's anything I can answer, questions or the such, i'll answer if i can
16:57 <adam_g> can we take this to #ubuntu-server?
16:57 <adam_g> 2 minutes left here
16:57 <TheLordOfTime> we can, or we can take it to the mailing list,
16:57 * TheLordOfTime is on both places
16:57 <jamespage> +1 ML
16:57 <rbasak> My concern would mainly be around whether it's suitable under main inclusion policy, who would look after it, and how much work it'd be.
16:58 <adam_g> #topic Announce next meeting date and time
16:58 <adam_g> May 28th 16:00 UTC
16:58 <TheLordOfTime> last point on that last topic of nginx: we may want to discuss on the ML about this, so others who weren't here can chime in.
16:59 <TheLordOfTime> i'd say that's the first place to bring it up
16:59 * TheLordOfTime is done.
16:59 <arosales> adam_g, thanks for chairing
16:59 <adam_g> TheLordOfTime, i agree. there are plenty of admins out there who are heavily vested that are not on IRC
16:59 <rbasak> TheLordOfTime: will do - thanks for bringing it up
16:59 <adam_g> till next week
16:59 <adam_g> #endmeeting