20:02 <micahg-work> #startmeeting Developer Membership Board
20:02 <meetingology> Meeting started Mon May 20 20:02:29 2013 UTC.  The chair is micahg-work. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:02 <meetingology> 
20:02 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:03 <micahg-work> welcome to the Developer Membership Board meeting, this will be an abridged meeting as we've previous discussed the outstanding agenda items
20:03 <bdrung> then the agenda is not up-to-date regarding the upcoming chairs. but I don't deny your offer to chair again. ;)
20:03 <micahg-work> #topic PPU for glatzor (Sebastian Heinlein)
20:03 <micahg-work> #link https://wiki.ubuntu.com/SebastianHeinlein/PerPackageUploadApplication
20:04 <micahg-work> glatzor, please introduce yourself
20:04 <glatzor> thanks for taking the time so late in the evening.
20:04 <glatzor> I am Sebastian Heinlein. I contribute to Ubuntu since 2006.
20:05 <glatzor> I am involved in Free and Open Source Software development for one third of my so far 34 year long life. Starting as a translator for the Synaptic package manager I soon got interested in documentation and user interface design. The main developer of Synaptic and long standing Debian and Ubuntu developer Michael Vogt became a kind of mentor to me and introduced me to the Ubuntu community.
20:05 <glatzor> My first UDS was in Paris, 2006. I was mainly working on user interfaces and implementing them using Python. But over the time I dived down the package management stack. So after the PackageKit project was started I wrote a Python based APT backend. Unfortunately the technical design policies of PackageKit did not allow to support essential features of APT and the upcoming software-center. This was the time when I created
20:05 <glatzor> the aptdaemon project which is used as the default package management service in Ubuntu's desktop.
20:06 <glatzor> And I think that I even shared once a room stgrabber at an UDS :)
20:07 <glatzor> I would like to apply for for PPU for the packages that I am mainly working on:
20:07 <glatzor> aptdaemon, packagekit, sessioninstaller, python-defer
20:08 <glatzor> You can find additional information on my PPU wike page:
20:08 <glatzor> https://wiki.ubuntu.com/SebastianHeinlein/PerPackageUploadApplication
20:10 <micahg-work> glatzor, so, we see that you're very active on IRC, but less so with regard to sponsored uploads, is there any reason for that?
20:10 <stgraber> glatzor: haha, yeah, I believe that was the UDS in Dallas (though that was a long time ago, memory is getting fuzzy)
20:11 <micahg-work> #chair bdrung
20:11 <meetingology> Current chairs: bdrung micahg-work
20:12 <glatzor> micahg, that was part of mvo's and mine workflow. I commited many changes to the bzr packaging repositories and mvo uploaded them.
20:12 <micahg-work> ah, ok
20:12 <glatzor> micahg, so that is perhaps a reason why you don't see so many official sponsorships. But I have not been very active on IRC recently to be honest.
20:13 <micahg-work> ah, neither have I, maybe that's why I remember you as being active :)
20:14 <glatzor> micahg-work, :)
20:15 <glatzor> micahg-work, but in the last monthes I have been quite busy with my new job position and I moved places. So the time for development was a little bit short.
20:15 <micahg-work> glatzor, I can certainly relate to that
20:16 <bdrung> glatzor: what's your relation to Debian?
20:17 <glatzor> micahg-work, currently the big picture for my projects also isn't very clear. I don't know what the mobile focus of Canonical will mean for them: If aptdaemon/packagekit is a choice there.
20:17 <micahg-work> glatzor, do you feel comfortable with the packaging for all the packages that you're applying for?  I see that you're upstream for 3 out of the 4
20:17 <glatzor> micahg-work, that is another reason why it was getting a little calmer.
20:17 <micahg-work> *at least 3
20:18 <glatzor> micahg-work, Actually I was even part of packagekit before. I wrote the now obsolete Python APT based backend for packagekit :) But that is years ago.
20:19 <glatzor> micahg-work, packagekit and aptdaemon are very related to each other, since aptdaemon provides a packagekit compatibilty layer for Ubuntu - so that you can still use the PackageKit client libraries.
20:19 <micahg-work> glatzor, you're credited with the first packagekit upload in Ubuntu :)
20:20 <glatzor> bdrung, I am not officially involved in any Debian institutions - excluding the Munich Debian meeting :)
20:23 <glatzor> bdmurray,  micahg-work, I was in the lucky position that mvo made nearly all needed uploads of my projects. So I haven't feeled the need to apply for wider privileges before - regarding Ubuntu and Debian.
20:23 <micahg-work> glatzor, so, I think bdrung meant more in the Debian community at large (you are listed as the maintainer of a couple of packages)
20:25 <bdrung> one package is in sync with debian and the others are derived (more or less long time ago)
20:25 <micahg-work> glatzor, right, so, what I was wondering was that since now that you're applying, do you feel comfortable enough with the packaging (we know that you're an expert with the upstream code :))
20:26 <glatzor> bdrung, micahg-work python-distutils-extra is actually maintained by pitti who extended the project. Perhaps we should change the maintainer filed.
20:26 <micahg-work> (that's in sync as well FWIW)
20:26 <micahg-work> glatzor, ah, you're just an uploader on that
20:26 <bdrung> are there plans to get back in sync with the other packages?
20:30 <glatzor> bdrung, for aptdaemon and packagekit?
20:30 <micahg-work> aptdaemon + sessioninstaller
20:30 <micahg-work> ximion has done a great job getting packagekit back in sync
20:31 <bdrung> ^ micah is faster than I
20:32 <glatzor> micahg-work, I don't know if aptdaemon can add any benefit to Debian at the current time. The current maintainer Julian isn't a big fan of the aptdaemon/software-center stack
20:32 * ScottK is here now.
20:32 <micahg-work> glatzor, so, why does he maintain it?
20:32 * barry is finally off the phone
20:32 <glatzor> micahg-work, bdrung, since the GNOME desktop will use PackageKit directly I could even make sense to remove aptdaemon/sessioninstaller/software-center from the Debian archive
20:33 <micahg-work> packagekit has sessioninstaller functionality?
20:34 <glatzor> micahg-work, Julian is very good guy. He made really much progress in his development skills. I can still remember when I re-viewed his first patch.
20:34 <glatzor> micahg-work, He wanted to bring all the good things from Ubuntu to Debian to improve the Debian desktop experience some years ago.
20:36 <glatzor> micahg-work, So I think that the his maintainership is a mix of leftover and missing alternative maintainers who would step in
20:37 <bdrung> glatzor: would you step in?
20:38 <glatzor> micahg-work, packagekit provides thow DBus interfaces: on the system and the session bus. aptdaemon provides its own interface and the packagekit interface on the system bus. sessioninstaller implements the session packagekit interface.
20:39 <glatzor> bdrung, I would, but I haven't yet talked with Julian about this.
20:42 <glatzor> micahg-work, and indeed ximon has put a lot of effort into packagekit. That is also why I have got a bad conscience: the 0.8 packagekit interface isn't yet support by aptdaemon and so the 0.8.x series of packagekit cannot enter Ubuntu
20:43 <glatzor> micahg-work, there will only be a very small difference between the Debian and Ubuntu packagekit packaging. Mostly adding a small provides packagekit-system-interface.
20:43 <bdrung> glatzor: do I get it right that aptdaemon daemon is a replacement for the packagekit daemon, because both provide the same DBus interface?
20:44 <glatzor> ximon would like to reduce the bug load if people report bugs about packagekit clients but they are running aptdaemon on the server side.
20:44 <bdrung> with aptdeamon being a superset of packagekit?
20:45 <glatzor> bdrung, I would not say superset. I am not very happy with the current situation. Aptdaemon was written since we could not agree on technical design issues in packagekit.
20:46 <glatzor> bdrung, Richard didn't want to support any interactiveness in the package operations: So no terminal, no debconf, no conf file conflict handling.
20:47 <bdrung> btw, packagekit 0.8.7-2 was merged in saucy: https://launchpad.net/ubuntu/+source/packagekit/0.8.7-2ubuntu1
20:49 <glatzor> bdrung, So I started with aptdaemon. Aptdaemon has got another focus: we have got very fat clients (mainly using python-apt and xapian index) in Ubuntu. So we only needed a daemon that handles the "root" part only. packagekit is a complete solution.
20:49 <bdrung> glatzor: so minus the interactiveness, could software-center use packagekit instead of aptdaemon?
20:50 <ScottK> bdrung: In Kubuntu, we used a packagekit front end for awhile, but gave up on it.
20:51 <bdrung> ScottK: because?
20:51 <ScottK> It just didn't seem to fit in very well.
20:52 <ScottK> For example, the only way it could find out if additional packages needed to be installed, was to actually do a package install dry run and see.
20:52 <ScottK> So it was incredibly slow.
20:52 <barry> glatzor: when can we get py3 xapian and then move the whole stack to python 3? (it's a trick question :)
20:53 <glatzor> bdrung, theoretically. but you could e.g. not buy any software. s-c introduced its own package operation abstraction level. so you could adapt it with the needed development resources.
20:53 <glatzor> bdrung, there is a fork of software-center (mainly beacuse of the CLA) which tried to use it packagekit to also query all the package information.
20:54 <glatzor> bdrung, I think ximion worked on it. But it seems to be stalled AFAIK.
20:54 <glatzor> barry, that is the question that I would like to ask you :)
20:54 <bdrung> thanks for the information.
20:54 * barry cries a little into his afternoon tea
20:56 <glatzor> bdrung, to be honest I would be happy if we didn't had the conflicts some years ago and we would only see packagekit around. especially since now the strict ban of any interactiveness in packagekit is gone. but the code has been written and is used.
20:57 <ScottK> I'll believe a package management system written for rpm will work well on Debian/Ubuntu when I see it.
20:57 <bdrung> glatzor: so it would be possible in the future to switch from aptdaemon to packagekit if someone invests the development time?
20:57 <ScottK> It seemed like "Oh, here's what we need for rpm, we'll just bolt on some bits for Debian and I'm sure it'll be fine".
20:59 <glatzor> bdrung, The process of buying software is currently made of several aptdaemon transactions. I would like to merge them into a single one. So that we could think about implementing a buy transaction type in packagekit. Mvo and me talked about this with richard last year. but getting API into packagekit is always a compromise - since it supports multiple platforms.
21:00 <glatzor> bdrung, right. but I think we are talking about a multiple years perspective.
21:01 <glatzor> bdrung, The APTcc backend of packagekit also would need some love. Dantti started with some rough code from synaptic and aptitude and it improved quite a lot lately.
21:03 <micahg-work> glatzor, I'm not sure my question about your comfort level with the packaging was ever addressed
21:03 <glatzor> bdrung, there isn't even a test suite for the APTcc backend. Unfortunately most Debian/Ubuntu developers don't the stack. Even the GNOME desktop team uses the good old terminal commands for the daily package operations.
21:06 <glatzor> micahg-work, right. I am quite confident that I can manage the packaging of the given packages. But I hope that I can still ask somebody if I would need help :) I wrote most of the initial packaging bits for the corresponding packages.
21:06 <micahg-work> glatzor, oh, sure, help's always available
21:06 <glatzor> micahg-work, But I need to test more before uploading. that is clear.
21:07 <glatzor> micahg-work, for the aptdaemon 1.0 release I made the "one-small-last-untested-commit-won't-hurt" error.
21:08 <glatzor> micahg-work, which thankfully was fixed by barry.
21:09 <glatzor> bdrung, oh, so the packagekit sync is perhaps also the reason why jenkins reports broken aptdaemon tests.
21:09 <glatzor> bdrung, I wasn't aware of the sync to be honest.
21:09 <bdrung> glatzor: merge, not sync
21:11 <bdrung> but the result is the same ;)
21:12 <glatzor> bdmurray, right merge. I will talk with pitti about this issue.
21:12 <micahg-work> #voters bdrung ScottK stgraber barry Laney micahg-work tumbleweed
21:12 <meetingology> Current voters: Laney ScottK barry bdrung micahg-work stgraber tumbleweed
21:12 <stgraber> +1
21:12 <stgraber> oops, a bit early ;)
21:12 <bdrung> stgraber: too early :P
21:13 <micahg-work> #vote Please vote on glatzor to get PPU for sessioninstaller, aptdaemon, packagekit, and python-defer
21:13 <meetingology> Please vote on: Please vote on glatzor to get PPU for sessioninstaller, aptdaemon, packagekit, and python-defer
21:13 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
21:13 <barry> +1
21:13 <meetingology> +1 received from barry
21:14 <stgraber> +1
21:14 <meetingology> +1 received from stgraber
21:14 <bdrung> +1
21:14 <meetingology> +1 received from bdrung
21:14 <micahg-work> +1
21:14 <meetingology> +1 received from micahg-work
21:14 <ScottK> +1
21:14 <meetingology> +1 received from ScottK
21:14 <micahg-work> Laney also registered a +1
21:15 <micahg-work> #endvote
21:15 <meetingology> Voting ended on: Please vote on glatzor to get PPU for sessioninstaller, aptdaemon, packagekit, and python-defer
21:15 <meetingology> Votes for:5 Votes against:0 Abstentions:0
21:15 <meetingology> Motion carried
21:15 <micahg-work> glatzor, congratulations
21:16 <micahg-work> #action stgraber to set up PPU for glatzor per vote
21:16 * meetingology stgraber to set up PPU for glatzor per vote
21:16 <micahg-work> #topic AOB
21:16 <micahg-work> anything else?
21:16 <bdrung> hopefully not
21:16 <glatzor> thanks a lot.
21:17 <bdrung> congrats glatzor :)
21:17 <glatzor> what is the next step for me?
21:17 <micahg-work> glatzor, stgraber has to add the ACLs to the archive
21:18 <micahg-work> #endmeeting