19:00:55 <bdrung> #startmeeting
19:00:55 <meetingology> Meeting started Mon Apr 22 19:00:55 2013 UTC.  The chair is bdrung. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:00:55 <meetingology> 
19:00:55 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:01:10 <bdrung> #topic Review of previous action items
19:01:16 <ScottK> \o
19:01:31 <tumbleweed> hi
19:02:28 <bdrung> stgraber, barry, and laney said via mail that they (probably) won't attend the meeting
19:03:23 <ScottK> But we have their votes on the applications.
19:03:38 <ScottK> Short version of the action items is no change, nothing done.
19:04:24 <bdrung> i will do  the summary of sweetshark's recent sponsorship as  soon as possible.
19:05:14 <bdrung> we can discuss the review separation of PPU from membership at the end of the meeting if time permits
19:05:41 <bdrung> #topic PerPackageUploader Application: Sebastian Heinlein
19:06:04 <ScottK> I'm ready to vote.
19:06:26 <bdrung> glatzor doesn't seem to be online
19:06:44 * micahg-work has questions
19:08:14 * tumbleweed would be interested in chatting with the applicant, but I'm fairly sure I know how I'd vote
19:08:32 <bdrung> let skip him for now
19:08:54 <bdrung> #topic PerPackageUploader Application: Gunnar Hjalmarsson
19:09:04 <GunnarHj> Good evening, DMB!
19:09:09 <bdrung> #link https://wiki.ubuntu.com/GunnarHj/PerPackageUploaderApplication
19:09:25 <bdrung> GunnarHj: hi. can you introduce yourself?
19:09:34 <GunnarHj> I started with Ubuntu in 2010, and instantly noticed that I wasn't able to (easily) set languages and regional formats to my liking. Noticed bug 553162, and started to work on it. Seems like I got stuck with this problem area. ;-)
19:09:35 <ubottu> bug 553162 in gdm (Ubuntu) "Set $LANGUAGE if the user picks a different locale in gdm, so that language-selector and gdm stop disagreeing" [High,Fix released] https://launchpad.net/bugs/553162
19:09:36 <GunnarHj> I'm an i18n bug fixer, and you may want to consider me an i18n watchdog, since I tend to jump at bugs in many different packages as soon I smell a problem with respect to language and locale handling etc.
19:09:37 <ScottK> I'm ready to vote.
19:09:38 <GunnarHj> language-selector and accountsservice are the packages I most often come back to, and I know quite well by now what they do.
19:09:40 <GunnarHj> I have a question: If you would accept my application, would it make me an ubuntu-dev member, or would that be a separate application? (It would be nice to be able to post to the ubuntu-devel list without moderation.)
19:10:27 <tumbleweed> you'd be an ubuntu-dev member (as things stand right now)
19:10:44 <GunnarHj> tumbleweed: Great, thanks.
19:11:13 <micahg-work> well, I think we'd fix the moderation if we change the base dev group, but we can discuss that later
19:11:46 <GunnarHj> I'm already an ubuntu-member and bug control member.
19:13:02 <micahg-work> GunnarHj, have you collaborated with Debian at all WRT any of the i18n stuff and specifically accountservice since that's what you're seeking upload rights for
19:13:47 <micahg-work> *accountsservice
19:14:05 <GunnarHj> With Debian, yes absolutely, but not with respect to accountsservice since my interest there is Ubuntu specific stuff only.
19:14:44 <GunnarHj> Not sold to Debian, at least not yet. :)
19:17:09 <micahg-work> GunnarHj, the changes you're making only affect Ubuntu, not Debian?
19:17:25 <GunnarHj> micahg-work: Yes.
19:17:51 <micahg-work> and I guess those get pushed straight upstream then?
19:18:48 <GunnarHj> micahg-work: Yes, but they are patches that Debian does not apply (at least that's my understanding).
19:19:53 <bdrung> GunnarHj: are there any intentions to get the patches upstream? the latest package version contains 15 patches.
19:21:19 <GunnarHj> bdrung: The most obvious one I tried to get upstream yet another level, but nothing has happened so far. GNOME seems not very interested in ideas from other distros...
19:23:05 <micahg-work> GunnarHj, FTR, alessio is usually fine with Ubuntu specific patches being forwarded to Debian (might make the maintenance burden easier)
19:23:12 <bdrung> GunnarHj: did you get no response or was the patch rejected?
19:23:40 <GunnarHj> bdrung: Neither. Response, then silence.
19:24:15 <GunnarHj> micahg-work: I'll take your tip and try to do something about Debian.
19:24:46 <micahg-work> GunnarHj, he might even be up for a co-maintainer
19:24:49 <bdrung> sometimes you need to poke upstream more than once and sometimes improving the patch is required to get it accepted.
19:25:00 <GunnarHj> micahg-work: Ok.
19:25:07 <micahg-work> GunnarHj, maybe desrt can help you get the patches upstream (I see him in the commit log)
19:25:48 <bdrung> getting patches as upstream as possible reduces the maintenance burden.
19:25:53 <micahg-work> GunnarHj, are you familiar with the various freezes and exception processes?
19:26:29 <GunnarHj> Please note that the Ubuntu patches in accountsservice presuppose a different approach to part of language locale handling in general. It's a little complicated...
19:26:51 <GunnarHj> micahg-work: Yes. Know them quite well by now.
19:28:36 <micahg-work> GunnarHj, sure, we just like to encourage applicants to collaborate with upstreams where possible to reduce the maintenance burden over time
19:29:10 <micahg-work> GunnarHj, are you subscribed to ubuntu-devel-announce?
19:29:21 <GunnarHj> micahg-work: I fully understand and agree on the goal to reduce the maintenance burden.
19:29:41 <GunnarHj> I'm subscribed to -announce.
19:32:39 <bdrung> GunnarHj: you stated that you dislike the amount of bugs. I agree with you there. Do you have any other idea than throwing more man power at fixing bugs?
19:33:29 <bdrung> there are initiatives like DEP-8 and automated testing that seem to aim in the right direction.
19:33:35 <GunnarHj> bdrung: Well, that would be to test more carefully before uploading, I suppose. ;-)
19:33:38 <micahg-work> FTR, I think most of the bugs are really upstream bugs, there are too many, but no software is perfect
19:34:34 <micahg-work> unfortunately, I think bug control membership has been about the same since I joined about 4 years ago, that certainly doesn't help
19:34:38 <GunnarHj> Agree that the automated testing initiative sounds good.
19:35:14 <GunnarHj> Haven't involved myself in it yet, though.
19:35:28 <bdrung> at least bugs lead to people joining the developer teams. take GunnarHj or me as example. ;)
19:35:44 <GunnarHj> Indeed. :)
19:36:58 <bdrung> let's vote
19:37:46 <bdrung> #vote Should Gunnar Hjalmarsson get upload rights for language-selector and accountsservice?
19:37:46 <meetingology> Please vote on: Should Gunnar Hjalmarsson get upload rights for language-selector and accountsservice?
19:37:46 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:37:54 <micahg-work> +1
19:37:54 <meetingology> +1 received from micahg-work
19:38:00 <tumbleweed> +1
19:38:00 <meetingology> +1 received from tumbleweed
19:38:01 <bdrung> +1
19:38:01 <meetingology> +1 received from bdrung
19:38:34 <ScottK> +1
19:38:34 <meetingology> +1 received from ScottK
19:38:42 <ScottK> +3 from mail too.
19:39:02 <bdrung> #endvote
19:39:02 <meetingology> Voting ended on: Should Gunnar Hjalmarsson get upload rights for language-selector and accountsservice?
19:39:02 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:39:02 <meetingology> Motion carried
19:39:15 <bdrung> GunnarHj: congrats.
19:39:24 <ScottK> Can we go over glaztor's application now like we would for an email vote?
19:39:34 <GunnarHj> Thanks guys! Won't misuse my new access rights. :)
19:39:35 <ScottK> (there's no actual requirement the person be present)
19:39:51 <micahg-work> no, since I have questions for the applicant
19:40:04 <bdrung> #topic PerPackageUploader Application: Sebastian Heinlein
19:40:08 <micahg-work> well, I shouldn't say no, but I have questions for the applicant :)
19:40:30 <ScottK> micahg-work: He's already +4, so why block the application?
19:40:46 <bdrung> ScottK: we used to have the application on the meeting to ask questions
19:40:49 <ScottK> Nothing says you can't ask questions anyway.
19:41:34 <ScottK> Yes and so we'll defer it two week, he'll get at least +4 next time and take up an application slot that maybe someone else would use.
19:41:36 <bdrung> but what does asking question bring if you don't get an answer?
19:42:05 <micahg-work> ScottK, depending on the answers, people can change their minds...
19:42:29 <micahg-work> and the vote needs +4 total, not just 4 +1s...
19:42:30 <ScottK> Then we need to document that a meeting is required and votes can't be done over email.
19:42:44 <ScottK> Right, but is anyone considering -1?
19:42:53 <ScottK> I could image a +0, but really.
19:43:03 <bdrung> micahg-work: can we move the application to email?
19:43:08 <micahg-work> email votes are at the discretion of the DMB
19:43:26 <micahg-work> bdrung, I suppose, should I send my questions by E-Mail?
19:43:27 <ScottK> If we can do it on email, why can't we do it right now?
19:43:50 <bdrung> ScottK: a meeting is normally required, but we can do it over email for special cases.
19:44:09 <micahg-work> bdrung, is there a pressing need that it can't wait 2 weeks?  we usually do e-mail when it's difficult for an applicant to attend a meeting
19:44:34 <ScottK> There's never a pressing need and things keep getting kicked down the road.
19:44:49 <ScottK> Look at the impressive DMB progress on open actions in the last two weeks.
19:45:28 * bdrung promises improving on processing action items.
19:46:47 <bdrung> I like to talk to glatzor on IRC before voting to hear his answers to micahg's question and to ask him questions.
19:47:57 <ScottK> OK.  Looks like a victory for process over substance, but that's what some people think is important.
19:48:01 <bdrung> there are no applications for the next meeting and therefore I see no pressing need for moving the application to email.
19:49:15 <ScottK> Will someone take the action to email glatzor and tell him we decided to wait two weeks.
19:49:48 <bdrung> I propose to ask glatzor if he is fine with attending the next meeting or if he want to be asked via email to avoid the waiting time.
19:50:16 <ScottK> Sounds good.  Will you do it?
19:50:55 <bdrung> okay, i will to it as part of the chair's duties.
19:52:07 <bdrung> #topic Any other business
19:52:22 <micahg-work> meeting time change for 14:00?
19:52:57 <ScottK> What about PPU/membership?
19:53:02 <ScottK> I thought that was on the agenda?
19:53:17 <ScottK> micahg-work: Who asked for it to be changed?
19:53:19 <micahg-work> I did
19:53:26 <bdrung> let's discuss the time change before PPU/membership.
19:53:33 <ScottK> Oh.
19:53:35 <micahg-work> we took a poll, 15:00 UTC Mon seemed to be fine
19:53:44 <micahg-work> unanimous in fact
19:53:46 <ScottK> It's fine for me.
19:53:59 <micahg-work> 13:00 was also on the poll, but I forgot I had a previous commitment
19:54:40 <micahg-work> so, barring any objections, can we announce the new time for the early meeting?
19:54:45 <bdrung> IIRC there was a question about using UTC or DST.
19:54:49 <micahg-work> ah, right
19:55:12 <micahg-work> I'm not sure we settled that one, 15:00 UTC in the winter would be problematic right now
19:55:19 <bdrung> did we come to a conclusion there?
19:56:27 <micahg-work> I'd prefer 16:00 london time if I had a choice
19:56:53 <micahg-work> that should work for me year round...
19:57:44 <micahg-work> but that moves the winter meeting 2 hours ahead of where it was
19:57:49 <bdrung> so 16:00 and 21:00 London time? when do they switch the time?
19:58:15 <micahg-work> hrm, that's the other problem I guess, US switches earlier/later than London
19:58:34 <bdrung> We switch at the last Sunday in March/October in Germany IIRC.
19:58:37 <micahg-work> it's easier for me to remember UTC...but it's only 4 weeks out of the year that it's off
19:59:16 <micahg-work> same in London as Germany
20:01:48 <ScottK> I'd suggest we either decide based on poll results or go back to the list since we're short three people.
20:02:04 <ScottK> Personally, I'm flexible.
20:02:08 <bdrung> let's sum it up
20:04:16 <micahg-work> 15:00 UTC works for now, need to decide if we're switching to GMT or keeping UTC
20:04:24 <bdrung> The proposal is to move to 15:00 / 20:00 UTC in the Summer (from the last Sunday in March till October) and to 14:00 / 19:00 UTC in Winter (from the last Sunday in October til March)
20:05:06 <micahg-work> I'd prefer 16:00/21:00 for the winter
20:05:40 * bdrung is confused with time zones.
20:05:48 <micahg-work> BTW, the 19:00 meeting is fine for me ATM, unless there's a desire to keep 5 hours between meetings
20:08:21 <bdrung> The proposal is to move to 15:00 / 19:00 UTC in the Summer (from the last Sunday in March till October) and to 16:00 / 20:00 UTC in Winter (from the last Sunday in October til March)
20:08:44 <bdrung> micahg-work: i calculated the times wrongly. i didn't want to the the late meeting.
20:09:00 <micahg-work> seems fine
20:09:06 <micahg-work> should we do a list vote?
20:09:12 <bdrung> yes
20:09:35 <micahg-work> bdrung, I can take an action item to call for the vote
20:09:55 <micahg-work> I can also take an action item to poke about PPU/membership decoupling
20:10:31 <micahg-work> unless ScottK wants the seocnd one
20:10:32 <bdrung> #action micahg to call for votes for the new meeting times
20:10:32 * meetingology micahg to call for votes for the new meeting times
20:11:12 <ScottK> Don't we have a proposal we can vote on for the PPU thing?
20:11:20 <bdrung> should we move the next meeting from 14:00 UTC to 15:00 UTC?
20:11:39 <micahg-work> ScottK, ISTR there being some disagreement on a few points still
20:12:00 <micahg-work> bdrung, I would prefer to move the meeting, yes (especially since the poll results were unanimous)
20:12:01 <ScottK> micahg-work: Give me a link to your last proposal and I'll take the action.
20:12:02 <bdrung> (before getting a consensus on changing the schedule?)
20:12:25 <micahg-work> ScottK, ok, I'll have to do that when I get home, there should be a thread on the DMB list
20:12:32 <ScottK> OK
20:13:03 <bdrung> #action bdrung to change the meeting time for the next meeting from 14:00 UTC to 15:00 UTC
20:13:03 * meetingology bdrung to change the meeting time for the next meeting from 14:00 UTC to 15:00 UTC
20:13:09 <micahg-work> bdrung, yes, I think the UTC/GMT question is separate
20:13:37 <micahg-work> I didn't see any conflicts on the fridge when I checked either
20:14:10 <bdrung> #topic Decoupling PPU rights from Ubuntu membership
20:15:33 <bdrung> micahg-work sent a mail with the subject "Proposal to decouple PPU from Membership" to d-m-b@
20:16:26 <micahg-work> bdrung, we've done that already, "micahg to give ScottK link to proposal and ScottK to move it forward"
20:17:09 <ScottK> I found it.
20:17:50 <ScottK> Having the subject line helps.
20:17:55 <bdrung> we need to vote on it and then?
20:17:56 <ScottK> I'll write a mail to the list.
20:18:19 <ScottK> micahg-work wanted to argue the color of the bike shed some more.
20:18:29 <ScottK> Let me review and mail the list and we'll have a mail vote.
20:18:41 <ScottK> Something that important I think everyone should vote on anyway.
20:18:47 <micahg-work> it needs a nice floral pattern!
20:20:03 <bdrung> #action ScottK to call for votes on the decoupling PPU rights from Ubuntu membership proposal
20:20:03 * meetingology ScottK to call for votes on the decoupling PPU rights from Ubuntu membership proposal
20:22:47 <bdrung> next chair will be Laney
20:22:52 <bdrung> thanks for attending.
20:22:57 <bdrung> #endmeeting