18:01:55 <mhall119> #startmeeting Ubuntu TV discussion
18:01:55 <meetingology> Meeting started Fri Mar  8 18:01:55 2013 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:01:55 <meetingology> 
18:01:55 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:02:29 <mhall119> hi everybody, who is here for the Ubuntu TV meeting?
18:02:44 <jhodapp> mhall119, let's try now :)
18:03:02 <YoBoY> hi mhall119, here but just to follow (not participating :p)
18:03:37 <pinguy> YoBoY, same here. Would like to see how this is handled
18:04:09 <_danialjose> just to watch
18:04:11 <mhall119> I'm going to give a few more minutes, I hope some of the TV community guys can make it
18:04:45 <jhodapp> hey tgm4883
18:04:53 <tgm4883> o/
18:05:22 <pinguy> Doesn't seem like much work has been done to Ubuntu TV for awhile now: http://bazaar.launchpad.net/~ubuntutv-dev-team/ubuntutv/trunk/files
18:05:33 <pinguy> Would be nice to see how far it has come
18:06:05 <mhall119> ok, I'm going to get started with some of the back story
18:06:10 <mhall119> #topic History
18:06:20 <tgm4883> do we have more people here than normal?
18:06:35 <mhall119> tgm4883: yeah, I put out a call for more discussion
18:07:00 <mhall119> so, around this time last year Canonical debuted the Ubuntu TV at CES, and it was a pretty big hit
18:07:25 <mhall119> at the time, the TV UI was based on the Unity 2D code
18:07:32 <mhall119> which in early 2012 was still actively developed
18:08:03 <tgm4883> quick correction, it was uds-P
18:08:04 <mhall119> we opened up all of the source code that had been worked on, and recruited interested developers from the community to participate in it's development
18:08:21 <mhall119> tgm4883: what was?
18:08:28 <tgm4883> mhall119, oh wait, nm, I misread what you said
18:08:29 <tgm4883> carry on
18:08:32 <mhall119> ok
18:09:18 <mhall119> so by this time last year the TV was open and we were getting great contributors like tgm4883 and bobweaver on board
18:10:12 <mhall119> then, at UDS-Q, there was a decision made by the Unity team that actively developing 2 separate Unity codebases (2D and 3D) was too much
18:10:39 <mhall119> and a big dicussion followed which ultimately resulted in Unity 3D being chosen
18:11:01 <mhall119> I wasnt a part of those conversations, so I can't tell you what the arguments were either way
18:11:49 <mhall119> so, with Unity 2D no longer being actively developed, we had to shift Ubuntu TV on to Nux and the Compiz plugin that powers Unity 3D
18:13:03 <mhall119> and it wasn't long after that when the Canonical engineers who had been working on the multi-media functionality for the TV were also tasked with getting that same multi-media functionality working on the new Phone/Tablet codebase
18:13:31 <mhall119> so for several months after we had started the transition to Unity 3D, we didn't have Canonical resources to help
18:14:00 <mhall119> and despite a large amount of effort from bobweaver, porting it from Qt (which he was familiar with) to Nux (which he wasn't) was no simple task
18:14:46 <mhall119> after months of this, those of us inside Canonical were frustrated that we couldn't contribute, and concerned that our absence was holding back to the community developers
18:15:24 <mhall119> so jhodapp and I spent some time gathering up all the internal documentation about design and implementation details that we could, and worked to get approval to open them up to the community
18:16:03 <mhall119> at this point, we were pretty much "throwing it over the wall", not because we wanted to, but because if we didn't it wouldn't get over the wall at all
18:16:39 <mr_man> what does throwing it over the wall mean ?
18:17:00 <mhall119> mr_man: it's a common term for making something open source but not supporting the community around it
18:17:22 <mhall119> like Google does with Android, or Sun/Oracle was known to do with their open source projects
18:17:27 <mr_man> sounds like the last year
18:17:46 <mr_man> cool so Ubuntu is droping the tv ?
18:17:48 <pinguy> mr_man, in-house code getting out to the public
18:17:55 <mhall119> Now, even though the phone shell was being written in Qt/QML at this time, as far as everybody inside Canonical knew the future was still Unity 3D, and the expectation was that the phone shell would eventually be integrated into Unity 3D as well
18:18:03 <mhall119> mr_man: no, this is the back story
18:18:34 <mhall119> so for a long time we kept encouraging the community TV hackers to port to Unity 3D, because as far as *we* knew, that was the right direction to take it
18:18:55 <mr_man> so you all got community members to do it ?
18:19:05 <mhall119> mr_man: yes
18:19:18 <mr_man> port to 3d ? that is or are you going to tell the to do that then change your mind 5 times
18:19:29 <mr_man> will is on board with this ?
18:19:33 <mhall119> and while tgm4883 made good progress on a MythTV lens/scope that didn't depend on the UI toolkit, bobweaver was still struggling to make heads or tails of Nux and Compiz
18:19:36 * tgm4883 encourages mr_man to hold his questions until the end of the history section
18:19:51 <mhall119> mr_man: I'm explaining what happened, not what is going to happen
18:19:56 <mr_man> sorry
18:20:40 <mr_man> I thought that bobweaver quit because of many many reasons
18:20:49 <tgm4883> perhaps we should open the second channel for questions?
18:20:59 <mhall119> mr_man: I'll get to some of that in a bit
18:21:14 <mhall119> finally, as the phone's releasing was approaching, the conversation inside Canonical went back to the Unity 2D vs. Unity 3D debate, and after proving how quickly and efficiently the Unity shell could be done in Qt/QML, the decision was reversed
18:21:56 <pinguy> a lack of communication seems to be the problem. You thought Unity 2d was dead so strating working on gettting Ubuntu TV working on Compiz, only to find out that up-stream was now using qt/Unity-2D.
18:22:08 <mhall119> which put us in a difficult position, we weren't allowed to talk about the phone before it was announced, but we didn't want to waste developer's time either
18:22:32 <mr_man> pinguy:  that is not true pm me if yyou want the truth
18:23:06 <mhall119> but we did discretely let bobweaver know that the debate had restarted, and there was a distinct possibility that Unity 2D, or at least a Qt/QML version of Unity, would become the new target
18:23:35 <bobweaver> really you did
18:24:50 <mhall119> Which brings us to where we are now, we have an old Unity 2D codebase, some regretably wasted time and effort on Unity 3D porting, and a new Qt/QML foundating that we want to converge all of our devices around
18:25:13 <mhall119> so, that's the history
18:25:21 <mhall119> #topic Future
18:25:51 <bobweaver> maybe I should say my side of the history as it was me that wasted 3 months or more of programming
18:26:09 <pinguy> bobweaver, I think thats only fair
18:26:19 <mhall119> so we wasted a lot of development time, and burned through a non-significant amount of developer good will, but we still want to see an Ubuntu TV, and we still want it to be a community project
18:26:46 <mhall119> bobweaver: go ahead
18:26:47 <tgm4883> #topic alternate history, community edition
18:26:55 <mhall119> #topic more history
18:27:07 <mhall119> tgm4883: feel free to add your input as well
18:27:19 <bobweaver> what really happened . after the last non virtual uds I was told o make nux I was also told that 3 times before then I was told back to 2d then back to this then back to that. It seems like there needs to be better leadership
18:27:43 <bobweaver> so it was a flip flop falure
18:27:57 <jhodapp> bobweaver, nobody will argue with that point I think
18:28:04 <bobweaver> meaning that I was lead along a fake road
18:28:46 <bobweaver> this is no one fault but mine
18:29:19 <bobweaver> but for the people in the future I do not want to see them have the same thing happen to them. so in other words you all need better leadership
18:29:38 <pinguy> bobweaver, was it ever at the back of your mind this may happen? Qt is really the only way to make apps fully cross platform. Compiz isn't really that great for this. From an outsider looking in. Ubuntu TV always seemed it was being made to work on many devices.
18:30:01 <bobweaver> I knew that it was always going to be qt
18:30:02 <mhall119> pinguy: sure, he was pushing us to just stick with Qt/QML the whole time
18:30:12 <mhall119> he was a constant advocate for it
18:30:30 <bobweaver> I fought that for months pinguy  the point is I do not want to see you all have something like this happen to the next bobweaver
18:30:46 <mhall119> tgm4883: do you have anything you want to add?
18:31:12 <tgm4883> just that I'm available for questions
18:31:17 <tgm4883> oh
18:31:26 <bobweaver> btw I have ubunntu tv running on my nexus 7
18:31:34 <mhall119> really? that's awesome
18:31:40 <tgm4883> and that for all the help i've asked for (testing wise), nobody has actually come though
18:32:18 <mhall119> are we ready to talk about the future now?
18:33:11 <ogra_> bobweaver, how is the signal reception ? :P
18:33:18 <bobweaver> listen you all are never going to get any where fighting about the code base. in this world it seems like it is about hardware and that is it. until the right people get the right tools it is not going to work
18:33:25 <pinguy> tgm4883, its a shame you didn't have that many testers. You probably could of done with the project being more open
18:33:34 <bobweaver> why build something that is for the desktop when it is going on a tv
18:33:46 <bobweaver> people have said that on the channel before
18:33:48 <tgm4883> pinguy, the stuff I need testing doesn't have anything to do with the ubuntu tv code
18:33:50 <mhall119> pinguy: the project was open, tgm4883 and bobweaver are both community contributors
18:34:04 <mhall119> alright
18:34:06 <tgm4883> so let me add a little here, what I actually am doing
18:34:29 <tgm4883> I'm a Mythbuntu developer. What I bring to the table is the Ubuntu TV integration with a MythTV backend
18:34:45 <tgm4883> This is done via Unity scopes, so it works on any platform that runs Unity
18:34:53 <bobweaver> ogra_:  I am using brodcom java drivers
18:35:03 <tgm4883> The requests I've had for testing are 2 things
18:35:26 <tgm4883> 1) Testing the scopes. This admittedly is a little more difficult, as it requires you to have a MythTV backend in your environment
18:35:54 <tgm4883> 2) Testing of the MythTV backend quick start guide I wrote. This is far easier for people to test, as you can do it in a VM
18:36:24 <mhall119> https://docs.google.com/document/d/19knOlqz8cV5_8VQ1tCvEd8tjEk6U50KsSOJCROR60o4/edit?usp=sharing
18:36:31 <tgm4883> Ironically, the few people that have tested the scope have given me feedback. The people that said they would test the QSG haven't given me any feedback yet
18:36:57 <tgm4883> Comments are open on the QSG, which is where I'm looking for them
18:37:00 <mhall119> I'm guilty of that, it's still on my task list, but I've been quite behind lately
18:37:06 <bobweaver> tgm4883:  what is QSG?
18:37:12 <mhall119> Quick Start Guide
18:37:13 <tgm4883> Quick Start Guide
18:37:15 <mhall119> the link I pasted above
18:37:30 <tgm4883> The link above is the long version, that includes every screen in the backend setup
18:37:50 <tgm4883> I would prefer to ship the smaller version, but it skips parts that aren't changed and may be more confusing
18:38:26 <tgm4883> Short version https://docs.google.com/document/d/1eGJ8gGtRqFxQ8xVWlR6XgP6FAFJEVZ-Ntq_TT8XhWEs/edit?usp=sharing
18:38:28 <bobweaver> tgm4883:  I will read the guide and get back to you
18:38:48 <mhall119> tgm4883: bobweaver: I'd like to start talking about where we go from here, since we only have 20 minutes left
18:38:48 <tgm4883> ok
18:38:56 <tgm4883> mhall119, sounds good
18:39:02 <mhall119> #topic Future
18:39:23 <mhall119> alright, so now that everybody has the brief history of the TV project, I want to know how we progress from here
18:39:55 <mhall119> we still want a TV formfactor of Unity, and we still (miraculously) have community interest in it
18:40:49 <bobweaver> if it is going to be part of the phablet then you all should just tell them to do it they wrote the stuff to start with
18:41:07 <mhall119> the goal is to have it all in one codebase
18:41:17 <mhall119> which we're evidently calling "Unity Next"
18:41:24 <bobweaver> I think that they are re-writing libunity no one can do anything till then
18:41:32 <mhall119> which will start with the phablet code, and add in desktop and TV formfactors
18:41:35 <tgm4883> I think "Unity Next" developers need to develop the interface
18:41:47 <bobweaver> that is a HUGE trouble that there not communicating between teams that is why I am out
18:41:52 <pinguy> I hate to be the bad guy here, but Ubuntu TV is really only going to work with Ubuntu Touch. In the last 4 months XBMC has really come into its own.
18:41:55 <bobweaver> well that and many many other reasons
18:42:33 <tgm4883> pinguy, Unity brings more to the table than XBMC
18:42:41 <bobweaver> pinguy:  you wath live tv with xbmc ?
18:42:55 <mhall119> tgm4883: the "Unity Next" developers in Canonical have a short window to both polish the phablet UI for potential OEM partners, *and* port the desktop by 13.10 time-frame
18:42:55 <pinguy> bobweaver, yes. It was part of the last release
18:42:57 <bobweaver> also manage all your apps
18:43:14 <pinguy> bobweaver, the android version also manages all of your apps
18:43:28 <tgm4883> mhall119, it makes more sense for the Unity developers to develop the new layouts
18:43:29 <mhall119> if we wait for Canonical developers to port the TV UI, it's going to take a while
18:43:39 <jhodapp> bobweaver, that's not true, it's just Qt5 and QML so what exactly do you think you need to wait on from the unity devs?
18:44:03 <bobweaver> pinguy:  so then you should use it and stop telling people what they should or should not do. you know that I could have xbmc in the dash right
18:44:12 <bobweaver> because there is qtmediahub
18:44:24 <mhall119> tgm4883: they will be writing the code to support adding and switching to different formfacts, but I doubt they'll be able to port the TV UI unless we wait unti the end of this year
18:44:30 <bobweaver> jhodapp:  they are re-writing unity
18:44:35 <bobweaver> libunity I should say
18:44:36 <mhall119> and I really don't want to wait another year on this
18:44:42 <tgm4883> This is OT, but XBMC doesn't have TV capabilities built in. They farm it out and use PVR backends (such as MythTV)
18:45:06 <mhall119> bobweaver: yes, the libunity APIs are going to be changing, but the TV layout and what data it will need shouldn't be
18:45:26 <jhodapp> bobweaver, sure, but we have a phablet UI today right? what's the difference between having the TV UI today and getting it working, vs the phablet one that already works?
18:45:44 <bobweaver> Umm... that is not possible it listens to libunity it uses nux all of that
18:46:01 <tgm4883> Can't we just blow up the tablet interface and use that for TV?
18:46:03 <mhall119> bobweaver: the converged codebase will all be on the same libunity API
18:46:14 <mhall119> tgm4883: that would be a good place ot start I think
18:46:27 <bobweaver> the phablet is not using all the parts of unity also the main thing would be dconf-qt that right there is huge
18:46:28 <mhall119> but the tablet is still geared to touch input
18:46:32 <jhodapp> tgm4883, yes, I think that's a good place to start too
18:46:49 <tgm4883> mhall119, IMHO, the work that we need to do is ensure that you can control the interface via remote control
18:46:55 <bobweaver> also qx11info  as you all are making new server one can not do anything that is why I made into standalone app that runs on android
18:47:08 <mhall119> ok, things are starting to fall apart into technical implementation here, I'd like to keep this more high-level
18:47:23 <tgm4883> well, that and ensure you can use it from 10' away, but I think that is going to deal more with font sizes
18:47:32 <bobweaver> mhall119:  you ant tell people to waste there time that is not fair to them
18:47:34 <tgm4883> mhall119, +1
18:47:36 <bobweaver> bottom line ^^
18:47:37 <mhall119> so let's re-cap what we have and what we don't
18:48:13 <bobweaver> spinning wheels in the mud just gets you more stuck
18:48:16 <mhall119> we have the phablet codebase, we have a design spec for the TV interface, we have some existing Qt4/QML1 code that may or may not be reusable
18:48:48 <mhall119> we don't have: Canonical resources devoted exclusively to porting TV to the new codebase
18:48:59 <bobweaver> mhall119:  have you looked at the code you can not use it
18:49:14 <mhall119> bobweaver: I haven't but I'm not as technically proficient as you when it comes to code
18:49:17 <tgm4883> mhall119, perhaps a better angle would be to list all the needs (even stuff currently done), then list what is done
18:49:32 <mhall119> tgm4883: ok
18:49:32 <bobweaver> esp because of the things that are happening with the server and libunity you are telling people to waste there time
18:49:37 <tgm4883> eg. what is needed to ship something the community would deem "Ubuntu TV"
18:50:00 <mhall119> * We need the converged Unity foundation to support multiple formfactors (Canonical resources are workign on this, it doesn't exist yet)
18:50:25 <bobweaver> libhbris ??
18:50:34 <mhall119> * We need a stable set of APIs for building the interface (libunity, indicator services, hud services, etc)
18:50:35 <bobweaver> er wrong place so sorry
18:50:47 <mhall119> some of that exists, some doesn't
18:50:52 <bobweaver> phablet has almost all that ^^
18:50:57 <mhall119> Canonical resources have already been allocated to it
18:51:17 <mhall119> bobweaver: on the surface yes, I don't know how much is mocked and how much is subject to change
18:51:31 <mhall119> at the very least, the phablet's use of libunity is going to change when libunity changes
18:51:38 <tgm4883> for lack of a better way to mark those, I'm going to put those as actions
18:51:44 <bobweaver> but you all are digging your selfs deeper until the things that I have stated change then nothing can be done. OH HOW I whis that I could have talked about this at UDS
18:51:48 <mhall119> tgm4883: good idea
18:52:02 <mhall119> #action * We need the converged Unity foundation to support multiple formfactors (Canonical resources are workign on this, it doesn't exist yet)
18:52:02 * meetingology * We need the converged Unity foundation to support multiple formfactors (Canonical resources are workign on this, it doesn't exist yet)
18:52:23 <mhall119> #action * We need a stable set of APIs for building the interface (libunity, indicator services, hud services, etc) Canonical resources are already allocated to this
18:52:23 * meetingology * We need a stable set of APIs for building the interface (libunity, indicator services, hud services, etc) Canonical resources are already allocated to this
18:52:46 <bobweaver> you all need to know how this is going to work on mer
18:52:52 <bobweaver> Woops I mean mir
18:53:06 <tgm4883> IMO, it's way to early to think about mir
18:53:11 <mhall119> #action we need to re-create the TV shell layout and components on top of Unity Next
18:53:11 * meetingology we need to re-create the TV shell layout and components on top of Unity Next
18:53:32 <tgm4883> mhall119, we need remote control functionality of Unity Next
18:53:43 <mhall119> bobweaver: that's something that should be done in the common Unity Next code, there shouldn't be anything TV specific about it
18:53:45 <jhodapp> tgm4883, agreed
18:53:52 <bobweaver> if that is action then you are going to need all the libs that are used some are not open as of yet
18:54:07 <tgm4883> mhall119, I'm leaving you to add the actions so we don't duplicate them
18:54:08 <mhall119> #action We need Remote control/navigation in the TV shell
18:54:08 * meetingology We need Remote control/navigation in the TV shell
18:54:18 <bobweaver> mhall119:  what the heck are you talking about
18:54:19 <tgm4883> mhall119, we need a TV backend
18:54:23 <bobweaver> that is bull
18:54:44 <mhall119> *action We need to make sure that all of the libs necessary to write apps and the shell are available and open source
18:54:46 <bobweaver> how are you going to handle windowing how are you going to handle spread ect ect
18:54:54 <bobweaver> alt+tab so many things
18:55:15 <jhodapp> bobweaver, don't get buried in the details for now
18:55:18 <mhall119> *action we need to specify a data model for passing TV data between Scopes and the Shell
18:55:20 <bobweaver> this was all done on X before
18:55:24 <bobweaver> with qx11info
18:55:30 <mhall119> #action We need to make sure that all of the libs necessary to write apps and the shell are available and open source
18:55:30 * meetingology We need to make sure that all of the libs necessary to write apps and the shell are available and open source
18:55:35 <mhall119> #action we need to specify a data model for passing TV data between Scopes and the Shell
18:55:35 * meetingology we need to specify a data model for passing TV data between Scopes and the Shell
18:55:55 <bobweaver> so if you are going to have all the things that the TV had then you are going to have to implant all that
18:56:02 <mhall119> #action we need scopes that pull TV content from various backends and services that use the datamodel and new API
18:56:02 * meetingology we need scopes that pull TV content from various backends and services that use the datamodel and new API
18:56:08 <bobweaver> which I hear hush hush words that canonical is doing that
18:56:26 <mhall119> bobweaver: doing what?
18:56:38 <bobweaver> there is no work for the community because canonical can change anything at any second giving the community the eff bomb
18:57:03 <mhall119> bobweaver: that's what I'm actively working to change
18:57:14 <mhall119> and jhodapp has been pushing for that to change too
18:57:21 * jhodapp will back mhall119 on that
18:57:35 <bobweaver> mhall119:  good for you I am glade to see that
18:57:39 <mhall119> so we're almost out of time, tgm4883 any more actions you want me to record?
18:58:03 <tgm4883> nope
18:58:05 <bobweaver> Listen the only reason that I am hear is because I have to tell you all what happend to me and how you can NOT make it happen to the next me
18:58:14 <mhall119> I'd like to end this by asking how you guys, on the community, want us in Canonical to work with you
18:58:34 <bobweaver> you know what you all can do stop laughing at people
18:58:39 <bobweaver> take them for real
18:59:01 <mhall119> bobweaver: none of us has been laughing at all about this
18:59:03 <jhodapp> bobweaver, come on man, that's not fair
18:59:06 <bobweaver> listen to them and dont clang them up to be just people make them part of the team
18:59:26 <bobweaver> mhall119:  should I take out the video of uds and saviq laughing ?
18:59:42 <bobweaver> life is not fair
19:00:24 <bobweaver> listen if you seee some like me again just tell them that they need to contact saviq and the other people that are too cool to show up to these meeting
19:00:27 <mhall119> I certainly hope that didn't happen, but if it did I apologize on their behalf
19:00:32 <bobweaver> even though they said that they would make it
19:00:42 <bobweaver> member at the last real UDS
19:00:44 <mhall119> bobweaver: Saviq doesn't work on TV anymore, he hasn't for some time
19:01:00 <mhall119> neither does jhodapp really, he's here on his own volition
19:01:15 <bobweaver> that is not the point the point is these are the people that CONTROL things
19:01:25 <bobweaver> you must make them work with people
19:01:26 <mhall119> bobweaver: no, they don't
19:01:32 <jhodapp> bobweaver, no that's not right
19:01:35 <bobweaver> if they dont want to then this is doomed
19:01:41 <mhall119> they've been yanked around and re-directed as much as you have (more probably)
19:01:50 * jhodapp can attest to that
19:01:54 <bobweaver> if you can not work together then what do you have
19:01:55 <bobweaver> ?>
19:02:00 <bobweaver> people wasting there time
19:02:10 <mhall119> alright, our time is up, if anybody has any other questions, concerns or comments, you can find us in #ubuntu-tv
19:02:21 <mhall119> #endmeeting